Subject: Re: [v6ops] draft-ietf-v6ops-64share WGLC... query

From: sajjad akbar <[email-masked]>
Date: Fri, 27 Sep 2013 02:08:58 -0700 (PDT)

hi...

There is a following  issue regarding dual stack in context of DNS for IPv6.

If a dual stack enable node try to connect a server which is also dual stack but having issue in his IPv6 stack temporary. In this case, DNS returned the AAAA address to the requesting node. What are the possibilities to identify this issues or how we can solve it?

Regards
Sajjad

---

From: "cb.list6" <[email-masked]>
Date: Fri, 27 Sep 2013 06:44:45 -0700

Inline

On Sep 27, 2013 2:09 AM, "sajjad akbar" <[email-masked]> wrote:
> If a dual stack enable node try to connect a server which is also dual
stack but having issue in his IPv6 stack temporary. In this case, DNS
returned the AAAA address to the requesting node. What are the
possibilities to identify this issues or how we can solve it?

Please see http://tools.ietf.org/html/rfc6555
> Regards
> Sajjad
>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: sajjad akbar <[email-masked]>
Date: Fri, 27 Sep 2013 07:32:02 -0700 (PDT)

Dear fellows

Thanks for referring RFC 6555.   Actually we are doing a project tittled  

Design and Development of Hybrid IPv4 and IPv6 Network for QoS Enabled Video Streaming Multicast Application

 in Pakistan (http://www.corenet.org.pk/projects.php). It is funded by a Telecom sector. The purpose is to build confidence of ISP's on IPv6. There is very limited implementation of V6 in Pakistan.  

We are implementing multicast pim-sm for v6 on this hybrid v4 and v6 network. To handle transition we have decided to use dual stack and tunneling mechanisms.
Multicast for hybrid v4 and v6 network is only working with dual stack. No tunneling technique (6to4, 6RD) is supporting multicast. 

Can you people suggest a way to test multicast for these tunneling mechanisms? 

Regards
Sajjad
IPv4 project team lead

________________________________
 From: cb.list6 <[email-masked]>
To: sajjad akbar <[email-masked]> 
Cc: [email-masked]; [email-masked] 
Sent: Friday, September 27, 2013 6:44 PM
Subject: Re: [v6ops] draft-ietf-v6ops-64share WGLC... query

Inline

---

From: Tom Taylor <[email-masked]>
Date: Fri, 27 Sep 2013 13:18:25 -0400

You might look at
http://datatracker.ietf.org/doc/draft-sarikaya-softwire-6rdmulticast/, 
taking note that it has not drawn any interest in the Softwires Working 
Group.

---

From: sajjad akbar <[email-masked]>
Date: Sat, 28 Sep 2013 01:50:53 -0700 (PDT)

Thanks for the suggested link. we have studied this draft earlier. It,s not very simple to deploy this mechanism on every router. Tunneling is already costly and by applying such mechanisms we will make it more complex. So, can we conclude that IPv6 tunneling mechanisms are not supporting multicast? I think its alarming for the transition phase as in coming days technologies like IPTV etc will be very common.
May be we can also state that only dual stack is a complete solution for transition phase. As per my knowledge translation techniques are also not supporting multicast.

Regards
Sajjad

________________________________
 From: Tom Taylor <[email-masked]>
To: sajjad akbar <[email-masked]> 
Cc: "[email-masked]" <[email-masked]> 
Sent: Friday, September 27, 2013 10:18 PM
Subject: Re: [v6ops] draft-ietf-v6ops-64share WGLC... query

You might look at

---

From: sajjad akbar <[email-masked]>
Date: Sat, 28 Sep 2013 06:34:08 -0700 (PDT)

Yes,i guess this is the right statement.
I have visited the link

http://www.csc.fi/english/institutions/funet/networkservices/ipv6/mcast46

Can we figure out the basic reason that why tunneling and translation are lacking multicast?

Is it due to header reconstruction issues?
or
is it due to limitation of one to one tunnel basic mechanism?

Regards

________________________________
 From: Jouni <[email-masked]>
To: sajjad akbar <[email-masked]> 
Sent: Saturday, September 28, 2013 3:34 PM
Subject: Re: [v6ops] draft-ietf-v6ops-64share WGLC... query

> May be we can also state that only dual stack is a complete solution for transition phase. As per my knowledge translation techniques are also not supporting multicast.

http://www.csc.fi/english/institutions/funet/networkservices/ipv6/mcast46

- Jouni