Subject: [v6ops] frag success, or not

From: Randy Bush <[email-masked]>
Date: Mon, 02 Sep 2013 18:39:12 +0900

be sure to understand footnote.  almost 10% of the atlas probes which
think they have ipv6 connectivity actually do not.  so one has to
subtract that 9.94% from all entries in fail% column.

if you are unfamiliar with the ncc atlas project, grab your board and go
to https://atlas.ripe.net/

randy

---

Message-ID: <[email-masked]>
Date: Sun, 01 Sep 2013 22:34:22 +0200
From: Emile Aben <[email-masked]>
To: Randy Bush <[email-masked]>
CC: [email-masked]
Subject: Re: IP Fragmentation - Not reliable over the Internet?

On 31/08/2013 13:13, Randy Bush wrote:
> could you please test with ipv6?

This is what I see for various IPv6 payloads (large ICMPv6 echo
requests) from all RIPE Atlas probes that where available at the time to
a single "known good" MTU 1500 destination:

plen	fail%	nr_probes
100	9.64	1266
500	9.34	1039
1000	9.94	1298
1240	9.94	1308
1241	11.62	1300
1440	12.70	890
1441	14.70	1306
1460	15.18	1304
1461	19.84	1290
1462	22.02	1294

plen: IPv6 payload length (ie. not including 40byte IPv6 header)
fail%: percentage of probes that didn't get any of the 5 pkts that were
sent. Note that there is a large baseline failure rate in IPv6 on RIPE
Atlas probes [1], which would explain the ~10% failure rate for the
smaller packets.

I plan to do more analysis and start writing this up on RIPE Labs over
the next few days.

cheers,
Emile Aben
RIPE NCC

[1]
https://labs.ripe.net/Members/stephane_bortzmeyer/how-many-atlas-probes-believe-they-have-ipv6-but-are-wrong

---

From: Ole Troan <[email-masked]>
Date: Mon, 2 Sep 2013 11:48:17 +0200

> to https://atlas.ripe.net/

I don't quite understand what he is testing?
just sending large packets?
or as the subject says, fragmented packets?
or path MTU discovery?

cheers,
Ole

> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Randy Bush <[email-masked]>
Date: Mon, 02 Sep 2013 18:51:01 +0900

>> requests) 

beyond that, emile would have to speak for himself

randy