Subject: [v6ops] new draft: draft-v6ops-jaeggli-pmtud-ecmp-problem

From: Fred Baker <[email-masked]>
Date: Wed, 19 Feb 2014 05:45:13 -0800 (PST)

A new draft has been posted, at http://tools.ietf.org/html/draft-v6ops-jaeggli-pmtud-ecmp-problem. Please take a look at it and comment.

---

From: Fernando Gont <[email-masked]>
Date: Wed, 19 Feb 2014 16:02:57 -0300

Hi, Joel,

Minor comment:
While one would expect that a host implementation checks the packet
embedded in the ICMPv6 payload, the ones that I recall checking do not.

e.g., if you send an ICMPv6 error to a node that references a
non-existent transport-protocol instance (e.g., a TCP connection that
doesn't exist), they will honor the error message anyway.

One might argue that that's not really harmful -- at the end of the day,
you don't *raise* the assummed Path-MTU in response to ICMPv6 errors,
but rather only lower it... so in the worst case scenario, you'd reduce
the PMTUD for transport-protocol instances for which you didn't need to.

Another one, which probably doesn't matter in practice:
Even with RFC7112 in place, if a packet is emitted with a very long
header chain, the ICMPv6 error might not not contain the transport header.

(yes, I'm aware that packets with EHs are commonly filtered, etc.)

Thanks,
Fernando

On 02/19/2014 10:45 AM, Fred Baker wrote:
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
> 

-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492