Subject: [v6ops] Facebook v6 deployment

From: Brian E Carpenter <[email-masked]>
Date: Sat, 22 Mar 2014 05:51:28 +1300

Apologies if this is old news, but there is lots
of meat in this talk that Robert Watson just pointed me to:

https://www.dropbox.com/s/doazzo5ygu3idna/WorldIPv6Congress-IPv6_LH%20v2.pdf

Regards
   Brian

---

From: Nabil Benamar <[email-masked]>
Date: Fri, 21 Mar 2014 17:09:17 +0000

On Mar 21, 2014 5:07 PM, "Nabil Benamar" <[email-masked]> wrote:

> Thank you Brian for sharing this valuable presentation !
> On Mar 21, 2014 4:52 PM, "Brian E Carpenter" <[email-masked]>
> wrote:
>
>> _______________________________________________
>> v6ops mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/v6ops
>>
>

---

From: Ted Lemon <[email-masked]>
Date: Fri, 21 Mar 2014 13:53:35 -0400

> of meat in this talk that Robert Watson just pointed me to:

I hadn't seen it.   Thanks for the pointer—you are right, it was very interesting.

---

From: "Mukom Akong T." <[email-masked]>
Date: Mon, 31 Mar 2014 06:58:31 +0400

The best part for me in the presentation (don't know if it's in the slides)
was this

a) No product can go live if it doesn't support IPv6

b) Take away IPv4 from the environment in which devs work

That is certainly forcing people to think IPv6 first before IPv4.

-- 

Mukom Akong T.

http://about.me/perfexcellence |  twitter: @perfexcellent
------------------------------------------------------------------------------------------------------------------------------------------
“When you work, you are the FLUTE through whose lungs the whispering of the
hours turns to MUSIC" - Kahlil Gibran
-------------------------------------------------------------------------------------------------------------------------------------------

---

From: Mohammad Aazam <[email-masked]>
Date: Mon, 31 Mar 2014 08:31:03 +0500

Hi,

Respected v6ops Members,

What if we first think about QoS provisioning in IPv6? Because migration
towards IPv6 would require tunneling for a reasonable period, until IPv6
completely takes over from IPv4. During that time, IPv6 tunneling overhead
would affect the overall efficiency and data delivery.

Regards,
Mohammad Aazam
www.aazamcs.com

On Mon, Mar 31, 2014 at 7:58 AM, Mukom Akong T. <[email-masked]>wrote:

> The best part for me in the presentation (don't know if it's in the
> slides) was this
>
>> I hadn't seen it.   Thanks for the pointer--you are right, it was very
>> interesting.
>>
> "When you work, you are the FLUTE through whose lungs the whispering of
> the hours turns to MUSIC" - Kahlil Gibran
>

-- 
"The best time to plant a tree was 20 years ago. The second best time is
now." - Chinese Proverb.
Regards,
Mohammad Aazam

---

From: Owen DeLong <[email-masked]>
Date: Sun, 30 Mar 2014 21:31:45 -0700

Actually, tunnel usage is a tiny fraction of a percent of IPv6 traffic already today. While there are some tunnels in use, the use of tunnels has been dramatically reduced and continues to decline.

Owen

On Mar 30, 2014, at 8:31 PM, Mohammad Aazam <[email-masked]> wrote:

> Hi,
> 
> Respected v6ops Members,
> 
> What if we first think about QoS provisioning in IPv6? Because migration towards IPv6 would require tunneling for a reasonable period, until IPv6 completely takes over from IPv4. During that time, IPv6 tunneling overhead would affect the overall efficiency and data delivery.
> 
> Regards,
> Mohammad Aazam
> www.aazamcs.com
> 
> 
> On Mon, Mar 31, 2014 at 7:58 AM, Mukom Akong T. <[email-masked]> wrote:
> The best part for me in the presentation (don't know if it's in the slides) was this
> 
> “When you work, you are the FLUTE through whose lungs the whispering of the hours turns to MUSIC" - Kahlil Gibran
> "The best time to plant a tree was 20 years ago. The second best time is now." - Chinese Proverb. 
> 
> Regards,
> Mohammad Aazam

---

From: Gert Doering <[email-masked]>
Date: Mon, 31 Mar 2014 13:35:42 +0200

Hi,

> would affect the overall efficiency and data delivery.

The period for tunneling was... uh... 1997 to 2000, or so.

Gert Doering
        -- NetMaster
-- 
have you enabled IPv6 on something today...?

SpaceNet AG                        Vorstand: Sebastian v. Bomhard
Joseph-Dollinger-Bogen 14          Aufsichtsratsvors.: A. Grundner-Culemann
D-80807 Muenchen                   HRB: 136055 (AG Muenchen)
Tel: +49 (0)89/32356-444           USt-IdNr.: DE813185279

---

From: Nalini Elkins <[email-masked]>
Date: Mon, 31 Mar 2014 07:08:31 -0700 (PDT)

>The period for tunneling was... uh... 1997 to 2000, or so.

You have got to be kidding.   Most large enterprises are just starting to learn to spell IPv6.  I talk to quite few who say it is not even in their 5-year plan yet.  And these are MAJOR US corporations.

At home, I certainly can't get IPv6 native connectivity from my ISP or ANY ISP without paying huge amounts of money.   When our engineers do IPv6 testing over the Internet we use IPv4 / IPv6  tunneling.

Just trying to inject a little reality into the conversation.

Thanks,

Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

---

From: Mohammad Aazam <[email-masked]>
Date: Mon, 31 Mar 2014 19:26:05 +0500

Hi,

If this is the case, then how incompatible traffic is routed through a
network? If I'm on IPv6, how my traffic would be routed through the core?
Since core is not yet completely on IPv6.

---

From: "Bjoern A. Zeeb" <[email-masked]>
Date: Mon, 31 Mar 2014 14:27:46 +0000

>> The period for tunneling was... uh... 1997 to 2000, or so.

Maybe till 2002/2003.  I still remember a lot of tunnelling from back then.  Certainly there was enough connectivity around that one didn’t need it anymore in a well connected place.

> You have got to be kidding.   Most large enterprises are just starting to learn to spell IPv6.  I talk to quite few who say it is not even in their 5-year plan yet.  And these are MAJOR US corporat…

Until one of their major suppliers in Asia says “and by tomorrow please do all this over IPv6”.  I am still waiting for a publicly known case of this.  Certainly no one will switch over night but no IPv6 at all in the next five years for a major company is not realistic anymore.  There will be surprises.

> At home, I certainly can't get IPv6 native connectivity from my ISP or ANY ISP without paying huge amounts of money.   When our engineers do IPv6 testing over the Internet we use IPv4 / IPv6  tunnelling.

I think there are two types of ISPs left without IPv6;  the ones that just won’t do it, and the ones that would love to give it to you but just cannot until they are confident with their deployment working edge-to-edge.  The number of the latter seems to increase, the number of the former might cease to exist in one way or the other in a couple of years.

> Just trying to inject a little reality into the conversation.

I think what Gert was trying to say is that in places that matter tunnels are gone.  The vast majority of the IPv6 core connectivity should run without any tunnels involved these days.  What happens at the edge is, as you point out, a different story but numbers show a static increase in end-user IPv6 connectivity and I would almost assume the it’s “geeks waiting patiently prodding people every other week” and “people who really need it but had no other choice on short notice” who are on tunnels, and that’s it.

Bjoern

— 
Bjoern A. Zeeb                             ????????? ??? ??????? ??????:
'??? ??? ???? ??????  ??????? ?? ?? ??????? ??????? ??? ????? ????? ????
?????? ?? ????? ????',  ????????? ?????????, "??? ????? ?? ?????", ?.???

---

From: Mikael Abrahamsson <[email-masked]>
Date: Mon, 31 Mar 2014 16:29:53 +0200 (CEST)

On Mon, 31 Mar 2014, Mohammad Aazam wrote:

> network? If I'm on IPv6, how my traffic would be routed through the 
> core? Since core is not yet completely on IPv6.

It would be helpful if you explained your world view and why you're 
writing what you're writing. It seems you're making assumptions others 
aren't agreeing with.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Nalini Elkins <[email-masked]>
Date: Mon, 31 Mar 2014 07:44:21 -0700 (PDT)

>I think there are two types of ISPs left without IPv6;  the ones that just won’t do it, and the ones that would love to give it to you but just cannot until they are confident with their deployment working edge-to-edge.  The number of >the latter seems to increase, the number of the former might cease to exist in one way or the other in a couple of years.

The ISP to my home is Comcast.  Just saying.  Seems doubtful that they will go under since they seem to have a near monopoly in the US.

>I think what Gert was trying to say is that in places that matter tunnels are gone.  The vast majority of the IPv6 core connectivity should run without any tunnels involved these days.  What happens at the edge is, as you point out, a >different story but numbers show a static increase in end-user IPv6 connectivity and I would almost assume the it’s “geeks waiting patiently prodding people every other week” and “people who really need it but had no other choice
>on short notice” who are on tunnels, and that’s it.

We will ignore the "edge" at our peril. 

BTW, I happen to be an IPv6 bigot and prod all end user corporations who will listen (and many who would prefer not to!) to start the IPv6 conversion.  (And have done so for the last 5 years.)  My cries have often fallen on deaf ears.

Bjoern

—

---

From: Bill Jouris <[email-masked]>
Date: Mon, 31 Mar 2014 07:47:22 -0700 (PDT)

"...in places that matter tunnels are gone."

Perhaps you could share what, exactly, you consider "places that matter."  Is it simply that places which offer IPv6 end-to-end are the only places that matter?

Just for the edification of those of us living in places which, apparently, do not matter....

Bill Jouris
Inside Products, Inc.
www.insidethestack.com
831-659-8360
925-855-9512 (direct)

________________________________
 From: Bjoern A. Zeeb <[email-masked]>
To: Nalini Elkins <[email-masked]> 
Cc: IPv6 Operations <[email-masked]> 
Sent: Monday, March 31, 2014 7:27 AM
Subject: Re: [v6ops] Facebook v6 deployment

Bjoern

—

---

From: Mikael Abrahamsson <[email-masked]>
Date: Mon, 31 Mar 2014 16:48:25 +0200 (CEST)

On Mon, 31 Mar 2014, Nalini Elkins wrote:

> The ISP to my home is Comcast.  Just saying.  Seems doubtful that they 
> will go under since they seem to have a near monopoly in the US.

Comcast is doing IPv6 on a wide scale. http://www.comcast6.net/

As far as I can tell, they now have the largest IPv6 deployment in the 
world.

---

From: Daniel Corbe <[email-masked]>
Date: Mon, 31 Mar 2014 10:50:00 -0400

> seem to have a near monopoly in the US.

But Comcast will give you IPv6 if you ask them nicely.

---

From: joel jaeggli <[email-masked]>
Date: Mon, 31 Mar 2014 07:55:05 -0700

On 3/31/14, 7:47 AM, Bill Jouris wrote:
> Perhaps you could share what, exactly, you consider "places that
> matter."  Is it simply that places which offer IPv6 end-to-end are
> the only places that matter?

He means that you don't need to hop over a transit provider to build out
ipv6 connectivity anymore. The networks that enterprises an operators
need to connect to on the big I internet are and have been engaged in
IPv6 deployment in their networks and to their commercial customers for
some time.

> 
> 
> Bill Jouris Inside Products, Inc. www.insidethestack.com 
> 831-659-8360 925-855-9512 (direct)
> 
> 
> 
> 
> ________________________________ From: Bjoern A. Zeeb
> <[email-masked]> To: Nalini Elkins
> <[email-masked]> Cc: IPv6 Operations
> <[email-masked]> Sent: Monday, March 31, 2014 7:27 AM Subject: Re:
> [v6ops] Facebook v6 deployment
> 
> 
> 
> On 31 Mar 2014, at 14:08 , Nalini Elkins
> <[email-masked]> wrote:
> 
>> 
>> 
>>> What if we first think about QoS provisioning in IPv6? Because
>>> migration towards IPv6 would require tunneling for a reasonable
>>> period, until IPv6 completely takes over from IPv4. During that
>>> time, IPv6 tunneling overhead would affect the overall efficiency
>>> and data delivery.
>> 
> Maybe till 2002/2003.  I still remember a lot of tunnelling from back
> then.  Certainly there was enough connectivity around that one didn’t
> need it anymore in a well connected place.
> 
> 
>> You have got to be kidding.   Most large enterprises are just
>> starting to learn to spell IPv6.  I talk to quite few who say it is
>> not even in their 5-year plan yet.  And these are MAJOR US
>> corporations.
> 
> Until one of their major suppliers in Asia says “and by tomorrow
> please do all this over IPv6”.  I am still waiting for a publicly
> known case of this.  Certainly no one will switch over night but no
> IPv6 at all in the next five years for a major company is not
> realistic anymore.  There will be surprises.
> 
> 
>> At home, I certainly can't get IPv6 native connectivity from my ISP
>> or ANY ISP without paying huge amounts of money.   When our
>> engineers do IPv6 testing over the Internet we use IPv4 / IPv6
>> tunnelling.
> 
> I think there are two types of ISPs left without IPv6;  the ones that
> just won’t do it, and the ones that would love to give it to you but
> just cannot until they are confident with their deployment working
> edge-to-edge.  The number of the latter seems to increase, the number
> of the former might cease to exist in one way or the other in a
> couple of years.
> 
> 
> I think what Gert was trying to say is that in places that matter
> tunnels are gone.  The vast majority of the IPv6 core connectivity
> should run without any tunnels involved these days.  What happens at
> the edge is, as you point out, a different story but numbers show a
> static increase in end-user IPv6 connectivity and I would almost
> assume the it’s “geeks waiting patiently prodding people every other
> week” and “people who really need it but had no other choice on short
> notice” who are on tunnels, and that’s it.
> 
> 
> Bjoern
> 
> — Bjoern A. Zeeb                             ????????? ??? ???????
> ??????: '??? ??? ???? ??????  ??????? ?? ?? ??????? ??????? ??? ?????
> ????? ???? ?????? ?? ????? ????',  ????????? ?????????, "??? ????? ??
> ?????", ?.???
> 
> _______________________________________________ v6ops mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/v6ops
> 
> 
> 
> _______________________________________________ v6ops mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Nalini Elkins <[email-masked]>
Date: Mon, 31 Mar 2014 07:59:08 -0700 (PDT)

>As far as I can tell, they now have the largest IPv6 deployment in the world.

Guys, 

Comcast is indeed doing IPv6 but it seems to depend on how close you are to a major urban center.   I have asked before and was told that it was not available in my area.  BTW,  I  do not live COMPLETELY in the middle of nowhere.   Just where you can actually be surrounded by trees and clean air.

The local office opens at 9:00am my time.  (about an hour).  I will ask again (nicely!) and post the results of what I get.  I hope to stand corrected.   

Nalini

---

From: Mikael Abrahamsson <[email-masked]>
Date: Mon, 31 Mar 2014 17:03:01 +0200 (CEST)

On Mon, 31 Mar 2014, Nalini Elkins wrote:

> Comcast is indeed doing IPv6 but it seems to depend on how close you are 
> to a major urban center.   I have asked before and was told that it was 
> not available in my area.  BTW,  I  do not live COMPLETELY in the middle 
> of nowhere.   Just where you can actually be surrounded by trees and 
> clean air.
>

When listening to Comcast staff presentations on this issue, it didn't 
seem like something you need to ask for and they turn it on only for you, 
instead it'll be turned on whenever they're done with your area.

---

From: joel jaeggli <[email-masked]>
Date: Mon, 31 Mar 2014 08:03:16 -0700

On 3/31/14, 7:08 AM, Nalini Elkins wrote:
> or ANY ISP without paying huge amounts of money.   When our engineers
> do IPv6 testing over the Internet we use IPv4 / IPv6  tunneling.

If you stick a verizon 4g dongle in your laptop you will get IPv6
connectivity anywhere there is coverage in the united states. It's been
deployed that way since the LTE network went into production (2010).

> Nalini Elkins Inside Products, Inc. (831) 659-8360 
> www.insidethestack.com
>

---

From: joel jaeggli <[email-masked]>
Date: Mon, 31 Mar 2014 08:10:16 -0700

On 3/31/14, 8:03 AM, Mikael Abrahamsson wrote:
> seem like something you need to ask for and they turn it on only for
> you, instead it'll be turned on whenever they're done with your area.

you will need a docsis 3.0 modem...

but you need that for more than 40 down anyway.

---

From: Nalini Elkins <[email-masked]>
Date: Mon, 31 Mar 2014 08:12:48 -0700 (PDT)

>When listening to Comcast staff presentations on this issue, it didn't seem like something you need to ask for and they turn it on only for you, instead it'll be turned on whenever they're done with your area.

Sure.  That is indeed the question.   They do some areas before others (and rightfully so - they are in business and need to get the majority of their customers who live in the urban centers.  Comcast is a very well run business.)

I am just saying that many of us, at least in the US, do not live in urban centers - by choice.   BTW, it took us years to get high speed broadband as well.  Probably 5 years after the major urban center in my area (San Jose / San Francisco) had it.  I have an artist friend who lives in quite a rural area in the middle of the US and she does not have high speed broadband yet.

IMHO, there will be for a long time issues along the lines of digital divide.  Those who have native IPv6 and those who do not.

And, the issues will be those of the edge. 

Nalini

---

From: Nalini Elkins <[email-masked]>
Date: Mon, 31 Mar 2014 08:14:06 -0700 (PDT)

>deployed that way since the LTE network went into production (2010).

Thanks, Joel.  I will check with the local Verizon office.

Nalini

---

From: "Ackermann, Michael" <[email-masked]>
Date: Mon, 31 Mar 2014 15:17:07 +0000

Same here in Michigan.    I tried to get IPV6 on Comcast and it is not available in the 3 areas I tried within the state of MI.

From: v6ops [mailto:[email-masked]] On Behalf Of Nalini Elkins
Sent: Monday, March 31, 2014 10:59 AM
To: Mikael Abrahamsson
Cc: IPv6 Operations
Subject: Re: [v6ops] Facebook v6 deployment

Guys,

Nalini

The information contained in this communication is highly confidential and is intended solely for the use of the individual(s) to whom this communication is directed. If you are not the intended recipient, you are hereby notified that any viewing, copying, disclosure or distribution of this information is prohibited. Please notify the sender, by electronic mail or telephone, of any unintended receipt and delete the original message without making any copies.
 
 Blue Cross Blue Shield of Michigan and Blue Care Network of Michigan are nonprofit corporations and independent licensees of the Blue Cross and Blue Shield Association.

---

From: Gert Doering <[email-masked]>
Date: Mon, 31 Mar 2014 17:19:40 +0200

Hi,

> Since core is not yet completely on IPv6.

Why not?  Our core has been IPv6-enabled since about 2005 or so.

Fully dual-stack v4+v6, not lame excuses.

(For those that prefer excuses, you can use 6PE or 6VPE to do MPLS
tunneling, which will be about good or bad as your IPv4-over-MPLS, and
if you need QoS for that, you need it for IPv6 as well.  If you have
enough bandwidth, you do not need extra QoS for IPv6)

Gert Doering
        -- NetMaster

---

From: Gert Doering <[email-masked]>
Date: Mon, 31 Mar 2014 17:21:06 +0200

Hi,

> You have got to be kidding.   Most large enterprises are just starting to learn to spell IPv6.  I talk to quite few who say it is not even in their 5-year plan yet.  And these are MAJOR US corporat…

Yeah, the US.  "We do not need IPv6, we have IPv4", right?

> Just trying to inject a little reality into the conversation.

I tend to forget...

But then, the US has taken the lead as far as IPv6 in mobile networks
go - just subscribe to verizon LTE, get native IPv6 :-)

Gert Doering
        -- NetMaster

---

From: Gert Doering <[email-masked]>
Date: Mon, 31 Mar 2014 17:23:56 +0200

Hi,

> The ISP to my home is Comcast.  Just saying.  Seems doubtful that they will go under since they seem to have a near monopoly in the US.

Comcast actually is one of the first really large ISPs in the world that
went to IPv6...

Gert Doering
        -- NetMaster

---

From: Tim Chown <[email-masked]>
Date: Mon, 31 Mar 2014 16:23:53 +0100

> Just for the edification of those of us living in places which, apparently, do not matter....

Perhaps one view is that the addition of IPv6 connectivity/addresses for most of the root name servers is a positive indication that IPv6 is robustly deployed, and therefore likely to be native end-to-end, "where it matters" ?

Indeed the position in access networks is patchy at best, else we'd not see Google at only 3-4% IPv6 access.  In that light, tunnelbroker.net and friends are very valuable.

I suspect also that there might be more IPv4-in-Ipv6 tunnelling out there than most would expect.

Tim

---

From: Tim Chown <[email-masked]>
Date: Mon, 31 Mar 2014 16:26:06 +0100

For a pretty recent and very positive update on Comcast on IPv6, see:

http://www.youtube.com/watch?v=rWuvAOdsztk

Tim

---

From: Bill Jouris <[email-masked]>
Date: Mon, 31 Mar 2014 08:31:12 -0700 (PDT)

"...just subscribe to verizon LTE, get native IPv6"

Fine, as far as it goes.  There is, however, a little problem with bandwidth using wireless vs wired.  So while wireless may be great for trying out IPv6, that still leaves some issues to be addressed by those trying to get real work done.

Bill Jouris
Inside Products, Inc.
www.insidethestack.com
831-659-8360
925-855-9512 (direct)

________________________________
 From: Gert Doering <[email-masked]>
To: Nalini Elkins <[email-masked]> 
Cc: IPv6 Operations <[email-masked]> 
Sent: Monday, March 31, 2014 8:21 AM
Subject: Re: [v6ops] Facebook v6 deployment

Hi,

I tend to forget...

Gert Doering
        -- NetMaster

---

From: Gert Doering <[email-masked]>
Date: Mon, 31 Mar 2014 17:37:46 +0200

Hi,

> Fine, as far as it goes.  There is, however, a little problem with bandwidth using wireless vs wired.  So while wireless may be great for trying out IPv6, that still leaves some issues to be addres…

It really depends on what you need.  If you need a business ISP, there's
ISPs like NTT that have been offering fully commercially supported IPv6
(as in "not an 'experimental' service") for a decade now.  I have no
idea how widespread NTT's coverage is, in the US - in europe, they
are available in all "major" internet hubs at least.

If you're looking for an end user ISP, LTE bandwidth is more than you
can get in rural countries in DE - so I wouldn't frown on that...

Gert Doering
        -- NetMaster

---

From: Ted Lemon <[email-masked]>
Date: Mon, 31 Mar 2014 11:44:57 -0400

> As far as I can tell, they now have the largest IPv6 deployment in the world.

Unfortunately, those of us who live in backwaters still have IPv4-only service, despite being connected via Comcast.   This is certainly the case where I live, and apparently also where Nalini lives.

---

From: Ted Lemon <[email-masked]>
Date: Mon, 31 Mar 2014 11:47:48 -0400

> but you need that for more than 40 down anyway.

20 is the most I can get.   :)

---

From: Daniel Corbe <[email-masked]>
Date: Mon, 31 Mar 2014 11:48:57 -0400

Ted Lemon <[email-masked]> writes:

> Unfortunately, those of us who live in backwaters still have IPv4-only
> service, despite being connected via Comcast.  This is certainly the
> case where I live, and apparently also where Nalini lives.
>

Which is still a long way away from "we're never going to get it."
Which is what the OP seemed to imply.  Comcast customers need to be a
little more forceful with their monopolistic overlords.

---

From: Ted Lemon <[email-masked]>
Date: Mon, 31 Mar 2014 12:07:59 -0400

On Mar 31, 2014, at 11:48 AM, Daniel Corbe <[email-masked]> wrote:
> Which is what the OP seemed to imply.

I think she just said "not here yet, no idea when it will be."   John's deadline of 1Q2014 (from his slides) has already passed.   I know this is hard, but we've been waiting a _long_ time, so it's hard to be optimistic.

> Comcast customers need to be a

We have _zero_ leverage.   That's the problem with monopolies.

---

From: Nalini Elkins <[email-masked]>
Date: Mon, 31 Mar 2014 09:14:41 -0700 (PDT)

+1

---

From: Nalini Elkins <[email-masked]>
Date: Mon, 31 Mar 2014 10:35:40 -0700 (PDT)

>When listening to Comcast staff presentations on this issue, it didn't seem like something you need to ask for and they turn it on only for you, instead it'll be turned on whenever they're done with…

I talked to the local Comcast office 1/2 an hour ago.  They said "No IPv6.  No ETA on when it might be available."

I commend Comcast on their efforts in implementing IPv6.   It is just that some of who live in rural areas would like it also.   I know it takes a while to get coverage everywhere and these are business decisions.

I will stop by the local Verizon office this afternoon and ask about the dongle that Joel spoke of.

Thanks,
Nalini

---

From: "Brzozowski, John" <[email-masked]>
Date: Mon, 31 Mar 2014 18:51:37 +0000

DOCSIS 3.0 and many pre DOCSIS 3.0 devices support IPv6, see the following:

http://mydeviceinfo.comcast.net

http://www.comcast6.net

John
=========================================
John Jason Brzozowski
Comcast Cable
m) 609-377-6594
o) 484-962-0060
w) www.comcast6.net
e) [email-masked]
=========================================

-----Original Message-----
From: Joel Jaeggli <[email-masked]>
Date: Monday, March 31, 2014 at 11:10
To: Mikael Abrahamsson <[email-masked]>, Nalini Elkins
<[email-masked]>
Cc: v6ops <[email-masked]>
Subject: Re: [v6ops] Facebook v6 deployment

---

From: "Brzozowski, John" <[email-masked]>
Date: Mon, 31 Mar 2014 18:53:19 +0000

FWIW - we are deploying IPv6 nationwide.  We are nearly 90% complete with
30%+ of our customers actively provisioned with native dual stack.

The 30% will increase throughout the year into next year and beyond.

John

-----Original Message-----
From: Nalini Elkins <[email-masked]>
Reply-To: Nalini Elkins <[email-masked]>
Date: Monday, March 31, 2014 at 11:12
To: Mikael Abrahamsson <[email-masked]>
Cc: v6ops <[email-masked]>
Subject: Re: [v6ops] Facebook v6 deployment

>>> Comcast is indeed doing IPv6 but it seems to depend on how close you
>>>are to a major urban center.   I have asked before and was told that it
>>>was not available in my area.  BTW,  I  do not live COMPLETELY in the
>>>middle of nowhere.   Just where you can actually be surrounded by trees
>>>and clean air.
>>> 
>>> The local office opens at 9:00am my time.  (about an hour).  I will
>>>ask again (nicely!) and post the results of what I get.  I hope to
>>>stand corrected.
>
>Sure.  That is indeed the question.   They do some areas before others
>(and rightfully so - they are in business and need to get the majority of
>their customers who live in the urban centers.  Comcast is a very well
>run business.)
>
>I am just saying that many of us, at least in the US, do not live in
>urban centers - by choice.   BTW, it took us years to get high speed
>broadband as well.  Probably 5 years after the major urban center in my
>area (San Jose / San Francisco) had it.  I have an artist friend who
>lives in quite a rural area in the middle of the US and she does not have
>high speed broadband yet.
>
>IMHO, there will be for a long time issues along the lines of digital
>divide.  Those who have native IPv6 and those who do not.
>

---

From: "Brzozowski, John" <[email-masked]>
Date: Mon, 31 Mar 2014 18:55:14 +0000

People who are Comcast customers that do not have IPv6 can contact me offline or unicast via email.

To date we have launched residential broadband support for native IPv6.  Commercial DOCSIS IPv6 support is in planning and will be launched soon hopefully before the summer time.

John
=========================================
John Jason Brzozowski
Comcast Cable
m) 609-377-6594
o) 484-962-0060
w) www.comcast6.net
e) [email-masked]<mailto:[email-masked]>
=========================================

From: <Ackermann>, Mike Ackermann <[email-masked]<mailto:[email-masked]>>
Date: Monday, March 31, 2014 at 11:17
To: Nalini Elkins <[email-masked]<mailto:[email-masked]>>, Mikael Abrahamsson <[email-masked]<mailto:[email-masked]>>
Cc: v6ops <[email-masked]<mailto:[email-masked]>>
Subject: Re: [v6ops] Facebook v6 deployment

Guys,

Nalini

---

From: "Brzozowski, John" <[email-masked]>
Date: Mon, 31 Mar 2014 19:01:27 +0000

Ted,

Parts of New England have started to see native IPv6 support deployed.  I
know you and others have been waiting patiently.

John

---

From: "Brzozowski, John" <[email-masked]>
Date: Mon, 31 Mar 2014 19:03:39 +0000

Nalini,

I will email you unicast.

John

From: Nalini Elkins <[email-masked]<mailto:[email-masked]>>
Reply-To: Nalini Elkins <[email-masked]<mailto:[email-masked]>>
Date: Monday, March 31, 2014 at 13:35
To: Nalini Elkins <[email-masked]<mailto:[email-masked]>>, Mikael Abrahamsson <[email-masked]<mailto:[email-masked]>>
Cc: v6ops <[email-masked]<mailto:[email-masked]>>
Subject: Re: [v6ops] Facebook v6 deployment

Thanks,
Nalini

---

From: "Ackermann, Michael" <[email-masked]>
Date: Mon, 31 Mar 2014 19:55:20 +0000

Thanks John

I would be interested in when Comcast will have IPV6 in 48083, 48858 and 48226.   All are in Michigan.    I cannot seem to get an estimate on this through conventional mechanisms, so any info you might have would be greatly appreciated.

Thanks

Mike

From: Brzozowski, John [mailto:[email-masked]]
Sent: Monday, March 31, 2014 2:55 PM
To: Ackermann, Michael; Nalini Elkins; Mikael Abrahamsson
Cc: IPv6 Operations
Subject: Re: [v6ops] Facebook v6 deployment

John
=========================================
John Jason Brzozowski
Comcast Cable
m) 609-377-6594
o) 484-962-0060
w) www.comcast6.net<http://www.comcast6.net>
e) [email-masked]<mailto:[email-masked]>
=========================================

Guys,

Nalini

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 01 Apr 2014 09:03:19 +1300

Would whoever completely changed the subject of this thread
please hop into their time machine, go back, and change the
Subject to "Comcast IPv6" or something like that?

Regards
   Brian

On 01/04/2014 08:55, Ackermann, Michael wrote:
> ------------------------------------------------------------------------
>

---

From: Owen DeLong <[email-masked]>
Date: Mon, 31 Mar 2014 13:08:22 -0700

> You have got to be kidding.   Most large enterprises are just starting to learn to spell IPv6.  I talk to quite few who say it is not even in their 5-year plan yet.  And these are MAJOR US corporat…

Then they are major corporations asleep at the switch which are on the verge of getting a rude awakening. This isn’t really unusual for major US corporations, there’s a long tradition including GM (Japanese cars), IBM (personal computing), Enron (market adjustments and creative accounting practices), and many many more.

However, anyone who hasn’t started deploying IPv6 shouldn’t be looking at a tunneled solution to doing so at this point, they should go straight to native dual stack. There’s really no remaining reason to do tunneled. Just because the corporations haven’t advanced doesn’t mean that the hardware and software was standing still while they were sleeping.

> At home, I certainly can't get IPv6 native connectivity from my ISP or ANY ISP without paying huge amounts of money.   When our engineers do IPv6 testing over the Internet we use IPv4 / IPv6  tunne…

Most of California can get native IPv6 from Comcast at no additional charge. While DSL remains the one place where 6rd (tunneled) is more common than native, there’s little advantage to worrying about that from the QoS perspective proposed by Mohammad.

> Just trying to inject a little reality into the conversation.

The conversation is based in reality. The reality in Carmel Valley is _NOT_ the reality in much of the world.

Owen

---

From: Owen DeLong <[email-masked]>
Date: Mon, 31 Mar 2014 13:17:06 -0700

> When listening to Comcast staff presentations on this issue, it didn't seem like something you need to ask for and they turn it on only for you, instead it'll be turned on whenever they're done wit…

Yes and no.

If your equipment is old, you might have to ask for them to swap it out to give you something IPv6 capable.

Owen

---

From: Owen DeLong <[email-masked]>
Date: Mon, 31 Mar 2014 13:26:28 -0700

How so? In most cases, my LTE connections are faster than many of the wifi networks I encounter in my travels.

Owen

---

From: "Brzozowski, John" <[email-masked]>
Date: Mon, 31 Mar 2014 20:30:07 +0000

IPv6 has been launched in MI, please contact me off list so I can verify for you specifically.  I have replied to several folks unicast.  So far the issue has either been old customer owned modems or customer owned CPE that has not been upgraded or enabled to support IPv6.  In one case I have the ball to launch IPv6 capable firmware for our commercial broadband device.

John

From: <Ackermann>, Mike Ackermann <[email-masked]<mailto:[email-masked]>>
Date: Monday, March 31, 2014 at 15:55
To: John Brzozowski <[email-masked]<mailto:[email-masked]>>, Nalini Elkins <[email-masked]<mailto:[email-masked]>>, Mikael Abrahamsson <[email-masked]<mailto:[email-masked]>>
Cc: v6ops <[email-masked]<mailto:[email-masked]>>
Subject: RE: [v6ops] Facebook v6 deployment

Thanks John

Thanks

Mike

John

Guys,

Nalini

---

From: "Brzozowski, John" <[email-masked]>
Date: Mon, 31 Mar 2014 20:31:36 +0000

Or if you prefer to buy your own make sure it supports IPv6 before you buy
it.

---

From: Bill Jouris <[email-masked]>
Date: Mon, 31 Mar 2014 13:41:23 -0700 (PDT)

I was thinking of wireless vs, for example, cable modem wired connections.  LTE may be better than WiFi, but still seems to struggle in comparison to wired.

Bill Jouris
Inside Products, Inc.
www.insidethestack.com
831-659-8360
925-855-9512 (direct)

________________________________
 From: Owen DeLong <[email-masked]>
To: Bill Jouris <[email-masked]> 
Cc: Gert Doering <[email-masked]>; IPv6 Operations <[email-masked]> 
Sent: Monday, March 31, 2014 1:26 PM
Subject: Re: [v6ops] Facebook v6 deployment

Owen

>I tend to
 forget...

---

From: Owen DeLong <[email-masked]>
Date: Mon, 31 Mar 2014 13:49:32 -0700

> I was thinking of wireless vs, for example, cable modem wired connections.  LTE may be better than WiFi, but still seems to struggle in comparison to wired.

I’m assuming that the wifi in hotels, conference centers, airports, etc. is some form of wired connection as you describe behind it. My performance problems generally don’t seem to be the wifi, but the wired connection behind it. Indeed, my LTE performance at home is better than if I had basic cable service, but I pay (a lot) extra for middle-tier service on a business line (more than I pay for LTE as a matter of fact) and it does, in fact, perform slightly better (LTE 30Mbps, Comcast 35-50Mbps).

Often, my LTE uplink performs better than my Comcast uplink.

Owen

---

From: "Ackermann, Michael" <[email-masked]>
Date: Mon, 31 Mar 2014 20:59:45 +0000

That sounds real good!    But unfortunately for me does not match what I experience.    More than 50% of the locations I have been in the past 6 months,  are 3G.   Of the 4G systems, only 2  I can remember ever being over 20 Mbps (never 30 for me).   Most of the time the 4G systems are below 5Mbps.   And very inconsistent during speed or throughput tests.
Where are you getting 30Mbps?    I am VERY jealous!

Thanks

Mike

From: v6ops [mailto:[email-masked]] On Behalf Of Owen DeLong
Sent: Monday, March 31, 2014 4:50 PM
To: Bill Jouris
Cc: IPv6 Operations
Subject: Re: [v6ops] Facebook v6 deployment

On Mar 31, 2014, at 1:41 PM, Bill Jouris <[email-masked]<mailto:[email-masked]>> wrote:

I'm assuming that the wifi in hotels, conference centers, airports, etc. is some form of wired connection as you describe behind it. My performance problems generally don't seem to be the wifi, but the wired connection behind it. Indeed, my LTE performance at home is better than if I had basic cable service, but I pay (a lot) extra for middle-tier service on a business line (more than I pay for LTE as a matter of fact) and it does, in fact, perform slightly better (LTE 30Mbps, Comcast 35-50Mbps).

Owen

Bill Jouris
Inside Products, Inc.
www.insidethestack.com<http://www.insidethestack.com>
831-659-8360
925-855-9512 (direct)

________________________________
From: Owen DeLong <[email-masked]<mailto:[email-masked]>>
To: Bill Jouris <[email-masked]<mailto:[email-masked]>>
Cc: Gert Doering <[email-masked]<mailto:[email-masked]>>; IPv6 Operations <[email-masked]<mailto:[email-masked]>>
Sent: Monday, March 31, 2014 1:26 PM
Subject: Re: [v6ops] Facebook v6 deployment

Owen

On Mar 31, 2014, at 8:31 AM, Bill Jouris <[email-masked]<mailto:[email-masked]>> wrote:

Bill Jouris
Inside Products, Inc.
www.insidethestack.com<http://www.insidethestack.com/>
831-659-8360
925-855-9512 (direct)

________________________________
From: Gert Doering <[email-masked]<mailto:[email-masked]>>
To: Nalini Elkins <[email-masked]<mailto:[email-masked]>>
Cc: IPv6 Operations <[email-masked]<mailto:[email-masked]>>
Sent: Monday, March 31, 2014 8:21 AM
Subject: Re: [v6ops] Facebook v6 deployment

Hi,

I tend to forget...

Gert Doering
        -- NetMaster

_______________________________________________
v6ops mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/v6ops

_______________________________________________
v6ops mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/v6ops

---

From: Owen DeLong <[email-masked]>
Date: Mon, 31 Mar 2014 14:06:54 -0700

> Where are you getting 30Mbps?    I am VERY jealous! 

San Jose bay area, NYC, Chicago, Seattle, Vancouver (BC), Los Angeles, San Diego, Sacamento, Portland, Austin, and many others.

The only place I’ve gotten the poor performance you describe recently has been Dallas and then only in a few locations like the airport and parts of Richardson.

Owen

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Mon, 31 Mar 2014 21:22:09 +0000

I’m going to say something that my co-chair probably wishes he could say, and can’t because of his position.

This working group is chartered to enable operators to talk with each other, and others to talk with operators, and either write documents that report on or improve the operational behavior of the IPv6 Internet, or advise other working groups that they should. Generic statements about networks and network operation are well in order, and reports of success or failure (“we got X going!” or “we tried it, and Y didn’t work for reasons {Z}”) are well in order. We are amused by, and tolerate, exuberance.

The recent diversion-of-a-thread re Comcast seemed a bit more like “going after a vendor of a service”. I’d suggest that if we want to quiz an operator over his (or her) service, that’s something to take up with the operator in private email.

Back to your regularly scheduled diatribes :-)

---

From: Erik Nygren <[email-masked]>
Date: Mon, 31 Mar 2014 14:22:55 -0700

I'd encourage people who haven't looked at IPv6 deployment statistics
recently to go and look at where we are now.  Over the past year or so a
number of the largest end-user networks in the U.S., Germany, and other
parts of Europe have been actively rolling out *native*  IPv6.  Some
reference points include:

      http://www.worldipv6launch.org/measurements/
      http://6lab.cisco.com/stats/

http://vyncke.org/ipv6status/compare.php?metric=p&countries=us,de,ch,be

https://blogs.akamai.com/2014/03/ipv6-by-the-numbers-strong-growth-in-second-half-of-2013.html

There are certainly ISPs that are way behind, but many at least do have
plans in-flight and are waiting on the the pioneers to work through the
issues with various vendors and hardware devices.  For those doing active
roll-outs, it is worth looking at some of the graphs at the worldipv6launch
list above.  Many are quietly rolling out IPv6 by city/market, so just
because it doesn't exist in your city doesn't mean that it won't quietly be
there soon.

For content providers, native IPv6 connectivity is available in data
centers all around the world (as well as from many CDNs and similar).  For
example, Akamai has been able to get working IPv6 from almost 500 network
partners in over 1000 locations in 76 countries.  So while there are
certainly

> Most large enterprises are just starting to learn to spell IPv6.  I talk
to quite few who say
> it is not even in their 5-year plan yet.  And these are MAJOR US
corporations.

I've run into some of the same, and I think many of these people will be
very surprised soon by the growth and will need to adjust those plans
ASAP.  One factor seems to be that after 15 years of "IPv6 any day now"
assumptions are made that adoption is still like it was a few years ago
(mostly tunnels, plus some native in smaller regions in Asia).  However,
now the reality is that many of the largest end-users in the world (in the
US, Germany, and elsewhere) are done with trials and turning the activation
crank.

       Erik

On Mon, Mar 31, 2014 at 7:08 AM, Nalini Elkins <
[email-masked]> wrote:

> You have got to be kidding.   Most large enterprises are just starting to
> learn to spell IPv6.  I talk to quite few who say it is not even in their
> 5-year plan yet.  And these are MAJOR US corporations.
>
> At home, I certainly can't get IPv6 native connectivity from my ISP or ANY
> ISP without paying huge amounts of money.   When our engineers do IPv6
> testing over the Internet we use IPv4 / IPv6  tunneling.
>

---

From: Nalini Elkins <[email-masked]>
Date: Mon, 31 Mar 2014 14:34:40 -0700 (PDT)

Guys,

John Brzozowski of Comcast has been EXTREMELY helpful & feels that indeed my area DOES have IPv6 service.   I will have to physically go to my local office with the modem & see what I have to do.
May have to swap out the equipment.

Unfortunately, it will take me a day or two to get to this because I have to actually do my day job!

Thanks very much, John!
 
Will report back on my progress.

Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

---

From: Ted Lemon <[email-masked]>
Date: Mon, 31 Mar 2014 17:44:56 -0400

> Often, my LTE uplink performs better than my Comcast uplink.

Mine does too, but Comcast doesn't bill by the gigabyte.   This is getting _really_ offtopic.

---

From: "Ackermann, Michael" <[email-masked]>
Date: Mon, 31 Mar 2014 21:47:43 +0000

Echoing!

John has helped several of us OFF LIST and his efforts are GREATLY appreciated!

Thanks JOHN!

From: v6ops [mailto:[email-masked]] On Behalf Of Nalini Elkins
Sent: Monday, March 31, 2014 5:35 PM
To: IPv6 Operations
Subject: [v6ops] Comcast IPv6

Guys,

Thanks very much, John!

Nalini Elkins
Inside Products, Inc.
(831) 659-8360