Subject: Re: [v6ops] I-D Action: draft-ietf-v6ops-ula-usage-recommendations-02.txt

From: Mikael Abrahamsson <[email-masked]>
Date: Thu, 6 Mar 2014 14:33:47 +0100 (CET)

In 3.3, it would probably be worthwhile to mention the replacement of 
RFC3484, ie RFC6724. If hosts implement RFC6724, running ULA for IPv6 
connectivity and only having IPv4 Internet connectivity means a lot less 
breakage. If hosts implement RFC3484 then breakage will most likely be 
greater.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: William Cerveny <[email-masked]>
Date: Mon, 10 Mar 2014 15:49:33 -0400

Posting onto the list with what I said at the v6ops meeting on Thursday:

I’ve been using a ULA in a test lab for perhaps 6 years.  They work fine
and serve our requirement for having a block of addresses that can be
routed within the test lab at a single location.  It is possible that at
some point we will want to route with a different test lab, for which we
wouldn’t want this traffic to leave either test lab. We aren’t routing
the traffic outside of the test lab and for our application it is
undesirable for our test traffic left the test lab.

I can think of two situations where ULAs would be more valuable in
“isolated” networks than GUAs would be:
1) We don’t ever want the traffic addressed with ULAs to leave the test
network. If we addressed with a GUA, it would be easier for the traffic
to be accidentally routed outside the test lab (I think Fred spelled out
this scenario).
2) There may be administratively complex or prohibitive challenges in
acquiring GUAs for specific projects. If one were to need addresses
(other than link-local addresses) for a small isolated network an
assigned GUA is unavailable, it could be desirable to use a ULA instead
of random address space.

Bill Cerveny

On Fri, Feb 14, 2014, at 05:13 AM, [email-masked] wrote:
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>  This draft is a work item of the IPv6 Operations Working Group of the
>  IETF.
> 
>         Title           : Recommendations of Using Unique Local Addresses
>         Authors         : Bing Liu
>                           Sheng Jiang
> 	Filename        : draft-ietf-v6ops-ula-usage-recommendations-02.txt
> 	Pages           : 15
> 	Date            : 2014-02-14
> 
> Abstract:
>    This document provides guidance of how to use ULAs. It analyzes ULA
>    usage scenarios and recommends use cases where ULA addresses might be
>    beneficially used.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-v6ops-ula-usage-recommendations/
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-ietf-v6ops-ula-usage-recommendations-02
> 
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-ietf-v6ops-ula-usage-recommendations-02
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Owen DeLong <[email-masked]>
Date: Mon, 10 Mar 2014 14:01:45 -0700

> to be accidentally routed outside the test lab (I think Fred spelled out

It might be easier for this to occur over a wider area of routing, but, I do not believe that it is any easier to accidentally route GUA somewhere than it is to accidentally route ULA there.

I will agree that it will be more obviously visible in the routing table if such were to occur, but the ability to misconfigure a router does not change simply by using ULA addresses.

> assigned GUA is unavailable, it could be desirable to use a ULA instead

I agree that in all cases where GUA is unavailable, ULA is a preferred alternative.

However, I will point out that the policies for obtaining GUA have been made very liberal and easy in most RIRs and that the requirements are barely above “I have a network I want to number with IPv6 addresses. Please assign me a prefix. Kthxbye.”

IMHO, this is desirable.

My point is that we should avoid recommending ULA+NPT for hosts that are communicating to the outside world because NPT and all other forms of NAT should be considered harmful.

Owen