Subject: [v6ops] JANOG34 provides 3.2.1 and 3.2.2

From: Shishio Tsuchiya <[email-masked]>
Date: Fri, 27 Jun 2014 19:27:39 +0900

Leo and v6ops
F.Y.I
JANOG(JApan Network Operator's Group) decided to provide ula address to the JANOG34 conference network.
http://www.janog.gr.jp/en/index.php?JANOG34_Meeting

They will provide 3.2.1. ULA-only Deployment and 3.2.2. ULA along with GUA.
http://tools.ietf.org/html/draft-ietf-v6ops-ula-usage-recommendations-02

If you would like to confirm something on the network , please let me know.

Regards,
-Shishio

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Sat, 28 Jun 2014 00:58:09 +0000

> If you would like to confirm something on the network , please let me know.

Thanks for this.

I would expect that the key things to prove are the statements in the draft. Also, any observations that might come up would be useful. For example, was it fair to say that the network that was isolated remained isolated? Did using a ULA and a GUA on a globally-accessible network cause any issues? What, if anything, was necessary in the router(s) in question to prevent hosts from using ULA source addresses to connect to GUA addresses? Did hosts in fact form both ULA and GUA-based addresses and use them appropriately when connecting to applications inside and outside the network? 

What one might hope would be that ULA-based addresses were used to connect to other ULA-based addresses, as their bit strings were most similar, and GUA-based addresses were used to connect to other GUA-based addresses, for the same reason. One might hope that ULA prefixes were not announced in BGP without needing extra thought, and that if they were announced, they were not accepted. One might further hope that when a ULA was not announced into a neighboring domain, a packet sent to the ULA prefix didn’t cross the domain boundary.

Of course, we need to hear about any extra work that was required, and any problems that arose. And we need to understand if the deployment of a ULA prefix necessarily implied the deployment of an IPv6/IPv6 NAT or NAPT. I don’t expect that it will and am certainly not asking for it to, but that expectation has been promoted.

JANOG will be Wednesday-Friday the week before IETF 90, and v6ops will meet Monday and Tuesday. It would be nice if someone could make a point of reporting on the experiment.

---

From: "Liubing (Leo)" <[email-masked]>
Date: Mon, 30 Jun 2014 04:10:40 +0000

Hi Shishio,

Thanks much for sharing the information. It's great that JANOG34 will provide more experience of using ULAs.

Basically I agree with Fred that it is important to see whether the statements of the draft is correct. In addition to Fred's comments, I have some other concerns:
- Is it easy to configure a host with ULA+PA? E.g., both through SLAAC or through SLAAC/DHCPv6 respectively.
- Are there still many hosts using the old address selection algorithm [3484]? Since [RFC3484] hosts will face the problem of selecting un-expected ULA-PA source/destination address pairs.
- Let me confirm the ULA-only Deployment in JANOG34, did you mean "connect to the Internet through ULA-only" or "ULA-only in an isolated network or for internal use only"? (The 3.2.1 of the draft specifically means the former.) 

Best regards,
Bing

> -----Original Message-----
> From: Fred Baker (fred) [mailto:[email-masked]]
> Sent: Saturday, June 28, 2014 8:58 AM
> To: Shishio Tsuchiya (shtsuchi)
> Cc: Liubing (Leo); [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [v6ops] JANOG34 provides 3.2.1 and 3.2.2
> 
> 
> I would expect that the key things to prove are the statements in the draft.
> Also, any observations that might come up would be useful. For example,
> was it fair to say that the network that was isolated remained isolated? Did
> using a ULA and a GUA on a globally-accessible network cause any issues?
> What, if anything, was necessary in the router(s) in question to prevent hosts
> from using ULA source addresses to connect to GUA addresses? Did hosts in
> fact form both ULA and GUA-based addresses and use them appropriately
> when connecting to applications inside and outside the network?
> 
> What one might hope would be that ULA-based addresses were used to
> connect to other ULA-based addresses, as their bit strings were most similar,
> and GUA-based addresses were used to connect to other GUA-based
> addresses, for the same reason. One might hope that ULA prefixes were not
> announced in BGP without needing extra thought, and that if they were
> announced, they were not accepted. One might further hope that when a
> ULA was not announced into a neighboring domain, a packet sent to the ULA
> prefix didn't cross the domain boundary.
> 
> Of course, we need to hear about any extra work that was required, and any
> problems that arose. And we need to understand if the deployment of a ULA
> prefix necessarily implied the deployment of an IPv6/IPv6 NAT or NAPT. I
> don't expect that it will and am certainly not asking for it to, but that
> expectation has been promoted.
> 
> JANOG will be Wednesday-Friday the week before IETF 90, and v6ops will
> meet Monday and Tuesday. It would be nice if someone could make a point
> of reporting on the experiment.

---

From: Shishio Tsuchiya <[email-masked]>
Date: Mon, 30 Jun 2014 13:15:14 +0900

Fred
Thanks.
Report on experience @v6ops is good idea.
Unfortunately I can't go to ietf90 , so I  will ask help to janoger who can attend both and report the experience to v6ops.
Anyway I will post the report to v6ops after janog34.

Regards,
-Shishio

---

From: Shishio Tsuchiya <[email-masked]>
Date: Mon, 30 Jun 2014 13:48:44 +0900

Leo
> - Is it easy to configure a host with ULA+PA? E.g., both through SLAAC or through SLAAC/DHCPv6 respectively.

This is good point.
I will confirm about how to assign ipv6 address to users.

> - Are there still many hosts using the old address selection algorithm [3484]? Since [RFC3484] hosts will face the problem of selecting un-expected ULA-PA source/destination address pairs.

Yes, this is the most interesting for me.
If we can confirm a lot of client it would be great implementation report of RFC3484.

> - Let me confirm the ULA-only Deployment in JANOG34, did you mean "connect to the Internet through ULA-only" or "ULA-only in an isolated network or for internal use only"? (The 3.2.1 of the draft s…

"connect to the Internet through ULA-only"
I think we can check utilization of tcp port for each of client on CGN.

Regards,
-Shishio

> .