Subject: [v6ops] FW: New Version Notification for draft-ietf-v6ops-dhcpv6-slaac-problem-01.txt

From: "Liubing (Leo)" <[email-masked]>
Date: Wed, 18 Jun 2014 08:47:08 +0000

Hi all,

We've uploaded a new version of the draft.

This version doesn't have much technical changes, but lots of re-wording and some structure adjustment.
1. The test results are totally removed to the Appendix, so that the main body is focusing on common problems, rather than detailed behavior of some specific operating systems. 
Because the implementation is always evolving, even different versions of the same vendor might have different behavior. The point of the draft is to caution the administrators, as long as the ambiguity exists in the standard, there are possible problems they might face. The test results are only an instance/proof of the ambiguity problem, it should not be the main content.
But as some people suggested, we'll refresh the test of newest operation systems when the document could be published in the future.
2. The structure was adjusted, to emphasize the problem statement as a standalone Section 3.
3. Some titles were changed as well
4. Not a few re-wording both in main body and the appendix

Your comments are welcomed.

Many thanks!

Best regards,
Bing (on behalf of all co-authors)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, June 18, 2014 4:33 PM
To: Ron Bonica; Ron Bonica; Xiangyang Gong; Liubing (Leo); Wendong Wang; Liubing (Leo); Xiangyang Gong; Wendong Wang
Subject: New Version Notification for draft-ietf-v6ops-dhcpv6-slaac-problem-01.txt

A new version of I-D, draft-ietf-v6ops-dhcpv6-slaac-problem-01.txt
has been successfully submitted by Bing Liu and posted to the IETF repository.

Name:		draft-ietf-v6ops-dhcpv6-slaac-problem
Revision:	01
Title:		DHCPv6/SLAAC Address Configuration Interaction Problem Statement
Document date:	2014-06-18
Group:		v6ops
Pages:		12
URL:            http://www.ietf.org/internet-drafts/draft-ietf-v6ops-dhcpv6-slaac-problem-01.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-v6ops-dhcpv6-slaac-problem/
Htmlized:       http://tools.ietf.org/html/draft-ietf-v6ops-dhcpv6-slaac-problem-01
Diff:           http://www.ietf.org/rfcdiff?url2=draft-ietf-v6ops-dhcpv6-slaac-problem-01

Abstract:
   This document analyzes the DHCPv6/SLAAC interaction issue on host.
   More specifically, the interaction is regarding with the A, M, and O
   flags which are defined in ND protocol. Test results identify that
   current implementations in operating systems have varied on
   interpreting the flags. The variation might cause some operational
   issues as described in the document.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Karsten Thomann <[email-masked]>
Date: Thu, 19 Jun 2014 18:44:26 +0200

Hi,

one short question regarding the Introduction:
   And there is an O (OtherConfig) flag, if set, indicating
   configure information other than addresses (e.g. DNS, Route .etc) is
   available through DHCPv6 configuration.
What I've missed that it is possible to distribute any routing information in 
DHCPv6?

Regards
Karsten

Am Mittwoch, 18. Juni 2014, 08:47:08 schrieb Liubing:
> This version doesn't have much technical changes, but lots of re-wording 
and
> some structure adjustment. 1. The test results are totally removed to 
the
> Appendix, so that the main body is focusing on common problems, 
rather than
> detailed behavior of some specific operating systems. Because the
> implementation is always evolving, even different versions of the same
> vendor might have different behavior. The point of the draft is to caution
> the administrators, as long as the ambiguity exists in the standard, 
there
> are possible problems they might face. The test results are only an
> instance/proof of the ambiguity problem, it should not be the main 
content.
> But as some people suggested, we'll refresh the test of newest 
operation
> systems when the document could be published in the future. 2. The
> structure was adjusted, to emphasize the problem statement as a 
standalone
> Section 3. 3. Some titles were changed as well
> To: Ron Bonica; Ron Bonica; Xiangyang Gong; Liubing (Leo); Wendong 
Wang;
> Liubing (Leo); Xiangyang Gong; Wendong Wang Subject: New Version
> Notification for draft-ietf-v6ops-dhcpv6-slaac-problem-01.txt
> 
> 
> URL:           
> http://www.ietf.org/internet-drafts/draft-ietf-v6ops-dhcpv6-slaac-problem-0
> 1.txt Status:        
> https://datatracker.ietf.org/doc/draft-ietf-v6ops-dhcpv6-slaac-problem/
> Htmlized:      
> http://tools.ietf.org/html/draft-ietf-v6ops-dhcpv6-slaac-problem-01 Diff:  
>        
> http://www.ietf.org/rfcdiff?url2=draft-ietf-v6ops-dhcpv6-slaac-problem-01
> 
> Abstract:
> Please note that it may take a couple of minutes from the time of 
submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Thu, 19 Jun 2014 16:52:53 +0000

> What I've missed that it is possible to distribute any routing information in DHCPv6?
No ... Routing information for IPv6 is handled by Neighbor Discovery. See http://www.isc.org/blogs/routing-configuration-over-dhcpv6-2/.

There have been several attempts at this - see http://tools.ietf.org/html/draft-ietf-mif-dhcpv6-route-option for an example of one attempt.

-          Bernie

From: v6ops [mailto:[email-masked]] On Behalf Of Karsten Thomann
Sent: Thursday, June 19, 2014 12:44 PM
To: [email-masked]
Subject: Re: [v6ops] FW: New Version Notification for draft-ietf-v6ops-dhcpv6-slaac-problem-01.txt

Hi,

What I've missed that it is possible to distribute any routing information in DHCPv6?

Regards

Karsten

> This version doesn't have much technical changes, but lots of re-wording and

> some structure adjustment. 1. The test results are totally removed to the

> Appendix, so that the main body is focusing on common problems, rather than

> the administrators, as long as the ambiguity exists in the standard, there

> instance/proof of the ambiguity problem, it should not be the main content.

> But as some people suggested, we'll refresh the test of newest operation

> structure was adjusted, to emphasize the problem statement as a standalone

> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]

> To: Ron Bonica; Ron Bonica; Xiangyang Gong; Liubing (Leo); Wendong Wang;

> has been successfully submitted by Bing Liu and posted to the IETF

> repository.

> Please note that it may take a couple of minutes from the time of submission

> [email-masked]<mailto:[email-masked]>

---

From: Karsten Thomann <[email-masked]>
Date: Thu, 19 Jun 2014 19:58:23 +0200

That's the same link I already read, and that draft expired over one year ago.
I know that there were several attempts to implement it, but I won't use it as 
an example, if it is until now not standardized.

I would like to replace the route withfor example NTP, DNS Suffix or 
Bootserver...

Am Donnerstag, 19. Juni 2014, 16:52:53 schrieb Bernie Volz:
> No ... Routing information for IPv6 is handled by Neighbor Discovery. See
> http://www.isc.org/blogs/routing-configuration-over-dhcpv6-2/.
> 
> There have been several attempts at this - see
> http://tools.ietf.org/html/draft-ietf-mif-dhcpv6-route-option for an
> example of one attempt.
> 
> 
> -          Bernie
> 
> Subject: Re: [v6ops] FW: New Version Notification for
> draft-ietf-v6ops-dhcpv6-slaac-problem-01.txt
> 
> 
> Hi,
> 
> 
> 
> > http://www.ietf.org/internet-drafts/draft-ietf-v6ops-dhcpv6-slaac-problem-> > 0
> > 
> > 1.txt Status:
> >

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Thu, 19 Jun 2014 18:18:36 +0000

That sounds fine.

There are plenty of options to use as of potential interest to clients ...

http://www.iana.org/assignments/dhcpv6-parameters/dhcpv6-parameters.xml#dhcpv6-parameters-2

- Bernie

-----Original Message-----
From: Karsten Thomann [mailto:[email-masked]] 
Sent: Thursday, June 19, 2014 1:58 PM
To: Bernie Volz (volz)
Cc: [email-masked]
Subject: Re: [v6ops] FW: New Version Notification for draft-ietf-v6ops-dhcpv6-slaac-problem-01.txt

That's the same link I already read, and that draft expired over one year ago.
I know that there were several attempts to implement it, but I won't use it as an example, if it is until now not standardized.

I would like to replace the route withfor example NTP, DNS Suffix or Bootserver...

Am Donnerstag, 19. Juni 2014, 16:52:53 schrieb Bernie Volz:
> No ... Routing information for IPv6 is handled by Neighbor Discovery. 
> See http://www.isc.org/blogs/routing-configuration-over-dhcpv6-2/.
>