Subject: [v6ops] I-D Action: draft-ietf-v6ops-mobile-device-profile-08.txt

From: [email-masked]
Date: Mon, 11 Aug 2014 06:21:08 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the IPv6 Operations Working Group of the IETF.

        Title           : An Internet Protocol Version 6 (IPv6) Profile for 3GPP Mobile Devices
        Authors         : David Binet
                          Mohamed Boucadair
                          Ales Vizdal
                          Cameron Byrne
                          Gang Chen
	Filename        : draft-ietf-v6ops-mobile-device-profile-08.txt
	Pages           : 18
	Date            : 2014-08-11

Abstract:
   This document defines an IPv6 profile that a number of operators
   recommend in order to connect 3GPP mobile devices to an IPv6-only or
   dual-stack wireless network (including 3GPP cellular network and IEEE
   802.11 network).

   This document defines a different profile than the one for general
   connection to IPv6 cellular networks defined in the IPv6 for Third
   Generation Partnership Project (3GPP) Cellular Hosts document.  In
   particular, this document identifies also features to deliver IPv4
   connectivity service over an IPv6-only transport.

   Both hosts and devices with capability to share their WAN (Wide Area
   Network) connectivity are in scope.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-v6ops-mobile-device-profile/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-v6ops-mobile-device-profile-08

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-v6ops-mobile-device-profile-08

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Ross Chandler <[email-masked]>
Date: Tue, 12 Aug 2014 15:41:10 +0100

> 	Filename        : draft-ietf-v6ops-mobile-device-profile-08.txt

Hi All,

I support this useful draft.

An item I’d like to see added to the “Connectivity Recommendations” list after C_REC#12 is.

   C_REC#??:  Because of the potential for separate parallel IPv4 and 
              IPv6 PDP/PDN connections when the network or subscriber 
              profile does not support IPv4v6 PDP-Contexts, the cellular
	      host must be able to be configured to exclude this type
              from the available options.

For example if the list was just IPv4 or IPv6 (with 464XLAT implied) then the cellular host 
would only ever attempt to set-up a single stack connection. 

I note that with:
	Android the options are IPv4, IPv6 and IPv4/IPv6.
	Windows Phone 8.1 the options are IPv4, IPv6, IPv4v6 and IPv4v6XLAT

Best regards,
Ross

---

From: <[email-masked]>
Date: Wed, 13 Aug 2014 10:53:10 +0000

Hi Ross,

Thank you for the support.

As for your proposed REC, wouldn't be appropriate to generalize the recommendation? e.g.:

   C_REC#x:   The cellular host must be able to be configured to limit
              PDP type(s) for a given APN.  The default mode is to allow
              all supported PDP types.  Note, C_REC#3 discusses the
              default behavior for requesting PDP-Context type(s).

If needed, the text can call out why this is needed (v4v6 not supported, subscriber profile, service-specific constraints (e.g., VoLTE), etc.

BTW, C_REC#12 already hints that PDP types can be limited. I'm particularly referring to this sentence:

"Note, distinct PDP type(s) can
              be configured for home and roaming cases."

Cheers,
Med

De : v6ops [mailto:[email-masked]] De la part de Ross Chandler
Envoyé : mardi 12 août 2014 16:41
À : IPv6 Ops WG
Objet : Re: [v6ops] I-D Action: draft-ietf-v6ops-mobile-device-profile-08.txt

On 11 Aug 2014, at 14:21, [email-masked]<mailto:[email-masked]> wrote:

Hi All,

An item I'd like to see added to the "Connectivity Recommendations" list after C_REC#12 is.

I note that with:

Best regards,
Ross

---

From: Ross Chandler <[email-masked]>
Date: Wed, 13 Aug 2014 12:28:24 +0100

Hi Med,

I agree it would be more appropriate to have it as a generalised recommendation, with the text explaining the situation where it might be considered useful to have it.

The reason I worded it like that was modelled on C_REC#12 which has an opening sentence explaining why it is needed, rather than just stating the requirement and having the explanation in the text. I suggested that it be placed after C_REC#12 in recognition that it is a similar type of recommendation.

Generalised this C_REC might also be useful when it comes to sunseting requests for IPv4 from UEs in 3GPP networks.

BR
Ross

On 13 Aug 2014, at 11:53, <[email-masked]> <[email-masked]> wrote:

> As for your proposed REC, wouldn’t be appropriate to generalize the recommendation? e.g.:
>  
> BTW, C_REC#12 already hints that PDP types can be limited. I’m particularly referring to this sentence:
>  
> “Note, distinct PDP type(s) can
>               be configured for home and roaming cases.”
>  
> Cheers,
> Med
>

---

From: <[email-masked]>
Date: Wed, 13 Aug 2014 12:59:49 +0000

Re-,

I updated my local copy with this NEW text:

   C_REC#12:  The cellular host must be able to be configured to limit
              PDP type(s) for a given APN.  The default mode is to allow
              all supported PDP types.  Note, C_REC#3 discusses the
              default behavior for requesting PDP-Context type(s).

                 This feature is useful to drive the behavior of the UE
                 to be aligned with: (1) service-specific constraints
                 such as the use of IPv6-only for VoLTE (Voice over
                 LTE), (2) network conditions with regards to the
                 support of specific PDP types (e.g., IPv4v6 PDP-Context
                 is not supported), (3) IPv4 sunset objectives, (4)
                 subscription data, etc.

Please let me know if this is OK or more text is needed.

Thank you.

Cheers,
Med

De : Ross Chandler [mailto:[email-masked]]
Envoyé : mercredi 13 août 2014 13:28
À : BOUCADAIR Mohamed IMT/OLN
Cc : IPv6 Ops WG
Objet : Re: [v6ops] I-D Action: draft-ietf-v6ops-mobile-device-profile-08.txt

Hi Med,

BR
Ross

On 13 Aug 2014, at 11:53, <[email-masked]<mailto:[email-masked]>> <[email-masked]<mailto:[email-masked]>> wrote:

Hi Ross,

Cheers,
Med

Hi All,

I note that with:

Best regards,
Ross

---

From: <[email-masked]>
Date: Wed, 13 Aug 2014 13:14:59 +0000

Dear all,

Joel has kindly provided suggestions to address some concerns raised during the IETF LC. Those suggestions have been implemented in this new version.

We hope to see the document advance in the publication process. 

Cheers,
Med

>-----Message d'origine-----
>De : v6ops [mailto:[email-masked]] De la part de internet-
>[email-masked]
>Envoyé : lundi 11 août 2014 15:21
>À : [email-masked]
>Cc : [email-masked]
>Objet : [v6ops] I-D Action: draft-ietf-v6ops-mobile-device-profile-08.txt
>
>
>_______________________________________________
>v6ops mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/v6ops

---

From: Ross Chandler <[email-masked]>
Date: Wed, 13 Aug 2014 14:48:22 +0100

Hi Med,

That looks good. 

I understand the existing C_REC#12 remains in the document and the two are listed together.

BR 
Ross

---

From: <[email-masked]>
Date: Wed, 13 Aug 2014 13:54:05 +0000

Re-,

Yes, I confirm.

A new version with this new item will be available online soon.

Thank you.

Cheers,
Med

De : Ross Chandler [mailto:[email-masked]]
Envoyé : mercredi 13 août 2014 15:48
À : BOUCADAIR Mohamed IMT/OLN
Cc : IPv6 Ops WG
Objet : Re: [v6ops] I-D Action: draft-ietf-v6ops-mobile-device-profile-08.txt

On 13 Aug 2014, at 13:59, <[email-masked]<mailto:[email-masked]>> <[email-masked]<mailto:[email-masked]>> wrote:

Re-,

Hi Med,

That looks good.

BR
Ross

Hi Med,

BR
Ross

Hi Ross,

Cheers,
Med

Hi All,

I note that with:

Best regards,
Ross

---

From: joel jaeggli <[email-masked]>
Date: Wed, 13 Aug 2014 20:30:21 -0700

> We hope to see the document advance in the publication process. 

Thank the authors for their diligent efforts. I think some of the
explanatory text as the beginning of each section goes a ways towards
establishing a rational for the recommendations.

I now fine it very hard to read as normative requirements (this is a
good thing), so I would hope that we can look at the substance of the
recommendations with the stakes reduced.