Subject: Re: [v6ops] I-D Action: draft-ietf-v6ops-ipv6-roaming-analysis-02.txt

From: Ross Chandler <[email-masked]>
Date: Thu, 07 Aug 2014 06:47:06 +0100

Well Telenor have done us all a service. They've made it simple. We all now have to turn on IPv6 in the user-plane.
Ross

<div>-------- Original message --------</div><div>From: Tore Anderson <[email-masked]> </div><div>Date:07/08/2014  6:28 a.m.  (GMT+00:00) </div><div>To: Ross Chandler <[email-masked]>,IPv6 Ops WG <[email-masked]> </div><div>Subject: Re: [v6ops] I-D Action: draft-ietf-v6ops-ipv6-roaming-analysis-02.txt </div><div>
</div>* Ross Chandler

>> It might be that when the UE visits a network that doesn’t allow
>> IPv6 in the user-plane Android behaviour is kicking in.
>> 
>> I’ve been told that Android treats all APNs as “roughly equal”.
>> 
>> If the new IPv6-only-without-IPv4-fallback APN fails then Android
>> might be trying the IPv4 one.
> 
> If this is what’s going on in Telenor case the plus is it maximises
> the number of roaming partners that come up with IPv6 but at the
> possible cost of indeterminism on which APN the UE settles on using
> when it gets back home.

I'm fairly certain there is no such indeterminism.

Basically the UEs get set up to request IPv6 PDP type both home and when
roaming. So when they establish a data bearer they get IPv6 (+464XLAT)
no matter where in the world they are, or they get no data bearer at all
(if there's some sort of problem somewhere).

That Telenor feels confident in doing it in this manner is very good
news, I think. It reminds me of the World IPv6 Launch, actually - where
it was decided that the bugs and issues that had previously made it
unsafe to deploy IPv6 on a global scale (as opposed to a select few
known good networks, corresponding well to "the home PLMN only" in the
mobile case), has been sufficiently solved so that IPv6 can be made
generally available instead.

I guess now it's up to Cameron and Michał to follow suit. ;-)

Tore

---

From: Ross Chandler <[email-masked]>
Date: Fri, 08 Aug 2014 05:17:43 +0100

Hi Gang,
In a draft about 3gpp roaming failure modes when using IPv6 or IPv4v6 PDP/PDN connections it is fairly natural to have some references like that. It can probably be done in a way that is consistent with the normal form of an I-D.
BR
Ross

<div>-------- Original message --------</div><div>From: GangChen <[email-masked]> </div><div>Date:08/08/2014  2:25 a.m.  (GMT+00:00) </div><div>To: "holger.metschulat" <[email-masked]>,Ross Chandler <[email-masked]> </div><div>Cc: IPv6 Ops WG <[email-masked]> </div><div>Subject: Re: [v6ops] I-D Action: draft-ietf-v6ops-ipv6-roaming-analysis-02.txt </div><div>
</div>2014-08-07 19:16 GMT+08:00, Ross Chandler <[email-masked]>:
>
> On 7 Aug 2014, at 11:47, <[email-masked]>
> <[email-masked]> wrote:
>
>> But then, ticking the correct “I am IPv6 capable" and "I am IPv4v6
>> capable" boxes in the IR.21 database should not be forgotten...
>
> AFAIK the latest version of IR.21 is version 9.1 (05 July 2013)
>
> Relevant sections look like:
>
> Section ID: 16   on Packet Data Services Information
>
> Section ID: 20   on LTE Roaming Information
>
> Both are optional sections, but it is clearly good practise to update them,
> and seeing entries being made should help encourage other operators to also
> deploy IPv6.

Yes. Uploading your IR.21 database with IPv6 capable and IPv4v6
capable is definitely helpful. Should this be encouraged in the draft?

Gang

> Ross
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>