Subject: [v6ops] new draft: draft-vyncke-v6ops-happy-eyeballs-cookie

From: [email-masked]
Date: Wed, 29 Oct 2014 08:08:20 -0700

A new draft has been posted, at http://tools.ietf.org/html/draft-vyncke-v6ops-happy-eyeballs-cookie. Please take a look at it and comment.

---

From: Joe Touch <[email-masked]>
Date: Thu, 30 Oct 2014 15:14:27 -0700

> A new draft has been posted, at http://tools.ietf.org/html/draft-vyncke-v6ops-happy-eyeballs-cookie. Please take a look at it and comment.

Under potential mitigations, is there a reason not to refer to the use
of alternate (non-IP address) host IDs?

E.g., as noted in RFC 6967 and
draft-boucadair-intarea-host-identifier-scenarios.

Joe

---

From: Erik Nygren <[email-masked]>
Date: Thu, 30 Oct 2014 18:22:05 -0400

It's unclear if the solution space here is the same as for host IDs?  In
particular, that draft talks about "remote servers are not able to
distinguish between hosts sharing the same IP address" whereas here the
case is "remote servers are not able to distinguish that a single host uses
multiple IP addresses, some of which may be shared with other hosts".  In
particular, the multiple IP addresses in the multi-homing context may not
even be in the same administrative domain.

   Erik

On Thu, Oct 30, 2014 at 6:14 PM, Joe Touch <[email-masked]> wrote:

> > A new draft has been posted, at
> http://tools.ietf.org/html/draft-vyncke-v6ops-happy-eyeballs-cookie.
> Please take a look at it and comment.
>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Joe Touch <[email-masked]>
Date: Thu, 30 Oct 2014 15:42:52 -0700

On 10/30/2014 3:22 PM, Erik Nygren wrote:
> case is "remote servers are not able to distinguish that a single host
> uses multiple IP addresses, some of which may be shared with other
> hosts". 

Yes, the role of client and server is reversed, but in both cases the
issue is the same:

	a single host using multiple IP addresses

The key issue for this doc is that the addresses are IPv4 and IPv6, but
the potential solutions remain relevant, AFAICT.

> In particular, the multiple IP addresses in the multi-homing
> context may not even be in the same administrative domain.

That affects *some* of the solutions, but not all.

Joe

> 
>    Erik
> 
> 
> On Thu, Oct 30, 2014 at 6:14 PM, Joe Touch <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
> 
> 
>     On 10/29/2014 8:08 AM, [email-masked] <mailto:[email-masked]> wrote:
>     [email-masked] <mailto:[email-masked]>