Subject: [v6ops] IPv6 & iOS9 - interesting factoids in this Ars Technica post

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 16 Jun 2015 18:52:30 +0000

http://arstechnica.com/apple/2015/06/apple-to-ios-devs-ipv6-only-cell-service-is-coming-soon-get-your-apps-ready/

---

From: Mikael Abrahamsson <[email-masked]>
Date: Wed, 17 Jun 2015 05:23:09 +0200 (CEST)

> http://arstechnica.com/apple/2015/06/apple-to-ios-devs-ipv6-only-cell-service-is-coming-soon-get-your-apps-ready/

https://developer.apple.com/videos/wwdc/2015/?id=719 is the talk that 
discussed this directly. Well worth spending an hour on.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Erik Kline <[email-masked]>
Date: Wed, 17 Jun 2015 15:10:51 +0900

> discussed this directly. Well worth spending an hour on.

Sigh.

    "Streaming is available in Safari, and through the WWDC app."

---

From: Mikael Abrahamsson <[email-masked]>
Date: Wed, 17 Jun 2015 08:13:45 +0200 (CEST)

>    "Streaming is available in Safari, and through the WWDC app."

There is a download link at the bottom right, and vlc and mplayer can play 
these streams.

Yes, I agree that it's a pain, but...

Actually, if you paste 
<http://devstreaming.apple.com/videos/wwdc/2015/719ui2k57m/719/719_hd_your_app_and_next_generation_networks.mp4?dl=1> 
into "open network stream" in VLC, it'll stream it just fine.

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 17 Jun 2015 19:36:20 +0200

> discussed this directly. Well worth spending an hour on.

Thanks Mikael for the pointer. It's good it is described at that length 
- 1 hour.  It's an opportunity to learn before the others where these 
products go with respect to IPv6.  But I dont have that hour :-)

I would like to know though what kind of IPv6 is made mandatory in that 
manufacturer's smartphones.

Is it using ULAs?

Is it using DHCPv6?  Prefix Delegation?

Is it using NAT66 or not?

To those who spent that hour may know...

Alex

---

From: Ca By <[email-masked]>
Date: Wed, 17 Jun 2015 10:38:04 -0700

On Wed, Jun 17, 2015 at 10:36 AM, Alexandru Petrescu <
[email-masked]> wrote:

> Thanks Mikael for the pointer. It's good it is described at that length -
> 1 hour.  It's an opportunity to learn before the others where these
No

> Is it using DHCPv6?  Prefix Delegation?
No

> Is it using NAT66 or not?
No

> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 18 Jun 2015 11:30:28 +0200

Then is it using 64share?  CLAT?

Alex

Le 17/06/2015 19:38, Ca By a écrit :
>
>
> On Wed, Jun 17, 2015 at 10:36 AM, Alexandru Petrescu
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Thanks Mikael for the pointer. It's good it is described at that
>     length - 1 hour.  It's an opportunity to learn before the others
>     where these products go with respect to IPv6.  But I dont have that
>     hour :-)
>
>     I would like to know though what kind of IPv6 is made mandatory in
>     that manufacturer's smartphones.
>
>     Is it using ULAs?
>
>
> No
>
>     [email-masked] <mailto:[email-masked]>

---

From: Ross Chandler <[email-masked]>
Date: Thu, 18 Jun 2015 11:04:23 +0100

> On 18 Jun 2015, at 10:30, Alexandru Petrescu <[email-masked]> wrote:
> 

I don’t see any mention of the 464xlat CLAT or 64share in their presentation. 

Single IPv6-only APN designs for handset and tethered IPv4 traffic don’t seem to be supported yet. 

Ross

---

From: Czerwonka Michał 1 - Hurt <[email-masked]>
Date: Thu, 18 Jun 2015 10:09:19 +0000

https://developer.apple.com/videos/wwdc/2015/?id=719   and get PDF

slide 26

What Works?
IPv4 address literals, in NAT64 + DNS64 networks
New for OS X 10.11 and iOS 9
Use higher-layer networking frameworks
• NSURLSession and CFNetwork-layer APIs
Client supplies IPv4 address Literal
• OS synthesizes IPv6 address

BR,
Mcz

-----Original Message-----
From: v6ops [mailto:[email-masked]] On Behalf Of Ross Chandler
Sent: Thursday, June 18, 2015 12:04 PM
To: Alexandru Petrescu
Cc: IPv6 Ops WG
Subject: Re: [v6ops] IPv6 & iOS9 - interesting factoids in this Ars Technica post

Ross

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 18 Jun 2015 19:26:01 +0200

Right, thanks for the pdf method.

> • OS synthesizes IPv6 address

  looks like a method to make IPv4 work in the hotspot of a smartphone 
connected to an IPv6-only APN.

Maybe we have to wait to see IPv6 work in the hotspot of a smartphone 
connected to an IPv6-only APN.

Akex

---

From: Ross Chandler <[email-masked]>
Date: Thu, 18 Jun 2015 19:30:06 +0100

> On 18 Jun 2015, at 18:26, Alexandru Petrescu <[email-masked]> wrote:
> 
> looks like a method to make IPv4 work in the hotspot of a smartphone connected to an IPv6-only APN.
> 
> Maybe we have to wait to see IPv6 work in the hotspot of a smartphone connected to an IPv6-only APN.
> 
> Akex

It would be nice if anyone can clarify if “Client supplies IPv4 address Literal - OS synthesizes IPv6 address” is Apple’s way of saying they’ve implemented 464xlat.

Ross

---

From: Mikael Abrahamsson <[email-masked]>
Date: Thu, 18 Jun 2015 20:33:38 +0200 (CEST)

On Thu, 18 Jun 2015, Ross Chandler wrote:

> It would be nice if anyone can clarify if “Client supplies IPv4 address 
> Literal - OS synthesizes IPv6 address” is Apple’s way of saying they’ve 
> implemented 464xlat.

My take on this is "no". I believe they've implemented the heuristics of 
discovering the NAT64 prefix and do the "bump-in-the-API" approach to 
supporting IPv4 literals for their high-level APIs.

---

From: Paul Saab <[email-masked]>
Date: Thu, 18 Jun 2015 18:38:20 +0000

> supporting IPv4 literals for their high-level APIs.

It is a "bump-in-the-API" approach, not 464xlat