Subject: Re: [v6ops] draft-ietf-v6ops-pmtud-ecmp-problem WGLC

From: joel jaeggli <[email-masked]>
Date: Sun, 7 Jun 2015 12:02:41 -0700

On 5/31/15 4:45 PM, Brian E Carpenter wrote:
> Hi,
> 
> Generally I think this is useful and almost ready.
> 
>> 3.1.  Alternatives
>>
>>    As an alternative, it may be appropriate to lower the TCP MSS to 1220
>>    in order to accommodate 1280 byte MTU.  We consider this undesirable
>>    as hosts may not be able to independently set TCP MSS by address-
>>    family thereby impacting IPv4, or alternatively that it relies on a
>>    middle-box to clamp the MSS independently from the end-systems.
> 
> The "that" in the second sentence doesn't parse. I don't understand
> what the draft is trying to say about MSS clamping.

Is this better?

or alternatively that middle-boxes need to be employed to clamp the MSS
independently from the end-systems.

> Also, shouldn't we say "undesirable but possibly necessary in some
> cases"? A server at the mercy of an ISP might *need* to apply MSS clamping.

since we are dealing with alternative mitigations we are justifying why
we don't like them, I thin they can be employed.

> Nit:
> 
> It's confusing to have these two sections with identical titles:
> 
>> 3.1.  Alternatives
>> 3.2.1.  Alternatives
> 
> Maybe 3.1 should be "MSS-based Alternatives"
> and 3.2.1 "Distributed Proxy Alternatives"

nice.

thanks

>    Brian
> On 01/06/2015 06:00, [email-masked] wrote:
>> This is to initiate a two week working group last call of
>> http://tools.ietf.org/html/draft-ietf-v6ops-pmtud-ecmp-problem.  
>> Please read it now. If you find nits (spelling errors, minor suggested
>> wording changes, etc), comment to the authors; if you find greater
>> issues, such as disagreeing with a statement or finding additional
>> issues that need to be addressed, please post your comments to the
>> list.
>>
>> We are looking specifically for comments on the importance of the
>> document as well as its content. If you have read the document and
>> believe it to be of operational utility, that is also an important
>> comment to make.
>>
>> _______________________________________________
>> v6ops mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/v6ops
>>
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 08 Jun 2015 08:10:46 +1200

> independently from the end-systems.

That's fine.

   Brian

---

From: Mark ZZZ Smith <[email-masked]>
Date: Tue, 9 Jun 2015 10:09:23 +0000 (UTC)

________________________________
From: joel jaeggli <[email-masked]>
To: Brian E Carpenter <[email-masked]>; [email-masked] 
Sent: Monday, 8 June 2015, 5:02
Subject: Re: [v6ops] draft-ietf-v6ops-pmtud-ecmp-problem WGLC

Is this better?

/ I think it is also necessary to point out that the 1220 MSS value doesn't allow for any EHs if the packet size is limited / being limited to 1280. Middle boxes should also be taking into account the present EHs if they adjust the TCP MSS.

nice.

thanks

---

From: joel jaeggli <[email-masked]>
Date: Tue, 9 Jun 2015 22:44:00 -0700

It's worth noting i suppose, as a potential contributor to mtu size
issues I think we can do that. if you send extension header containing
packets or fragments to my servers, pmtud is maybe isn't the biggest
problem because they'll never arrive.  :/