Subject: [v6ops] Letting apps select outbound path

From: "STARK, BARBARA H" <[email-masked]>
Date: Thu, 21 Jul 2016 14:06:48 +0000

In response to the comment about operators not wanting to let hosts determine path...
That's not relevant to the discussion of letting hosts or apps on hosts select the outbound link to use for their traffic in a multi homed environment. The selection is already under the host / app control through source address selection. The question is how to allow the host/app to make an informed decision. 
Barbara

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 22 Jul 2016 03:24:39 +1200

> That's not relevant to the discussion of letting hosts or apps on hosts select the outbound link to use for their traffic in a multi homed environment. The selection is already under the host / app…

And that is where the path probing performed by shim6 came in, and the effective
probing done by MPTCP comes in. I never really understood why the operators hated
shim6 with such a passion, but that's another story. They don't seem to hate MPTCP
the same way.

    Brian

---

From: Tim Chown <[email-masked]>
Date: Thu, 21 Jul 2016 15:39:48 +0000

> On 21 Jul 2016, at 16:24, Brian E Carpenter <[email-masked]> wrote:
> 

But was that really the issue, or was it simply crappy handling of (especially “unknown") IPv6 Extension Headers?

Regardless, choice of path from a home or an enterprise shouldn’t be of interest to an ISP, should it? In the IPv6 multi-addressed multihoming model, they shouldn’t even need to know if you have one or more other ISPs connected to your network. All you’d expect is that they BCP38 what they take from you.

Tim

---

From: Gert Doering <[email-masked]>
Date: Thu, 21 Jul 2016 17:43:28 +0200

Hi,

> That's not relevant to the discussion of letting hosts or apps on hosts select the outbound link to use for their traffic in a multi homed environment. The selection is already under the host / app…

I haven't followed the discussion, but I assume it's the usual 
misunderstanding that not all networks are borne equal.

In a fully managed, administrator controlled enterprise environment, having
hosts decide routing policy is a no-go area.

In a homenet / SOHO environment, there is no administrator, and nobody
will install policies in "WAN devices" - so the host *MUST* make the 
decision, because nobody else is around.  As Barbara said: giving the
host data to make this an *informed* decision is good.

Gert Doering
        -- NetMaster
-- 
have you enabled IPv6 on something today...?

SpaceNet AG                        Vorstand: Sebastian v. Bomhard
Joseph-Dollinger-Bogen 14          Aufsichtsratsvors.: A. Grundner-Culemann
D-80807 Muenchen                   HRB: 136055 (AG Muenchen)
Tel: +49 (0)89/32356-444           USt-IdNr.: DE813185279

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 22 Jul 2016 03:52:47 +1200

> hosts decide routing policy is a no-go area.

Sure. But nobody ever proposed that - all the host can do is select
a source/destination address pair. That impacts where the packets flow
but doesn't touch routing policy itself.

    Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 22 Jul 2016 03:54:05 +1200

> But was that really the issue, or was it simply crappy handling of (especially “unknown") IPv6 Extension Headers?

That came later, the NANOG abreaction was long before we discovered how bad that
problem was.

    Brian

---

From: Gert Doering <[email-masked]>
Date: Thu, 21 Jul 2016 19:20:33 +0200

Hi,

> but doesn't touch routing policy itself.

In a fully controlled environment, you don't want the hosts to make
decisions (unless directed by configured policy).  I just wanted to 
point out that "enterprise" and "SOHO" are really totally different
problem spaces regarding multihoming and "who makes decisions?".

Gert Doering
        -- NetMaster

---

From: Joe Touch <[email-masked]>
Date: Thu, 21 Jul 2016 10:22:13 -0700

On 22/07/2016 02:06, STARK, BARBARA H wrote:

> That's not relevant to the discussion of letting hosts or apps on hosts select the outbound link to use for their traffic in a multi homed environment. The selection is already under the host / app control through source address selection. 

A source address might be bound to multiple interfaces.

Existing requirements account for the application having control over
the source and destination L3 *address*, nothing more. They do NOT
control interface selection except as a *side effect* of controlling
those addresses.

Joe

---

From: Joe Touch <[email-masked]>
Date: Thu, 21 Jul 2016 10:29:21 -0700

> control interface selection except as a *side effect* of controlling

PS - to see the confusion that ensues when you release control from the
forwarding plane to anyone else, see RFC 3884. I.e., let's not let apps
create the kind of problems that came out of IPsec tunnel mode when it
tried to embed forwarding control outside the IP data plane.

Joe

---

From: "Toerless Eckert (eckert)" <[email-masked]>
Date: Thu, 21 Jul 2016 20:00:16 +0000

Host has 2 addresses == configured policy.

If your where an enterprise and your SP recommended you to set dscp for traffic according to the app requirements to get best results. How would you do that ?

typos = smartphone

On Jul 21, 2016 7:21 PM, Gert Doering <[email-masked]> wrote:
Hi,

Gert Doering
        -- NetMaster

---

From: Gert Doering <[email-masked]>
Date: Thu, 21 Jul 2016 22:14:57 +0200

Hi,

> If your where an enterprise and your SP recommended you to set dscp for traffic according to the app requirements to get best results. How would you do that ?

Please do not mix in arbitrary complications.  This was about address
selection, and address selection influencing ISP selection.

Gert Doering
        -- NetMaster

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 22 Jul 2016 19:04:46 +1200

> selection, and address selection influencing ISP selection.

Yes, I think we can't add that layer of complexity here. Possibly this
is covered by the MIF provisioning domain concept? (If you believe in that
particular kind of magic, that is.) Or by a connection manager.

   Brian

---

From: "Toerless Eckert (eckert)" <[email-masked]>
Date: Fri, 22 Jul 2016 09:47:30 -0700

*sigh*

I brought that up to help me understand what the term "fully controlled"
would mean in other similar contexts. Its just not very helpful to say
"can't do MultiPrefix because fully conrolled network" when you're not
willing to explain what "Fully controlled" is supposed to mean.

I didn't mean at all to say that we should bother about DSCP design in this 
discussion.

Enterprises should definitely have the ability to define/control source address
selection through enterprise operator defined policy. But we'd need to start
collecting what those policies should be to design the right solution. And
yes, if hosts / apps override the target policy we need security to prohibit this.
Thats not differrent from any other security policy (DSCP comes to mind,
or if thats a red flag any other firewall / security functions).

And lets also understand that there will be fewer and fewer enterprise specific
apps, so we'd definitely be well advised to come up with a host model where
apps can develop against the expectation to support whats desired in the
home, and then also work well in an enterprise.

Cheers
    Toerless