Subject: [v6ops] IETF meeting with IPv6 routes over IPv4?

From: Philip Matthews <[email-masked]>
Date: Mon, 24 Oct 2016 16:52:55 -0400

I have a memory that there was an IETF meeting some years ago where the IPv6 connectivity used BGP sessions where the IPv6 routes were carried over an BGP session that ran over IPv4 transport.  Does anyone remember which meeting that was, and why this was done?  We are updating the BGP section in the Design Choices draft and are considering mentioning this.

-Philip

---

From: Hemant Singh <[email-masked]>
Date: Mon, 24 Oct 2016 17:51:20 -0400

I suspect it would have been a MPLS network which supported only IPv4 MPLS
at the time and thus carried IPv6 BGP routers over IPv4 transport.

Hemant

On Mon, Oct 24, 2016 at 4:52 PM, Philip Matthews <[email-masked]>
wrote:

> I have a memory that there was an IETF meeting some years ago where the
> IPv6 connectivity used BGP sessions where the IPv6 routes were carried over
> an BGP session that ran over IPv4 transport.  Does anyone remember which
> meeting that was, and why this was done?  We are updating the BGP section
> in the Design Choices draft and are considering mentioning this.
>
> -Philip
> _______________________________________________
>

---

From: Philip Matthews <[email-masked]>
Date: Wed, 26 Oct 2016 15:13:16 -0400

Hemant:

I don't think that was the reason.  I know of a number of networks running IPv4 MPLS that carry IPv6 BGP routes over IPv6 transport.

-Philip

On 2016-10-24, at 17:51 , Hemant Singh wrote:

> I suspect it would have been a MPLS network which supported only IPv4 MPLS at the time and thus carried IPv6 BGP routers over IPv4 transport.  
> 
> Hemant
> 
> 
> On Mon, Oct 24, 2016 at 4:52 PM, Philip Matthews <[email-masked]> wrote:

---

From: Warren Kumari <[email-masked]>
Date: Sun, 30 Oct 2016 13:04:24 +0100

> I have a memory that there was an IETF meeting some years ago where the IPv6 connectivity used BGP sessions where the IPv6 routes were carried over an BGP session that ran over IPv4 transport.  Doe…

You are probably thinking of IETF81, IETF84 or IETF88.

For some reason Telus (who very kindly donate circuits) like to
provide a single BGP peering, and carry both IPv4 and IPv6 over it.

I cannot remember the justification, but I'll try find more / grab the
archived configs where we rewrite the next hop...

W

> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: Philip Matthews <[email-masked]>
Date: Mon, 31 Oct 2016 22:21:18 -0400

Warren:

Thanks for your reply.

I really don't remember which meeting it was, but I attended both IETF84 and IETF88, so I might have heard it at one of those meetings.

If you have any ability to find out more about their justification, that would be interesting. I'll try myself through my own contacts.  For now, the draft just says that sometimes one needs to do this.

- Philip