Subject: [v6ops] possible path forward with RFC7084 and transition/other stuff

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 21 Jul 2017 09:51:40 +0200

Hi all,

We will like to know the WG opinions on this.

(I’m sending this email after checking with the WG chairs if they agree on it)

Yesterday during the bits-N-bytes here in Prague, a few of us (in copy), have a chat about a possible path forward with the RFC7084-bis and related docs.

If I understood correctly, we somehow agreed that a possible path is (let’s call this CHOICE 1):
1) Not change/update the existing RFC7084.
2) Use my “Transition Requirements for IPv6 Customer Edge Routers” document (draft-palet-v6ops-rfc7084-bis-transition-00) as a starting point, which “extend” the requirements of RFC7084 towards supporting actual world transition requirements.
3) In this updated document, the transition requirements can then be a MUST, so vendors take it seriously.
4) I will include the reference to RFC8026 (some more text, as this reference is already in all my docs regarding this topic), so there is a “flow” of how the pair “ISP-CE” can get working IPv6 and then IPv4 if it is available from the ISP “as a service”. I think this can have also what Fred was suggesting as “IPv6 must be on by default”, right?

CHOICE 2 (to make it clear, my own toughs after waking up this morning, not discussed with the other folks yesterday):
Same as choice 1 above, but include also support for HNCP and may be something else if we believe it is required during the development of this document (for example it seems clear that if we offer IPv4 as a service, because actual multicast-based IPTV services run on IPv4, we need to keep supporting that on top of an IPv6-only access).
So then the document will be renamed to something such as “Transition and extended requirements for IPv6 CE routers”.

Tim, Barbara, James, can you confirm if I got right choice 1, or misunderstood/missed anything?

WG participants, could you provide your view on those two options?

Tim (Winters), could you tell from the perspective of the IPv6 Ready Logo Program your view on those two approaches?

It will be nice to be able to double check all the inputs from yesterday v6ops sessions, but looking at the etherpad I can’t see them, so may be the note takers were using something else. It is possible to access the minutes already someway? I will like to start working on this immediately …

Thanks!

Regards,
Jordi

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Fri, 21 Jul 2017 09:25:13 +0000

> 2) Use my “Transition Requirements for IPv6 Customer Edge Routers”
> document (draft-palet-v6ops-rfc7084-bis-transition-00) as a starting point,
> which “extend” the requirements of RFC7084 towards supporting actual
> world transition requirements.
> 4) I will include the reference to RFC8026 (some more text, as this reference
> is already in all my docs regarding this topic), so there is a “flow” of how the
> pair “ISP-CE” can get working IPv6 and then IPv4 if it is available from the ISP
> “as a service”. I think this can have also what Fred was suggesting as “IPv6
> must be on by default”, right?

I would support this. If your goal really is encouraging the availability of CE routers with these v4 over v6 technologies, this is the approach I would recommend.

> CHOICE 2 (to make it clear, my own toughs after waking up this morning, not
> discussed with the other folks yesterday):
> Same as choice 1 above, but include also support for HNCP and may be
> something else if we believe it is required during the development of this
> document (for example it seems clear that if we offer IPv4 as a service,
> because actual multicast-based IPTV services run on IPv4, we need to keep
> supporting that on top of an IPv6-only access).
> So then the document will be renamed to something such as “Transition and
> extended requirements for IPv6 CE routers”.

I would not support this. I think it would make the document less focused and therefore more likely to be ignored.

Barbara

---

From: <[email-masked]>
Date: Fri, 21 Jul 2017 10:51:49 +0000

Hi Jordi, all,

I agree with Barbara, here. 

I do see a vale in not obsoleting 7084. So scoping your document accordingly is the right approach to adopt here.  

I would not add the flow to restate what is already in 8026. Citing it would be sufficient, IMO.

Cheers,
Med

> -----Message d'origine-----
> De : v6ops [mailto:[email-masked]] De la part de STARK, BARBARA H
> Envoyé : vendredi 21 juillet 2017 11:25
> À : [email-masked]; [email-masked]
> Cc : james woodyatt
> Objet : Re: [v6ops] possible path forward with RFC7084 and
> transition/other stuff
> 
> 
> 
> I would support this. If your goal really is encouraging the availability
> of CE routers with these v4 over v6 technologies, this is the approach I
> would recommend.
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Nick Hilliard <[email-masked]>
Date: Fri, 21 Jul 2017 12:00:28 +0100

> WG participants, could you provide your view on those two options?

I haven't seen much deployment of HNCP, so at this stage it would
probably be premature to state it as a requirement in a CPE router
scenario.  Otherwise, option 1 looks great, so go for it!

Nick