Subject: [v6ops] [*SPAM* Score/Req: 3.5/3.3] possible path forward with RFC7084 and transition/other stuff

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 21 Jul 2017 09:48:15 +0200

Hi all,

We will like to know the WG opinions on this.

(I’m sending this email after checking with the WG chairs if they agree on it)

Yesterday during the bits-N-bytes here in Prague, a few of us (in copy), have a chat about a possible path forward with the RFC7084-bis and related docs.

If I understood correctly, we somehow agreed that a possible path is (let’s call this CHOICE 1):
1) Not change/update the existing RFC7084.
2) Use my “Transition Requirements for IPv6 Customer Edge Routers” document (draft-palet-v6ops-rfc7084-bis-transition-00) as a starting point, which “extend” the requirements of RFC7084 towards supporting actual world transition requirements.
3) In this updated document, the transition requirements can then be a MUST, so vendors take it seriously.
4) I will include the reference to RFC8026 (some more text, as this reference is already in all my docs regarding this topic), so there is a “flow” of how the pair “ISP-CE” can get working IPv6 and then IPv4 if it is available from the ISP “as a service”. I think this can have also what Fred was suggesting as “IPv6 must be on by default”, right?

CHOICE 2 (to make it clear, my own toughs after waking up this morning, not discussed with the other folks yesterday):
Same as choice 1 above, but include also support for HNCP and may be something else if we believe it is required during the development of this document (for example it seems clear that if we offer IPv4 as a service, because actual multicast-based IPTV services run on IPv4, we need to keep supporting that on top of an IPv6-only access).
So then the document will be renamed to something such as “Transition and extended requirements for IPv6 CE routers”.

Tim, Barbara, James, can you confirm if I got right choice 1, or misunderstood/missed anything?

WG participants, could you provide your view on those two options?

Tim (Winters), could you tell from the perspective of the IPv6 Ready Logo Program your view on those two approaches?

It will be nice to be able to double check all the inputs from yesterday v6ops sessions, but looking at the etherpad I can’t see them, so may be the note takers were using something else. It is possible to access the minutes already someway? I will like to start working on this immediately …

Thanks!

Regards,
Jordi

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Ted Lemon <[email-masked]>
Date: Fri, 21 Jul 2017 09:59:25 +0200

I am not enthusiastic about making changes at this time, first because I
think there's no urgency, and second because I do not know what "require
HNCP" means.   Can you elaborate?

On Fri, Jul 21, 2017 at 9:48 AM, JORDI PALET MARTINEZ <
[email-masked]> wrote:

> Yesterday during the bits-N-bytes here in Prague, a few of us (in copy),
> have a chat about a possible path forward with the RFC7084-bis and related
> docs.
>
> 2) Use my “Transition Requirements for IPv6 Customer Edge Routers”
> document (draft-palet-v6ops-rfc7084-bis-transition-00) as a starting
> point, which “extend” the requirements of RFC7084 towards supporting actual
> world transition requirements.
> 4) I will include the reference to RFC8026 (some more text, as this
> reference is already in all my docs regarding this topic), so there is a
> “flow” of how the pair “ISP-CE” can get working IPv6 and then IPv4 if it is
> available from the ISP “as a service”. I think this can have also what Fred
> was suggesting as “IPv6 must be on by default”, right?
>
> CHOICE 2 (to make it clear, my own toughs after waking up this morning,
> not discussed with the other folks yesterday):
> Same as choice 1 above, but include also support for HNCP and may be
> something else if we believe it is required during the development of this
> document (for example it seems clear that if we offer IPv4 as a service,
> because actual multicast-based IPTV services run on IPv4, we need to keep
> supporting that on top of an IPv6-only access).
> So then the document will be renamed to something such as “Transition and
> extended requirements for IPv6 CE routers”.
>
> Tim (Winters), could you tell from the perspective of the IPv6 Ready Logo
> Program your view on those two approaches?
>
> It will be nice to be able to double check all the inputs from yesterday
> v6ops sessions, but looking at the etherpad I can’t see them, so may be the
> note takers were using something else. It is possible to access the minutes
> already someway? I will like to start working on this immediately …
>
> Thanks!
>
> Regards,
> Jordi
>
>
>
>
> This electronic message contains information which may be privileged or
> confidential. The information is intended to be for the use of the
> individual(s) named above. If you are not the intended recipient be aware
> that any disclosure, copying, distribution or use of the contents of this
> information, including attached files, is prohibited.
>
>
>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>