Subject: Re: [v6ops] question about draft-ietf-v6ops-unique-ipv6-prefix-per-host-06 (was draft-jjmb-v6ops-unique-ipv6-prefix-per-host)

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 03 Jul 2017 09:56:31 +0200

Note: Of course, I was referring to the latest version draft-ietf-v6ops-unique-ipv6-prefix-per-host-06, not sure how I miscopied the wrong one in the subject.

I’m not sure my question was understood. You need to “read” the document as if you never followed the discussion in the list and is the first time you read the document.

What I mean is that, reading the document a “new” reader may understand that only hosts with a single link may use this, and I think the original goal is that a unique IPv6 prefix can be used by a host and not just in one interface, but in any of the interfaces.

One possible solution for that is to look for a better title, for example:
- Unique IPv6 Prefix Per Host/Link
- Unique IPv6 Prefix Per Host/Interface

Another possible solution is to clarify it in the text, or both choices together.

I know the document don’t say something such as “this can only be applied to a single interface”, but is not either clarifying that it works as well for multiple interfaces/link in the same host.

Some possible text improvements for that:
New p., at the end of the abstract:
This approach may be used also in several interfaces of a single host.

Actual:
This document will focus upon the process for UEs to obtain a unique
   IPv6 prefix.

New:
This document will focus upon the process for UEs to obtain a unique
   IPv6 prefix and it may also happen in several interfaces.

Actual:
The Best Current Practice documented in this note is to provide a
   unique IPv6 prefix to hosts/subscribers devices

New:
The Best Current Practice documented in this note is to provide a
   unique IPv6 prefix to hosts/subscribers devices (and if needed to several of their interfaces)

Actual:
The architected result of designing the RA as documented above is
   that each UE/subscriber gets its own unique IPv6 prefix for which it

New:
The architected result of designing the RA as documented above is
   that each UE/subscriber gets its own unique IPv6 prefix (and if needed at multiple interfaces) for which it

Regards,
Jordi

-----Mensaje original-----
De: Ole Troan <[email-masked]>
Responder a: <[email-masked]>
Fecha: lunes, 3 de julio de 2017, 9:23
Para: Lorenzo Colitti <[email-masked]>
CC: Jordi Palet Martinez <[email-masked]>, "[email-masked] WG" <[email-masked]>
Asunto: Re: [v6ops] question about draft-jjmb-v6ops-unique-ipv6-prefix-per-host

    > -1
    > 
    > I think "per host" is the best title. It clearly explains that the network provides a unique prefix for every host. Of course, a host may be connected to other networks at the same time, but that is true whether this draft is in use or not.
    > 
    > "Per link" is not a good title, because a link almost always has a unique prefix, even though in general there may be many hosts on it.
    
    in my implementation I have a unique link per host.
    
    Ole

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Lorenzo Colitti <[email-masked]>
Date: Mon, 3 Jul 2017 17:03:45 +0900

On Mon, Jul 3, 2017 at 4:56 PM, JORDI PALET MARTINEZ <
[email-masked]> wrote:

> What I mean is that, reading the document a “new” reader may understand
> that only hosts with a single link may use this, and I think the original
> goal is that a unique IPv6 prefix can be used by a host and not just in one
> interface, but in any of the interfaces.
>

I don't think using the same prefix on multiple interfaces is necessarily a
goal The goal is to route an entire prefix to a host, such that different
hosts are guaranteed to have different prefixes.

> This approach may be used also in several interfaces of a single host.

That is true of *any* IP addressing mechanism. All existing mechanisms for
IP address assignment (SLAAC, manual configuration, DHCPv6, ...) can be
used on multiple interfaces simultaneously.

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 03 Jul 2017 10:06:47 +0200

I guess I’m not good describing what I want to say …

What I mean is that a host can be connected to multiple networks, and it may need to use a single prefix (from each network, not the same prefix in different ones).

Regards,
Jordi

-----Mensaje original-----
De: Lorenzo Colitti <[email-masked]>
Responder a: <[email-masked]>
Fecha: lunes, 3 de julio de 2017, 10:03
Para: Jordi Palet Martinez <[email-masked]>
CC: "[email-masked] WG" <[email-masked]>
Asunto: Re: [v6ops] question about draft-ietf-v6ops-unique-ipv6-prefix-per-host-06 (was draft-jjmb-v6ops-unique-ipv6-prefix-per-host)

    On Mon, Jul 3, 2017 at 4:56 PM, JORDI PALET MARTINEZ <[email-masked]> wrote:

    
    I don't think using the same prefix on multiple interfaces is necessarily a goal The goal is to route an entire prefix to a host, such that different hosts are guaranteed to have different prefixes.

    
    That is true of *any* IP addressing mechanism. All existing mechanisms for IP address assignment (SLAAC, manual configuration, DHCPv6, ...) can be used on multiple interfaces simultaneously.