Subject: Re: [v6ops] draft-templin-v6ops-pdhost a working group draft?

From: <[email-masked]>
Date: Sat, 10 Mar 2018 07:08:23 -0500

> Please review and comment on the latest draft version (below). Would like to
> see support for this as a working group item, as it provides value to the
> community.

I support this as a WG draft.

😊

Russ

---

From: "Templin, Fred L" <[email-masked]>
Date: Tue, 13 Mar 2018 15:15:51 +0000

Thanks Russ,

Others have also expressed their support in earlier posts:

https://www.ietf.org/mail-archive/web/v6ops/current/msg28663.html
https://www.ietf.org/mail-archive/web/v6ops/current/msg28675.html
https://www.ietf.org/mail-archive/web/v6ops/current/msg28746.html

There was also quite a bit of list discussion about it back in the Nov-Dec
timeframe since IETF100.

Fred

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Saturday, March 10, 2018 4:08 AM
> To: Templin, Fred L <[email-masked]>; [email-masked]
> Subject: RE: [v6ops] draft-templin-v6ops-pdhost a working group draft?
> 
>

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 14 Mar 2018 17:23:38 +0000

To add to what I said yesterday, to my understanding this qualifies the
work to be added to the IETF101 agenda. Please confirm.

> From: v6ops [mailto:[email-masked]] On Behalf Of Templin, Fred L
> Sent: Tuesday, March 13, 2018 8:16 AM
> To: [email-masked]; [email-masked]
> Subject: Re: [v6ops] draft-templin-v6ops-pdhost a working group draft?
> 
> Thanks Russ,
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 15 Mar 2018 05:23:49 +0000

v6ops chairs,

My understanding from what I have been told in the past is that, in order
to get a meeting agenda slot for a document, there needs to be discussion
on the list and people expressing support for adoption. This document
has seen both of those, so please add 'draft-templin-v6ops-pdhost' to
the agenda - 10mins should be fine.

Thanks - Fred

> Sent: Wednesday, March 14, 2018 10:24 AM
> To: [email-masked]

---

From: Fred Baker <[email-masked]>
Date: Thu, 15 Mar 2018 05:47:44 -0400

> On Mar 15, 2018, at 1:23 AM, Templin, Fred L <[email-masked]> wrote:
> 
> v6ops chairs,
> 

I have updated the agenda at https://datatracker.ietf.org/meeting/101/materials/agenda-101-v6ops

I would't actually agree that support for adoption is required; that comes when we want to discuss adoption. And for adoption, on a mailing list with 1000 people, of which 100-200 show up at meetings, four (and with the author, five) doesn't constitute a consensus. What I have told you is that people need to show operational interest in the draft - "this would be useful in my environment". What the chairs are looking for in the case of pdhost is people saying "that would be a useful model for me to deploy in my data center or other environment".

---

From: Mikael Abrahamsson <[email-masked]>
Date: Thu, 15 Mar 2018 13:44:49 +0100 (CET)

On Thu, 15 Mar 2018, Fred Baker wrote:

> I would't actually agree that support for adoption is required; that 
> comes when we want to discuss adoption. And for adoption, on a mailing 
> list with 1000 people, of which 100-200 show up at meetings, four (and 
> with the author, five) doesn't constitute a consensus. What I have told 
> you is that people need to show operational interest in the draft - 
> "this would be useful in my environment". What the chairs are looking 
> for in the case of pdhost is people saying "that would be a useful model 
> for me to deploy in my data center or other environment".

Hi,

I would like to be able to delegate lots of addresses to hosts/routers, 
using something that has the properties of what we can currently do in RA, 
ie zero-lifetime things very quickly (and other aspects). I agree with 
Fred in that there is a need to do what he wants to do.

I might not agree in the exact details in his proposals, but I believe we 
should work on this problem, either here or in 6man.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 15 Mar 2018 14:02:53 +0100

+1

Saludos,
Jordi
 
-----Mensaje original-----
De: v6ops <[email-masked]> en nombre de Mikael Abrahamsson <[email-masked]>
Organización: People's Front Against WWW
Fecha: jueves, 15 de marzo de 2018, 13:45
Para: Fred Baker <[email-masked]>
CC: "[email-masked]" <[email-masked]>
Asunto: Re: [v6ops] draft-templin-v6ops-pdhost a working group draft?

    
    Hi,

    

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Ole Troan <[email-masked]>
Date: Thu, 15 Mar 2018 15:31:40 +0100

Mikael,

> I would like to be able to delegate lots of addresses to hosts/routers, using something that has the properties of what we can currently do in RA, ie zero-lifetime things very quickly (and other aspects). I agree with Fred in that there is a need to do what he wants to do.
> 

Could you elaborate on the requirements, so that we can understand what is missing in the existing mechanisms?

Ole

---

From: David Farmer <[email-masked]>
Date: Thu, 15 Mar 2018 13:10:29 -0500

On Thu, Mar 15, 2018 at 4:47 AM, Fred Baker <[email-masked]>
wrote:

> I would't actually agree that support for adoption is required; that comes
> when we want to discuss adoption. And for adoption, on a mailing list with
> 1000 people, of which 100-200 show up at meetings, four (and with the
> author, five) doesn't constitute a consensus. What I have told you is that
> people need to show operational interest in the draft - "this would be
> useful in my environment". What the chairs are looking for in the case of
> pdhost is people saying "that would be a useful model for me to deploy in
> my data center or other environment".
>

I'll say I'm interested in the deployment model of assigning hosts whole
/64 prefixes. I'm pushing my vendors (router and WiFi systems) to support
RFC8273 now. I'd actaully prefer a DHCPv6-PD in the host model.  However,
until at least one large OS vendor includes this capability in their base
software, deployment in my campus environment is pointless.

So please count me as operationally interested in this model, I'm not yet
ready to say this draft is the one that should carry the torch for the
model, but I have a great interest in the model of DHCPv6-PD to the host.

Thanks.

===============================================
David Farmer               Email:[email-masked]
Networking & Telecommunication Services
Office of Information Technology
University of Minnesota
2218 University Ave SE        Phone: 612-626-0815
Minneapolis, MN 55414-3029   Cell: 612-812-9952
===============================================

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 15 Mar 2018 23:30:52 +0000

Hi David,

> but I have a great interest in the model of DHCPv6-PD to the host.

That is good to know. You would probably be interested in reviewing
and/or experimenting with our code:

https://www.ietf.org/mail-archive/web/v6ops/current/msg28860.html
https://www.ietf.org/mail-archive/web/v6ops/current/msg29024.html

Thanks for your interest,

Fred

From: David Farmer [mailto:[email-masked]]
Sent: Thursday, March 15, 2018 11:10 AM
To: Fred Baker <[email-masked]>
Cc: Templin, Fred L <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [v6ops] draft-templin-v6ops-pdhost a working group draft?

On Thu, Mar 15, 2018 at 4:47 AM, Fred Baker <[email-masked]<mailto:[email-masked]>> wrote:

I'll say I'm interested in the deployment model of assigning hosts whole /64 prefixes. I'm pushing my vendors (router and WiFi systems) to support RFC8273 now. I'd actaully prefer a DHCPv6-PD in the host model.  However, until at least one large OS vendor includes this capability in their base software, deployment in my campus environment is pointless.

So please count me as operationally interested in this model, I'm not yet ready to say this draft is the one that should carry the torch for the model, but I have a great interest in the model of DHCPv6-PD to the host.

Thanks.

David Farmer               Email:[email-masked]<mailto:[email-masked]>