Subject: Re: [v6ops] I-D Action: draft-ietf-v6ops-transition-ipv4aas-04.txt

From: Yannis Nikolopoulos <[email-masked]>
Date: Wed, 4 Jul 2018 18:32:27 +0300

Hi,

just a nit to pick:

    1
    <https://tools.ietf.org/html/draft-ietf-v6ops-transition-ipv4aas-04#section-1>.
    Introduction

    ...

    These routers are likely to rely upon "Basic Requirements for IPv6
    Customer Edge Routers" ([RFC7084 <https://tools.ietf.org/html/rfc7084>])

and then:

    3
    <https://tools.ietf.org/html/draft-ietf-v6ops-transition-ipv4aas-04#section-3>.
    Requirements

    The IPv6 Transition CE Router MUST comply with [RFC7084 <https://tools.ietf.org/html/rfc7084>] (Basic
    Requirements for IPv6 Customer Edge Routers)

Also, as an operator who deals with CPE vendors, I need to really 
complain about having 2 RFCs instead of 7084bis.

cheers,

Yannis

On 06/25/2018 10:51 AM, JORDI PALET MARTINEZ wrote:
> Hi all,
>
>
>
> We have uploaded a new version of this draft.
>
>
>
> No major changes, just the text for the transition requirements (but not an actual change from the previous version).
>
>
>
> https://datatracker.ietf.org/doc/draft-ietf-v6ops-transition-ipv4aas/?include_text=1
>
>
>
> Regards,
>
> Jordi
>
>   
>
>   
>
>
>
> -----Mensaje original-----
>
> De: v6ops <[email-masked]> en nombre de <[email-masked]>
>
> Fecha: lunes, 25 de junio de 2018, 9:42
>
> Para: <[email-masked]>
>
> CC: <[email-masked]>
>
> Asunto: [v6ops] I-D Action: draft-ietf-v6ops-transition-ipv4aas-04.txt
>
>
>
>      
>
>      A New Internet-Draft is available from the on-line Internet-Drafts directories.
>
>      This draft is a work item of the IPv6 Operations WG of the IETF.
>
>      
>
>              Title           : Requirements for IPv6 Customer Edge Routers to Support IPv4 Connectivity as-a-Service
>
>              Authors         : Jordi Palet Martinez
>
>                                Hans M.-H. Liu
>
>                                Masanobu Kawashima
>
>      	Filename        : draft-ietf-v6ops-transition-ipv4aas-04.txt
>
>      	Pages           : 21
>
>      	Date            : 2018-06-25
>
>      
>
>      Abstract:
>
>         This document specifies the IPv4 service continuity requirements for
>
>         an IPv6 Customer Edge (CE) router, either provided by the service
>
>         provider or thru the retail market.
>
>      
>
>         Specifically, this document extends the "Basic Requirements for IPv6
>
>         Customer Edge Routers" in order to allow the provisioning of IPv6
>
>         transition services for the support of "IPv4 as-a-Service" (IPv4aaS)
>
>         by means of new transition mechanisms.  The document only covers
>
>         transition technologies for delivering IPv4 in IPv6-only access
>
>         networks, commonly called "IPv4 as-a-Service" (IPv4aaS), as required
>
>         in a world where IPv4 addresses are no longer available, so hosts in
>
>         the customer LANs with IPv4-only or IPv6-only applications or
>
>         devices, requiring to communicate with IPv4-only services at the
>
>         Internet, are still able to do so.
>
>      
>
>      
>
>      The IETF datatracker status page for this draft is:
>
>      https://datatracker.ietf.org/doc/draft-ietf-v6ops-transition-ipv4aas/
>
>      
>
>      There are also htmlized versions available at:
>
>      https://tools.ietf.org/html/draft-ietf-v6ops-transition-ipv4aas-04
>
>      https://datatracker.ietf.org/doc/html/draft-ietf-v6ops-transition-ipv4aas-04
>
>      
>
>      A diff from the previous version is available at:
>
>      https://www.ietf.org/rfcdiff?url2=draft-ietf-v6ops-transition-ipv4aas-04
>
>      
>
>      
>
>      Please note that it may take a couple of minutes from the time of submission
>
>      until the htmlized version and diff are available at tools.ietf.org.
>
>      
>
>      Internet-Drafts are also available by anonymous FTP at:
>
>      ftp://ftp.ietf.org/internet-drafts/
>
>      
>
>      _______________________________________________
>
>      v6ops mailing list
>
>      [email-masked]
>
>      https://www.ietf.org/mailman/listinfo/v6ops
>
>      
>
>
>
>
> **********************************************
> IPv4 is over
> Are you ready for the new Internet ?
> http://www.consulintel.es
> The IPv6 Company
>
> This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.
>
>
>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Sat, 07 Jul 2018 13:39:29 +0200

Hi Yannis,

Thanks a lot for your input!

I think we just need to change in the intro that text to:

“These routers rely upon "Basic Requirements for IPv6 Customer Edge Routers" (RFC7084).”

We had an endless discussion about having a bit for RFC7084, and I think we should not go back into that. My view now is, if you’re an ISP and will need IPv4aaS support, you just ask for the new RFC, no need to reference RFC7084, as it is already a MUST on it.

If you only need “IPv6” and no IPv4aaS (which I doubt it will be the case for at least a few years), then you keep asking only for RFC7084.

Regards,

Jordi

De: v6ops <[email-masked]> en nombre de Yannis Nikolopoulos <[email-masked]>
Fecha: miércoles, 4 de julio de 2018, 17:33
Para: JORDI PALET MARTINEZ <jordi.palet=[email-masked]>, <[email-masked]>
Asunto: Re: [v6ops] I-D Action: draft-ietf-v6ops-transition-ipv4aas-04.txt

Hi,

just a nit to pick:

1.  Introduction

   ...
 
   These routers are likely to rely upon "Basic Requirements for IPv6
   Customer Edge Routers" ([RFC7084])

and then: 

3.  Requirements

   The IPv6 Transition CE Router MUST comply with [RFC7084] (Basic
   Requirements for IPv6 Customer Edge Routers)

Also, as an operator who deals with CPE vendors, I need to really complain about having 2 RFCs instead of 7084bis. 

cheers,

Yannis

 

 

Regards,
 
Jordi

 
 
-----Mensaje original-----

 
 
CC: <[email-masked]>

 

 

                              Hans M.-H. Liu
 
                              Masanobu Kawashima

           Pages           : 21
 
           Date            : 2018-06-25

    Abstract:

 

 

 

 

 

 

 

 

 

 
 
    v6ops mailing list
 
    [email-masked]

 

 

_______________________________________________ v6ops mailing list [email-masked] https://www.ietf.org/mailman/listinfo/v6ops