Subject: [v6ops] I-D Action: draft-ietf-v6ops-nat64-deployment-00.txt

From: [email-masked]
Date: Mon, 02 Jul 2018 11:04:36 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IPv6 Operations WG of the IETF.

        Title           : NAT64/464XLAT Deployment Guidelines in Operator and Enterprise Networks
        Author          : Jordi Palet Martinez
	Filename        : draft-ietf-v6ops-nat64-deployment-00.txt
	Pages           : 34
	Date            : 2018-07-02

Abstract:
   This document describes how NAT64 and 464XLAT can be deployed in an
   IPv6 network, whether cellular ISP, broadband ISP, or enterprise and
   the issues to be considered when having an IPv6-only access link,
   regarding: a) DNS64, b) applications or devices that use literal IPv4
   addresses or non-IPv6 compliant APIs, and c) IPv4-only hosts or
   applications.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-v6ops-nat64-deployment/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-v6ops-nat64-deployment-00
https://datatracker.ietf.org/doc/html/draft-ietf-v6ops-nat64-deployment-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 02 Jul 2018 20:26:35 +0200

Hi Fred, all,

I just submitted it, tried to address your comments and added a section for DNS privacy (addressing the comments for DoH, but also applied to other DNS privacy protocols, which I think have the same issues). Basically, they are the same issues as if the user changes the DNS (what I call "Manual Configuration of Foreign DNS").

I tried to address also other few comments received the last days, but didn't have sufficient time to double-check that all them are done.

I think possible new sections may be related to expanding the (actual annex) benchmarking and may be explaining possible approaches for HA/redundancy of the NAT64/DNS64. I will work on that ASAP.

Any other ideas from the WG about what is missing or should be revised?

Regards,

Jordi

-----Mensaje original-----

De: v6ops <[email-masked]> en nombre de <[email-masked]>

Fecha: lunes, 2 de julio de 2018, 20:05

Para: <[email-masked]>

CC: <[email-masked]>

Asunto: [v6ops] I-D Action: draft-ietf-v6ops-nat64-deployment-00.txt

    	Pages           : 34

    	Date            : 2018-07-02

    Abstract:

       applications.

    

    _______________________________________________

    v6ops mailing list

    [email-masked]

    https://www.ietf.org/mailman/listinfo/v6ops

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: <[email-masked]>
Date: Tue, 3 Jul 2018 07:43:53 +0000

Hi Jordi, 

FWIW, you may find some comments at:

* pdf: https://github.com/boucadair/IETF-Drafts-Reviews/blob/master/draft-ietf-v6ops-nat64-deployment-00-rev%20Med.pdf 
* doc: https://github.com/boucadair/IETF-Drafts-Reviews/blob/master/draft-ietf-v6ops-nat64-deployment-00-rev%20Med.pdf 

The main comments are: 
* The document should be explicit about its scope: DNS64/DNSEEC. The title/file name/abstract are all misleading.
* The document can be simplified by removing sections which are not about valid deployment scenarios.
* Some of the statements should be revisited and aligned with existing RFCs.    
* I have some "troubles" with the recommendations section. 
* A recommendation that you missed there is to consider alternate approaches which do not "suffer" from the issues you want to solve (DS-Lite, A+P). 

Hope this helps. 

Cheers, 
Med

> -----Message d'origine-----
> De : v6ops [mailto:[email-masked]] De la part de JORDI PALET MARTINEZ
> Envoyé : lundi 2 juillet 2018 20:27
> À : [email-masked]
> Objet : Re: [v6ops] I-D Action: draft-ietf-v6ops-nat64-deployment-00.txt
> 
> Hi Fred, all,
> 
> 
> 
> I just submitted it, tried to address your comments and added a section for
> DNS privacy (addressing the comments for DoH, but also applied to other DNS
> privacy protocols, which I think have the same issues). Basically, they are
> the same issues as if the user changes the DNS (what I call "Manual
> Configuration of Foreign DNS").
> 
> 
> 
> I tried to address also other few comments received the last days, but didn't
> have sufficient time to double-check that all them are done.
> 
> 
> 
> I think possible new sections may be related to expanding the (actual annex)
> benchmarking and may be explaining possible approaches for HA/redundancy of
> the NAT64/DNS64. I will work on that ASAP.
> 
> 
> 
> This electronic message contains information which may be privileged or
> confidential. The information is intended to be for the exclusive use of the
> individual(s) named above and further non-explicilty authorized disclosure,
> copying, distribution or use of the contents of this information, even if
> partially, including attached files, is strictly prohibited and will be
> considered a criminal offense. If you are not the intended recipient be aware
> that any disclosure, copying, distribution or use of the contents of this
> information, even if partially, including attached files, is strictly
> prohibited, will be considered a criminal offense, so you must reply to the
> original sender to inform about this communication and delete it.
> 
> 
>

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 03 Jul 2018 09:56:42 +0200

Hi Med,

Thanks a lot for the detailed review, and for sure I will go thru all the details ASAP.

However, I think there is an issue in the sense that you read the document with a scope "what transition you should deploy", while the scope is "if you already decided to use NAT64/464XLAT, this is what you need to consider".

Regards,

Jordi

-----Mensaje original-----

De: v6ops <[email-masked]> en nombre de <[email-masked]>

Fecha: martes, 3 de julio de 2018, 9:44

Para: JORDI PALET MARTINEZ <jordi.palet=[email-masked]>, "[email-masked]" <[email-masked]>

Asunto: Re: [v6ops] I-D Action: draft-ietf-v6ops-nat64-deployment-00.txt

    Hi Jordi, 

    The main comments are: 

    Hope this helps. 

    Cheers, 

    Med

    >     A New Internet-Draft is available from the on-line Internet-Drafts

    > directories.

    >             Title           : NAT64/464XLAT Deployment Guidelines in Operator

    > and Enterprise Networks

    >     https://datatracker.ietf.org/doc/html/draft-ietf-v6ops-nat64-deployment-

    > 00

    >     Please note that it may take a couple of minutes from the time of

    > submission

    v6ops mailing list

    [email-masked]