Subject: [v6ops] Weekly Review: draft-ietf-v6ops-transition-ipv4aas

From: Ron Bonica <[email-masked]>
Date: Mon, 30 Jul 2018 13:12:50 +0000

Folks,

Each week between now and IETF 103, we will review and discuss one draft with an eye towards progressing it.

This week, please review and comment on draft-ietf-v6ops-transition-ipv4aas.

                                                Fred and Ron

---

From: Alejandro D'Egidio <[email-masked]>
Date: Mon, 30 Jul 2018 12:38:23 -0300 (ART)

Hello Ron,
I really like this draft!
Just a simple comment.
Where says:
This document covers a set of IP transition techniques required when
ISPs have an IPv6-only access network.

Maybe could say:
This document covers a set of IP transition techniques required when
ISPs wants to have an IPv6-only access network.

Maybe you can include some example of why ISPs wants to have an IPv6 only access network.
For example, in my case, as we don't have more public IPv4 addresses and we have IPv6 developed, why should I need to continue managing IPv4 addresses?
Maybe some kind of this scenario could be included.

Regarding 3.2.1.  464XLAT:
Cablelabs defines that the CableModem must subnet the IPv6 Prefix received from ISP to use different subnets on each LAN Interface. The size of IPv6 "sub" prefix on each LAN depends on is ISP configured the CM to use either favor depth or favor width. If ISP provides just a /64 IPv6 prefix (which is not recommended) CM must share it with all LAN interfaces.

For IPv4, by the same private IPv4 prefix is shared between all LAN interfaces (customer-facing interfaces). For this case I think it "3.2.1.  464XLAT" is ok.
There are some cases where CM could have different private IPv4 prefixes to each customer-facing interfaces. So I think, this is another scenario that should be covered where CLAT will need to work with all the IPv4 LAN prefixes. Maybe running multiple instances of its NAT46 (one for each LAN interface) or one instance supporting multiple IPv4 addresses.

All this is in: https://apps.cablelabs.com/specification/ipv4-and-ipv6-erouter-specification/

Regards,
ALEJANDRO D'EGIDIO 
Jefe de Ingeniería de Backbone | Dirección de Ingeniería 
M: [ callto:+54 911 5794-1589 | +54 911 5794-1589 ] | F: [ callto:+54 11 3977-1025 | +54 11 3977-1025 ] | [ mailto:[email-masked] | [email-masked] ] 
Pje. Lavardén 157. Piso 3. CABA (C1437FBC)

----- Mensaje original -----
De: "Ron Bonica" <[email-masked]>
Para: "[email-masked] list" <[email-masked]>
Enviados: Lunes, 30 de Julio 2018 10:12:50
Asunto: [v6ops] Weekly Review: draft-ietf-v6ops-transition-ipv4aas

Folks,

                                                Fred and Ron

_______________________________________________
v6ops mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/v6ops