Subject: Re: [v6ops] Time to dump dual-stack networks and get on the IPv6 train - with LW4o6

From: Lorenzo Colitti <[email-masked]>
Date: Mon, 2 Jul 2018 11:42:20 +0900

On Sun, Jul 1, 2018 at 5:50 AM Brian E Carpenter <
[email-masked]> wrote:

> There's no need to "dump" dual stack in situations where
> it's the best solution,

>From a pure network operations perspective, dual-stack is rarely the best
solution. It is much cheaper and operationally simpler to support only IPv6
in the network and run IPv4 on top of it.

---

From: George Michaelson <[email-masked]>
Date: Mon, 2 Jul 2018 12:53:08 +1000

I think this is one of those times the technologist narrow meaning
behind a phrase like "dual stack" and "IPv4 on top of IPv6" are lost
on a lot of people.

I know its "wrong" but I sympathise with a tech journalist seeking
clarity in this. The edge user situation is very hard to distinguish
in both cases, the user functionally can see both Ipv4 and Ipv6
resources. How is this not "dual" in the sense a man or woman in the
street would understand it?

-George

On Mon, Jul 2, 2018 at 12:42 PM, Lorenzo Colitti
<lorenzo=[email-masked]> wrote:
> On Sun, Jul 1, 2018 at 5:50 AM Brian E Carpenter
> <[email-masked]> wrote:
>>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Mikael Abrahamsson <[email-masked]>
Date: Mon, 2 Jul 2018 05:15:29 +0200 (CEST)

On Mon, 2 Jul 2018, George Michaelson wrote:

> clarity in this. The edge user situation is very hard to distinguish in 
> both cases, the user functionally can see both Ipv4 and Ipv6 resources. 
> How is this not "dual" in the sense a man or woman in the street would 
> understand it?

Yes, we (networking people) still do not have proper wording for what we 
mean where. In my deployment we use LW4o6 (IPv6 only WAN with IPv4aaS), 
but on the LAN side of the HGW, it's dual stack.

I would of course want to go full IPv6 only everywhere so I don't have to 
do any IPv4 anywhere, but this seems to be far away still.

What I'd like to see is guidance to the host OS vendors what to do when it 
detects that there is NAT64 support but also IPv4 native available. Should 
it prefer NAT64 (including synthesising NAT64 usage for IPv4 literals in 
API calls) over native IPv4? Perhaps just in certain cases? In what WG 
should this be discussed? v6ops? The mobile OS vendors have implemented 
NAT64 support (including handling IPv4 literals), but most desktop vendors 
have only done this partly, or not at all. So we're still far away on 
hosts being able to handle this themselves.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: David Farmer <[email-masked]>
Date: Sun, 1 Jul 2018 22:19:23 -0500

> in the network and run IPv4 on top of it.

While I generally agree, which is simpler Dual Stack versus LW4o6 with A+P,
is definitely in the eye of the beholder. The point is, if there were easy
or obvious answers to this, we would have solved it a long time ago.

-- 
===============================================
David Farmer               Email:[email-masked]
Networking & Telecommunication Services
Office of Information Technology
University of Minnesota
2218 University Ave SE        Phone: 612-626-0815
Minneapolis, MN 55414-3029   Cell: 612-812-9952
===============================================

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 2 Jul 2018 16:20:39 +1200

> in the network and run IPv4 on top of it.

I doubt that this generalisation is true everywhere, and what happens inside
the network and what is presented to the transport layer in the host are two
different things. As long as it *looks* like a dual stack at the socket API,
that's fine.

    Brian

---

From: Fred Baker <[email-masked]>
Date: Sun, 1 Jul 2018 23:28:22 -0700

> street would understand it?

Of course. From the perspective of a residential - or enterprise - user, they have both IPv4 and IPv6, and the network is carrying them. So from their perspective they retain dual stack capabilities in the near term. However, here's another factoid.

For the residential user, the number of services that actually require IPv4 is relatively small. I mentioned home security as a market that required the ability to make an IPv4 connection to the home. Suppose that could be changed? One way to change that would be for a few large ISPs to convince companies like LINK or ADT to become IPv6-capable, whereupon it becomes a market requirement for their competitors.

The ISP has just made having IPv4 at all a second priority for them; it's in their interest to move residential/soho/enterprise to IPv6, with the goal of removing the final translation step. I would expect their next move to be to charge for the service, and if possible move it to the edge itself  - which is where draft-*-v6ops-nat64-deployment is going. The transition rolls out from there.

The more outfits that find it in their interest to be able to operate without IPv4 at all, the better this is for all of us. And this becomes an important step in the general transition.

---

From: George Michaelson <[email-masked]>
Date: Mon, 2 Jul 2018 16:32:41 +1000

I don't want to over-play it, but some of this goes to "the death of
transit" -IPv6 works fine as a direct relationship, or to content in
the CDN, especially if the CDN is tight to your ISP.

But there are downsides, like the loss of end-to-end in this. its a
model driving to vertical capture, where the CDN players and your ISP
own you and nothing happens normally beyond those boundaries.

I *like* immediacy,  I'm no different to anyone else @home, I like
short RTT and jumbogram service delivery. But, lets be careful we
don't forget packets have to go outside, and when they do, IPv6 still
has some issues in transit: There are far too many tunnels, and far
too many routes where it bounces, trombones, or just doesn't work.

-George

---

From: Tim Chown <[email-masked]>
Date: Mon, 2 Jul 2018 08:16:37 +0000

> On 2 Jul 2018, at 07:28, Fred Baker <[email-masked]> wrote:
> 

Sadly I don't see my TV upgrading itself to IPv6 any time soon; that will happen when I buy a new TV, in maybe 10 years time.  Streamed iPlayer and other video content to that TV is more than half of my home network traffic.

As for charging more, how would a customer know what devices support IPv4 and/or IPv6, or need IPv4?  Why should they care?  "We're charging you an extra $5/mo because you have v4 traffic" isn't helpful. 

> The more outfits that find it in their interest to be able to operate without IPv4 at all, the better this is for all of us. And this becomes an important step in the general transition.

I agree with the rest of what you say, but in a home network situation, there's going to be a lot of legacy IPv4 traffic externally, just look at https://arxiv.org/abs/1803.05368 for example.

Tim

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 02 Jul 2018 10:25:16 +0200

And that's why we need to ensure the CEs to support IPv4aaS urgently, so we can progress with the deployment of IPv6 in access networks without impacting the users (asking them to replace the cameras, TVs, etc.).

Regards,

Jordi

-----Mensaje original-----

De: v6ops <[email-masked]> en nombre de Tim Chown <[email-masked]>

Fecha: lunes, 2 de julio de 2018, 10:17

Para: "[email-masked] WG" <[email-masked]>

Asunto: Re: [v6ops] Time to dump dual-stack networks and get on the IPv6 train - with LW4o6

    Tim

    v6ops mailing list

    [email-masked]

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Fred Baker <[email-masked]>
Date: Mon, 2 Jul 2018 01:50:32 -0700

> On Jul 2, 2018, at 1:16 AM, Tim Chown <[email-masked]> wrote:

True, but they can survive quite well with RFC 6092, which calls on the host attaching to such a service to connect to the CDN or other service. If there is a CPE translator, they'll be find in an otherwise IPv6-only network. Where I'm worried is an application that uses IPv4 to connect to the host in the home/SOHO/enterprise, such as surveillance system you can monitor from your handset (dynamic DNS creating an A record plus a firewall hole punch using PCP or equivalent).

> I agree with the rest of what you say, but in a home network situation, there's going to be a lot of legacy IPv4 traffic externally, just look at https://arxiv.org/abs/1803.05368 for example.

How much that isn't initiated from the home?

---

From: Fred Baker <[email-masked]>
Date: Mon, 2 Jul 2018 02:38:51 -0700

On Jun 30, 2018, at 12:16 AM, Fred Baker <[email-masked]> wrote:
>> Time to dump dual-stack networks and get on the IPv6 train - with LW4o6 https://news360.com/article/460267064
> 
> IPv6 in the press. Thinking about this as we approach IETF 102, where IPv4 overlaid on or translated to IPv6 is on the agenda.

For the record, the thing I found interesting here wasn't hearing that someone was deploying it. It was where I found it.

I have an application on my telephone (I imagine many of us do) that gives me a selection of news articles to read every day. Articles about Israel come from the Jerusalem Post or Haaretz. The editor seems to really like BBC and Reuters, which is fine by me, as I find American news sources very beltway-centric (if Mr Trump isn't mentioned, the editor considers the article to be "not worth reading"). There are occasionally US news sources as well, and AL-Jezerah. I read about asteroids that come closer to the Earth than the moon - regularly - and a variety of other topics. Some have to do with Christianity, which is something important to me, and some have to do with technology, often BitCoin or other buzzword-level topics.

I rarely read about the Internet, and if I do, it's not anything I would consider "news". Maybe the fact that the Internet Society chose a new CEO (congratulations, Andrew!). But not much.

An IPv6-only network is "news" coming from that perspective. So I found this very interesting in that editorial context. The editor, I gather, thought that this was less esoteric than a discussion from a scientific journal filled with words that are unpronounceable by mere mortals, which I get pretty regularly.

Let me put this into context. In the 1980's and early 1990's, I didn't usually tell people what I did for a living. If I said the then-current vernacular for "software engineer", I would get asked applications layer questions like "so why can't my bank balance my checkbook?". "Gee, I dunno, I don't do that." I would tell people that I taught computers to talk amongst themselves, and people would think I was really strange.

In 1994, I was walking on State Street (what Santa Barbara calls "Main Street") and watched a bus pass by. End to end, the side of the bus displayed a lipstick ad, on which the only writing was a URL. Obviously, someone was test marketing: "if we show this ad, what happens nest?". Well, no woman equipped with a right mind buys lipstick from either an ad on a bus or a URL; they go to a store and look at the colors. But it set me thinking: maybe my technology is now mainstream enough that I can mention the Internet and people will have a clue. Sometimes.

So for a number of years, I would respond to
	"what do you do for a living"
with
	"you know what the Internet is, right?"
Depending on the response, I might actually answer, or might say
	"well, I teach computers to converse amongst themselves".
More often the latter than the former...

In 2000, I sat down in a prayer meeting next to a college coed.
	"What do you do for a living?"
	"Well, you know what the Internet is, right?"
	"That's so condescending!"

Now (2018) I tell people what I do for a living. But that was easily 20 years into actually doing it.

Thinking about where this goes next.

---

From: Philip Homburg <[email-masked]>
Date: Mon, 02 Jul 2018 11:56:50 +0200

>different things. As long as it *looks* like a dual stack at the socket API,

There are plenty of ISPs that offer one or even multiple static IPv4 addresses
to customers and where customers are using those to run services locally.

As far as I know there are no RFCs that describe how to run such a setup
with IPv4 as a service. But maybe I missed something.

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 02 Jul 2018 13:04:34 +0200

I will say that this is possible in every IPv4aaS mechanism, it is a matter of the configuration at the ISP side. I've tested it with one persistent IP, but I'm sure it can be done with multiple as well.

Regards,

Jordi

-----Mensaje original-----

De: v6ops <[email-masked]> en nombre de Philip Homburg <[email-masked]>

Fecha: lunes, 2 de julio de 2018, 11:57

Para: <[email-masked]>

    

    v6ops mailing list

    [email-masked]

---

From: Ole Troan <[email-masked]>
Date: Mon, 2 Jul 2018 14:22:46 +0300

> On 2 Jul 2018, at 09:28, Fred Baker <[email-masked]> wrote:
> 

That’s a bit like saying that an ISP using MPLS tunneling, has made IP second priority.

Ole

---

From: Ole Troan <[email-masked]>
Date: Mon, 2 Jul 2018 14:33:26 +0300

> On 2 Jul 2018, at 14:04, JORDI PALET MARTINEZ <jordi.palet=[email-masked]> wrote:
> 

Incorrect. 
MAP-E/T has explicit support for full IPv4 addresses or an IPv4 prefix. LW46 supports full IPv4 address, and can in theory support prefix, although not specified in 7596. 

DS-lite, 464XLAT can not. 

Ole

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 02 Jul 2018 13:36:59 +0200

I've not tried with DS-Lite, but I tried with 464XLAT and you can do it, depending on the NAT64 arrangements. Is not specified in the RFC, same as in the case of lw4o6.

Regards,

Jordi

-----Mensaje original-----

De: v6ops <[email-masked]> en nombre de Ole Troan <[email-masked]>

Fecha: lunes, 2 de julio de 2018, 13:34

Para: JORDI PALET MARTINEZ <jordi.palet=[email-masked]>

CC: <[email-masked]>

    

    Incorrect. 

    Ole

    v6ops mailing list

    [email-masked]

---

From: Ole Troan <[email-masked]>
Date: Mon, 2 Jul 2018 14:44:11 +0300

And how do you provision a global IPv4 prefix with 464XLAT?

Ole

> On 2 Jul 2018, at 14:36, JORDI PALET MARTINEZ <[email-masked]> wrote:
>

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 02 Jul 2018 13:50:08 +0200

I only tested a single address, not a prefix, and in this case was done for a few specific business customers, in the context of a big 464XLAT trial, so it was a manual configuration, and DMZ/port forwarding to the services required inside the business customer network.

I'm sure we can find a way, if this is interesting, to make it fully automated. 

Regards,

Jordi

-----Mensaje original-----

De: Ole Troan <[email-masked]>

Fecha: lunes, 2 de julio de 2018, 13:44

Para: JORDI PALET MARTINEZ <[email-masked]>

CC: JORDI PALET MARTINEZ <jordi.palet=[email-masked]>, <[email-masked]>

    Ole

---

From: Lencse Gábor <[email-masked]>
Date: Mon, 2 Jul 2018 15:43:38 +0200

Hi,

This discussion is definitely useful for our planned draft "Pros and 
Cons of IPv6 Transition Technologies for IPv4aaS". :-)

I hope to send the first version of our table for crowd source 
information collection to the v6ops list next week...

Gábor

---

From: Ole Troan <[email-masked]>
Date: Mon, 2 Jul 2018 17:09:41 +0300

> On 2 Jul 2018, at 14:50, JORDI PALET MARTINEZ <[email-masked]> wrote:
> 

We already did. See 7599/7598. That’s called MAP-T. 464XLAT is just double translation with a limited form of provisioning. 

Ole