Subject: Re: [v6ops] New Version Notification for draft-ietf-v6ops-transition-ipv4aas-05.txt

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 20 Jul 2018 09:16:53 -0400

Hi all,

Following yesterday discussion, I've posted a new version, removing G-1 (RFC7608).

Also, considering draft-pref64folks-6man-ra-pref64, we have included this (after consulting with the chairs, as it is a time being an individual ID).

We have also included a very simple priority mechanism in case several NAT64 prefix discovery are available.

As we have free time today in the meeting, if somebody disagree with this, please speak up and let's discuss it.

Thanks!

Here is the relevant text:

   464XLAT-4:  The IPv6 Transition CE Router MUST implement

               [I-D.pref64folks-6man-ra-pref64] (Discovering PREF64 in

               Router Advertisements) and [RFC7050] (Discovery of the

               IPv6 Prefix Used for IPv6 Address Synthesis) in order to

               discover the PLAT-side translation IPv4 and IPv6

               prefix(es)/suffix(es).

   464XLAT-7:  The priority for the NAT64 prefix, in case the network

               provides several choices, MUST be: 1) [RFC7225], 2)

               [RFC8115], 3) [I-D.pref64folks-6man-ra-pref64] and 4)

               [RFC7050].

Regards,

Jordi

-----Mensaje original-----

De: <[email-masked]>

Fecha: viernes, 20 de julio de 2018, 9:12

Para: Masanobu Kawashima <[email-masked]>, "Hans M.-H. Liu" <[email-masked]>, Jordi Palet Martinez <[email-masked]>, Jordi Palet <[email-masked]>, Hans Liu <[email-masked]>

Asunto: New Version Notification for draft-ietf-v6ops-transition-ipv4aas-05.txt

    A new version of I-D, draft-ietf-v6ops-transition-ipv4aas-05.txt

    has been successfully submitted by Jordi Palet Martinez and posted to the

    IETF repository.

    Name:		draft-ietf-v6ops-transition-ipv4aas

    Revision:	05

    Title:		Requirements for IPv6 Customer Edge Routers to Support IPv4 Connectivity as-a-Service

    Document date:	2018-07-20

    Group:		v6ops

    Pages:		21

    URL:            https://www.ietf.org/internet-drafts/draft-ietf-v6ops-transition-ipv4aas-05.txt

    Status:         https://datatracker.ietf.org/doc/draft-ietf-v6ops-transition-ipv4aas/

    Htmlized:       https://tools.ietf.org/html/draft-ietf-v6ops-transition-ipv4aas-05

    Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-v6ops-transition-ipv4aas

    Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-v6ops-transition-ipv4aas-05

    Abstract:

       This document specifies the IPv4 service continuity requirements for

       an IPv6 Customer Edge (CE) router, either provided by the service

       provider or thru the retail market.

       Specifically, this document extends the "Basic Requirements for IPv6

       Customer Edge Routers" in order to allow the provisioning of IPv6

       transition services for the support of "IPv4 as-a-Service" (IPv4aaS)

       by means of new transition mechanisms.  The document only covers

       transition technologies for delivering IPv4 in IPv6-only access

       networks, commonly called "IPv4 as-a-Service" (IPv4aaS), as required

       in a world where IPv4 addresses are no longer available, so hosts in

       the customer LANs with IPv4-only or IPv6-only applications or

       devices, requiring to communicate with IPv4-only services at the

       Internet, are still able to do so.

    

    Please note that it may take a couple of minutes from the time of submission

    until the htmlized version and diff are available at tools.ietf.org.

    The IETF Secretariat

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: <[email-masked]>
Date: Fri, 20 Jul 2018 14:08:16 +0000

Hi Jordi, 

I disagree with including I-D.pref64folks-6man-ra-pref64 for the same reason the WG decided to removed your dhcp individual draft. 

Please remove it from the draft. Thanks

Cheers,
Med

> -----Message d'origine-----
> De : v6ops [mailto:[email-masked]] De la part de JORDI PALET MARTINEZ
> Envoyé : vendredi 20 juillet 2018 09:17
> À : v6ops
> Objet : Re: [v6ops] New Version Notification for draft-ietf-v6ops-transition-
> ipv4aas-05.txt
> 
> Hi all,
> 
> 
> 
> Also, considering draft-pref64folks-6man-ra-pref64, we have included this
> (after consulting with the chairs, as it is a time being an individual ID).
> 
> 
> 
> Para: Masanobu Kawashima <[email-masked]>, "Hans M.-H. Liu"
> <[email-masked]>, Jordi Palet Martinez
> <[email-masked]>, Jordi Palet
> <[email-masked]>, Hans Liu <[email-masked]>
> 
> This electronic message contains information which may be privileged or
> confidential. The information is intended to be for the exclusive use of the
> individual(s) named above and further non-explicilty authorized disclosure,
> copying, distribution or use of the contents of this information, even if
> partially, including attached files, is strictly prohibited and will be
> considered a criminal offense. If you are not the intended recipient be aware
> that any disclosure, copying, distribution or use of the contents of this
> information, even if partially, including attached files, is strictly
> prohibited, will be considered a criminal offense, so you must reply to the
> original sender to inform about this communication and delete it.
> 
> 
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops