Subject: Re: [v6ops] Weekly Review: draft-ietf-v6ops-transition-ipv4aas

From: Fred Baker <[email-masked]>
Date: Thu, 2 Aug 2018 10:08:45 -0700

No hats, just a dumb question.

I think having the CPE put a separate subnet onto each customer LAN makes sense. To begin with, it fits the architectural intent. But I'm a little confused by the need to have a requirement regarding IPv4 addressing, and very much confused by having a *different* requirement. Why?

If I were setting up my home router to be an all-facing thing, I would perhaps put, for each segment or SSID enumerated as "N", 2001:db8:m:N::/64 and 192.168.N.0/24. (Note that I don't; for reasons related to the structure of my house, I have three APs scattered around, and they all attach to the wired plant. Hence, they use the same address space as the wired LAN. I have several SSIDs coming from the router itself, which I don't use because they don't reach). But I would follow the same rule for IPv4 as for IPv6; if I'm specifying  a different subnet per LAN/WLAN in IPv6, why would I not do so for IPv4?

> On Jul 31, 2018, at 1:55 PM, Alejandro D'Egidio <[email-masked]> wrote:
> 
> Hello Jordi,
>  My notes in lines.
> 
> Regards,
> Alejandro
> 
> ----- Mensaje original -----
>> De: "JORDI PALET MARTINEZ" <[email-masked]>
>> Para: "Alejandro Degidio" <[email-masked]>, "Ron Bonica" <[email-masked]>
>> CC: "[email-masked] list" <[email-masked]>
>> Enviados: Lunes, 30 de Julio 2018 20:58:52
>> Asunto: Re: [v6ops] Weekly Review: draft-ietf-v6ops-transition-ipv4aas
> 
>> Hi Alejandro,
>> 
>> 
>> 
>> Thanks for the input!
>> 
>> 
>> 
>> I think it is easy to understand:
>> 
>> "This document covers a set of IP transition techniques required when
>> 
>>  ISPs have an IPv6-only access network."
>> 
>> 
>> 
>> even if the ISP already have an IPv6-only access network, or want to have it.
>> 
>> 
>> 
>> But this may be something that a native English speaker could tell us how better
>> to say it. May be:
>> 
>> "This document covers a set of IP transition techniques required when
>> 
>>  ISPs have or want to move to an IPv6-only access network."
>> 
>> 
> Yes, it's great.
> 
>> 
>> I'd some text in earlier versions about the reasons to have an IPv6-only access
>> network, but it was suggested to move it to the Annex A ... not sure if you
>> read them also. I'm happy to add some more text, if needed to the annex A to
>> describe several possible reasons.
>> 
> 
> Yes, I've read all the document included the Annexes.
> 
> 
>> 
>> 
>> The case for having multiple IPv4 subnets (one for each interface), is feasible,
>> as you say, by having multiple instances of the NAT46, which I think is not a
>> problem.
>> 
>> 
>> 
>> However, open question is valid also for any other IPv4aaS mechanism.
>> 
>> 
>> 
>> I'm not sure if we want to have that case considered as something that MUST be
>> supported as one more requirement, and if this is the case, it will be a
>> "general" transition requirement, and no need to go in the details for each
>> transition mechanism, or we really want to go to describe a specific new
>> requirement for this for each transition mechanism ...
>> 
> 
> Just knowing that a CPE can have different LAN IPv4 prefixes I was thinking that maybe it could be considered in General transition requirements with something like:
> 
> "TRANS-6: The IPv6 Transition CE Router MAY have different IPv4 prefixes on each Customer-Facing interfaces and the transition mechanisms MUST have options to be compatible with it."
> 
> 
>> 
>> 
>> What others think?
>> 
>> 
>> 
>> Regards,
>> 
>> Jordi
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> -----Mensaje original-----
>> 
>> De: v6ops <[email-masked]> en nombre de Alejandro D'Egidio
>> <[email-masked]>
>> 
>> Fecha: lunes, 30 de julio de 2018, 10:39
>> 
>> Para: Ron Bonica <[email-masked]>
>> 
>> CC: "[email-masked] list" <[email-masked]>
>> 
>> Asunto: Re: [v6ops] Weekly Review: draft-ietf-v6ops-transition-ipv4aas
>> 
>> 
>> 
>>   Hello Ron,
>> 
>>   I really like this draft!
>> 
>>   Just a simple comment.
>> 
>>   Where says:
>> 
>>   This document covers a set of IP transition techniques required when
>> 
>>   ISPs have an IPv6-only access network.
>> 
>> 
>> 
>>   Maybe could say:
>> 
>>   This document covers a set of IP transition techniques required when
>> 
>>   ISPs wants to have an IPv6-only access network.
>> 
>> 
>> 
>>   Maybe you can include some example of why ISPs wants to have an IPv6 only access
>>   network.
>> 
>>   For example, in my case, as we don't have more public IPv4 addresses and we have
>>   IPv6 developed, why should I need to continue managing IPv4 addresses?
>> 
>>   Maybe some kind of this scenario could be included.
>> 
>> 
>> 
>>   Regarding 3.2.1.  464XLAT:
>> 
>>   Cablelabs defines that the CableModem must subnet the IPv6 Prefix received from
>>   ISP to use different subnets on each LAN Interface. The size of IPv6 "sub"
>>   prefix on each LAN depends on is ISP configured the CM to use either favor
>>   depth or favor width. If ISP provides just a /64 IPv6 prefix (which is not
>>   recommended) CM must share it with all LAN interfaces.
>> 
>> 
>> 
>>   For IPv4, by the same private IPv4 prefix is shared between all LAN interfaces
>>   (customer-facing interfaces). For this case I think it "3.2.1.  464XLAT" is ok.
>> 
>>   There are some cases where CM could have different private IPv4 prefixes to each
>>   customer-facing interfaces. So I think, this is another scenario that should be
>>   covered where CLAT will need to work with all the IPv4 LAN prefixes. Maybe
>>   running multiple instances of its NAT46 (one for each LAN interface) or one
>>   instance supporting multiple IPv4 addresses.
>> 
>> 
>> 
>>   All this is in:
>>   https://apps.cablelabs.com/specification/ipv4-and-ipv6-erouter-specification/
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>>   Regards,
>> 
>>   ALEJANDRO D'EGIDIO
>> 
>>   Jefe de Ingeniería de Backbone | Dirección de Ingeniería
>> 
>>   M: [ callto:+54 911 5794-1589 | +54 911 5794-1589 ] | F: [ callto:+54 11
>>   3977-1025 | +54 11 3977-1025 ] | [ mailto:[email-masked] |
>>   [email-masked] ]
>> 
>>   Pje. Lavardén 157. Piso 3. CABA (C1437FBC)
>> 
>> 
>> 
>>   ----- Mensaje original -----
>> 
>>   De: "Ron Bonica" <[email-masked]>
>> 
>>   Para: "[email-masked] list" <[email-masked]>
>> 
>>   Enviados: Lunes, 30 de Julio 2018 10:12:50
>> 
>>   Asunto: [v6ops] Weekly Review: draft-ietf-v6ops-transition-ipv4aas
>> 
>> 
>> 
>>   Folks,
>> 
>> 
>> 
>>   Each week between now and IETF 103, we will review and discuss one draft with an
>>   eye towards progressing it.
>> 
>> 
>> 
>>   This week, please review and comment on draft-ietf-v6ops-transition-ipv4aas.
>> 
>> 
>> 
>>                                                   Fred and Ron
>> 
>> 
>> 
>>   _______________________________________________
>> 
>>   v6ops mailing list
>> 
>>   [email-masked]
>> 
>>   https://www.ietf.org/mailman/listinfo/v6ops
>> 
>> 
>> 
>>   _______________________________________________
>> 
>>   v6ops mailing list
>> 
>>   [email-masked]
>> 
>>   https://www.ietf.org/mailman/listinfo/v6ops
>> 
>> 
>> 
>> 
>> 
>> 
>> **********************************************
>> IPv4 is over
>> Are you ready for the new Internet ?
>> http://www.consulintel.es
>> The IPv6 Company
>> 
>> This electronic message contains information which may be privileged or
>> confidential. The information is intended to be for the exclusive use of the
>> individual(s) named above and further non-explicilty authorized disclosure,
>> copying, distribution or use of the contents of this information, even if
>> partially, including attached files, is strictly prohibited and will be
>> considered a criminal offense. If you are not the intended recipient be aware
>> that any disclosure, copying, distribution or use of the contents of this
>> information, even if partially, including attached files, is strictly
>> prohibited, will be considered a criminal offense, so you must reply to the
>> original sender to inform about this communication and delete it.
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

--------------------------------------------------------------------------------
The fact that there is a highway to hell and a stairway to heaven is an interesting comment on projected traffic volume...

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 02 Aug 2018 18:51:15 -0500

Actually, you do also in some cases for both, IPv4 and IPv6.

If you want to have a specific subnet for a special "guest" SSID, you want to separate that from the SSID of the home owners.

You may want to have a separated segment also for a wired home office. You don't want the kids being able to reach your work documents, etc.

Regards,

Jordi

-----Mensaje original-----

De: Fred Baker <[email-masked]>

Fecha: jueves, 2 de agosto de 2018, 12:08

Para: Alejandro D'Egidio <[email-masked]>

CC: JORDI PALET MARTINEZ <[email-masked]>, "[email-masked] list" <[email-masked]>

    

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.