Subject: [v6ops] I-D Action: draft-ietf-v6ops-transition-ipv4aas-06.txt

From: [email-masked]
Date: Fri, 10 Aug 2018 06:36:26 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IPv6 Operations WG of the IETF.

        Title           : Requirements for IPv6 Customer Edge Routers to Support IPv4 Connectivity as-a-Service
        Authors         : Jordi Palet Martinez
                          Hans M.-H. Liu
                          Masanobu Kawashima
	Filename        : draft-ietf-v6ops-transition-ipv4aas-06.txt
	Pages           : 21
	Date            : 2018-08-10

Abstract:
   This document specifies the IPv4 service continuity requirements for
   an IPv6 Customer Edge (CE) router, either provided by the service
   provider or thru the retail market.

   Specifically, this document extends the "Basic Requirements for IPv6
   Customer Edge Routers" in order to allow the provisioning of IPv6
   transition services for the support of "IPv4 as-a-Service" (IPv4aaS)
   by means of new transition mechanisms.  The document only covers
   transition technologies for delivering IPv4 in IPv6-only access
   networks, commonly called "IPv4 as-a-Service" (IPv4aaS), as required
   in a world where IPv4 addresses are no longer available, so hosts in
   the customer LANs with IPv4-only or IPv6-only applications or
   devices, requiring to communicate with IPv4-only services at the
   Internet, are still able to do so.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-v6ops-transition-ipv4aas/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-v6ops-transition-ipv4aas-06
https://datatracker.ietf.org/doc/html/draft-ietf-v6ops-transition-ipv4aas-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-v6ops-transition-ipv4aas-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 10 Aug 2018 08:42:15 -0500

Hi all, Ron,

I just posted the new version, which I think resolves all the issues:

https://datatracker.ietf.org/doc/draft-ietf-v6ops-transition-ipv4aas/?include_text=1

We didn't get confirmation from Richard, who has provided text for the UPnP section, but I think should be fine (he may be in vacations), in case you want to start already the last call.

Regards,

Jordi

-----Mensaje original-----

De: v6ops <[email-masked]> en nombre de <[email-masked]>

Responder a: <[email-masked]>

Fecha: viernes, 10 de agosto de 2018, 8:38

Para: <[email-masked]>

CC: <[email-masked]>

Asunto: [v6ops] I-D Action: draft-ietf-v6ops-transition-ipv4aas-06.txt

                              Hans M.-H. Liu

                              Masanobu Kawashima

    	Pages           : 21

    	Date            : 2018-08-10

    Abstract:

    

    

    _______________________________________________

    v6ops mailing list

    [email-masked]

    https://www.ietf.org/mailman/listinfo/v6ops

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: <[email-masked]>
Date: Fri, 10 Aug 2018 13:48:33 +0000

Hi Jordi, 

I'm afraid this version does not address the comments I shared on -05. 

Cheers,
Med

> -----Message d'origine-----
> De : v6ops [mailto:[email-masked]] De la part de JORDI PALET MARTINEZ
> Envoyé : vendredi 10 août 2018 15:42
> À : [email-masked]; Ron Bonica
> Objet : Re: [v6ops] I-D Action: draft-ietf-v6ops-transition-ipv4aas-06.txt
> 
> Hi all, Ron,
> 
> 
> 
> We didn't get confirmation from Richard, who has provided text for the UPnP
> section, but I think should be fine (he may be in vacations), in case you
> want to start already the last call.
> 
> 
> 
> Regards,
> 
> Jordi
> 
> 
> 
> 
> 
> 
> 
> This electronic message contains information which may be privileged or
> confidential. The information is intended to be for the exclusive use of the
> individual(s) named above and further non-explicilty authorized disclosure,
> copying, distribution or use of the contents of this information, even if
> partially, including attached files, is strictly prohibited and will be
> considered a criminal offense. If you are not the intended recipient be aware
> that any disclosure, copying, distribution or use of the contents of this
> information, even if partially, including attached files, is strictly
> prohibited, will be considered a criminal offense, so you must reply to the
> original sender to inform about this communication and delete it.
> 
> 
>

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 10 Aug 2018 08:53:58 -0500

Hi Med,

I guess you're referring basically regarding [I-D.pref64folks-6man-ra-pref64].

We know it, and we are waiting for a decision on this from 6man.

I'm happy to remove that if we don't hear anything on that, and also up to the indications from Ron and Fred.

Regards,

Jordi

-----Mensaje original-----

De: v6ops <[email-masked]> en nombre de <[email-masked]>

Fecha: viernes, 10 de agosto de 2018, 8:49

Para: JORDI PALET MARTINEZ <jordi.palet=[email-masked]>, "[email-masked]" <[email-masked]>, Ron Bonica <[email-masked]>

Asunto: Re: [v6ops] I-D Action: draft-ietf-v6ops-transition-ipv4aas-06.txt

    Hi Jordi, 

    Cheers,

    Med

    > https://datatracker.ietf.org/doc/draft-ietf-v6ops-transition-

    > ipv4aas/?include_text=1

    >     A New Internet-Draft is available from the on-line Internet-Drafts

    > directories.

    >             Title           : Requirements for IPv6 Customer Edge Routers to

    > Support IPv4 Connectivity as-a-Service

    >     https://datatracker.ietf.org/doc/html/draft-ietf-v6ops-transition-

    > ipv4aas-06

    >     Please note that it may take a couple of minutes from the time of

    > submission

    v6ops mailing list

    [email-masked]

---

From: <[email-masked]>
Date: Fri, 10 Aug 2018 14:00:55 +0000

Re-,

Yes, that is a major one...but there are also many other minor ones that I would like to see fixed. 

The only ones which are fixed in -06 are the ones about UPnP. Thanks. 

Cheers,
Med

> Envoyé : vendredi 10 août 2018 15:54
> À : [email-masked] list
> Para: JORDI PALET MARTINEZ <jordi.palet=[email-masked]>,
> "[email-masked]" <[email-masked]>, Ron Bonica <[email-masked]>
> 
> ipv4aas/

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 13 Aug 2018 10:04:30 -0500

Hi Med,

I've reviewed again your comments on version 5, and I think we addressed them in the version that just submitted:

Most of them were already resolved, but I missed to respond you in the list, sorry about that.

The main one: we removed the reference and text related to pref64folks-6man-ra-pref64.

One of your comments was regarding the retail models. Since we started this work we have a clear idea: If you're an ISP, you choose what transition mechanisms you want in your device, but if you are a vendor, you must have all them, so a customer going to retail can purchase a product that will work in ISP A, B, C, X ... Z. That's one of the main goals, because small ISPs always buy in the retails, not high volumes, so we also offer a solution for them, regardless of what they want to use. It also offers a solution for a customer that has purchased his own device and move form ISP A to ISP Z.

The other point is a change vs. RFC7084. This happens in several sections, including DS-Lite. There have been new important requirements since RFC7084 was published and the WG decided to "disconnect" both documents, so it is perfectly fine to say even is something was SHOULD in RFC7084, now is MUST if you want to comply with the new document.

We hope this clarify all your pending issues, otherwise, let us know please.

Regards,

Jordi

-----Mensaje original-----

Fecha: viernes, 10 de agosto de 2018, 9:01

Para: JORDI PALET MARTINEZ <jordi.palet=[email-masked]>, "[email-masked] list" <[email-masked]>

    Re-,

    Cheers,

    Med

    > I guess you're referring basically regarding [I-D.pref64folks-6man-ra-

    > pref64].

    > I'm happy to remove that if we don't hear anything on that, and also up to

    > the indications from Ron and Fred.

    > De: v6ops <[email-masked]> en nombre de

    > <[email-masked]>

    >     > De : v6ops [mailto:[email-masked]] De la part de JORDI PALET

    > MARTINEZ

    >     > Objet : Re: [v6ops] I-D Action: draft-ietf-v6ops-transition-ipv4aas-

    > 06.txt

    >     > We didn't get confirmation from Richard, who has provided text for the

    > UPnP

    >     > section, but I think should be fine (he may be in vacations), in case

    > you

    >     > De: v6ops <[email-masked]> en nombre de <internet-

    > [email-masked]>

    >     >             Title           : Requirements for IPv6 Customer Edge

    > Routers to

    >     >        This document specifies the IPv4 service continuity requirements

    > for

    >     >        an IPv6 Customer Edge (CE) router, either provided by the

    > service

    >     >        Specifically, this document extends the "Basic Requirements for

    > IPv6

    >     >        Customer Edge Routers" in order to allow the provisioning of

    > IPv6

    >     >        transition services for the support of "IPv4 as-a-Service"

    > (IPv4aaS)

    >     >        networks, commonly called "IPv4 as-a-Service" (IPv4aaS), as

    > required

    >     >        in a world where IPv4 addresses are no longer available, so

    > hosts in

    >     >     https://www.ietf.org/rfcdiff?url2=draft-ietf-v6ops-transition-

    >     >     until the htmlized version and diff are available at

    > tools.ietf.org.

    >     > confidential. The information is intended to be for the exclusive use

    > of the

    >     > individual(s) named above and further non-explicilty authorized

    > disclosure,

    >     > copying, distribution or use of the contents of this information, even

    > if

    >     > considered a criminal offense. If you are not the intended recipient be

    > aware

    >     > that any disclosure, copying, distribution or use of the contents of

    > this

    >     > prohibited, will be considered a criminal offense, so you must reply to

    > the

    v6ops mailing list

    [email-masked]