Subject: Re: [v6ops] inputs on NAT64/464XLAT Deployment Guidelines in Operator and Enterprise Networks draft-ietf-v6ops-nat64-deployment

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 26 Feb 2019 10:12:12 +0900

Hi Alejandro,

(removed dnsop, as this is not - I think - relevant for them)

My understanding is that CDNs today have IPv6 already (at least the most important ones, the ones with more traffic). If that's the case, the traffic from the CEs, will be IPv6.

Now, if a CDN don't have IPv6 support, in 464XLAT, the link is IPv6-only, so I don't see how we can change that.

However, also I see that a possible solution for an IPv4-only CDN to support IPv6 in this scenario, may be via stateless NAT64, with pre-configured EAMT (RFC7757) rules or something similar and the relevant AAAA entries. I think this is more an operational issue than a new protocol.

Clearly that means that you don't have that traffic in the stateful NAT64, which I understand is your main goal.

Anyway, of course, the right thing for those IPv4-only CDNs will be to push them for IPv6 support! I will be nice if you can publicly name them ...

That make sense to you?

Regards,
Jordi

-----Mensaje original-----
De: v6ops <[email-masked]> en nombre de Alejandro D'Egidio <adegidio=[email-masked]>
Fecha: martes, 26 de febrero de 2019, 0:24
Para: JORDI PALET MARTINEZ <jordi.palet=[email-masked]>
CC: "[email-masked] list" <[email-masked]>, dnsop <[email-masked]>
Asunto: Re: [v6ops] inputs on NAT64/464XLAT Deployment Guidelines in Operator and Enterprise Networks draft-ietf-v6ops-nat64-deployment

    Hello Jordi,
    I like 464XLAT and this is something I would like to implement in DOCSIS networks.
    As Deployment Guidelines maybe you can include/consider the next case, if not please forget it or we can include it on another document.
    
    Today we still have many devices that don't support IPv6 or some applications on it don't support it, this is the case of SMART TVs and set top boxes.
    There is a common scenario where big public CDNs support deliver content to private IPv4 destinations (usually CGN prefixes) directly without going through a CGN.
    In that scenario, CPEs (with eRouter) that have IPv4 of CGN (ie 100.64.x.x) can connect receive traffic from CDNs directly without having any CGN in the middle.
    
    So I see three points in this case:
    1- Traffic avoids a point of failure (CGN), obviously it should be redundant but the point of failure exists.
    2- Traffic is more "transparent" avoiding another translation for CDN.
    3- This traffic doesn't impact in CGN sizing.
    
    As I said, I like 464XLAT and I would like to have a IPv6-Only access network but this is a real case where ISPs can consider to continue provisioning IPv4 to customers.

    Regards,
    Alejandro
    
    ----- Mensaje original -----
    De: "JORDI PALET MARTINEZ" <jordi.palet=[email-masked]>
    Para: "[email-masked] list" <[email-masked]>, "dnsop" <[email-masked]>
    Enviados: Jueves, 21 de Febrero 2019 2:58:36
    Asunto: [v6ops] inputs on NAT64/464XLAT Deployment Guidelines in Operator and Enterprise Networks draft-ietf-v6ops-nat64-deployment
    
    Hi all,
    
    (dnsop copied because DNS64)
    
    I'm working in a new version of this document.
    
    Link to the document:
    
    https://datatracker.ietf.org/doc/draft-ietf-v6ops-nat64-deployment/
    
    It will be great if we can get some new inputs.
    
    Thanks!
    
    Regards,
    Jordi

    **********************************************
    IPv4 is over
    Are you ready for the new Internet ?
    http://www.theipv6company.com
    The IPv6 Company
    
    This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

    _______________________________________________
    v6ops mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/v6ops
    
    _______________________________________________
    v6ops mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/v6ops

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Alejandro D'Egidio <[email-masked]>
Date: Tue, 26 Feb 2019 13:54:42 -0300 (ART)

Hello Jordi,

All these big public CDNs work in dual-stack natively.
The case is when we have a customer in dual-stack but behind CGN for IPv4 and he/she also has devices (or applications within those devices) that don't support IPv6 (e.g.: Smart TVs and Set-top-Boxes).
This is the scenario:
                           +------------+
                           |            |
                           |Public CDN  |                                                Priv IPv4 +-----------+
                           |            |                                                          |           |
                           |            |                                                +---------+  SMART TV |
                           +------------+                                                |         |           |
                                 |Dual-Stack                                             |         +-----------+
                                 |Pub IPv4                                               |
                                 |GUA IPv6                                               |
                           +------------+       +------------------+                     |
+-------------+            |            |       |                  |             +-------+-+ Priv  +-----------+
|             |Dual-Stack  |            |       |                  |             |         | IPv4  |           |
|  Internet   +------------+   Router   +-------+    ISP Network   +-------------+  CPE    +-------+  STB      |
|             |            |            |       |                  |             |         |       |           |
+-------------+            |            |       |                  |             +-------+-+       +-----------+
                           +-+--------+-+       +------------------+         Dual-Stack  |
                             |        |                                      IPv4 CGN    |
                             |        |                                      IPv6        |
                             |        |                                                  |         +-----------+
                     Outside |        |Inside                                            |         |           |
                     Pub IPv4|        |IPv4 CGN                                          +---------+ Notebook  |
                           +------------+                                                Dual-Stack|           |
                           |            |                                                Priv IPv4 +-----------+
                           |  CGN       |                                                GUA IPv6
                           |            |
                           +------------+

Notebook has dual-stack. It will prefer IPv6 to connect to CDN.
Smart TV and STB don't have IPv6. They will usually need to go through CGN to connect to Public CDN.
Some Public CDNs are supporting to receive connections from CGN addresses (usually 100.64.x.x). In this case we can avoid to go through CGN and have a direct connection between customers and CDN. Customers normally are behind NAT of CPEs but they can have a CPE in bridge mode.
So, customers behind CGN don't need a CGN to connect to a public CDN installed within the ISP.

This case is where I see the three points where an ISP can use to consider to don't have an IPv6-only access network:
1- Traffic avoids a point of failure (CGN), obviously it should be redundant but the point of failure exists.
2- Traffic is more "transparent" avoiding another translation for CDN.
3- This traffic doesn't impact in CGN sizing.

Regards,
Alejandro

----- Mensaje original -----
De: "JORDI PALET MARTINEZ" <jordi.palet=[email-masked]>
Para: "Alejandro Degidio" <[email-masked]>
CC: "[email-masked] list" <[email-masked]>
Enviados: Lunes, 25 de Febrero 2019 22:12:12
Asunto: Re: [v6ops] inputs on NAT64/464XLAT Deployment Guidelines in Operator and Enterprise Networks draft-ietf-v6ops-nat64-deployment

Hi Alejandro,

That make sense to you?

Regards,
Jordi

-----Mensaje original-----
De: v6ops <[email-masked]> en nombre de Alejandro D'Egidio <adegidio=[email-masked]>
Fecha: martes, 26 de febrero de 2019, 0:24
Para: JORDI PALET MARTINEZ <jordi.palet=[email-masked]>
CC: "[email-masked] list" <[email-masked]>, dnsop <[email-masked]>
Asunto: Re: [v6ops] inputs on NAT64/464XLAT Deployment Guidelines in Operator and Enterprise Networks draft-ietf-v6ops-nat64-deployment

    Hello Jordi,

    

    Regards,
    Alejandro
    
    ----- Mensaje original -----
    De: "JORDI PALET MARTINEZ" <jordi.palet=[email-masked]>
    Para: "[email-masked] list" <[email-masked]>, "dnsop" <[email-masked]>
    Enviados: Jueves, 21 de Febrero 2019 2:58:36
    Asunto: [v6ops] inputs on NAT64/464XLAT Deployment Guidelines in Operator and Enterprise Networks draft-ietf-v6ops-nat64-deployment
    
    Hi all,

    
    Link to the document:

    
    Thanks!
    
    Regards,
    Jordi