Subject: [v6ops] Operational Implications of IPv6 Packets with Extension Headers - MTU

From: Vasilenko Eduard <[email-masked]>
Date: Mon, 27 Jul 2020 08:46:42 +0000

Hi Fernando,
It is possible to search "MTU" in your draft. But I am surprised anyway how small attention (to this problem) is in your draft.
IMHO: MTU deserves to be section 5.4
Eduard
-----Original Message-----
From: v6ops [mailto:[email-masked]] On Behalf Of Fernando Gont
Sent: 26 июля 2020 г. 8:46
To: IPv6 Operations <[email-masked]>
Cc: [email-masked]
Subject: [v6ops] Operational Implications of IPv6 Packets with Extension Headers (Fwd: New Version Notification for draft-gont-v6ops-ipv6-ehs-packet-drops-04.txt)

Folks,

We have posted a rev of our IETF I-D "Operational Implications of IPv6 Packets with Extension Headers".

The I-D is available at: 
https://www.ietf.org/internet-drafts/draft-gont-v6ops-ipv6-ehs-packet-drops-04.txt

Your feedback will be appreciated.

Thanks!

Cheers,
Fernando

-------- Forwarded Message --------
Subject: New Version Notification for
draft-gont-v6ops-ipv6-ehs-packet-drops-04.txt
Date: Sat, 25 Jul 2020 22:28:50 -0700
From: [email-masked]
To: Fernando Gont <[email-masked]>, Gert Doering <[email-masked]>, Geoff Huston <[email-masked]>, Warren Kumari <[email-masked]>, Nick Hilliard <[email-masked]>

A new version of I-D, draft-gont-v6ops-ipv6-ehs-packet-drops-04.txt
has been successfully submitted by Fernando Gont and posted to the IETF repository.

Name:		draft-gont-v6ops-ipv6-ehs-packet-drops
Revision:	04
Title:		Operational Implications of IPv6 Packets with Extension Headers
Document date:	2020-07-25
Group:		Individual Submission
Pages:		15
URL: 
https://www.ietf.org/internet-drafts/draft-gont-v6ops-ipv6-ehs-packet-drops-04.txt
Status: 
https://datatracker.ietf.org/doc/draft-gont-v6ops-ipv6-ehs-packet-drops/
Htmlized: 
https://tools.ietf.org/html/draft-gont-v6ops-ipv6-ehs-packet-drops-04
Htmlized: 
https://datatracker.ietf.org/doc/html/draft-gont-v6ops-ipv6-ehs-packet-drops
Diff: 
https://www.ietf.org/rfcdiff?url2=draft-gont-v6ops-ipv6-ehs-packet-drops-04

Abstract:
    This document summarizes the security and operational implications of
    IPv6 extension headers, and attempts to analyze reasons why packets
    with IPv6 extension headers may be dropped in the public Internet.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_______________________________________________
v6ops mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/v6ops

---

From: Fernando Gont <[email-masked]>
Date: Mon, 27 Jul 2020 06:18:23 -0300

Hello, Edward,

> IMHO: MTU deserves to be section 5.4

Could you please clarify what's the discussion you expect to see about 
the MTU?

Thanks!

Cheers,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Vasilenko Eduard <[email-masked]>
Date: Mon, 27 Jul 2020 09:39:35 +0000

Hi Fernando,
It is more important to have the problem mentioned on the list, then the quality of the section itself.
It is definitely a problem if one would like to activate any EH - potential admin should be warned.
What could be inside:
- small discussion that fragmentation in the middle of IPv6 path is not possible
- some IPCMPv6 messages should not be filtered
- MTU is better to change on networking links
In reality, I do not believe that it is difficult to compile this section, because so many materials on the IETF for this subject.
IMHO: it is very important to have this warning on the list.

If you like, I could try to write this small section. Just this week is a little busy for me.
Eduard
-----Original Message-----
From: Fernando Gont [mailto:[email-masked]] 
Sent: 27 июля 2020 г. 12:18
To: Vasilenko Eduard <[email-masked]>; IPv6 Operations <[email-masked]>
Cc: [email-masked]
Subject: Re: Operational Implications of IPv6 Packets with Extension Headers - MTU

Hello, Edward,

> IMHO: MTU deserves to be section 5.4

Could you please clarify what's the discussion you expect to see about the MTU?

Thanks!

Cheers,

---

From: Fernando Gont <[email-masked]>
Date: Mon, 27 Jul 2020 06:56:07 -0300

> It is more important to have the problem mentioned on the list, then the quality of the section itself.

I fail to understand what's the MTU problem you are referring to.  the 
Path-MTU being reduced as a consequence of the use of EHs? something else?

> - MTU is better to change on networking links

That seems to be unrelated with this particular document.  If anything, 
MTU issues are a problem to the folks at both endpoints of an application.

But this documents is concern with the operational challenges 
represented by EHs. i.e., why operators need to deal with them.

Thanks,

---

From: Nick Hilliard <[email-masked]>
Date: Mon, 27 Jul 2020 11:24:27 +0100

Eduard

MTUs don't change the principal that EHs can be operationally 
troublesome, although there may be a minor impact in terms of scope. 
It's probably a good idea to touch on the subject in the draft, but I 
don't think it needs much more than a mention.

Nick

---

From: Vasilenko Eduard <[email-masked]>
Date: Mon, 27 Jul 2020 10:25:33 +0000

If User would lose connectivity
Because additional EH increased packet size
And packet would be dropped.
Then it is the problem of Carrier.

There are a lot of recommendation how to avoid drop that happen as a result of bigger MTU demands.

-----Original Message-----
From: Fernando Gont [mailto:[email-masked]] 
Sent: 27 июля 2020 г. 12:56
To: Vasilenko Eduard <[email-masked]>; IPv6 Operations <[email-masked]>
Cc: [email-masked]
Subject: Re: Operational Implications of IPv6 Packets with Extension Headers - MTU

> It is more important to have the problem mentioned on the list, then the quality of the section itself.

I fail to understand what's the MTU problem you are referring to.  the Path-MTU being reduced as a consequence of the use of EHs? something else?

Thanks,

---

From: Gert Doering <[email-masked]>
Date: Mon, 27 Jul 2020 19:14:15 +0200

Hi,

> There are a lot of recommendation how to avoid drop that happen as a result of bigger MTU demands.

MTU issues (and any other sort of IPv6 misconfiguration at the end systems)
are out of scope of this documents.

There are many reasons why an end system would want to send a packet that
is too big, and EH-or-not does not make a material difference to
"application requests too-big UDP packet" (like, DNS).

Gert Doering
        -- NetMaster
-- 
have you enabled IPv6 on something today...?

SpaceNet AG                      Vorstand: Sebastian v. Bomhard, Michael Emmer
Joseph-Dollinger-Bogen 14        Aufsichtsratsvors.: A. Grundner-Culemann
D-80807 Muenchen                 HRB: 136055 (AG Muenchen)
Tel: +49 (0)89/32356-444         USt-IdNr.: DE813185279