Subject: [v6ops] Fwd: Status of Teredo?

From: Bob Hinden <[email-masked]>
Date: Thu, 9 Sep 2021 08:03:56 -0700

FYI

> Begin forwarded message:
> 
> From: Jeroen Massar <jeroen=[email-masked]>
> Subject: Status of Teredo?
> Date: September 9, 2021 at 5:49:02 AM PDT
> To: [email-masked]
> 
> Hi Folks,
> 
> What is the status of Teredo? Many parts of it have been shutdown, for instance:
> https://www.ietf.org/proceedings/87/slides/slides-87-v6ops-5.pdf
> Which is a few years back already again...
> 
> 
> But the prefix is still on the Internet:
> https://stat.ripe.net/widget/prefix-routing-consistency#w.resource=2001%3A%3A%2F32
> 
> What the BGP column, as some of those sources are IRR related!
> 
> Thus still originated from:
> 
>  1101 IP-EEND[1]
>  6939 HE.net
> 25192 CZ-NIC
> 29432 Trex.fi
> 211722 NULLROUTE-AS  which even got it IRR signed... fun
> 
> Should that prefix still be:
> a) routable? (given the microsoft teredo service is shutdown; one needs to manually do things)
> b) filtered, as many people do?
> c) marked deprecated in IANA?
> 
> Is there still traffic?
> 
> Greets,
> Jeroen
> 
> [1] Wim Biemolt @ Surfnet-- lookup "WC Eend" to get, part of, the joke ;)
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Clark Gaylord <[email-masked]>
Date: Thu, 9 Sep 2021 16:08:41 -0400

I haven't seen it in use for years, certainly not to good effect. My
recommendation for Windows GPO (or local policy) is to *disable* the IP
Helper service (and of course run IPv6 natively on all reasonable
interfaces.)

--
Clark Gaylord
[email-masked]
... autocorrect may have improved this message ...

On Thu, Sep 9, 2021, 11:04 Bob Hinden <[email-masked]> wrote:

> FYI
>
> Begin forwarded message:
>
> *From: *Jeroen Massar <jeroen=[email-masked]>
> *Subject: **Status of Teredo?*
> *Date: *September 9, 2021 at 5:49:02 AM PDT
> *To: [email-masked]
>
> Hi Folks,
>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 10 Sep 2021 08:58:50 +1200

Is it causing active harm?

If yes: do something like RFC7526.

If no: don't worry, be happy.

Regards
   Brian

On 10-Sep-21 08:08, Clark Gaylord wrote:
> I haven't seen it in use for years, certainly not to good effect. My recommendation for Windows GPO (or local policy) is to *disable* the IP Helper service (and of course run IPv6 natively on all reasonable interfaces.)
> 
> --
> Clark Gaylord
> [email-masked] <mailto:[email-masked]>
> On Thu, Sep 9, 2021, 11:04 Bob Hinden <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     FYI
> 
>>     Begin forwarded message:
>>
>>     *From: *Jeroen Massar <jeroen=[email-masked] <mailto:jeroen=[email-masked]>>
>>     *To: [email-masked] <mailto:[email-masked]>
>>
>>     Hi Folks,
>>
>>     https://www.ietf.org/proceedings/87/slides/slides-87-v6ops-5.pdf <https://www.ietf.org/proceedings/87/slides/slides-87-v6ops-5.pdf>
>>     https://stat.ripe.net/widget/prefix-routing-consistency#w.resource=2001%3A%3A%2F32 <https://stat.ripe.net/widget/prefix-routing-consistency#w.resource=2001%3A%3A%2F32>
>>
>>     [email-masked] <mailto:[email-masked]>
>>     Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6 <https://www.ietf.org/mailman/listinfo/ipv6>
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/listinfo/v6ops <https://www.ietf.org/mailman/listinfo/v6ops>
> 
>