Subject: [v6ops] Call for adoption: draft-peng-v6ops-hbh

From: Gorry Fairhurst <[email-masked]>
Date: Sat, 11 Sep 2021 14:28:01 +0100

I read draft-peng-v6ops-hbh as a part of thinking about the adoption 
call in v6OPS.

* I do think that it would be useful for v6OPS to produce an 
Informational RFC in this topic. As someone who reviews documents across 
different areas, I'd be keen to understand the limitations and 
short-term plans for using and evolving equipment - I see WG document as 
important in informing the standards process, especially if it has a 
representative cross-section of equipment vendors/operators (which I am 
not).

* I think the present discussion provided in the ID is likely had some 
particular size of router in mind, and I expect that does need to come 
across better in scoping the information provided. e.g. I can find a 
software a v6 router in my AP, and in an IoT gateway... and many other 
places, this I think isn't the target of this ID?  Actually, I suspect 
the IETF just needs some (new?) commonly understood terms and I don't 
see this as a problem to adoption, but I think it will be a problem that 
needs to be addressed before WGLC, especially if this to be utilized by 
other WGs as an input!

* I do have one issue: I realise there can be a fine line between 
understanding what is feasible/useful and  best current preactive on one 
hand, and placing requirements on future specifictaions on the other. I 
would be concerned if such an informational draft from the OPS area 
attempts to constrain development of INT area standards track specs and 
I think the present current section 7 and 8 do have several parts that 
cross that line, to me, these need to be rephrased here (or omitted). 
I'dd hope that co-ordination with 6man can  ensure that these 
operational considerations do reach the people developing the specs.

Gorry Fairhurst

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Mon, 13 Sep 2021 10:44:43 +0000

Hi Gorry,

Many thanks for your careful review and valuable suggestions.

First of all, thank you for acknowledging the need for such work and its direction towards an informational RFC to serve the community.

I agree with you that we need a clear scope and we will work on that.

Our intention is to make this draft actively aid rather than constrain the work on producing any INT area standards specs. We agree that the last two sections need work, and we will rework on them with the help from the folks in the two WGs. Considering that we have already got a lot of very good suggestions, we will shape them up relatively easily.

Thank you!

Best regards,
Shuping

From: v6ops [mailto:[email-masked]] On Behalf Of Gorry Fairhurst
Sent: Saturday, September 11, 2021 9:28 PM
To: [email-masked]
Subject: [v6ops] Call for adoption: draft-peng-v6ops-hbh

I read draft-peng-v6ops-hbh as a part of thinking about the adoption call in v6OPS.

* I do think that it would be useful for v6OPS to produce an Informational RFC in this topic. As someone who reviews documents across different areas, I'd be keen to understand the limitations and short-term plans for using and evolving equipment - I see WG document as important in informing the standards process, especially if it has a representative cross-section of equipment vendors/operators (which I am not).

* I think the present discussion provided in the ID is likely had some particular size of router in mind, and I expect that does need to come across better in scoping the information provided. e.g. I can find a software a v6 router in my AP, and in an IoT gateway... and many other places, this I think isn't the target of this ID?  Actually, I suspect the IETF just needs some (new?) commonly understood terms and I don't see this as a problem to adoption, but I think it will be a problem that needs to be addressed before WGLC, especially if this to be utilized by other WGs as an input!

* I do have one issue: I realise there can be a fine line between understanding what is feasible/useful and  best current preactive on one hand, and placing requirements on future specifictaions on the other. I would be concerned if such an informational draft from the OPS area attempts to constrain development of INT area standards track specs and I think the present current section 7 and 8 do have several parts that cross that line, to me, these need to be rephrased here (or omitted). I'dd hope that co-ordination with 6man can  ensure that these operational considerations do reach the people developing the specs.

Gorry Fairhurst