Subject: Re: [v6ops] ND Robustness - Real life data of issue

From: "Olopade, Olorunloba" <[email-masked]>
Date: Sat, 15 Jan 2022 19:31:59 +0000

Hello all,

One of the feedbacks from Eduard's presentation at IETF 112 was the need for real life data. i.e. Is the issue real and actually affecting people?

In reference to this, could people have a look at these ICMPv6 analysis of NTP traffic that was done by Johannes Weber.

UK IPv6 Council Spring 2020: Incorrect Working IPv6 Clients & Networks | Weberblog.net<https://weberblog.net/uk-ipv6-council-spring-2020-incorrect-working-ipv6-clients-networks/>
Incorrect Working IPv6 NTP Clients/Networks | Weberblog.net<https://weberblog.net/incorrect-working-ipv6-ntp-clients-networks/>

A key takeaway from this is that error rate for IPv6 was much higher than IPv4 - Not good.

<https://weberblog.net/wp-content/uploads/2020/04/Case-Stury-NTP-Pool-01-Number-of-NTP-Packets.png>

However, most of these errors were "host unreachable" (ICMPv6 type 1, code 3). It is my opinion/educated guess that these are due to IPv6 prefix changes by the service providers, but with the users still using the stale prefixes. Without unicast reverse path forwarding, traffic from the customer gets to the Internet server, but the return traffic doesn't reach the customer. Hence, we either get a network unreachable or host unreachable ICMP error.

These packet capture/analysis were done a couple of years ago. But I believe they are still valid. It would be great if someone has similar access to do a similar analysis now. Any takers?

Finally, I believe that recommendations in RFC9096 offers some mitigations. It is my opinion that it does not go far enough. And that we would need to make some changes to the protocol specifications.

Regards.

Save Paper - Do you really need to print this e-mail?

This email contains information from Virgin Media and/or Telefonica UK Limited (O2) and may be confidential and legally privileged. Statements and opinions expressed in this email or any attachment may not represent either those of Virgin Media or Telefonica UK Limited. Any representations or commitments in this email or any attachment are subject to contract.  The information in this email is intended solely for the attention of the addressee(s) and if you are not the intended recipient please delete it (including any attachment) from your system, and be aware that any disclosure, copying distribution or use of any of this information is not permitted.

If you are in receipt of a suspicious email or you have received an email in error from Virgin Media, please report it to www.virginmedia.com/netreport, or for Telefonica UK Limited (O2), please report it to www.o2.co.uk/help/safety-and-security. 

 Registered offices:

 Virgin Media Limited, 500 Brook Drive, Reading, RG2 6UU. Registered in England and Wales: 2591237

 Telefonica UK Limited, 260 Bath Road, Slough, Berkshire SL1 4DX. Registered in England and Wales: 1743099

 VMED O2 UK Limited, Griffin House, 161 Hammersmith Road, London, United Kingdom, W6 8BS. Registered in England and Wales: 12580944

---

From: "Olopade, Olorunloba" <[email-masked]>
Date: Tue, 18 Jan 2022 08:55:29 +0000

Sorry, sending again as it didn't show on 6man.

Hello all,

IPv6                                     Legacy IP
Number of NTP Packets                                              7M                                       85M
NTP Packets per second                                              1.24                                     14.9
Unique source address of NTP Packets                   0.65 M (9.3%)                   3.4 M (4%)
NTP sources that caused ICMP errors                     30K                                      96K
Percentage of failed NTP sources                             4.55%                                  2.81%

Regards.

 Registered offices: