Subject: [v6ops] Should we meet at IETF 113?

From: Fred Baker <[email-masked]>
Date: Wed, 26 Jan 2022 22:23:25 -0800

At this point, I can’t say that any of our posted drafts has much wind in its sails, and I don’t know of new drafts coming. I have requested a slot at IETF 113, but the chairs are seriously wondering whether we should meet.

If you plan to post a draft soon (e.g., by March 7), please drop a note to the list generating discussion on your proposed topic. If you would like to discuss IPv6 networks as a group of operators, please drop a note to the list saying that.

Sent from my iPad

---

From: Gabor LENCSE <[email-masked]>
Date: Thu, 27 Jan 2022 10:27:57 +0100

Dear Fred,

> If you plan to post a draft soon (e.g., by March 7), please drop a note to the list generating discussion on your proposed topic. If you would like to discuss IPv6 networks as a group of operators,…

I am working on the scale-up measurements of the Jool stateful NAT64 
solution for the "01" version of:

G. Lencse, "Scalability of IPv6 Transition Technologies for IPv4aaS", 
Internet Draft, Oct 16, 2021, draft-lencse-v6ops-transition-scalability-00
https://datatracker.ietf.org/doc/html/draft-lencse-v6ops-transition-scalability

Jool shows poor scalability against the number of CPU cores.

Its performance also degrades with the number of concurrent sessions. 
However, it works also with 1.6 billion sessions, whereas iptables was 
not able to handle so many session using the same hardware.

Due to the high number of sessions and low maximum connection 
establishment rate, my measurements take VERY long time. I hope to be 
able to upload the new version in about 2-3 week, definitely before March 1.

I would be happy to present my results at IETF 113, and I am eager to 
receive feedback!

Best regards,

Gábor

---

From: Xipengxiao <[email-masked]>
Date: Thu, 27 Jan 2022 11:39:24 +0000

Hi Fred,

I plan to post a new version of draft-xiao-v6ops-nd-deployment-guidelines based on feedbacks from IETF 112, and would like to request a time slot to present in IETF 113.

I would also like to take this opportunity to voice some observations for the chairs and guardians' consideration: we are setting the v6ops participation criteria too high to attract new participations.  To explain this, first let me state 2 facts: (1) most of the world's IPv6 deployment is at the overlay. There is very little deployment in IPv6 underlay, because many challenges exist in operating an IPv6 underlay (2) even for IPv6 overlay, many operators face challenges in deploying it.  Given these challenges (granted that some are not technical), we should expect v6ops to be a buzzing place, where some people talk about their challenges while others advising how to deal with these challenges.  But reality is very different.  Why?  

I want to share my personal experience as an example.  I submitted draft-xiao-v6ops-nd-deployment-guidelines in July 2021 shortly before deadline for IETF 111, and requested a time slot to present.  But the request was not granted because it didn't meet the presentation criterion: having interest/discussion in the mailing list.  I think this rule was very reasonable in the past, to prevent low quality works from competing with high quality works in the agenda.  But does this rule still serves the WG well today? I am not sure.  The fact is, after 20 years, even though many challenges still need to be solved, IPv6 is no longer so sexy.  This is also a world of too much information and too little time.  So if a new comer publishes another IPv6 draft, who cares!  I often wait till the IETF meeting time to process the IETF-related information/issues, and I suspect I am not the only one.  This means that a draft may not get attention until the meeting time, but by our rule, it cannot be presented.  This can be very discouraging for new participants.

I am not complaining here, but pointing out a situation.  To me, it's right to guard the quality of IETF work, but I think this can be done at WG adoption and RFC publication time, not necessarily at every step.  If we have more time than "qualified" presentations in IETF 113, why not welcome other people who want to present?  I think that many people still consider IETF presentation an honor, and if they know v6ops welcome that, we will see more contributions.  I understand that some balance must be maintained, but I think a buzzing WG with many discussions (even if some are sub-par) than little discussion.  

Thanks for your time and consideration.

XiPeng 

-----Original Message-----
From: v6ops <[email-masked]> On Behalf Of Gabor LENCSE
Sent: Thursday, January 27, 2022 10:28 AM
To: [email-masked]
Subject: Re: [v6ops] Should we meet at IETF 113?

Dear Fred,

> If you plan to post a draft soon (e.g., by March 7), please drop a note to the list generating discussion on your proposed topic. If you would like to discuss IPv6 networks as a group of operators,…

I am working on the scale-up measurements of the Jool stateful NAT64 solution for the "01" version of:

G. Lencse, "Scalability of IPv6 Transition Technologies for IPv4aaS", Internet Draft, Oct 16, 2021, draft-lencse-v6ops-transition-scalability-00
https://datatracker.ietf.org/doc/html/draft-lencse-v6ops-transition-scalability

Its performance also degrades with the number of concurrent sessions. 
However, it works also with 1.6 billion sessions, whereas iptables was not able to handle so many session using the same hardware.

Due to the high number of sessions and low maximum connection establishment rate, my measurements take VERY long time. I hope to be able to upload the new version in about 2-3 week, definitely before March 1.

I would be happy to present my results at IETF 113, and I am eager to receive feedback!

Best regards,

Gábor

_______________________________________________
v6ops mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/v6ops

---

From: Paolo Volpato <[email-masked]>
Date: Thu, 27 Jan 2022 14:19:24 +0000

Hi Fred, All,

We plan to submit a new version of the draft "IPv6 Deployment Status" (https://datatracker.ietf.org/doc/draft-ietf-v6ops-ipv6-deployment/) at the beginning of February, leaving enough time to people to read and comment it before IETF 113. 

The main changes in this new version should reflect:
1. the status of IPv6 at the beginning of 2022;
2. the adoption of IPv6 in further economies (in addition to China and the USA);
3. the role of overlay mechanisms to enable smoother transition to IPv6.

We believe that this latter topic is particularly important, at present, to raise the discussion on the transition to IPv6 (previous messages in the list have also underlined its importance).
On behalf of the co-authors of the draft, hope we have to opportunity to present our update at the IETF 113.

Best regards
Paolo

-----Original Message-----
From: v6ops <[email-masked]> On Behalf Of Fred Baker
Sent: Thursday, January 27, 2022 7:23 AM
To: IPv6 Ops WG <[email-masked]>
Subject: [v6ops] Should we meet at IETF 113?

Sent from my iPad

---

From: Fred Baker <[email-masked]>
Date: Thu, 27 Jan 2022 17:00:43 -0800

> On Jan 27, 2022, at 3:39 AM, Xipengxiao <[email-masked]> wrote:
> 

OK. Ron and I spoke this afternoon, and we plan to have these three items on our agenda, with about 15 minutes each of presentation and discussion. 

XiPeng, would you kindly also be prepared to lead a discussion of your concerns and how one gets agenda time?

Following that, we plan to have the working group decide how it wants us to manage the agenda.

---

From: Martin Huněk <[email-masked]>
Date: Sun, 30 Jan 2022 00:58:56 +0100

Hi Fred, Hi all,

I'm also planning to submit an updated version of the "NAT64/DNS64 detection via SRV Records" draft [1]. Changes planted so far are mostly editorial to 00 version.

If there is an interest, I would also like to present at IETF 113.

Sincerely,
Martin

[1] https://datatracker.ietf.org/doc/html/draft-hunek-v6ops-nat64-srv-00.txt