Subject: Re: [v6ops] New Version Notification for draft-ietf-v6ops-ipv6-deployment-04.txt

From: Paolo Volpato <[email-masked]>
Date: Tue, 8 Feb 2022 15:53:42 +0000

Dear WG,

We have published version 04 of draft-ietf-v6ops-ipv6-deployment (https://datatracker.ietf.org/doc/draft-ietf-v6ops-ipv6-deployment/).

We have reviewed most of the draft, to update the status of IPv6 deployment and to refresh some of its parts. 

Here is the summary of the main changes:
- Section 2: introduced the new numbers on the adoption IPv6 (as of January 2022).
- Section 3: updated the adoption of IPv6 in the enterprise, government and education domains. We have also added references to more countries (e.g. India, the European Union).
- Section 4: we have reviewed this section to address some offline comments and discussions on the concept of "overlay" (i.e. how IPv6 may support the service layer and its role to enable the transition to IPv6-only).
- Section 5: reviewed the description of IPv6 in the "underlay" (the network).

Please feel free to comment.

On behalf of the authors
Paolo

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Tuesday, February 8, 2022 4:34 PM
To: Gyan S. Mishra <[email-masked]>; Chongfeng Xie <[email-masked]>; Giuseppe Fioccola <[email-masked]>; Gyan Mishra <[email-masked]>; Jordi Martinez <[email-masked]>; Jordi Palet Martinez <[email-masked]>; Nalini Elkins <[email-masked]>; Paolo Volpato <[email-masked]>
Subject: New Version Notification for draft-ietf-v6ops-ipv6-deployment-04.txt

A new version of I-D, draft-ietf-v6ops-ipv6-deployment-04.txt
has been successfully submitted by Giuseppe Fioccola and posted to the IETF repository.

Name:		draft-ietf-v6ops-ipv6-deployment
Revision:	04
Title:		IPv6 Deployment Status
Document date:	2022-02-08
Group:		v6ops
Pages:		45
URL:            https://www.ietf.org/archive/id/draft-ietf-v6ops-ipv6-deployment-04.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-v6ops-ipv6-deployment/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-v6ops-ipv6-deployment
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-v6ops-ipv6-deployment-04

Abstract:
   This document provides an overview of IPv6 deployment status and a
   view on how the transition to IPv6 is progressing among network
   operators and enterprises.  It also aims to analyze the related
   challenges and therefore encourage actions and more investigations in
   those areas where the industry has not taken a clear and unified
   approach.

The IETF Secretariat

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 22 Feb 2022 12:20:31 +0100

Hi all,

I've cached some minor points that we have already confirmed among the co-authors, but it will be good to see if someone else in the WG has anything else to say before a new version.

1) After "The reasons for having high or medium-to-high IPv6 deployment may be
   quite different from country to country.  For example, in West
   European countries such as Belgium, France, Germany the outcome
   depends on a mix of government and regulation activities which
   incentivized the adoption of IPv6 in the recent years."

I think we should add "In some cases it has been industry self-regulation which created the traction for a bigger IPv6 adoption".

Explanation: This was for example the case for Belgium, much more than government regulation. It was an agreement among operators and to reduce the number of users behind NAT in a single IPv4 address.

2) Across all the document. There is no such thing as "migration", there are no "migration" techniques. We should replace it with "transition" or "transition and coexistence", etc., unless IPv4 is totally discarded from that network (that will be a real migration case, like when you move from Windows 7 to Windows 10, you don't keep both running at the same time). This is key, because this document will be read by people learning, not so versed in the topic, and when I do trainings, using migration is the aspect that most confuses people.

3) Usage of CPE or CE? I think to be consistent with other documents, we should use CE instead of CPE.

4) Terminology. Should we have a terminology section at the beggininig of the document? We can there define each term and abbreviation used across the document, so it clarifies the text and avoid duplication. For example my previous point will be:
CE:	Customer Edge router.

5) After "the consensus to move to IPv6-only is when IPv6
   traffic volume is between 50% and 60%.," I will say ", which easily happens from since the moment IPv6 is deployed in networks where residential customers traffic is higher than business traffic (because major content providers, as already explained, already use IPv6)".

6) After "For example, Sony Play
   Station Network or OpenDNS imply a higher rotation of IPv4 prefixes
   in CGN, until they get totally blocked.", I will say "which means extra CAPEX in new IPv4 transfers."

7) I'm included in the ack section, I guess should be removed from there.

        -----Original Message-----
        From: Paolo Volpato 
        Sent: Tuesday, February 8, 2022 4:54 PM
        To: [email-masked]
        Cc: Chongfeng Xie <[email-masked]>; Giuseppe Fioccola <[email-masked]>; Gyan Mishra <[email-masked]>; Jordi Palet Martinez <[email-masked]>; Nalini Elkins <[email-masked]>
        Subject: RE: New Version Notification for draft-ietf-v6ops-ipv6-deployment-04.txt

        Dear WG,

        On behalf of the authors
        Paolo

        -----Original Message-----
        From: [email-masked] <[email-masked]> 
        Sent: Tuesday, February 8, 2022 4:34 PM
        To: Gyan S. Mishra <[email-masked]>; Chongfeng Xie <[email-masked]>; Giuseppe Fioccola <[email-masked]>; Gyan Mishra <[email-masked]>; Jordi Martinez <[email-masked]>; Jordi Palet Martinez <[email-masked]>; Nalini Elkins <[email-masked]>; Paolo Volpato <[email-masked]>
        Subject: New Version Notification for draft-ietf-v6ops-ipv6-deployment-04.txt

        Abstract:

        The IETF Secretariat

    **********************************************
    IPv4 is over
    Are you ready for the new Internet ?
    http://www.theipv6company.com
    The IPv6 Company

    This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.