Subject: Re: [v6ops] New Version Notification for draft-ietf-v6ops-ipv6-deployment-04.txt

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 28 Feb 2022 15:51:05 +0100

Hi Cong,

Tks a lot for the inputs!

My responses below in-line, as co-author.

Regards,

Jordi

@jordipalet

El 28/2/22 9:49, "v6ops en nombre de Li Cong" <[email-masked] en nombre de [email-masked]> escribió:

Hi, Paolo,

This draft gives a comprehensive picture of global IPv6 development and extracts some basic challenges that need to be solved by the industry. I think this draft is useful. In addition, I also have some comments prefixed [Cong] below, 

[Cong]: In this draft, you use the terms of “IPv6 introduction” and “IPv6-only to illustrate the first stage and second stage of IPv6 development respectively. However, I think they may overlap in some scenarios, for instance, some operators may use IPv6-only directly and stride over the IPv6-introduction stage with dual-stack. What I mean here is that dual-stack and IPv6-only are different approaches of transition, they do not correspond to the stages absolutely.    

[Jordi] Yes, in some cases, the “IPv6 introduction”can/will be directly bypassed. I thought was obvious in the text, but definitively we need stress it to ensure that is sufficiently clear.

In section 3.6, “The preliminary step to take full benefit of the IPv6 capabilities is to write or adapt the application software for use in IPv6 networks”

[Cong]: As far as I know, the software code of most modern applications is agnostic to the type of IP address, whether the application uses IPv6 lies in the difference of address configuration of the host.

[Jordi] I don’t think that’s the case in some situation (unfortunately too many). I often still find all kinds of apps, including network management ones, that aren’t yet really working in a dual-stack or even IPv6-only environment. So I think we shall keep that section.

In Section 4.1， “Although the Dual-Stack IPv6 transition is a good solution to be followed in the IPv6 introductory stage,” 

[Cong]: From the perspective of network operation, I don’t think dual-stack is a GOOD solution, for it increase the cost of O&M. In addition, dual-stack provide exposure-face, it increases the risk of being attack. I think it should be replaced by other term.

[Jordi] I definitively agree with you. Again, I thought it was clear in the text, we shall stress it, but it is a case-by-case dependent. For example, if an ISP has sufficient IPv4 addresses, and the CPEs support dual-stack, but not IPv6-only with IPv4aaS, then the Capex may surpass the Opex if moving to IPv6-only instead of dual-stack. Of course, that will have a break point at some time, but it will depend on every case.

In section 4.. “IPv6-only transition technologies with IPv4aaS have a much lower need for IPv4 public addresses, because they make a more efficient usage without restricting the number of ports per subscriber.”

[Cong]: I think the restriction of number of ports per-subscriber is related to the policy of address/port usage, IMO it should be independent to the approach of IPv4aaS.

[Jordi] I will say that also depends a lot on the specific IPv6-only with IPv4aaS being used. In 464XLAT, you don’t need to restrict the number of ports per subscriber and the overall public IPv4 usage is lower. However, this is not the case in the other ones. I think this is very well described in another document, so one more reference to it (https://datatracker.ietf.org/doc/draft-ietf-v6ops-transition-comparison/) should clear that.

I hope my comments will be helpful to your document.

Best regards， 

Cong Li

-----Original Message-----
From: Paolo Volpato 
Sent: Tuesday, February 8, 2022 4:54 PM
To: [email-masked]
Cc: Chongfeng Xie <[email-masked]>; Giuseppe Fioccola <[email-masked]>; Gyan Mishra <[email-masked]>; Jordi Palet Martinez <[email-masked]>; Nalini Elkins <[email-masked]>
Subject: RE: New Version Notification for draft-ietf-v6ops-ipv6-deployment-04.txt

Dear WG,

We have published version 04 of draft-ietf-v6ops-ipv6-deployment (https://datatracker.ietf.org/doc/draft-ietf-v6ops-ipv6-deployment/).

We have reviewed most of the draft, to update the status of IPv6 deployment and to refresh some of its parts. 

Here is the summary of the main changes:
- Section 2: introduced the new numbers on the adoption IPv6 (as of January 2022).
- Section 3: updated the adoption of IPv6 in the enterprise, government and education domains. We have also added references to more countries (e.g. India, the European Union).
- Section 4: we have reviewed this section to address some offline comments and discussions on the concept of "overlay" (i.e. how IPv6 may support the service layer and its role to enable the transition to IPv6-only).
- Section 5: reviewed the description of IPv6 in the "underlay" (the network).

Please feel free to comment.

On behalf of the authors
Paolo

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Tuesday, February 8, 2022 4:34 PM
To: Gyan S. Mishra <[email-masked]>; Chongfeng Xie <[email-masked]>; Giuseppe Fioccola <[email-masked]>; Gyan Mishra <[email-masked]>; Jordi Martinez <[email-masked]>; Jordi Palet Martinez <[email-masked]>; Nalini Elkins <[email-masked]>; Paolo Volpato <[email-masked]>
Subject: New Version Notification for draft-ietf-v6ops-ipv6-deployment-04.txt

A new version of I-D, draft-ietf-v6ops-ipv6-deployment-04.txt
has been successfully submitted by Giuseppe Fioccola and posted to the IETF repository.

Name:        draft-ietf-v6ops-ipv6-deployment
Revision:    04
Title:        IPv6 Deployment Status
Document date:    2022-02-08
Group:        v6ops
Pages:        45
URL:            https://www.ietf.org/archive/id/draft-ietf-v6ops-ipv6-deployment-04.txt
Status:        https://datatracker.ietf.org/doc/draft-ietf-v6ops-ipv6-deployment/
Htmlized:      https://datatracker.ietf.org/doc/html/draft-ietf-v6ops-ipv6-deployment
Diff:          https://www.ietf.org/rfcdiff?url2=draft-ietf-v6ops-ipv6-deployment-04

Abstract:
  This document provides an overview of IPv6 deployment status and a
  view on how the transition to IPv6 is progressing among network
  operators and enterprises.  It also aims to analyze the related
  challenges and therefore encourage actions and more investigations in
  those areas where the industry has not taken a clear and unified
  approach.

The IETF Secretariat

_______________________________________________ v6ops mailing list [email-masked] https://www.ietf.org/mailman/listinfo/v6ops 

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Paolo Volpato <[email-masked]>
Date: Mon, 28 Feb 2022 16:32:43 +0000

Hi Cong,

Many thanks for your comments.
We are currently working on a new version of the draft that will be uploaded just before the deadline for the IETF 113.
That version will address some online/offline comments we have received after the publication of version -04 and will take your input into consideration.

Also, please see inline my answer (as [PV]).

Best regards
Paolo

From: v6ops <[email-masked]> On Behalf Of JORDI PALET MARTINEZ
Sent: Monday, February 28, 2022 3:51 PM
To: [email-masked]
Subject: Re: [v6ops] New Version Notification for draft-ietf-v6ops-ipv6-deployment-04.txt

Hi Cong,

Regards,
Jordi
@jordipalet

El 28/2/22 9:49, "v6ops en nombre de Li Cong" <[email-masked]<mailto:[email-masked]> en nombre de [email-masked]<mailto:[email-masked]>> escribió:

Hi, Paolo,

[PV] The sequence we have proposed comes from our experience and can be seen as a general approach often adopted by operators to deal with the introduction and deployment of IPv6. That does not preclude that, as you said, an operator directly jumps to an IPv6-only solution. We will better clarify this point in the next version of the draft.

[PV] I tend to agree with Jordi. Unfortunately, many applications don’t fully support IPv6 and have not been updated yet. The draft references some technical papers that discuss what it is still missing for a full support.

[PV] We will review the text here to be a bit more specific.

[PV] Sure, many thanks!

Best regards，
Cong Li

-----Original Message-----
From: Paolo Volpato
Sent: Tuesday, February 8, 2022 4:54 PM
To: [email-masked]<mailto:[email-masked]>
Cc: Chongfeng Xie <[email-masked]<mailto:[email-masked]>>; Giuseppe Fioccola <[email-masked]<mailto:[email-masked]>>; Gyan Mishra <[email-masked]<mailto:[email-masked]>>; Jordi Palet Martinez <[email-masked]<mailto:[email-masked]>>; Nalini Elkins <[email-masked]<mailto:[email-masked]>>
Subject: RE: New Version Notification for draft-ietf-v6ops-ipv6-deployment-04.txt

Dear WG,

On behalf of the authors
Paolo

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, February 8, 2022 4:34 PM
To: Gyan S. Mishra <[email-masked]<mailto:[email-masked]>>; Chongfeng Xie <[email-masked]<mailto:[email-masked]>>; Giuseppe Fioccola <[email-masked]<mailto:[email-masked]>>; Gyan Mishra <[email-masked]<mailto:[email-masked]>>; Jordi Martinez <[email-masked]<mailto:[email-masked]>>; Jordi Palet Martinez <[email-masked]<mailto:[email-masked]>>; Nalini Elkins <[email-masked]<mailto:[email-masked]>>; Paolo Volpato <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-ietf-v6ops-ipv6-deployment-04.txt

Abstract:

The IETF Secretariat

_______________________________________________ v6ops mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/v6ops