Subject: Re: refocusing: Re: [v6tc] Issue 2: service discovery: automaticormanual?

From: "Miguel Angel Diaz" <[email-masked]>
Date: Tue, 18 Jan 2005 10:14:30 +0100

>> IMHO if we wish a broad and fast deployment of IPv6 the answer is that an
>> automatic discovery mechanism is definitively required. 
> 
> There is already Teredo and 6to4, what more is needed?
> Teredo on it's own already solves most if not all problems.
> The only issue with Teredo _could_ be that one does not get the most
> local relay. But I think M$ can be easily pursuade to add a update to
> windowsupdate that will reconfigure the default teredoserver to an
> anycast address.
> 

Thousands (even millions) of users over the world can't use the current servers that M$ has pre-configured for 6to4 and Teredo implementations on the OS, which are 6to4.ipv6.microsoft.com and teredo.ipv6.microsoft.com. It is assumed that every ISP willing to offer IPv6 services to their customers will deploy a TEP infrastructure on its own network, either Teredo, 6to4, or whatever. The TEP discovery on the ISP network is the point.

> The point more is: who uses it?
> 
>> Today many ISPs are wondering why should they deploy IPv6 in their core networks
>> or in their access networks if no IPv6 traffic is detected.
> 
> How can they claim they don't see traffic if they don't have any
> connectivity. This is really a weird and invalid assumption.
> The thing has to do with one simple thing: Money.
> And IPv6 as connectivity does not get them extra cash in their pockets
> why would they even bother with it?
> 

I meant that ISPs don't detect IPv6 tunneled traffic (IPv6-IPv4, IPv6-UDP, etc) because obvioulsy they aren't deployed native IPv6 on the access network yet ;-)

> Tell them that they can generate revenue and how and they will focus on
> it. But getting a re-schooling for their, most likely already, under-
> educated helpdesk and the many other parts of their organization is
> really not where they are going to invest money into.
> As the moment the provide it they also need to provide support.
> 
> "Hi this is Grandma, my internet does not work"
> 
>> On the other hand, hardware manufacturers, application developers and users in
>> general are wondering why should they need IPv6 in the products that
>> they develop/use if users don't have IPv6 connectivity either native
>> or by mean of an easy/automatic transition mechanism.
> 
> Users don't know what IP is, what version it is, they don't care nor do
> they want to care.
> 
> To put it bluntly: they want ass, tits and a lot of killing in their
> virtual warfields.
> 
> Does Doom3 support IPv6? Does Halo2 support IPv6? Does Half Life support
> it? => No. Should somebody as a being a normal user care? No?
> Does their porn work over IPv4? => Yes, so do they care for IPv6? => No.
> 
> There is this nice blonde girl singing a nice song: It is all about the
> money. And even though in the US the DoD claim to invest billions for
> IPv6, there is no such thing toward the enduser. Thus should the
> provider for endusers care? => No.
> 
> 
> 
>> In these circumstances, ISP will never detect IPv6 traffic because users (normal
>> users) don't know (and likely don't want to) how to find TEPs and how to configure
>> IPv6 tunnels
> 
> They apparently know very well how to do all this. Google for newsserver
> and IPv6 and free and similar wordings. Tutorials are there for the grab
> and then you don't even see the backroom chats where the trading is
> going on.
> 
>> , and product developers aren't pushed neither to develop IPv6
>> products/application (which would generate the IPv6 traffic) because they depend
>> on the technical knowledge of users (usually minimal if any).
> 
> Product developers don't see money in IPv6 so why would they care?
> 
>> This is a bootstrapping and the only way to solve it is by easing the IPv6 transition.
>> One efficient mean is an auto-discovery mechanism that finds the TEP by itself and users don't have to be worried about it.
> 
> Ever considered Teredo ?
> 
>> Let's think that there could be a lot of IPv6 devices like cameras, home automation devices, cars, etc that
>> could take advantage of an automatic discovery method to find IPv6 connectivity without human intervention.
> 
> Now if I would live in Tokio I could live with this assumption, but
> unfortunately, unless I go to Akibara myself or import the stuff I will
> not be able to buy these cool toys (yet).
> 
> Also, the router in the house should provide this, not the camera, that
> should simply RA. Next to that does the word 'security' say anything?

The point is that "today" we are working on the networks for "tomorrow" and in the near future, I think we all are agree that many home devices will support IPv6. Such devices could implement methods to work with IPv6 even although only IPv4 (so not RA available) is available on the home network during the early deployments. In this scenario an automatic discovery method is required.

> 
>> So, IMHO the answer is that we can't live with methods that require users to enter any URL or data.
> 
> I know of almost 3500 happy users who lived with this perfectly fine and
> there are a number of other organizations who claim to have way more
> users.
> 

I guess we are thinking of different type of users. I sure that expert users (at least with some technical knowledge) are happy with that situation, but I'm thinking of thousands of users that aren't TI experts. My father might be a good example: he likes just plug-and-play devices because he has no technical knowledge at all, so he would like just plug its IPv6 camera (with transition mechanisms implemented) on the home network (IPv4) and see its house while traveling around the world. He wants that the camera itself is in charge of all the required configuration (TEP discovery included) to work.

**********************************
Madrid 2003 Global IPv6 Summit
Presentations and videos on line at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

_______________________________________________
v6tc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/v6tc

---

From: Jeroen Massar <[email-masked]>
Date: Tue, 18 Jan 2005 12:14:58 +0100

On Tue, 2005-01-18 at 10:14 +0100, Miguel Angel Diaz wrote:
> Thousands (even millions) of users over the world can't use the
> current servers that M$ has pre-configured for 6to4 and Teredo
> implementations on the OS, which are 6to4.ipv6.microsoft.com and
> teredo.ipv6.microsoft.com.

Did you notice the following:
6to4.ipv6.microsoft.com has address 192.88.99.1
6to4.ipv6.microsoft.com has address 131.107.33.60
6to4.ipv6.microsoft.com has IPv6 address 2002:836b:213c:1:e0:8f08:f020:8

If it isn't known, that first one is the 6to4 anycast address, which is
also the first thing that XP tries, after that it might fall back to the
microsoft provided relay.

They (6to4 and Teredo) work perfectly fine from the several places where
I have tried them. The only thing was the latency and throughput, which
is logical as the Teredo box is hosted in the US, which is not where I
am, but fortunately it uses those nice bubbles to locate a more local
server which then causes the traffic to be optimized a bit.

Any real argument why these millions of users can't use Teredo according
to you?

> It is assumed that every ISP willing to offer IPv6 services to their
> customers will deploy a TEP infrastructure on its own network, either Teredo,
> 6to4, or whatever. The TEP discovery on the ISP network is the point.

Of course they want that, just like this is expected from 6to4.
There is a very simple solution if you want this: anycast prefix for
Teredo. Does not require any weird mechanisms, no weird stuff in DNS
nothing. But to call this 'discovery', why bother with that ?

> The point is that "today" we are working on the networks for "tomorrow" and in the near future,

In the future there will be native IPv6 to the home, today there is need
for some tunneling. But in ~5 years it will be mostly native.

> I think we all are agree that many home devices will support IPv6. Such devices could implement
> methods to work with IPv6 even although only IPv4 (so not RA available) is available on the
> home network during the early deployments. In this scenario an automatic discovery method is required.

Thus you want every small device to implement tunneling and thus create
how many security holes in how many places?

You'd better start writing the security section of the draft like 3
years ago if you want to cover all the possible problems you will be
creating here.

Remember the following very simple thing: There will most likely be at
least one computer (XP, BSD, Linux, other 'router') that supports IPv6
in such networks. These are more than capable handling this and are also
way easier to make centrally secure/firewalled.

If you really want that you can plug in a IPv6 camera, which will then
also do IPv4 for the tunneling even though it is a IPv6-only cam, then
also remember the security problems.

> I guess we are thinking of different type of users. I sure that expert users (at least with some
> technical knowledge) are happy with that situation, but I'm thinking of thousands of users that
> aren't TI experts.

I am quite sure that most of those happy users are completely clueless
in what they are doing and just followed that nice article they found on
the internet or in that Computing Magazine For Dumbo's and are happily
downloading the newest movies/music and other warez they can find.
This is where the internet is used for and this already works.

> My father might be a good example: he likes just plug-and-play devices because
> he has no technical knowledge at all, so he would like just plug its IPv6 camera (with transition
> mechanisms implemented) on the home network (IPv4) and see its house while traveling around the world.
> He wants that the camera itself is in charge of all the required configuration (TEP discovery included) to work.

He is quite likely to not even want to know how it works, he wants it to
work, but without having his neighbor and that Brazilian kid and the
burglar watching his house for him too... or are you going to explain
him what security is? ;)

Next to that, implementors of small devices don't like to implement
multiple IP stacks and replicate work which should be done by other
equipment. Note that all the current IPv6 toys are IPv6-only and do not
have anything to do with IPv4. There is a reason for this: they don't
want to be bothered with IPv4 in the first place as those devices could
not communicate globally in the first place and they where sick of
building NAT workarounds.

Maybe a picture helps to illustrate this all:
 http://www.ibiblio.org/Dave/Dr-Fun/df200306/df20030604.jpg

Greets,
 Jeroen