Subject: Re: [VCARDDAV] property-kind

From: Simon Perreault <[email-masked]>
Date: Thu, 19 May 2011 09:45:32 -0400

On 2011-04-18 14:53, Peter Saint-Andre wrote:
> property-kind = element kind {
>     element text { "individual" | "group" | "org" | "location" }*
>   }
> 
> That seems to hardcode the possible values.
> 
> By contrast, vcardrev says that KIND may be one of "individual",
> "group", "org", "location", an x-name, or an iana-token.

In the lifetime of vcardxml, we went through a phase where we used
elements. See draft-perreault-vcarddav-vcardxml-02:

   kind =
     element kind {
       element individual { empty }
       | element group { empty }
       | element org { empty }
       | element location { empty }
     }

Obviously we reverted that to strings. The argument was:

- Simplicity.
- The schema is used for communication as part of an RFC. If you want a
schema for validating, you need to build one yourself. Many other things
will need to be tweaked.

I think where we are now represents working group consensus so far.

Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 19 May 2011 12:52:16 -0600

<hat type='individual'/>

>> "group", "org", "location", an x-name, or an iana-token.

My point was only that vcardrev and vcardxml are not in sync here, and
that we might want to change vcardxml to say:

property-kind = element kind {
    element text { "individual" | "group" | "org" | "location"
                   | x-name | iana-token
                   ^^^^^^^^^^^^^^^^^^^^^
                 }*
  }

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Simon Perreault <[email-masked]>
Date: Thu, 19 May 2011 14:56:41 -0400

>     element text { "individual" | "group" | "org" | "location"

Done.

Simon