Subject: [Videomgmt] RE: Overall thoughts on a standard Video Management MIB

From: "Larry R. Walsh" <[email-masked]>
Date: Thu, 6 Oct 2005 16:32:42 -0700

Some thoughts on various topics (from one who has never participated in
a standards effort, but who has read a lot of SNMP/IETF standards):

-- Any "standard" MIB designed will probably not be exactly like any one
vendor's existing MIB. So everyone who wants to use the new standard
video management MIB will have to choose between just keeping their own
MIBs, or also implementing the new standard.
-- Other industries have standard MIBS, and vendors implementing agent
support for the standard MIB typically also have their own proprietary
MIBs & agents. EG The Standard Printer MIB and HP-specific Printer MIBs.
Similar examples exist for data base systems, and other industries.
-- I have also seen "experimental" standard MIBs appear in the OID-space
of specific vendors. (Personal opinion - not a great idea)
-- The Entity MIB is useful for modeling chassis types of architectures.
It models components such as the chassis, the slots, the boards, the
ports in a manner that would allow a very smart manager to make a
drawing. It also has extensive Textual Conventions that "name"
components. But the actual modelling of very specific objects (eg power
supplies, what voltages they support, the status of those voltages) is
the responsibility of vendors. The Entity MIB will "point" to those
modelling MIBs.
-- However the Entity MIB does not have Video-industry specific Textual
Convention definitions (nor should it).
-- Is there a need for a Video-Management-specific-entity-type MIB?
-- RFC's always have a well-written textual description of what this RFC
(and any associated MIB) intends to accomplish. EG, the problem to be
solved, the system to be modelled, why are we doing this. It might be
well be have an agreed-on strategy before we move to actual MIB design.
(I like Bob's idea of starting small at first.)
-- Defining Standard Textual Conventions for video management might be
useful.
-- And perhaps Standard OID-enumerations for component types.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: Wednesday, September 28, 2005 9:10 AM
> To: [email-masked]
> Subject: Videomgmt Digest, Vol 1, Issue 4
> 
> 
> Send Videomgmt mailing list submissions to
> 	[email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> 	https://www1.ietf.org/mailman/listinfo/videomgmt
> or, via email, send a message with subject or body 'help' to
> 	[email-masked]
> 
> You can reach the person managing the list at
> 	[email-masked]
> 
> When replying, please edit your Subject line so it is more 
> specific than "Re: Contents of Videomgmt digest..."
> 
> 
> Today's Topics:
> 
>    1. The initial proposal... (Tendolkar Mohit)
>    2. RE: The initial proposal... (Ray, Robert)
> 
> 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Tue, 27 Sep 2005 09:45:11 -0700
> From: "Tendolkar Mohit" <[email-masked]>
> Subject: [Videomgmt] The initial proposal...
> To: "Ray, Robert" <[email-masked]>, <[email-masked]>
> Message-ID:
> 	
> <[email-masked]>
> Content-Type: text/plain;	charset="us-ascii"
> 
> Hi Ray,
> 
> Before we proceed to the MIB specific details, could you 
> please clarify whether PESA is willing to update portions of 
> its initial proposal to accommodate other existing IETF MIBs?
> 
> The reason I am asking this is based on previous experiences, 
> vendors wanted to "standardize" their MIB efforts "as is" 
> without allowing significant updates to their proposals based 
> on recommended or existing standards because it would "break" 
> their implementations already available on the market. I see 
> that the PESA MIBs have been drawn up starting from mid-2002, 
> so I reckon, there are products already supporting these MIB modules?
> 
> So before we spend the time and effort in drawing up a true 
> open MIB, it now becomes important to understand the stance 
> of the initial proposal. The PESA MIBs are certainly and 
> without doubt generic and truly useful MIBs as a starting 
> point, but given the usage of the other standardized MIBs 
> (ENTITY MIB, for instance) in conjunction with these modules 
> will imply certain structural changes to the proposed 
> modules. How strong is PESA on retaining the proposed MIB 
> modules "as is"?
> 
> Regards,
> 
> Mohit Tendolkar
> Thomson (Grass Valley)
> 
> 
> 
> 
> 
> ------------------------------
> 
> Message: 2
> Date: Tue, 27 Sep 2005 12:08:34 -0500
> From: "Ray, Robert" <[email-masked]>
> Subject: [Videomgmt] RE: The initial proposal...
> To: "Tendolkar Mohit" <[email-masked]>,
> 	<[email-masked]>
> Message-ID:
> 	<[email-masked]>
> Content-Type: text/plain;	charset="us-ascii"
> 
> Hi Mohit.
> 
> Responses inline...
> 
> Regards,
> Bob Ray
> 
> ---------------------------------------------------------------
> 
> From: Tendolkar Mohit [mailto:[email-masked]] 
> Sent: Tuesday, September 27, 2005 11:45 AM
> To: Ray, Robert; [email-masked]
> Subject: The initial proposal...
> 
> >Hi Ray,
> >
> >Before we proceed to the MIB specific details, could you please
> >clarify whether PESA is willing to update portions of its initial 
> >proposal to accommodate other existing IETF MIBs?
> 
> PESA is committed to this effort and hold no reservations about 
> revising our products to support these efforts.  As a 
> programmer, I do 
> like what I did (wrt the three MIBs) but am by no means 
> wedded to them. I welcome improvements and interoperability.  
> I believe our customers 
> would welcome that as well.  Even if it means starting from scratch.
> 
> >The reason I am asking this is based on previous experiences, vendors
> >wanted to "standardize" their MIB efforts "as is" without allowing 
> >significant updates to their proposals based on recommended 
> or existing
> 
> >standards because it would "break" their implementations already
> available 
> >on the market. I see that the PESA MIBs have been drawn up 
> starting for
> 
> >mid-2002, so I reckon, there are products already supporting 
> these MIB
> >modules?
> 
> Yes, PESA is shipping products that support the MIBs.  
> Technically, however, 
> We have no problem supporting multiple MIBs in one agent.  If 
> we (the list and possible working group) devise one or more 
> standardized MIBs which works
> 
> across multiple vendors, it would exist in a different branch 
> (as it would 
> have IANA-assigned identifiers, etc.).  We (PESA) would 
> simply add another 
> subtree to our agent (of course, there may be some 
> instrumentation details, 
> but that's how we programmers earn our keep!)
> 
> >So before we spend the time and effort in drawing up a true open MIB,
> >it now becomes important to understand the stance of the initial
> proposal. 
> >The PESA MIBs are certainly and without doubt generic and 
> truly useful
> MIBs,
> >but given the usage of the ENTITY MIB (for instance) in conjunction
> with 
> >these modules will imply certain structural changes to the proposed
> modules.
> >How strong is PESA on retaining the proposed MIB "as is"?
> 
> The stance is as I've said: the MIBs are simply placeholders, 
> a suggested 
> start, that could be reamed asunder by the advancements and 
> concerns of an 
> open working group.  And I would welcome such involvement.  
> Truly.  I value my good name (such as it is) too much to try 
> anything less.  Further, it would be 
> transparent to the IETF Area Directors and we would never get 
> anything done 
> anyway...
> 
> 
> 
> 
> ------------------------------
> 
> _______________________________________________
> Videomgmt mailing list
> [email-masked] https://www1.ietf.org/mailman/listinfo/videomgmt
> 
> 
> End of Videomgmt Digest, Vol 1, Issue 4
> ***************************************
> 

_______________________________________________
Videomgmt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/videomgmt

---

From: "Ray, Robert" <[email-masked]>
Date: Fri, 7 Oct 2005 09:26:48 -0500

It appears to be the new and improved Chassis MIB (the chassis MIB
working group closed in the early 90s, I think).  Which is exactly what
we need.  Fans, power supplies, slots, etc.

-- However the Entity MIB does not have Video-industry specific Textual 
-- Convention definitions (nor should it).

Agree with that.  The same mechanism works well for telecommunications
gear, for example.

As Mohit notted, the Entity MIB

http://www.ietf.org/rfc/rfc4133.txt?number=4133

can certainly handle our world.  I think a good first step might be to
see how well we can fit a very simple thing into the framework.  Like a
fan.

Would be a really simple thing: perhaps as few as four attributes, say:

Operational Status - a bitmap of things such as:
     on, fixed-speed, rpm-controlled, voltage-controlled
Rpm (0..10000)
Voltage (0..240)
Notification Flag - enables or disables notification generation

Creating a very simple MIB for this and writing the text for how it
integrates into the Entity MIB architecture would be a big step (IMHO),
no?  Adding Industry specific things such as power supplies, video
conversion, audio conversion, audio gain, mixing, etc., would surely
follow and could hopefully be kept small as well.

Bob Ray