Subject: Re: [vmeet] [BOFCHAIRS] Remote participation

From: Jeffrey Hutzelman <[email-masked]>
Date: Mon, 02 Apr 2012 10:58:47 -0400

On Mon, 2012-04-02 at 14:32 +0000, Ted Lemon wrote:
> > If we exclude WG adoption of drafts, how many decisions are taken (to
> > be confirmed on the list) in a meeting?
> > DHC       2
> > The metrics used do not paint a true picture of the sessions.
> 
> In the case of DHC at least, the metrics are pretty accurate.   There
>  was barely time in the wg meeting to actually have any meaningful
>  discussion about anything, so each presentation wound up being "sales
>  pitch, a few comments, chair interrupts for time, next steps, next
>  presentation."   It wasn't really a good use of f2f meeting time, and
>  I'd like to do it differently at the next IETF, but I don't really
>  know how, because there weren't a lot of presentations that the
>  working group shouldn't have heard, and we got one of the nice like
>  2.5h time slots.

Maybe you're not being conservative enough about what is a presentation
the working group should hear.  I generally try to avoid "presentations"
at all, reserving meeting time for things that actually require
face-to-face time in order to get work done and move things forward.  I
regularly turn down requests for meeting time to present some new work
or proposed work to the WG that hasn't been discussed on the meeting
list.

We still don't take a lot of decisions in any one meeting, but the ones
we do are often things for which discussion took a fair amount of time.

I don't claim to follow this principle perfectly, but it is something I
try to do, because I hate sitting in a meeting with a full agenda and
not getting work done because someone is droning on about something we
could have learned by reading a draft or having a discussion on the
mailing list.

-- Jeff

---

From: John C Klensin <[email-masked]>
Date: Mon, 02 Apr 2012 11:36:22 -0400

--On Monday, April 02, 2012 14:32 +0000 Ted Lemon
<[email-masked]> wrote:

> In the case of DHC at least, the metrics are pretty accurate.
> There was barely time in the wg meeting to actually have any
> meaningful discussion about anything, so each presentation
> wound up being "sales pitch, a few comments, chair interrupts
> for time, next steps, next presentation."   It wasn't really a
> good use of f2f meeting time, and I'd like to do it
> differently at the next IETF, but I don't really know how,
> because there weren't a lot of presentations that the working
> group shouldn't have heard, and we got one of the nice like
> 2.5h time slots.

Ted,

When the pressure for more and more meeting time is considered
in the light of my experience of the last week, I've started
wondering whether it is time to move toward a fundamental
change.  Suppose that, instead of having presentations at the
IETF meetings, we did the following:

(i) Encourage presentations to be prepared as a sequence of
slides accompanied by either written narrative or audio (or
possibly video) and made available with a cutoff not later that
the cutoff for new I-Ds and ideally earlier.   If people then
started discussing them on the relevant WG mailing lists, that
would strengthen the case for (ii) below.   

Note that recorded audio or video presentations have added
advantages: People who need a little extra time to understand
them could take that time (or back up and replay if needed),
early availability of the slides would be guaranteed, and asking
questions on mailing lists is both open-ended (no need to limit
the microphone line), more useful for anyone who has trouble
understanding English in real time, and more accessible for
anyone who can't easily translate their questions into English
in real time.  Those who hadn't really understood the relevant
I-Ds could view the presentation, read the I-D, and view the
presentation again.  And so on.

(ii) With presentations (all parts of each one, not just the
slides) available weeks before an actual IETF meeting, we would
ask the presenters to demonstrate to WG Chairs that their
subject matter (perhaps with a one or two minute review of
context) would benefit from f2f discussion time.  The strongest
demonstration would obviously be mailing list discussion after
people had looked at the presentation.

Obviously that would help the remote folks as well because
presentations could be studied at leisure and questions queued
up for f2f discussions before the relevant session even started.
Having someone who would be spending time making a presentation
under today's model instead start by responding to a series of
prepared audience questions (from both the on-site and remote
audiences) might also be a much better use of WG time.

There are lots of details associated with that sort of approach
that I haven't even started to think about, but, if it worked, I
think it could dramatically improve our overall productivity,
reverse the trend toward more presentations and work at meetings
in preference to real work on mailing lists, and reduce pressure
on meeting slots (WGs who have nothing to actually discuss cold
be denied f2f session time). WG Chairs would need discretion to
give time to things that they were confident were in the
critical path and there might need to be a fast-track appeal
procedure when presentation time was denied.   

If we could get it into our collective heads that audio or video
presentations with pre-distributed slides might actually be more
effective, it might help in a lot of ways.   Conversely, if
people needed to show that they were going to be in front of the
room to get permission to travel to IETF, it would be, IMO, far
more helpful to all concerned to have that role be "lead
discussion of presentation and I-D" rather than "give
presentation".

best,
   john

---

From: Ted Lemon <[email-masked]>
Date: Mon, 2 Apr 2012 14:32:45 +0000

> The metrics used do not paint a true picture of the sessions.

In the case of DHC at least, the metrics are pretty accurate.   There was barely time in the wg meeting to actually have any meaningful discussion about anything, so each presentation wound up being "sales pitch, a few comments, chair interrupts for time, next steps, next presentation."   It wasn't really a good use of f2f meeting time, and I'd like to do it differently at the next IETF, but I don't really know how, because there weren't a lot of presentations that the working group shouldn't have heard, and we got one of the nice like 2.5h time slots.

---

From: Joel jaeggli <[email-masked]>
Date: Mon, 02 Apr 2012 18:34:54 +0200

> would strengthen the case for (ii) below.   

What we've been encouraged to do, e.g. use the presentation/meeting
cycle for the problems, not the material is fundamentally at odds with
this approach. We're there to have a discussion and the slides are there
to support that. they should not be there to imho to present the
contents of the draft. We had the mailing list and the drafts themselves
to form the framework for the meeting.

> effective, it might help in a lot of ways. 

As a quite bad amateur ietf video producer, I'm going to go out on a
limb and say that a few hundred hours per meeting of cooked slides and
audio is not going to improve the productivity of the working groups
unless you're measuring that per byte.

> Conversely, if

it should be today.

---

From: John C Klensin <[email-masked]>
Date: Mon, 02 Apr 2012 14:26:46 -0400

--On Monday, April 02, 2012 18:34 +0200 Joel jaeggli
<[email-masked]> wrote:

>...
>> possibly video) and made available with a cutoff not later
>> that the cutoff for new I-Ds and ideally earlier.   If people
>> then started discussing them on the relevant WG mailing
>> lists, that would strengthen the case for (ii) below.   
 
> What we've been encouraged to do, e.g. use the
> presentation/meeting cycle for the problems, not the material
> is fundamentally at odds with this approach. We're there to
> have a discussion and the slides are there to support that.
> they should not be there to imho to present the contents of
> the draft. We had the mailing list and the drafts themselves

Joel, I apologize if I wasn't clear, but I was suggesting using
those previously-prepared presentations for online access at the
convenience of participants _before the IETF f2f meetings_ and
eliminating them from those meetings entirely.  If that is
"fundamentally at odds" with focusing the face time on problems
rather than presentations, I don't see how.

>> If we could get it into our collective heads that audio or
>> video presentations with pre-distributed slides might
>> actually be more effective, it might help in a lot of ways. 
> 
> As a quite bad amateur ietf video producer, I'm going to go
> out on a limb and say that a few hundred hours per meeting of
> cooked slides and audio is not going to improve the
> productivity of the working groups unless you're measuring
> that per byte.

And, again, I'm suggesting cutting the amount that appears
during the meeting, taking up meeting time, to nearly zero.

>> Conversely, if
>> people needed to show that they were going to be in front of
>> the room to get permission to travel to IETF, it would be,
>> IMO, far more helpful to all concerned to have that role be
>> "lead discussion of presentation and I-D" rather than "give
>> presentation".
> 
> it should be today.

Agreed.  But that isn't happening in presentation-heavy WGs.

   john

---

From: Joel Jaeggli <[email-masked]>
Date: Mon, 02 Apr 2012 21:02:12 +0200

> Agreed.  But that isn't happening in presentation-heavy WGs.

We got 4.5 hours of meeting during 83.  If we can do it but some other
wg's can't then no technological solution is likely needed.

>    john
> 
> 
> _______________________________________________
> NOTE WELL: This list operates according to
> http://mipassoc.org/dkim/ietf-list-rules.html.
> https://www.ietf.org/mailman/listinfo/vmeet

---

From: Ted Lemon <[email-masked]>
Date: Tue, 3 Apr 2012 09:55:13 +0000

It's difficult to set a good balance here.   When you have a bazillion different proposals, it's not really shocking that not everybody has read every proposal.   Even if you've read every proposal, it may be difficult to remember the details of each one if you didn't read them this week.   In that context, you'd like a presentation that explains what the proposal is, as a sales pitch to get people to read the document, and as a refresher for people who read the document a month ago and read two dozen more documents since then.   Then you'd like people who haven't read the documents to read the ones they've decided are worth the time.   Then you'd like to have a discussion, because you'd have a group of people who were sufficiently up to speed to *have* a discussion.

But to do this would require more time than any working group has, and harder agenda planning than the IETF can reasonably do.   The wish to keep presentations completely out of working group meetings isn't realistic, but after this meeting I feel like we (the DHC wg) need to do something differently.

BTW, I should point out that discussion-only sessions aren't always good.   Sometimes you have people with strong opinions who aren't open to debate on those opinions, and then you get an incredibly time-wasting "discussion" at the microphone, in which no forward progress is made.   So a disproportionate amount of working group time can spent "discussing" relatively minor proposals while the serious work of the working group doesn't get discussed due to time constraints.

This is a hard problem.

For DHC, I think that in the future presentations have to be very short, like maybe 1 minute or maybe 2 minutes for a really complex draft.   Essentially, they need to be just slightly longer than an elevator pitch.   The remainder of the slot needs to be spent on discussion.   Drafts that are contentious should be discussed offline, because no actual design discussion is going to happen anyway.   The wg chairs need to use their judgment on this--there's a very fine line between a contentious discussion that can actually produce results, and one that won't.

I'm thinking the presentation on the projector needs to have a timer on it, too.