Subject: [vnfpool] FW: New Version Notification for draft-hares-vnf-pool-use-case-00.txt

From: "Susan Hares" <[email-masked]>
Date: Tue, 21 Jan 2014 12:26:45 -0500

Hi all: 

I've posted a rough draft on use cases behind the VNF Pool effort. 
I look forward to your comments on the list.  

Sue 

PS - please be kind in comments .. it is a "rough" draft.. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, January 21, 2014 12:24 PM
To: Karthikeyan Subramaniam; Susan Hares; Susan Hares
Subject: New Version Notification for draft-hares-vnf-pool-use-case-00.txt

A new version of I-D, draft-hares-vnf-pool-use-case-00.txt
has been successfully submitted by Susan Hares and posted to the IETF repository.

Name:		draft-hares-vnf-pool-use-case
Revision:	00
Title:		Use Cases for Resource Pools with Virtual Network Functions (VNFs)
Document date:	2014-01-21
Group:		Individual Submission
Pages:		12
URL:            http://www.ietf.org/internet-drafts/draft-hares-vnf-pool-use-case-00.txt
Status:         https://datatracker.ietf.org/doc/draft-hares-vnf-pool-use-case/
Htmlized:       http://tools.ietf.org/html/draft-hares-vnf-pool-use-case-00

Abstract:
   In the context of virtualization, a service essentially consists of a
   set of Virtualized Network Functions (VNFs) with each VNF building on
   top of virtualization infrastructure to implement a specific network
   functions along with the data connections between VNFs.  VNFs may be
   highly distributed existing in devices in data center networks,
   mobile networks or satellite networks.  In some of these
   environments, the resources are highly constrained.

   This draft provides seven use cases the authors have implemented in
   demonstration or deployed code for the following network function
   virtualization: cloud bursting, parental controls, load balancer for
   multipath (L1-L7), WAN optimization that runs either between access
   nodes and Data Centers, WAN optimization between mobile phones to
   Data Centers (through access nodes), application placement
   optimization, and optimized placement of web applications utilizing
   minimal data transfer.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Zongning <[email-masked]>
Date: Mon, 27 Jan 2014 03:15:04 +0000

Hi, Sue,

This is really an excellent draft describing several interesting and real scenarios of vnfpool !

Some quick notes:
1) Quite a number of VNFs are listed in your implementations. Could you please roughly describe how these VNFs are organized (e.g., allocated amongst pools, managed by pool managers)? I strongly believe those details would be good reference to vnfpool architecture as potential next step work.
2) I am not sure I completely understand the case of "application scaling". Do you mean that VNFs are used to handle the application requests, or just used to implement the applications themselves? I also don't quite understand "2 Million URI references for each access node". Could you elaborate more on this?
3) Still some editorial nits - like "DCHP"? :-)

Thanks.

-Ning

> From: Susan Hares [mailto:[email-masked]]
> Sent: Wednesday, January 22, 2014 1:27 AM
> To: [email-masked]
> Cc: Spencer Dawkins; Martin Stiemerling; Zongning
> Subject: FW: New Version Notification for draft-hares-vnf-pool-use-case-00.txt
> 
> Hi all:
> 
> URL:
> http://www.ietf.org/internet-drafts/draft-hares-vnf-pool-use-case-00.txt
> Status:
> https://datatracker.ietf.org/doc/draft-hares-vnf-pool-use-case/
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>