Subject: [vnfpool] FW: New Version Notification for draft-zong-vnfpool-problem-statement-02.txt

From: Zongning <[email-masked]>
Date: Tue, 14 Jan 2014 01:24:55 +0000

Hi, folks,

Happy new year!

We made a new revision of VNF Pool Problem Statement. Please see the below abstract and links:

Abstract:
   There is a trend to implement network services by using a group of
   Virtualized Network Functions (VNFs) called a VNF set.  A VNF set can
   offer benefits like flexible service provisioning.  A VNF set also
   introduces additional points of failure, and therefore poses
   additional challenges on reliability.

   This document overviews the problems related to the reliability of a
   VNF set.  A VNF pooling architecture is also briefly introduced as
   candidate solution to address the problems.

URL:            http://www.ietf.org/internet-drafts/draft-zong-vnfpool-problem-statement-02.txt
Htmlized:       http://tools.ietf.org/html/draft-zong-vnfpool-problem-statement-02

Other related drafts including VNF Pool Use Cases, VNF Pooling Architecture are under development and will be available soon in this month...

Thanks.

-Ning

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, January 14, 2014 9:18 AM
> To: Zongning; Linda Dunbar; Melinda Shore; Linda Dunbar; Melinda Shore;
> Diego Lopez; Diego R. Lopez; Zongning
> Subject: New Version Notification for
> draft-zong-vnfpool-problem-statement-02.txt
> 
> 
> A new version of I-D, draft-zong-vnfpool-problem-statement-02.txt
> has been successfully submitted by Ning Zong and posted to the
> IETF repository.
> 
> Name:		draft-zong-vnfpool-problem-statement
> Revision:	02
> Title:		Virtualized Network Function (VNF) Pool Problem Statement
> Document date:	2014-01-14
> Group:		Individual Submission
> Pages:		10
> URL:
> http://www.ietf.org/internet-drafts/draft-zong-vnfpool-problem-statement-02.
> txt
> Status:
> https://datatracker.ietf.org/doc/draft-zong-vnfpool-problem-statement/
> Htmlized:
> http://tools.ietf.org/html/draft-zong-vnfpool-problem-statement-02
> Diff:
> http://www.ietf.org/rfcdiff?url2=draft-zong-vnfpool-problem-statement-02
> 
> Abstract:
>    There is a trend to implement network services by using a group of
>    Virtualized Network Functions (VNFs) called a VNF set.  A VNF set can
>    offer benefits like flexible service provisioning.  A VNF set also
>    introduces additional points of failure, and therefore poses
>    additional challenges on reliability.
> 
>    This document overviews the problems related to the reliability of a
>    VNF set.  A VNF pooling architecture is also briefly introduced as
>    candidate solution to address the problems.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 14 Jan 2014 16:21:43 -0500

Ning, Linda, Melinda, and Diego:

This draft is very readable and addresses the issues we raised. The
clarification of terminology builds a clear workable set of definitions for
the Pool with its manager, users, and elements; and a set of VNFs.  

However, I find the definition of VNF Set to be a little fuzzy.  Is the VNF
set a particular instance doing a specific set of functions (load balancing,
spam filtering, etc.)?   How does the pool work with several instances?  

VNF set 1        
(load-balance, spam filter, admin 1)

VNF set 2        
(load balance-spam filter (admin 2))

VNF set 3
(spam filter) 

Are these three valid sets? 

The  following 6 problems are a good set of initial problems to work on.  

1. Cases of VNF failures
2. backup advertisement across VNF set.
3. State notification across VNF set
4. Service state synchronization
5. Complication of VNF placement 
6. How get Reliable transport.

Beyond the VNF Set definition, there is a continuum between the service
state synchronization and information transfer for VNF placement? 

Does anyone have experience with this continuum and like to talk about it? 

Sue Hares 

-----Original Message-----
From: vnfpool [mailto:[email-masked]] On Behalf Of Zongning
Sent: Monday, January 13, 2014 8:25 PM
To: [email-masked]
Subject: [vnfpool] FW: New Version Notification for

Hi, folks,

Happy new year!

We made a new revision of VNF Pool Problem Statement. Please see the below
abstract and links:

Abstract:

URL:

Other related drafts including VNF Pool Use Cases, VNF Pooling Architecture
are under development and will be available soon in this month...

Thanks.

-Ning

> To: Zongning; Linda Dunbar; Melinda Shore; Linda Dunbar; Melinda 
> Shore; Diego Lopez; Diego R. Lopez; Zongning
> has been successfully submitted by Ning Zong and posted to the IETF 
> repository.
> 
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at
tools.ietf.org.
> The IETF Secretariat

_______________________________________________
vnfpool mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/vnfpool

---

From: Zongning <[email-masked]>
Date: Wed, 15 Jan 2014 03:23:03 +0000

Hi, Sue,

Thanks for your reply.

A VNF set have multiple instances, with each instance doing a specific function. So, you have listed three valid examples of VNF set. :)

As described in the draft, there are multiple pools for multiple VNFs (LB, Spam Filter, etc.). Currently we don't necessarily restrict to one-to-one mapping of pool and VNF. For example, a single pool can manage either the instances of a single VNF, or those of multiple VNFs.

I am not sure I understand your question about "continuum between the service state synchronization and information transfer". Do you actually want to scope the work around state synchronization? or just want to unify the terms?

Thanks.

-Ning

> From: Susan Hares [mailto:[email-masked]]
> Sent: Wednesday, January 15, 2014 5:22 AM
> To: Zongning; [email-masked]
> Subject: RE: [vnfpool] FW: New Version Notification for

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 14 Jan 2014 22:33:14 -0500

Ning: 

I'm glad I understand the VNF Set.   You may want to include that example in
your draft. 

The question is what information is included in the automatic state
synchronization.

The more information you send in the automatic state synchronization, the
less you need to send in "5. "Complication of VNF placement".  

If you are designing interoperable systems, you will need to agree on what
data gets sent where.  This agreement can be done in data models.  

For example, I am VNF set 1 uses Data model 1.  Due to its sub-second
fail-over requirements for load-balancing, it send more information in the
automatic state synchronization so that it can exchange minimal information
for placement.  

VNF Set 2 could use Data model 2 - where it send very little in the state
synchronization, but has a fast query set to place the VNFs. 

This example of data models provides a "whole tree" of data information
unique to VNFs.  You could also make it a composite model where VNF set 1
supports subtree 1-2, and VNF set 2 supports only subtree 1. 

Does this make sense at the architecture level, or would you prefer more
specific information?

Sue 

-----Original Message-----
From: Zongning [mailto:[email-masked]] 
Sent: Tuesday, January 14, 2014 10:23 PM
To: Susan Hares; [email-masked]
Subject: RE: [vnfpool] FW: New Version Notification for

Hi, Sue,

Thanks for your reply.

A VNF set have multiple instances, with each instance doing a specific
function. So, you have listed three valid examples of VNF set. :)

As described in the draft, there are multiple pools for multiple VNFs (LB,
Spam Filter, etc.). Currently we don't necessarily restrict to one-to-one
mapping of pool and VNF. For example, a single pool can manage either the
instances of a single VNF, or those of multiple VNFs.

I am not sure I understand your question about "continuum between the
service state synchronization and information transfer". Do you actually
want to scope the work around state synchronization? or just want to unify
the terms?

Thanks.

-Ning

> clarification of terminology builds a clear workable set of 
> definitions for the Pool with its manager, users, and elements; and a set
of VNFs.
> 
> However, I find the definition of VNF Set to be a little fuzzy.  Is 
> the VNF set a particular instance doing a specific set of functions (load
balancing,
> Beyond the VNF Set definition, there is a continuum between the 
> service state synchronization and information transfer for VNF placement?
> 
> Other related drafts including VNF Pool Use Cases, VNF Pooling 
> Architecture are under development and will be available soon in this
month...
> > http://www.ietf.org/rfcdiff?url2=draft-zong-vnfpool-problem-statemen
> > t-
> > 02
> >
> > Abstract:

---

From: Melinda Shore <[email-masked]>
Date: Tue, 14 Jan 2014 19:34:08 -0900

Hi, Sue:

Thanks for continuing to review this document.  I do think
that we could be clearer about what a "set" is and what
characteristics it has, and that's something we'll work on
for the next revision.

In terms of state synchronization I feel pretty strongly
that it's premature to be describing a data model.  Discussing,
yes, and possibly starting to work through, but I'd be
really reluctant to commit to paper (or electrons) in the
absence of an architecture.  I certainly think we need to be
talking about metadata, first, since the functions we're
talking about span a wide range of technologies and
consequently may have varying requirements.  I think
we don't have enough of a handle on the specifics of
what we're doing to do much beyond, perhaps, data
structures.

Melinda

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 14 Jan 2014 23:46:47 -0500

Melinda:

Thank you for accepting my suggestion on the VNF Set information. 

I agree that it is too early to setting on a state-synchronization method or
a data model.  My question was intended to again probe the scope of the
problem to help me revise a use case draft I am working on.

The use cases within a financial world or mobile phone application systems
that back-end to VNFs systems (to perform spam filtering, DPI, or other
specific applications), will need the rapid failover.  Certain institutions
may be willing to pay for the systems that do more state synchronization and
less queries for VNF placement.  

So, with explanation may I conclude that a description of these use case fit
within the VNF Pool operation. 

If I'm unclear, please ask questions.  Our discussions work to clarify the
work. 

Sue 

-----Original Message-----
From: vnfpool [mailto:[email-masked]] On Behalf Of Melinda Shore
Sent: Tuesday, January 14, 2014 11:34 PM
To: [email-masked]
Subject: Re: [vnfpool] FW: New Version Notification for

Hi, Sue:

Thanks for continuing to review this document.  I do think that we could be
clearer about what a "set" is and what characteristics it has, and that's
something we'll work on for the next revision.

In terms of state synchronization I feel pretty strongly that it's premature
to be describing a data model.  Discussing, yes, and possibly starting to
work through, but I'd be really reluctant to commit to paper (or electrons)
in the absence of an architecture.  I certainly think we need to be talking
about metadata, first, since the functions we're talking about span a wide
range of technologies and consequently may have varying requirements.  I
think we don't have enough of a handle on the specifics of what we're doing
to do much beyond, perhaps, data structures.

Melinda

---

From: Zongning <[email-masked]>
Date: Wed, 15 Jan 2014 06:06:00 +0000

Hi, Lingli,

Thanks for your suggestion.

Yes, as part of the function like choosing standby instance(s), VNF pool manager need to be aware of the related information and make such decision.

I will add a sentence to adopt this statement.

-Ning

> From: 邓灵莉/Lingli Deng [mailto:[email-masked]]
> Sent: Wednesday, January 15, 2014 1:44 PM
> Subject: 答复: [vnfpool] FW: New Version Notification for
> Hi Ning,
> Thanks a lot for providing such a great document. I am happy to see that it
> includes placement policy issue we have discussed earlier.
> However, I am not convinced that the following statement grasp the whole
> implication of this problem.
> 
>    VNF pool manager may also communicate with the pool user to
>    obtain the policies influencing the appropriate placement of VNFs.
>    When needed, VNF pool manager may interface with ALTO, I2RS to
>    collect information from the underlying network.
> 
> In the above description, the VNF pool manager collects from both upper and
> lower layers the information that would help to make an appropriate
> placement decision.
> It seems to me that the VNF pool manager would be the one who make the
> placement decision. Am I right?
> If this to be the case, I'd suggest state it clearly as a function of VNF
> pool manager.
> Otherwise, I think it would help to add an interface on VNF pool manager to
> a "virtualization manager" who does the physical-virtual mapping
> management.
> 
> BR
> Lingli
> 
> -----邮件原件-----
> 发件人: vnfpool [mailto:[email-masked]] 代表 Zongning
> 发送时间: 2014年1月14日 9:25
> 收件人: [email-masked]
> 主题: [vnfpool] FW: New Version Notification for
> submission

---

From: 김남곤(Cloud Application Project) <[email-masked]>
Date: Thu, 16 Jan 2014 00:56:08 +0000

Hi,

This new problem statement looks changed a lot from previous version.

Here’s my questions about the draft.

First, how about adding the definition of network service to the terminology section?
As this draft uses the term “service” without definition, it was not easy for me to understand how VNFs are related to a network service.
For example, in Section 3, there are two states.
One in “3.  State notification across VNF set.” and the other in “4. Service state synchronization”.
I just guess the former one means state of a VNF and latter one means service itself.

Second, is the interaction between VNF pool manager and VNF pool user out of scope?
It could be possible that a VNF user receive information from VNF pool manager and update/control policy based on the state.
And this can be applied to service function chaining, like choosing another service function chain, if we think of a VNF pool user as an entity controlling service function chaining.

Lastly, could anyone let me know the relation between service function chaining (sfc) and vnfpool?
The scope of vnfpool compared to sfc and how the two can interface with each other.
If it was discussed before, simply tell me the link.

Thank you.

Yours,
- Namgon

---------- Forwarded message ----------
From: Zongning <[email-masked]<mailto:[email-masked]>>
Date: 2014/1/14
Subject: [vnfpool] FW: New Version Notification for draft-zong-vnfpool-problem-statement-02.txt
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

Hi, folks,

Happy new year!

Abstract:

Thanks.

-Ning

> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
> until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.
>
> The IETF Secretariat

_______________________________________________
vnfpool mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/vnfpool

이 메일은 지정된 수취인만을 위해 작성되었으며, 중요한 정보나 저작권을 포함하고 있을 수 있습니다. 어떠한 권한 없이, 본 문서에 포함된 정보의 전부 또는 일부를 무단으로 제3자에게 공개, 배포, 복사 또는 사용하는 것을 엄격히 금지합니다. 만약, 본 메일이 잘못 전송된 경우, 발신인 또는 당사에 알려주시고, 본 메일을 즉시 삭제하여 주시기 바랍니다.
This E-mail may contain confidential information and/or copyright material. This email is intended for the use of the addressee only. If you receive this email by mistake, please either delete it without reproducing, distributing or retaining copies thereof or notify the sender immediately.

---

From: Zongning <[email-masked]>
Date: Thu, 16 Jan 2014 02:00:10 +0000

Hi, Namgon,

Please see inline.

From: vnfpool [mailto:[email-masked]] On Behalf Of ???(Cloud Application Project)
Sent: Thursday, January 16, 2014 8:56 AM
To: [email-masked]
Cc: 이광국(Network Innovation Projec); 김남곤(Cloud Application Project)
Subject: Re: [vnfpool] FW: New Version Notification for draft-zong-vnfpool-problem-statement-02.txt

Hi,

[Ning] Sure.

[Ning] VNFs are building blocks of a network service. A simple example is a web browsing service that may include NAT/packet filter, parental control, server load balancer, etc.

[Ning] The latter one is the state maintained by a VNF, but related to the specific function it performs, such as NAT translation table, TCP connection states. The former one is the state of VNF itself, such as overload status. Sorry for the confusion. I will give more explanation in next revision.

[Ning] We don’t exclude the interface between pool manager and user (please see item#4 in Section 4). What you have pointed is a good case to add, especially complementary to SFC.

[Ning] We believe VNF pool and SFC are independent but complementary. Please see item#3 in Section 5. Also we have previous list discussions, e.g., http://www.ietf.org/mail-archive/web/vnfpool/current/msg00091.html

Thank you.

Yours,
- Namgon

---------- Forwarded message ----------
From: Zongning <[email-masked]<mailto:[email-masked]>>
Date: 2014/1/14
Subject: [vnfpool] FW: New Version Notification for draft-zong-vnfpool-problem-statement-02.txt
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

Hi, folks,

Happy new year!

Abstract:

Thanks.

-Ning

---

From: 이광국(Network Innovation Projec) <[email-masked]>
Date: Thu, 16 Jan 2014 02:00:51 +0000

Regarding to the second question, I will add more comments.

For an end-to-end VNF reliablity, I think a central VNF pool user can access all VNF managers and check states of live VNF elements in a VNF set (one service function chaining). As such, a VNF pool manger can notify some information about states of its VNF elements to the upper pool user. So, we want to know northbound communication of VNF manger is also covered by VNFPool or not.

Best regards,
Kwang-koog Lee

From: 김남곤(Cloud Application Project)
Sent: Thursday, January 16, 2014 9:56 AM
To: [email-masked]
Cc: 김남곤(Cloud Application Project); 이광국(Network Innovation Projec)
Subject: RE: [vnfpool] FW: New Version Notification for draft-zong-vnfpool-problem-statement-02.txt

Hi,

Thank you.

Yours,
- Namgon

---------- Forwarded message ----------
From: Zongning <[email-masked]<mailto:[email-masked]>>
Date: 2014/1/14
Subject: [vnfpool] FW: New Version Notification for draft-zong-vnfpool-problem-statement-02.txt
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

Hi, folks,

Happy new year!

Abstract:

Thanks.

-Ning

---

From: 이광국(Network Innovation Projec) <[email-masked]>
Date: Thu, 16 Jan 2014 02:37:19 +0000

Thank you for your comment.

Regarding to your comments; the statement of item#4 in section 4 can be recognized as if the communication between pool manager and user limits for obtaining the information of underlying network for placement of VNF elements from i2rs or other standard.

Best regards,
Kwang-koog Lee

From: Zongning [mailto:[email-masked]]
Sent: Thursday, January 16, 2014 11:00 AM
To: 김남곤(Cloud Application Project); [email-masked]
Cc: 이광국(Network Innovation Projec)
Subject: RE: [vnfpool] FW: New Version Notification for draft-zong-vnfpool-problem-statement-02.txt

Hi, Namgon,

Please see inline.

To: [email-masked]<mailto:[email-masked]>

Hi,

[Ning] Sure.

Thank you.

Yours,
- Namgon

---------- Forwarded message ----------
From: Zongning <[email-masked]<mailto:[email-masked]>>
Date: 2014/1/14
Subject: [vnfpool] FW: New Version Notification for draft-zong-vnfpool-problem-statement-02.txt
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

Hi, folks,

Happy new year!

Abstract:

Thanks.

-Ning

---

From: Zongning <[email-masked]>
Date: Thu, 16 Jan 2014 02:59:54 +0000

Hi, Kwang-koog,

As replied, I will add your proposal into that item. :)

-Ning

From: 이광국(Network Innovation Projec) [mailto:[email-masked]]
Sent: Thursday, January 16, 2014 10:37 AM
To: Zongning; 김남곤(Cloud Application Project); [email-masked]
Subject: RE: [vnfpool] FW: New Version Notification for draft-zong-vnfpool-problem-statement-02.txt

Best regards,
Kwang-koog Lee

Hi, Namgon,

Please see inline.

Hi,

[Ning] Sure.

Thank you.

Yours,
- Namgon

---------- Forwarded message ----------
From: Zongning <[email-masked]<mailto:[email-masked]>>
Date: 2014/1/14
Subject: [vnfpool] FW: New Version Notification for draft-zong-vnfpool-problem-statement-02.txt
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

Hi, folks,

Happy new year!

Abstract:

Thanks.

-Ning

---

From: LAC Chidung <[email-masked]>
Date: Fri, 17 Jan 2014 17:52:41 +0100

Hi Ning,
Some cosmetic suggestions + comments.
Best,
Chidung

---

From: Zongning <[email-masked]>
Date: Sat, 18 Jan 2014 01:31:01 +0000

Hi, Chidung,

Really appreciate your inline suggestions + comments. While we will adopt most of your suggestions, I'd like to answer several of your questions at first, to make sure we are more align with each other. :)

[CL1]: Besides section 5 (Related Works), the word « availability »  is not used at all in this doc ... although it is the main objective of the pooling architecture, i.e., providing redundant VNF instances in order to maximize the network service's availability
You are right that the goal of VNF pool is to improve the service's availability, from the service(or user) perspective. IMHO, I prefer not to address the problem from service(or user) perspective, but simply from the VNF set itself. Another word, we may just focus how to use pooling mechanisms, e.g. redundancy model, stateful failover to improve the reliability of VNF set. But we could definitely mention that our work will benefit service availability. How do you think?

[CL2]: "A VNF set can introduce additional points of failure beyond those inherent in a single specialized server" - this sentence implies that a "single specialized server" currently hosts different NFs which will be virtualized in the future and  grouped in a "VNF set": is it really what we mean ?

No, we don't mean that VNF set is "released" from a single specialized server. The challenges are: 1) a single VNF may have more factors of risk than a traditional NF in single specialized server; 2) a group of VNFs need more coordination on reliability. I agree that comparing a VNF set to a single specialized server may be inappropriate. I will revise the sentence later.

[CL4]: "Load Sharing" - it is rather a performance mechanism (and not a reliability one).

I'd still think load sharing is not only for performance, but related to reliability, considering that potential overload will affect the reliability of VNF without applying efficient load sharing.

Again, thanks for your careful & kind inline editing.

-Ning

From: LAC Chidung [mailto:[email-masked]]
Sent: Saturday, January 18, 2014 12:53 AM
To: Zongning
Cc: [email-masked]
Subject: Re: [vnfpool] FW: New Version Notification for draft-zong-vnfpool-problem-statement-02.txt

Hi Ning,

Hi, folks,

Happy new year!

Abstract:

Thanks.

-Ning

-----Original Message-----

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]

IETF repository.

Revision: 02

Pages:            10

URL:

txt

Status:

Htmlized:

Diff:

Abstract:

The IETF Secretariat

vnfpool mailing list

________________________________

---

From: LAC Chidung <[email-masked]>
Date: Tue, 21 Jan 2014 18:42:58 +0100

Hi Ning,
1- I understand your point, i.e., "/... not to address the problem from 
service(or user) perspective, but simply from the VNF set itself/.". 
Actually, the VNF set reliability is commonly related to its 
availability, and its availability impacts on the service (which uses 
this VNF set) availability.
Nevertheless, a "purist" could say the following: '/the VNF set is 
reliable, i.e., once it starts working, you can trust it, because its 
embedded mechanisms such as redundancy will always provide a non-stop 
service BUT it may not have a high availability because, sometimes, when 
you need to launch the VNF set, it does not start .../'
Well, beyond this digression, ok for me to just mention that this "/work 
will benefit service availability/".
2- /performance /vs. /reliability /for load sharing (LS): I still think 
that LS is part of resource optimization mechanisms (if N components can 
do the same job, let's share the requests for this type of job properly 
- for efficiency purposes) and then, as a _second_ gain/advantage, LS 
helps to improve the overall reliability. Again, it is a subjective 
opinion ... It is like a half empty/full glass ...
Thank you + best,
Chidung

Le 18/01/2014 02:31, Zongning a écrit :
>
> Hi, Chidung,
>
> Really appreciate your inline suggestions + comments. While we will 
> adopt most of your suggestions, I'd like to answer several of your 
> questions at first, to make sure we are more align with each other. J
>
> [CL1]: Besides section 5 (Related Works), the word « availability »  
> is not used at all in this doc ... although it is the main objective 
> of the pooling architecture, i.e., providing redundant VNF instances 
> in order to maximize the network service's availability
> You are right that the goal of VNF pool is to improve the service's 
> availability, from the service(or user) perspective. IMHO, I prefer 
> not to address the problem from service(or user) perspective, but 
> simply from the VNF set itself. Another word, we may just focus how to 
> use pooling mechanisms, e.g. redundancy model, stateful failover to 
> improve the reliability of VNF set. But we could definitely mention 
> that our work will benefit service availability. How do you think?
>
> [CL2]: "A VNF set can introduce additional points of failure beyond 
> thoseinherent in a single specialized server" - this sentence implies 
> that a "single specialized server" currently hosts different NFs which 
> will be virtualized in the future and  grouped in a "VNF set": is it 
> really what we mean ?
>
> No, we don't mean that VNF set is "released" from a single specialized 
> server. The challenges are: 1) a single VNF may have more factors of 
> risk than a traditional NF in single specialized server; 2) a group of 
> VNFs need more coordination on reliability. I agree that comparing a 
> VNF set to a single specialized server may be inappropriate. I will 
> revise the sentence later.
>
> I'd still think load sharing is not only for performance, but related 
> to reliability, considering that potential overload will affect the 
> reliability of VNF without applying efficient load sharing.
>
>
> *From:*LAC Chidung [mailto:[email-masked]]
> *Sent:* Saturday, January 18, 2014 12:53 AM
> *To:* Zongning
> *Cc:* [email-masked]
> *Subject:* Re: [vnfpool] FW: New Version Notification for 
>     URL:http://www.ietf.org/internet-drafts/draft-zong-vnfpool-problem-statement-02.txt
>
>     Htmlized:http://tools.ietf.org/html/draft-zong-vnfpool-problem-statement-02
>
>       
>
>         From:[email-masked]  <mailto:[email-masked]>  [mailto:[email-masked]]
>
>     [email-masked]  <mailto:[email-masked]>
>
> ------------------------------------------------------------------------
>