Subject: [vnfpool] Overlap with SFC?

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 21 Jan 2014 17:56:50 -0000

Hi,

The IESG is looking at the BoF requests for London, and a question came up on
the overlap between the proposal here and items 4 and 5 in the SFC Charter.

I think it would be valuable if you could discuss the overlap and the
interaction between the two efforts so that there is a clear view.

Thanks,
Adrian

---

From: "King, Daniel" <[email-masked]>
Date: Tue, 21 Jan 2014 18:04:50 +0000

Hi All, 

The SFC charter items (specifically 4 & 5) are:

4. Control Plane Mechanisms: A document will be developed to describe requirements for conveying information between control or management    elements and SFC implementation points. All protocol extension work resulting from these requirements should be carried out in the working group responsible for the protocol being modified in coordination with this working group, but may be done in this working group under a revised charter after agreement with all the relevant WG chairs and responsible ADs.

5. Manageability: Work on the management and configuration of SFC components related to the support of Service Function Chaining will certainly be needed, but first needs to be better understood and scoped.

http://datatracker.ietf.org/doc/charter-ietf-sfc/

Br, Dan. 

-----Original Message-----
From: vnfpool [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: 21 January 2014 17:57
To: [email-masked]
Subject: [vnfpool] Overlap with SFC?

Hi,

The IESG is looking at the BoF requests for London, and a question came up on the overlap between the proposal here and items 4 and 5 in the SFC Charter.

I think it would be valuable if you could discuss the overlap and the interaction between the two efforts so that there is a clear view.

Thanks,
Adrian

_______________________________________________
vnfpool mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/vnfpool

---

From: Melinda Shore <[email-masked]>
Date: Tue, 21 Jan 2014 09:38:59 -0900

Hi, Adrian:

The vnfpool proposal is quite narrowly focused on redundancy
mechanisms for virtualized network functions.

Melinda

-- 
Melinda Shore
No Mountain Software
[email-masked]

"Software longa, hardware brevis."

---

From: "King, Daniel" <[email-masked]>
Date: Tue, 21 Jan 2014 19:24:04 +0000

Hi Again,  

Thanks Melinda, you are far more succinct than I have been. However, seeing as we may have some additional interest in the vnfpool work, it may be worth summarizing our problem space and some of our discussion thus far for anyone peeking at the list for the first time:

A Virtualized Network Function (VNF) (e.g. vBRAS vFirewall, vLoadbalancer) provides the equivalent function as a dedicated hardware platform. These VNF instances are typically instantiated in clusters running on general purpose servers via a variety of virtualization platforms. As per discussions within the SFC Working Group (WG), a user/network service is typically realized by a chain of VNFs (also known as a VNF Forwarding Graph -VNFG)  to deliver function in a deterministic sequence. Whereas SFC WG is tasked with investigating and documenting SFC architecture, and  SFC protocol mechanisms (new or extensions to existing solutions) in order to encapsulate and steer traffic, and convey SFC and Service Function Path (SFP) information to function nodes, both virtual and physical.

The vnfpool list was initiated to investigate the resilience requirements and solutions  for virtual network functions, running as single, or pools (sets) of VNFs. So clearly some of the vnfpool work may be complimentary to the SFC WG, but I think the majority of work will be in parallel to the SFC WG. Initially this list has scoped the vnfpool work into a problem statement, use cases, architecture and signalling to deploy and manage VNF pool resilience (reliability, redundancy, availability, failover), these discussions have included:

- Signalling between VNF pools for transition (e.g. state change, scaling, moving) management, notification, backup, performance monitoring and announcements;

- Service state management (e.g. synchronizing method, state data format, location and mechanism to access state data);

- Obtaining underlying network information (e.g., this is where we expect cooperation with existing working groups - ALTO, I2RS);

- Mechanisms for instance deployment reflecting resilience requirements (e.g. distribution of instances across different VMs or hypervisors);

- Explore and document requirements for reliable transport of traffic and security mechanisms between VNF pools, and reliable and secure control of VNF pools.

We have established that for some use cases (Virtualisation of Mobile Core Network and IMS (vEPC & vIMS), Virtualisation of the Home Environment (vHome), Virtualisation of Content Distribution Network (vCDN)) there will also be specific resilience requirements, when relevant to the SFC WG, i.e., traffic steering between (virtual) network function nodes, these application specific requirements may require co-operation (via requirements or problem statement I-Ds between vnfpool and SFC WG). 

Br, Dan. 

-----Original Message-----
From: vnfpool [mailto:[email-masked]] On Behalf Of Melinda Shore
Sent: 21 January 2014 18:39
To: [email-masked]
Cc: [email-masked]
Subject: Re: [vnfpool] Overlap with SFC?

Hi, Adrian:

The vnfpool proposal is quite narrowly focused on redundancy mechanisms for virtualized network functions.

Melinda

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 21 Jan 2014 19:24:43 -0500

Daniel:

All of my use cases show  control/management (as most network protocols do),
but the key part of use cases I posted is the need for pools for redundancy
with redundancy mechanisms for virtualized network functions.

I plan to work on the control/management part in SFC. 

Sue 

-----Original Message-----
From: vnfpool [mailto:[email-masked]] On Behalf Of King, Daniel
Sent: Tuesday, January 21, 2014 1:05 PM
To: [email-masked]
Subject: Re: [vnfpool] Overlap with SFC?

Hi All, 

4. Control Plane Mechanisms: A document will be developed to describe
requirements for conveying information between control or management
elements and SFC implementation points. All protocol extension work
resulting from these requirements should be carried out in the working group
responsible for the protocol being modified in coordination with this
working group, but may be done in this working group under a revised charter
after agreement with all the relevant WG chairs and responsible ADs.

5. Manageability: Work on the management and configuration of SFC components
related to the support of Service Function Chaining will certainly be
needed, but first needs to be better understood and scoped.

Br, Dan. 

-----Original Message-----
From: vnfpool [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: 21 January 2014 17:57
To: [email-masked]
Subject: [vnfpool] Overlap with SFC?

Hi,

The IESG is looking at the BoF requests for London, and a question came up
on the overlap between the proposal here and items 4 and 5 in the SFC
Charter.

Thanks,
Adrian

---

From: Melinda Shore <[email-masked]>
Date: Tue, 21 Jan 2014 15:48:56 -0900

> I plan to work on the control/management part in SFC. 

Thanks, Sue - I think it's really important to highlight what
distinguishes vnfpool from other effort.  On the control/management
front, there's been a fuzzy line between what ends up in the OPS
area and what ends up not in the OPS area on management topics,
and there's some flexibility there.  Mehmet has brought NFV
management discussion into the OPS area from ETSI (where it's
known as "MANO," management and orchestration).  Slides from
the Vancouver meeting here:
http://www.ietf.org/proceedings/88/slides/slides-88-opsawg-6.pdf

Melinda

---

From: Zongning <[email-masked]>
Date: Wed, 22 Jan 2014 00:57:02 +0000

Hi, Dan and Melinda,

Thanks for your reply.

Both of you are right in that our proposal here is narrowly focused on redundancy mechanism for VNF. This goal is basically complementary to SFC charter. Another point I want to add is that vnfpool is not only used in "chained service nodes", but applicable to other cases where service nodes are not necessarily sequentially connected.

-Ning

> Sent: Wednesday, January 22, 2014 3:24 AM
> To: Melinda Shore; [email-masked]
> Cc: [email-masked]
> Thanks Melinda, you are far more succinct than I have been. However, seeing
> as we may have some additional interest in the vnfpool work, it may be worth
> summarizing our problem space and some of our discussion thus far for anyone
> peeking at the list for the first time:
> 
> A Virtualized Network Function (VNF) (e.g. vBRAS vFirewall, vLoadbalancer)
> provides the equivalent function as a dedicated hardware platform. These VNF
> instances are typically instantiated in clusters running on general purpose
> servers via a variety of virtualization platforms. As per discussions within the
> SFC Working Group (WG), a user/network service is typically realized by a chain
> of VNFs (also known as a VNF Forwarding Graph -VNFG)  to deliver function in
> a deterministic sequence. Whereas SFC WG is tasked with investigating and
> documenting SFC architecture, and  SFC protocol mechanisms (new or
> extensions to existing solutions) in order to encapsulate and steer traffic, and
> convey SFC and Service Function Path (SFP) information to function nodes, both
> virtual and physical.
> 
> The vnfpool list was initiated to investigate the resilience requirements and
> solutions  for virtual network functions, running as single, or pools (sets) of
> VNFs. So clearly some of the vnfpool work may be complimentary to the SFC
> WG, but I think the majority of work will be in parallel to the SFC WG. Initially
> this list has scoped the vnfpool work into a problem statement, use cases,
> architecture and signalling to deploy and manage VNF pool resilience (reliability,
> redundancy, availability, failover), these discussions have included:
> 
> - Signalling between VNF pools for transition (e.g. state change, scaling, moving)
> management, notification, backup, performance monitoring and
> announcements;
> 
> - Service state management (e.g. synchronizing method, state data format,
> location and mechanism to access state data);
> 
> - Obtaining underlying network information (e.g., this is where we expect
> cooperation with existing working groups - ALTO, I2RS);
> 
> - Mechanisms for instance deployment reflecting resilience requirements (e.g.
> distribution of instances across different VMs or hypervisors);
> 
> - Explore and document requirements for reliable transport of traffic and
> security mechanisms between VNF pools, and reliable and secure control of
> VNF pools.
> 
> We have established that for some use cases (Virtualisation of Mobile Core
> Network and IMS (vEPC & vIMS), Virtualisation of the Home Environment
> (vHome), Virtualisation of Content Distribution Network (vCDN)) there will also
> be specific resilience requirements, when relevant to the SFC WG, i.e., traffic
> steering between (virtual) network function nodes, these application specific
> requirements may require co-operation (via requirements or problem
> statement I-Ds between vnfpool and SFC WG).
> 
> Br, Dan.
>

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 21 Jan 2014 20:14:45 -0500

Ning:

Therefore, some of the mechanisms may be in parallel or serial.  Shall I add
comments in my use cases to indicate when VNF functions are parallel or
serial? 

Sue 

-----Original Message-----
From: vnfpool [mailto:[email-masked]] On Behalf Of Zongning
Sent: Tuesday, January 21, 2014 7:57 PM
To: King, Daniel; Melinda Shore; [email-masked]
Cc: [email-masked]
Subject: Re: [vnfpool] Overlap with SFC?

Hi, Dan and Melinda,

Thanks for your reply.

Both of you are right in that our proposal here is narrowly focused on
redundancy mechanism for VNF. This goal is basically complementary to SFC
charter. Another point I want to add is that vnfpool is not only used in
"chained service nodes", but applicable to other cases where service nodes
are not necessarily sequentially connected.

-Ning

> Thanks Melinda, you are far more succinct than I have been. However, 
> seeing as we may have some additional interest in the vnfpool work, it 
> may be worth summarizing our problem space and some of our discussion 
> thus far for anyone peeking at the list for the first time:
> 
> A Virtualized Network Function (VNF) (e.g. vBRAS vFirewall, 
> vLoadbalancer) provides the equivalent function as a dedicated 
> hardware platform. These VNF instances are typically instantiated in 
> clusters running on general purpose servers via a variety of 
> virtualization platforms. As per discussions within the SFC Working 
> Group (WG), a user/network service is typically realized by a chain of 
> VNFs (also known as a VNF Forwarding Graph -VNFG)  to deliver function 
> in a deterministic sequence. Whereas SFC WG is tasked with 
> investigating and documenting SFC architecture, and  SFC protocol 
> mechanisms (new or extensions to existing solutions) in order to 
> encapsulate and steer traffic, and convey SFC and Service Function Path
(SFP) information to function nodes, both virtual and physical.
> 
> The vnfpool list was initiated to investigate the resilience 
> requirements and solutions  for virtual network functions, running as 
> single, or pools (sets) of VNFs. So clearly some of the vnfpool work 
> may be complimentary to the SFC WG, but I think the majority of work 
> will be in parallel to the SFC WG. Initially this list has scoped the 
> vnfpool work into a problem statement, use cases, architecture and 
> signalling to deploy and manage VNF pool resilience (reliability,
redundancy, availability, failover), these discussions have included:
> 
> - Signalling between VNF pools for transition (e.g. state change, 
> scaling, moving) management, notification, backup, performance 
> monitoring and announcements;
> 
> - Service state management (e.g. synchronizing method, state data 
> format, location and mechanism to access state data);
> 
> - Obtaining underlying network information (e.g., this is where we 
> expect cooperation with existing working groups - ALTO, I2RS);
> 
> - Explore and document requirements for reliable transport of traffic 
> and security mechanisms between VNF pools, and reliable and secure 
> control of VNF pools.
> 
> We have established that for some use cases (Virtualisation of Mobile 
> Core Network and IMS (vEPC & vIMS), Virtualisation of the Home 
> Environment (vHome), Virtualisation of Content Distribution Network 
> (vCDN)) there will also be specific resilience requirements, when 
> relevant to the SFC WG, i.e., traffic steering between (virtual) 
> network function nodes, these application specific requirements may 
> require co-operation (via requirements or problem statement I-Ds between
vnfpool and SFC WG).

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 21 Jan 2014 20:34:13 -0500

Thank you for the reference to MANO.  I had seen it before, but I will
review it and send comments. 

Sue 

-----Original Message-----
From: Melinda Shore [mailto:[email-masked]] 
Sent: Tuesday, January 21, 2014 7:49 PM
To: Susan Hares
Cc: 'King, Daniel'; [email-masked]; [email-masked]
Subject: Re: [vnfpool] Overlap with SFC?

On 1/21/14 3:24 PM, Susan Hares wrote:
> All of my use cases show  control/management (as most network 
> protocols do), but the key part of use cases I posted is the need for 
> pools for redundancy with redundancy mechanisms for virtualized network
functions.
> I plan to work on the control/management part in SFC. 

Thanks, Sue - I think it's really important to highlight what distinguishes
vnfpool from other effort.  On the control/management front, there's been a
fuzzy line between what ends up in the OPS area and what ends up not in the
OPS area on management topics, and there's some flexibility there.  Mehmet
has brought NFV management discussion into the OPS area from ETSI (where
it's known as "MANO," management and orchestration).  Slides from the
Vancouver meeting here:
http://www.ietf.org/proceedings/88/slides/slides-88-opsawg-6.pdf

Melinda

---

From: Zongning <[email-masked]>
Date: Wed, 22 Jan 2014 01:34:28 +0000

Hi, Adrian,

Thanks for raising this question. Actually vnfpool folks have been discussing this question a lot since the very beginning of this work.

We believe vnfpool and SFC are independent and complementary mainly due to the below reasons:
1) SFC targets on steering packets among service function nodes. vnfpool focuses on redundancy for service nodes, e.g., selecting standby nodes, handling nodes transition/failure cases, without caring how 
2) vnfpool manager in our proposal could interact with SFC control entity to: 1) advertise redundant service nodes; 2) notify status of redundant nodes when required; 3) receive resiliency requirements from SFC control entity (if any); and so on.
3) vnfpool is not only used in "chained service nodes", but applicable to other cases where service nodes are not necessarily sequentially connected.

I appreciate any further feedback and advice from you or IESG, as I believe these feedback will greatly improve the quality of our proposed charter.

Thanks.

-Ning

> Sent: Wednesday, January 22, 2014 1:57 AM
> To: [email-masked]

---

From: Zongning <[email-masked]>
Date: Wed, 22 Jan 2014 01:35:23 +0000

You are more than welcome, Sue. :-)

-Ning

> From: Susan Hares [mailto:[email-masked]]
> Sent: Wednesday, January 22, 2014 9:15 AM
> To: Zongning; 'King, Daniel'; 'Melinda Shore'; [email-masked]
> Cc: [email-masked]
> Subject: RE: [vnfpool] Overlap with SFC?
> 
> Ning:
>

---

From: Zongning <[email-masked]>
Date: Wed, 22 Jan 2014 01:41:47 +0000

Sorry, item 1) is obviously not finished. :-)

1) SFC targets on steering packets among service function nodes. vnfpool focuses on redundancy for service nodes, e.g., selecting standby nodes, handling nodes transition/failure cases, without caring about how to construct the data path.

Again, my fault.

-Ning

> From: Zongning
> Sent: Wednesday, January 22, 2014 9:34 AM
> To: [email-masked]'; [email-masked]
> Thanks for raising this question. Actually vnfpool folks have been discussing this
> question a lot since the very beginning of this work.
> 
> 1) SFC targets on steering packets among service function nodes. vnfpool
> focuses on redundancy for service nodes, e.g., selecting standby nodes,
> handling nodes transition/failure cases, without caring how
> 2) vnfpool manager in our proposal could interact with SFC control entity to: 1)
> advertise redundant service nodes; 2) notify status of redundant nodes when
> required; 3) receive resiliency requirements from SFC control entity (if any); and
> so on.
> 3) vnfpool is not only used in "chained service nodes", but applicable to other
> cases where service nodes are not necessarily sequentially connected.
> 
> I appreciate any further feedback and advice from you or IESG, as I believe
> these feedback will greatly improve the quality of our proposed charter.
> 
> Thanks.
> 
> -Ning
> 
> on

---

From: Qin Wu <[email-masked]>
Date: Wed, 22 Jan 2014 04:39:07 +0000

Sue:
I agree with your comment.

Regards!
-Qin
-----Original Message-----
From: vnfpool [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Wednesday, January 22, 2014 9:15 AM
To: Zongning; 'King, Daniel'; 'Melinda Shore'; [email-masked]
Cc: [email-masked]
Subject: Re: [vnfpool] Overlap with SFC?

Ning:

Sue 

-----Original Message-----
From: vnfpool [mailto:[email-masked]] On Behalf Of Zongning
Sent: Tuesday, January 21, 2014 7:57 PM
To: King, Daniel; Melinda Shore; [email-masked]
Cc: [email-masked]
Subject: Re: [vnfpool] Overlap with SFC?

Hi, Dan and Melinda,

Thanks for your reply.

-Ning

vnfpool and SFC WG).

---

From: Qin Wu <[email-masked]>
Date: Wed, 22 Jan 2014 05:05:28 +0000

My Understanding is 
in service chain, when a service node is down, what SFC is doing is to bypass this service node while
What nfvpool is doing is to replace the failing one with the new service node which provide the same functionality.
Please correct me if I am wrong.

Regards!
-Qin
-----Original Message-----
From: vnfpool [mailto:[email-masked]] On Behalf Of Zongning
Sent: Wednesday, January 22, 2014 9:42 AM
To: Zongning; [email-masked]; [email-masked]
Subject: Re: [vnfpool] Overlap with SFC?

Again, my fault.

-Ning

---

From: Qin Wu <[email-masked]>
Date: Wed, 22 Jan 2014 05:14:41 +0000

Good clarification.
I think SFC and NFVPool may share some common components, e.g., service function discovery, service function identifier, service function locator,
As for auto provision, SFC focuses on how to provision service function and setup service function path while NFVPool focuses on how to replace the
Failing one with the same class service function, irrespective the failing service node is in the service chain or not.

As for proposed work, I am not sure obtaining underlying network information is enough, service function is build on top of underlying network.The underlying network information should be abstracted and form service topology for service function.

Regards!
-Qin
-----Original Message-----
From: vnfpool [mailto:[email-masked]] On Behalf Of King, Daniel
Sent: Wednesday, January 22, 2014 3:24 AM
To: Melinda Shore; [email-masked]
Cc: [email-masked]
Subject: Re: [vnfpool] Overlap with SFC?

Hi Again,  

Br, Dan. 

-----Original Message-----
From: vnfpool [mailto:[email-masked]] On Behalf Of Melinda Shore
Sent: 21 January 2014 18:39
To: [email-masked]
Cc: [email-masked]
Subject: Re: [vnfpool] Overlap with SFC?

Hi, Adrian:

Melinda

---

From: LAC Chidung <[email-masked]>
Date: Wed, 22 Jan 2014 12:25:30 +0100

Hi Qin,
"/in service chain, when a service node is down, what SFC is doing is to 
bypass this service node/": is the following interpretation ok ?
A service chain needs X+Y service nodes in order to provide the _*full*_ 
service: the X service nodes are mandatory, while the Y service nodes 
are (kind of) optional, i.e., if one (or more) of these Y service nodes 
is (are) down, the service chain can still provide the service, but in a 
_*degraded mode*_. In this case,*the bypassing can only happen* for one 
of the Y service nodes, i.e., if one of the X service nodes is down, 
there is _*no service at all*_.
_NB:_ in this example, we consider, of course, that there is no 
redundancy anywhere, i.e., if a service node is down, the only thing to 
do is to fix it, and while waiting for the reparation, we face a 
degraded service, or no service at all.
Best,
Chidung

Le 22/01/2014 06:05, Qin Wu a écrit :
>>> The IESG is looking at the BoF requests for London, and a question came upon the overlap between the proposal here and items 4 and 5 in the SFC Charter.

---

From: Qin Wu <[email-masked]>
Date: Thu, 23 Jan 2014 01:37:45 +0000

Hi, Chidung:
That's one good interpretation.
You are right, I should add assumption that the service node that is bypassed is optional service node in the chain.

Regards!
-Qin
From: vnfpool [mailto:[email-masked]] On Behalf Of LAC Chidung
Sent: Wednesday, January 22, 2014 7:26 PM
To: Qin Wu
Cc: [email-masked]; [email-masked]
Subject: Re: [vnfpool] Overlap with SFC?

Hi Qin,
"in service chain, when a service node is down, what SFC is doing is to bypass this service node": is the following interpretation ok ?
A service chain needs X+Y service nodes in order to provide the full service: the X service nodes are mandatory, while the Y service nodes are (kind of) optional, i.e., if one (or more) of these Y service nodes is (are) down, the service chain can still provide the service, but in a degraded mode. In this case, the bypassing can only happen for one of the Y service nodes, i.e., if one of the X service nodes is down, there is no service at all.
NB: in this example, we consider, of course, that there is no redundancy anywhere, i.e., if a service node is down, the only thing to do is to fix it, and while waiting for the reparation, we face a degraded service, or no service at all.
Best,
Chidung

My Understanding is

Regards!

-Qin

-----Original Message-----

To: Zongning; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Again, my fault.

-Ning

-----Original Message-----

From: Zongning

To: [email-masked]<mailto:[email-masked]>'; [email-masked]<mailto:[email-masked]>

Hi, Adrian,

We believe vnfpool and SFC are independent and complementary mainly due to

the below reasons:

so on.

Thanks.

-Ning

-----Original Message-----

To: [email-masked]<mailto:[email-masked]>

Hi,

Thanks,

Adrian

vnfpool mailing list

[email-masked]<mailto:[email-masked]>

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 24 Jan 2014 22:54:56 +0000

Here is my take of the differences and the overlap with SFC:

If a service function has a small number of instances, say less than 5, and they are relative stable, then it is doable for Service Chain to specify the specific instances, the so called "Service Chain Path" by SFC drafts.

But if there are large number of instances, say in hundreds, and those instances' location/presence change over time (e.g. in NFV environment), then it is not scalable to have Service Chain path to specify the specific instances.

The service function instances' management, e.g. selection, replacement when failure occurs or over-utilized from a pool of available instances, notification should be  the scope of VNFpool.

Linda

From: vnfpool [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Wednesday, January 22, 2014 7:38 PM
To: LAC Chidung
Cc: [email-masked]; [email-masked]
Subject: Re: [vnfpool] Overlap with SFC?

Hi, Chidung:

Regards!
-Qin
From: vnfpool [mailto:[email-masked]] On Behalf Of LAC Chidung
Sent: Wednesday, January 22, 2014 7:26 PM
To: Qin Wu
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [vnfpool] Overlap with SFC?

Hi Qin,

My Understanding is

Regards!

-Qin

-----Original Message-----

Again, my fault.

-Ning

-----Original Message-----

From: Zongning

Hi, Adrian,

the below reasons:

so on.

Thanks.

-Ning

-----Original Message-----

Hi,

Thanks,

Adrian

vnfpool mailing list

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 24 Jan 2014 23:05:46 +0000

Chidung,

Do you have an example of "A service chain needs X+Y service nodes while X is mandatory and Y being optional"?

Thanks,
Linda

From: vnfpool [mailto:[email-masked]] On Behalf Of LAC Chidung
Sent: Wednesday, January 22, 2014 5:26 AM
To: Qin Wu
Cc: [email-masked]; [email-masked]
Subject: Re: [vnfpool] Overlap with SFC?

Hi Qin,

My Understanding is

Regards!

-Qin

-----Original Message-----

Again, my fault.

-Ning

-----Original Message-----

From: Zongning

Hi, Adrian,

the below reasons:

so on.

Thanks.

-Ning

-----Original Message-----

Hi,

Thanks,

Adrian

vnfpool mailing list

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 24 Jan 2014 20:04:28 -0500

Linda:

I agree with your use example, but would like to clarify it. 

VNF Pools  is about redundancy needs rather than chaining paths.   Pools
provide the redundancy.   You may need the redundancy for even a short chain
if it is High-availability.   You may have parallel chains to support the
redundancy. 

Cheers, 

Sue 

From: vnfpool [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Friday, January 24, 2014 5:55 PM
To: Qin Wu; LAC Chidung
Cc: [email-masked]; [email-masked]
Subject: Re: [vnfpool] Overlap with SFC?

If a service function has a small number of instances, say less than 5, and
they are relative stable, then it is doable for Service Chain to specify the
specific instances, the so called “Service Chain Path” by SFC drafts. 

But if there are large number of instances, say in hundreds, and those
instances’ location/presence change over time (e.g. in NFV environment),
then it is not scalable to have Service Chain path to specify the specific
instances. 

The service function instances’ management, e.g. selection, replacement when
failure occurs or over-utilized from a pool of available instances,
notification should be  the scope of VNFpool. 

Linda

Hi, Chidung:

That’s one good interpretation.

You are right, I should add assumption that the service node that is
bypassed is optional service node in the chain.

Regards!

-Qin

Hi Qin,
"in service chain, when a service node is down, what SFC is doing is to
bypass this service node": is the following interpretation ok ?
A service chain needs X+Y service nodes in order to provide the full
service: the X service nodes are mandatory, while the Y service nodes are
(kind of) optional, i.e., if one (or more) of these Y service nodes is (are)
down, the service chain can still provide the service, but in a degraded
mode. In this case, the bypassing can only happen for one of the Y service
nodes, i.e., if one of the X service nodes is down, there is no service at
all.
NB: in this example, we consider, of course, that there is no redundancy
anywhere, i.e., if a service node is down, the only thing to do is to fix
it, and while waiting for the reparation, we face a degraded service, or no
service at all.
Best,
Chidung

My Understanding is 
in service chain, when a service node is down, what SFC is doing is to
bypass this service node while
What nfvpool is doing is to replace the failing one with the new service
node which provide the same functionality.
Please correct me if I am wrong.
Regards!
-Qin
-----Original Message-----
From: vnfpool [mailto:[email-masked]] On Behalf Of Zongning
Sent: Wednesday, January 22, 2014 9:42 AM
To: Zongning; [email-masked]; [email-masked]
Subject: Re: [vnfpool] Overlap with SFC?
 
Sorry, item 1) is obviously not finished. :-)
1) SFC targets on steering packets among service function nodes. vnfpool
focuses on redundancy for service nodes, e.g., selecting standby nodes,
handling nodes transition/failure cases, without caring about how to
construct the data path.
Again, my fault.
-Ning

-----Original Message-----
From: Zongning
Sent: Wednesday, January 22, 2014 9:34 AM
To: [email-masked]'; [email-masked]
Subject: RE: [vnfpool] Overlap with SFC?
 
Hi, Adrian,
Thanks for raising this question. Actually vnfpool folks have been
discussing this
question a lot since the very beginning of this work.
We believe vnfpool and SFC are independent and complementary mainly due to
the below reasons:
1) SFC targets on steering packets among service function nodes. vnfpool
focuses on redundancy for service nodes, e.g., selecting standby nodes,
handling nodes transition/failure cases, without caring how
2) vnfpool manager in our proposal could interact with SFC control entity
to: 1)
advertise redundant service nodes; 2) notify status of redundant nodes when
required; 3) receive resiliency requirements from SFC control entity (if
any); and
so on.
3) vnfpool is not only used in "chained service nodes", but applicable to
other
cases where service nodes are not necessarily sequentially connected.
I appreciate any further feedback and advice from you or IESG, as I believe
these feedback will greatly improve the quality of our proposed charter.
Thanks.
-Ning

-----Original Message-----
From: vnfpool [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Wednesday, January 22, 2014 1:57 AM
To: [email-masked]
Subject: [vnfpool] Overlap with SFC?
 
Hi,
The IESG is looking at the BoF requests for London, and a question came upon
the overlap between the proposal here and items 4 and 5 in the SFC Charter.
I think it would be valuable if you could discuss the overlap and the
interaction between the two efforts so that there is a clear view.
Thanks,
Adrian

---

From: LAC Chidung <[email-masked]>
Date: Tue, 28 Jan 2014 15:33:08 +0100

Well, one can imagine plenty of situations:
* In a residential/home gateway, there is a dedicated VP-VC for VoIP. If 
this channel is down, the VoIP service will use instead the Internet 
VP-VC: in this case, if the user is alone at home, it could be ok, but 
if someone else (at home) is uploading/downloading huge files, the 
quality of the conversation is badly degraded.
* Case of a residential/home gateway which provides 2 wifi interfaces 
(e.g., 2.4 GHz and 5 GHz): if the 5 GHz interface is down, one can still 
use the 2.4 GHz interface for wifi connection, but it is slower.
* A smartphone connected to a service provider (SP) network is 
identified automatically, allowing the user to access to the SP (and its 
partners) services without additional identification. If the 
authentication module is down, the user wil need to provide the 
login/pwd (for instance) any time he/she wants to access to such services.
* Etc.
Best,
Chidung

Le 25/01/2014 00:05, Linda Dunbar a écrit :
>
> Chidung,
>
> Do you have an example of "A service chain needs X+Y service nodes 
> while X is mandatory and Y being optional"?
>
> Thanks,
>
> Linda
>
> *From:*vnfpool [mailto:[email-masked]] *On Behalf Of *LAC 
> Chidung
> *Sent:* Wednesday, January 22, 2014 5:26 AM
> *To:* Qin Wu
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [vnfpool] Overlap with SFC?
>
> Hi Qin,
> "/in service chain, when a service node is down, what SFC is doing is 
> to bypass this service node/": is the following interpretation ok ?
> A service chain needs X+Y service nodes in order to provide the 
> *_full_* service: the X service nodes are mandatory, while the Y 
> service nodes are (kind of) optional, i.e., if one (or more) of these 
> Y service nodes is (are) down, the service chain can still provide the 
> service, but in a *_degraded mode_*. In this case,*the bypassing can 
> only happen* for one of the Y service nodes, i.e., if one of the X 
> service nodes is down, there is *_no service at all_*.
> redundancy anywhere, i.e., if a service node is down, the only thing 
> to do is to fix it, and while waiting for the reparation, we face a 
>     To: Zongning;[email-masked]  <mailto:[email-masked]>;[email-masked]  <mailto:[email-masked]>
>
>         To: [email-masked]  <mailto:[email-masked]>';[email-masked]  <mailto:[email-masked]>
>
>             To:[email-masked]  <mailto:[email-masked]>
>
>             [email-masked]  <mailto:[email-masked]>
>

---

From: LAC Chidung <[email-masked]>
Date: Wed, 29 Jan 2014 17:28:40 +0100

_@ Linda:_ "/If a service function has a small number of instances, say 
less than 5/": a service function (SF) is composed of 5 Network 
Functions (NFs) - correct ?
_@ Susan:_ if the answer to the question above is "Y", then "/You may 
have parallel chains to support the redundancy/" seems strange ... 
Actually, a chain characterizes a SF, i.e., to obtain a certain SF, we 
are putting some NFs (5NFs in the previous example) in a chain. If this 
SF has to be highly available, the need is to make each NF highly 
available (using vnfpool for instance), but not to create another chain, 
because there is one unique chain to render the SF we are currently 
designing.
Thank you for correcting my interpretation.
Best,
Chidung

Le 25/01/2014 02:04, Susan Hares a écrit :
> VNF Pools  is about redundancy needs rather than chaining paths.  
>  Pools provide the redundancy.   You may need the redundancy for even 
> a short chain if it is High-availability.   You may have parallel 
> chains to support the redundancy.
>
> Cheers,
>
> Sue
>
> *From:*vnfpool [mailto:[email-masked]] *On Behalf Of *Linda 
> Dunbar
> *Sent:* Friday, January 24, 2014 5:55 PM
> *To:* Qin Wu; LAC Chidung
> If a service function has a small number of instances, say less than 
> 5, and they are relative stable, then it is doable for Service Chain 
> to specify the specific instances, the so called "Service Chain Path" 
> by SFC drafts.
>
> instances' location/presence change over time (e.g. in NFV 
> environment), then it is not scalable to have Service Chain path to 
> specify the specific instances.
>
> The service function instances' management, e.g. selection, 
> replacement when failure occurs or over-utilized from a pool of 
> available instances, notification should be  the scope of VNFpool.
>
> Linda
>
> *From:*vnfpool [mailto:[email-masked]] *On Behalf Of *Qin Wu
> *Sent:* Wednesday, January 22, 2014 7:38 PM
> *To:* LAC Chidung
> *Cc:* [email-masked] <mailto:[email-masked]>; [email-masked] 
> <mailto:[email-masked]>
> *Sent:* Wednesday, January 22, 2014 7:26 PM
> *To:* Qin Wu
> *Cc:* [email-masked] <mailto:[email-masked]>; [email-masked] 
> <mailto:[email-masked]>