Subject: [vnfpool] New revision of VNFPool Problem Statement posted

From: Zongning <[email-masked]>
Date: Thu, 10 Apr 2014 03:21:53 +0000

Hi, folks,

The new revision (-04) of VNFPool Problem Statement I-D is available on the below page.
https://datatracker.ietf.org/doc/draft-zong-vnfpool-problem-statement/

Here are the major changes:

1)       Clarify VNFPool architecture and intended scope.

1.         Add new section of VNF Pools before the section of Problem. This new section is mainly to outline our scope based on high level description of VNF Pools architecture.

2.         Add text to clarify that we are specifically concerned with reliability (e.g. redundancy model, state sharing) that is managed inside the VNF. We are only concerned with the whole VNF set (or forwarding graph) to the extent that it involves reliability impact on adjacent instances of different VNFs.

3.         We focus on reliability mechanisms based on VNF pool. Other VNF management aspects such as scaling, load balancing are out of scope.

2)       Update terminologies to define Service Control Entity, and delete Pool User as the pool will be internal to VNF only.

3)       Re-arrange the text in section of Problems.

4)       Update text of VNF instance performance degradation in section of Problems.

5)       Update text of Reliable Transport in section of Problems.

6)       Add text to explain why service availability is not in scope in section of Problems.

7)       Re-write the section describing the relationship of VNFPool and SFC.

8)       Add text of transfer of security states in section of Security Consideration.

We hope that the changes have addressed most of the comments, and reflected most of the suggestions during London BoF.

Please review this new revision. Your further comments and suggestions are highly appreciated!

Thanks.

-Ning

---

From: Zu Qiang <[email-masked]>
Date: Wed, 16 Apr 2014 18:12:54 +0000

Hello, Zongning
                Thanks for updating the draft. I do see this version is much better than the previous version. I have a few clarification questions below:

-          First, there are some existing HA solutions. Can you tell me what is the extra functionalities provided by the VNF Pool? Or the VNF Pool is only another alternative solution? Or are we going to use the existing HA solutions as inputs only?

-          Second, in the early version, you have the interactions between the Pool Managers of different pools and between the Pool Functions of different pools specified, which is removed in this version. Do you see that type of interactions are still needed? And why it is needed?

-          3rd, the VNF set is a new concept. What is the linkage with the proposed VNF Pool architecture?

-          4th, RSerPool is referred by your draft. I assume that VNF Pool will not reused the RSerPool  unchanged. So which part of RSerPool can be reused by VNF Pool?
Thanks.
Have a nice day
Zu Qiang

From: vnfpool [mailto:[email-masked]] On Behalf Of Zongning
Sent: Wednesday, April 09, 2014 11:22 PM
To: [email-masked]
Subject: [vnfpool] New revision of VNFPool Problem Statement posted

Hi, folks,

Thanks.

-Ning

---

From: Zongning <[email-masked]>
Date: Thu, 17 Apr 2014 03:44:43 +0000

Hi, Qiang,

Please see inline.

发件人: Zu Qiang [mailto:[email-masked]]
发送时间: 2014年4月17日 2:13
收件人: Zongning; [email-masked]
主题: RE: New revision of VNFPool Problem Statement posted

Hello, Zongning

[Ning] For sure there are existing HA solutions. For example, the SAF is about Service Availability mechanisms. I agree that there are definitely many pieces of existing work can be investigated as the basis of VNF Pool, e.g. redundancy model, state sharing. I think the extra work needed in VNF Pool is to address specific requirements on VNF failover procedure, VNF state sharing, etc. This will depend on further use case and gap analysis.

[Ning] Yes, I do think those interactions are still needed. But I prefer an VNF Pool architecture document to describe them, rather than Problem Statement draft.

[Ning] VNF set is just a general set of all the VNF instances. In VNF Pool architecture, these VNF instances are actually grouped into multiple pools, based on the functions they provided. For example, a VNF set {vFW#1, vFW#2, vLB#1, vLB#2, vLB#3} can be organized as two VNF pools – one pool is {vFW#1, vFW#2}, another is {vLB#1, vLB#2, vLB#3}. I will try to enhance this in the draft later on.

[Ning] Yes, we believe some mechanisms introduced by RSerPool can be extended and reused, such as PE registration, pool handle resolution and response. We have a RSerPool applicability and gap analysis draft dedicated on this perspective.

Thanks.
Have a nice day
Zu Qiang

From: vnfpool [mailto:[email-masked]] On Behalf Of Zongning
Sent: Wednesday, April 09, 2014 11:22 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [vnfpool] New revision of VNFPool Problem Statement posted

Hi, folks,

Thanks.

-Ning

---

From: Zu Qiang <[email-masked]>
Date: Mon, 21 Apr 2014 13:09:50 +0000

Hello, Zongning
                Thanks for your response. Can you give a use case of “the interactions between the Pool Managers of different pools and between the Pool Functions of different”? and a use case of “VNF set”?

Have a nice day
Zu Qiang

From: Zongning [mailto:[email-masked]]
Sent: Wednesday, April 16, 2014 11:45 PM
To: Zu Qiang; [email-masked]
Subject: 答复: New revision of VNFPool Problem Statement posted

Hi, Qiang,

Please see inline.

发件人: Zu Qiang [mailto:[email-masked]]
发送时间: 2014年4月17日 2:13
收件人: Zongning; [email-masked]<mailto:[email-masked]>
主题: RE: New revision of VNFPool Problem Statement posted

Hello, Zongning

Thanks.
Have a nice day
Zu Qiang

Hi, folks,

Thanks.

-Ning

---

From: Zongning <[email-masked]>
Date: Tue, 22 Apr 2014 01:38:19 +0000

Hi, Qiang,

I’d prefer to leave these questions to the co-authors of Use Case I-Ds. :)
I remember that we have a case of multi-tier service where data connections are directly between pool elements of different pools. Also in RSerPool, a pool element can announce its backup elements to the pool users via business card. The interaction between pool managers can be used for pooling information / status enquiry, and so on. Anyway, I think the details can be in the Use Case I-Ds.

Thanks.

-Ning

发送时间: 2014年4月21日 21:10

Hello, Zongning

Have a nice day
Zu Qiang

From: Zongning [mailto:[email-masked]]
Sent: Wednesday, April 16, 2014 11:45 PM
To: Zu Qiang; [email-masked]<mailto:[email-masked]>
Subject: 答复: New revision of VNFPool Problem Statement posted

Hi, Qiang,

Please see inline.

Hello, Zongning

Thanks.
Have a nice day
Zu Qiang

Hi, folks,

Thanks.

-Ning