Subject: Re: [vnfpool] new VNFPool draft charter

From: "King, Daniel" <[email-masked]>
Date: Wed, 4 Jun 2014 21:27:36 +0000

Hi All, 

Thanks Ning and Melinda for the draft charter text, overall the direction and work items look great to me. 

Still, being overly opinionated, I do have a few comments:

Charter Text
- Maybe break existing bullet, into two bullets (and minor grammar fix - "the Pool Manager": 

o Analysis of pooling security characteristics and requirements to identify and mitigate threats against the pooling mechanism. 
o Identification of an appropriate trust model between pool members, and between pool members and the Pool Manager.

- Also, does Trust imply Policy, or vice versa?     

- Adding [secure] as requirement in the transport protocol selection. Or maybe I am predetermining the protocol requirements, but then again we already state "reliable" mechanism:

o Investigate and select a [secure] and reliable transport protocol, such as MPTCP and SCTP, for delivery of the messages associated with the redundancy management within a VNF Pool.

Charter Milestones
- Perhaps specify a security should be investigated along with manageability in the following milestone:

"August 2015 - Submit VNFPool Requirements, including the manageability and security of VNF Pools to the IESG for publication as an Informational document."

- Slight clean up (grammar and adding the word "document") on the charter milestones, these would become (note the inclusion of "security"):

December 2014 - Submit VNFPool Problem Statement to IESG for publication as an Informational document.
April 2015 - Submit VNFPool Use Cases to IESG for publication as an Informational document.
August 2015 - Submit VNFPool Requirements, including the manageability and security of VNF Pools to the IESG for publication as an Informational document.
August 2015 - Submit VNFPool Architecture to IESG for publication as a Proposed Standard
December 2015 - Submit Applicability and Gap Analysis of RSerPool to IESG for publication as Informational document.

Spelling NITs in Charter Text
- "Conceptionally" to "Conceptually"
- " envisoned " to "envisioned"

Br, Dan.

---

From: Melinda Shore <[email-masked]>
Date: Wed, 04 Jun 2014 13:32:54 -0800

> - Also, does Trust imply Policy, or vice versa?

Typically in an IETF context it implies mechanism.

> Charter Milestones - Perhaps specify a security should be
> investigated along with manageability in the following milestone:
> 
> "August 2015 - Submit VNFPool Requirements, including the
> manageability and security of VNF Pools to the IESG for publication
> as an Informational document."

My general sense is that doing security requirements
separately is generally not successful, and that
including them in this sort of context tends to lead
to overly generic requirements that may not be
applicable to the technology that's ultimately adopted.

Melinda