Subject: Re: [vnfpool] 答复: new VNFPool draft charter

From: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]>
Date: Thu, 05 Jun 2014 07:45:53 +0000

Hi,

I support the WG Charter. However, I have a small concern regarding the first sentence in the third paragraph:

In order to achieve higher reliability, a pool of VNFs that perform the same function can be grouped together for the network services.

There is no mention to ‘the network services’ before.

Best,/PA

Dr. Pedro A. Aranda Gutiérrez

Technology Exploration -
Network Innovation & Virtualisation

mailto:[email-masked]
Telefónica, Investigación y Desarrollo
C/ D. Ramón de la Cruz,84
28006 Madrid, Spain

Fragen sind nicht da, um beantwortet zu werden.
Fragen sind da, um gestellt zu werden.
Georg Kreisler

De: Zongning <[email-masked]<mailto:[email-masked]>>
Fecha: jueves, 5 de junio de 2014 03:11
Para: Linda Dunbar <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Asunto: [vnfpool] 答复: new VNFPool draft charter

Hi, Linda,

Thanks for re-wording. I will incorporate some of the suggested changes in the final charter. Specifically, the below sentence means that a VNF appears to outside entity such as service control entity a normal, single VNF (instance), although internally there is a pool for high reliability.
“A VNF Pool-enabled VNF still appears as a normal VNF when orchestrated by a service control entity.”

We do have a dedicated paragraph about relation between VNFPool and SFC – it is the last paragraph of the main text, just above the milestone part. In that paragraph, we don’t emphasize much on how VNFPool and SFC are different (as they are different in nature), but describe how they relate and work with each other.

-Ning

发件人: Linda Dunbar
发送时间: 2014年6月5日 4:13
收件人: Zongning; [email-masked]<mailto:[email-masked]>
主题: RE: new VNFPool draft charter

Ning,

I made some wording changes to the proposed charter. The attached Word document has the changes mark, making it easier to see. In case the mailing list doesn’t allow attachment, here is the proposed changes.

Should we also add a paragraph to show why/how VNFpool is different from SFC?

Linda

Network functions such as firewalls, load balancers, and WAN optimizers are conventionally deployed as specialized hardware servers in both network operators' networks and data center networks as the building blocks of the network services. There is a trend to implement such network functions as software instances running on general purpose servers, via a virtualization layer (i.e., hypervisors). These virtualized functions are called Virtualized Network Functions (VNFs), which can be instantiated to build network services.

The use of VNFs introduces additional challenges to the reliability of the provided network services. A single VNF instance would typically not have built-in reliability mechanisms on its host (i.e., a general purpose server). Instead, there are more factors of risk such as software failure at various levels including hypervisors and virtual machines, hardware failure, and instance migration that can make a VNF instance unreliable.

In order to achieve higher reliability, a pool of VNFs that perform the same function can be grouped together for the network services.  Conceptionally, multiple instances of a same function are grouped together and managed by its Pool Manager. Different functions have different pool manager.  A Pool Manager is responsible for monitoring  the status of the instances in the pool, selecting active/standby instances for specific services, and potentially interacts with other entities, e.g. service control entity or  service orchestration system. The major benefit of using VNF Pool is that reliability mechanisms such as redundancy & protection are achieved by the VNF Pool and thus not visible to the service control entity. A VNF Pool-enabled VNF still appears as a normal VNF when orchestrated by a service control entity.[L1]

Questions that are raised by the addition of a pooling mechanism to VNF include:

·           How to manage the redundancy model, e.g., select active/standby VNF instances in a VNF Pool?

·           What pool states need to be maintained to support the pooling mechanism itself, and how are such states maintained?

·           What information is exchanged between a VNF and a service control entity? For example, how can a VNF Pool be addressed by the service control entity?

·           When a live VNF instance goes out of service, how does the service control entity learn which instance in a VNF Pool will replace it, and learn the characteristics of the new instance?
The WG initially focuses on several reliability mechanisms that are mainly associated with a redundancy model based on a VNF Pool in a VNF. Additional mechanisms might include state maintenance of instances in a VNF Pool only for pooling purpose (service state synchronization is out of scope). The WG assumes that a VNF Pool contains identical VNF instances of same functional type. Different types of VNFs are envisoned to be held in separate VNF Pools. The WG will address the reliability of an individual VNF, but not the reliability related to the control or the routing between adjacent VNFs that can form a network service.

From: vnfpool [mailto:[email-masked]] On Behalf Of Zongning
Sent: Tuesday, June 03, 2014 4:36 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [vnfpool] new VNFPool draft charter

Hi, folks,

Please see the below new draft charter of VNFPool. We believe that we have updated the charter to address most of the comments from London BoF. Main changes are:

1)       We narrow down our scope to only focus on the redundancy model and the related interfaces associated with the VNF Pool in a single VNF.

2)       Service state synchronization between VNF instances is out-of-scope. We may consider how to maintain the pool states in a VNF Pool only for pooling purpose.

3)       We assume that a VNF Pool contains redundant VNF instances of same functional type. Different types of VNFs are envisoned to be held in separate VNF Pools.

4)       We do not address reliability related control or routing between adjacent VNFs in the service graph. This is also applied to update the relation between VNF Pool and SFC WG.

==========================================================================
Network functions such as firewalls, load balancers, and WAN optimizers are conventionally deployed as specialized hardware servers in both network operators' networks and data center networks as the building blocks of the network services. There is a trend to implement such network functions as software instances running on general purpose servers, via a virtualization layer (i.e., hypervisors). These virtualized functions are called Virtualized Network Functions (VNFs), which can be used to build network services.

The use of VNFs introduces additional challenges to the reliability of the provided network services. A single VNF instance would typically not have built-in reliability mechanisms on its host (i.e., a general purpose server). Instead, there are more factors of risk such as software failure at various levels including hypervisors and virtual machines, hardware failure, and instance migration that can make a VNF instance unreliable.

In order to provide a reliable function, a VNF may adopt a pooling mechanism by using a number of VNF instances providing the same function, which we call a “VNF Pool”. Conceptionally, a Pool Manager is used to manage the VNF Pool, e.g., selects active/standby VNF instances, and potentially interacts with a service control entity. Such a service control entity is an entity that orchestrates a set of network functions to build network services. The major benefit of using VNF Pool is that reliability mechanisms such as redundancy model are achieved by the VNF Pool inside the VNF and thus not visible to the service control entity. A VNF Pool-enabled VNF still appears as a normal VNF when orchestrated by a service control entity.

Questions that are raised by the addition of a pooling mechanism to VNF include:

·           How to manage the redundancy model, e.g., select active/standby VNF instances in a VNF Pool?

·           What pool states need to be maintained to support the pooling mechanism itself, and how are such states maintained?

·           What information is exchanged between a VNF and a service control entity? For example, how can a VNF Pool be addressed by the service control entity?

·           When a live VNF instance goes out of service, how does the service control entity learn which instance in a VNF Pool will replace it, and learn the characteristics of the new instance?
The WG initially focuses on several reliability mechanisms that are mainly associated with a redundancy model based on a VNF Pool in a VNF. Additional mechanisms that may be needed include state maintenance in a VNF Pool only for pooling purpose (service state synchronization is out of scope). The WG assumes that a VNF Pool contains redundant VNF instances of same functional type. Different types of VNFs are envisoned to be held in separate VNF Pools. The WG will address the reliability of an individual VNF, but not the reliability related to the control or the routing between adjacent VNFs that can form a network service.
Specifically, the WG will work on the following technical aspects:

·           Redundancy management within a VNF Pool, such as the signaling between the Pool Manager and the instances in the pool for instance registration, backup instances selection, and switching between active and standby instances.

·           The protocol between the Pool Manager and the underlying network to collect the network information required for appropriate placement/selection of backup instances.

·           The protocol between a VNF and the service control entity to exchange operational information between a VNF Pool and the service control entity.

·           Identify and analyze reliable transport protocols, such as MPTCP and SCTP for reliable delivery of the messages associated with the redundancy management within a VNF Pool.

·           Analysis of pooling security characteristics and requirements to identify and mitigate threats against the pooling mechanism. Identification of an appropriate trust model between pool members, and between pool members and Pool Manager.
The WG plans to deliver a problem statement, a set of use cases, VNF Pool requirements and an architecture covering the aforementioned technical aspects, and applicability and gap analysis of existing technologies such as RSerPool. It is our expectation that we will be able to rely heavily on existing IETF technologies, but that gaps will be found around problems like redundancy mechanisms, state maintenance solely for pooling purposes, reliable transport, and trust/security, all of which will need to be considered and addressed. The WG will include consideration of the manageability of a VNF Pool. The WG will seek re-chartering before adopting any work to develop new, or extend existing, protocols.

In particular, we will work closely with the SFC WG, as we believe that SFC and VNF Pool are independent but complementary. SFC would essentially see a VNF Pool-enabled VNF as a normal service function and therefore be able to merge it into an SFC just like any other service functions. Information exchanged between the VNF Pool and the SFC may include some operational information from the VNF Pool including the pool address, pool instance characteristic, and so on, as requested by the SFC WG.

Goals and Milestones:
December 2014 - Submit VNFPool Problem Statement to IESG for publication as Informational
April 2015 - Submit VNFPool Use Cases to IESG for publication as Informational
August 2015 - Submit VNFPool Requirements, including the manageability of VNF Pool to IESG for publication as Informational
August 2015 - Submit VNFPool Architecture to IESG for publication as Proposed Standard
December 2015 - Submit Applicability and Gap Analysis of RSerPool to IESG for publication as Informational
==========================================================================

Your comments and suggestions to the charter text are highly appreciated!

Thanks.

-Ning
________________________________

 Not clear of the intent.

Do you mean: “VNF instances in the VNF pool are still visible by the service control entity”?

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: Zongning <[email-masked]>
Date: Thu, 5 Jun 2014 08:15:39 +0000

Hi, Pedro,

Thanks for your support. I guess “the network service” here could be “the network function”. Or we could delete the words after “grouped together” to avoid duplication.

-Ning

发件人: PEDRO ANDRES ARANDA GUTIERREZ [mailto:[email-masked]]
发送时间: 2014年6月5日 15:46
收件人: Zongning; Linda Dunbar; [email-masked]
主题: Re: [vnfpool] 答复: new VNFPool draft charter

Hi,

Best,/PA

Technology Exploration -

mailto:[email-masked]

Hi, Linda,

-Ning

发件人: Linda Dunbar
发送时间: 2014年6月5日 4:13

Ning,

Linda

Hi, folks,

Goals and Milestones:

Thanks.

-Ning

 Not clear of the intent.