Subject: [vnrg] Towards a Virtual Network definition

From: Roland Bless <[email-masked]>
Date: Wed, 16 Feb 2011 21:51:49 +0100

Hi,

here is another attempt to define what a virtual network
in the sense of network virtualization is:

A virtual network (VNet) is a set of (virtual) nodes directly
connected by (virtual) links and realized on top of a
set of underlying physical resources, the "substrate".

This essentially represents the view of a VNet owner/user,
so he sees virtual nodes that are directly connected
to other virtual nodes, i.e., a bare link layer topology.
Protocols running _inside_ the virtual topology are
typically layer 3 protocols, therefore we speak of
Network Virtualization (virtualization at the network layer,
and virtual nodes are thus virtual routers)

Some features of VNets:

- A virtual network resource (node or link) appears to a user
  of that resource as if he is the (exclusive) owner of that
  resource. (=> isolation)

- There should be no assumptions about the particular
  network protocols or architectures running
  inside the VNet, i.e., it is not necessarily IP.

- One may use various substrate techniques (even at different
  layers) to create virtual links, e.g., WDM, IP Tunnels,
  MPLS, Ethernet VLANs, or even TCP tunnels.
  The substrate may be composed of heterogeneous
  technologies. The main interest of the VNRG
  is probably to consider IP(v4/v6) related technologies
  as common substrate technology.

- Partitioning or aggregation of substrate resources is possible
  to create virtual resources.

- A host that wants to connect to a VNet needs a
  running instance of the protocol(s) that are
  required to communicate with the VNet.
  It needs a substrate path (i.e., the virtual last mile link)
  in order to attach to a virtual (access) node.

Question: does the host "belong" to the VNet topology or
not? IMHO, it is the same situation as in the Internet today:
hosts are part of the network but don't belong to an
ISPs infrastructure, i.e., they are attached to the
access routers/switches etc.

Another interesting question is, however, how the end of
a virtual link is represented inside the virtual node, e.g.,
it could appear as an "ordinary Ethernet" device (i.e., virtual
device) or as any other L2 device.

Regards,
 Roland

---

From: Roland Bless <[email-masked]>
Date: Thu, 17 Feb 2011 13:52:51 +0100

Hi Dae Young,

Am 17.02.2011 04:16, schrieb Dae Young KIM:
> Long time no see.

Yes.

> Are we sure about this? As a experimenter, I'd also be interested in
> virtualization of entities deeper in the layer, that is, virtualization
> of even L2 and L1.

Ok, why not, but IMHO one should distinguish, however, what is your
currently considered layer that is virtualized and what is the
substrate (which might be heterogeneous). And as I said, you may use
also virtualization techniques in the substrate, e.g. VLANs etc.

> 'Network' we're talking about here would not merely mean 'Network Layer'
> in the OSI sense, but mean more of generic 'network' realm compassing
> from Physical upwards even up to Transport or beyond.

Sure, if you want to. For me the focus is on layer 3, but
others may have different interests, e.g., wireless virtualization
is also highly interesting and useful.

> A host might be just one type of nodes in networking, i.e., stub node. A
> router, on the other hand might represent another type of node, i.e., a
> relay node.

Yep.

> With this notion, I'd think 'hosts' could also belong to the VNet topology.

In the 4WARD project the VNet topology description didn't include
hosts or stub nodes since they are dynamically attached and you usually
don't know a priori which hosts will be attached. Furthermore, mobility
of hosts is another reason why it is difficult to include them into
a topology description. So maybe it's better to say: hosts are part
of the VNet (topology) but don't belong to the VNet infrastructure.

Regards,
 Roland

---

From: Dae Young KIM <[email-masked]>
Date: Thu, 17 Feb 2011 12:16:04 +0900

Hi, Roland,

Long time no see.

On Thu, Feb 17, 2011 at 5:51 AM, Roland Bless <[email-masked]> wrote:

Are we sure about this? As a experimenter, I'd also be interested in
virtualization of entities deeper in the layer, that is, virtualization of
even L2 and L1.

'Network' we're talking about here would not merely mean 'Network Layer' in
the OSI sense, but mean more of generic 'network' realm compassing from
Physical upwards even up to Transport or beyond.

-- 
DY

---

From: Dae Young KIM <[email-masked]>
Date: Thu, 17 Feb 2011 22:07:32 +0900

> also virtualization techniques in the substrate, e.g. VLANs etc.

So, my deeper layer (L2 and L1) might be your substrate..?

Yes, your picture is simpler and cleaner. Yet, I'd like to experiment on my
new switching technology, like new kind of circuit switching or hybrid
switching.

Where do I get virtualized lambda pipe or virtualized switching fabric so
that I can test my wild L1 and L2 ideas in a global scale?

> of the VNet (topology) but don't belong to the VNet infrastructure.

Then what about mobile routers or subnets, i.e., MANETs? Subnets themselves
are moving around and touch each other in an ad hoc fashion; vehicular
network and many other futuristic scenarios.

Shall we say the belong to the VNet infra or such mobile subnets/routers are
off the infra?

(So, I'm trying to tease you... :-)).

-- 
DY