Subject: Re: [vnrg] Logical vs. virtual

From: Martin Stiemerling <[email-masked]>
Date: Tue, 8 Feb 2011 15:37:13 +0000

Dear all,

I'm replying to this rather old email thread about "Logical vs. virtual", as I haven't found a compelling definition yet of what is logical and what is virtual. Not that it wasn't stated before, I have just a hard time to catch the definitions. 

After spending some time with reasoning (on my own and with a colleague) about logical and virtual, I see them orthogonal to each other, as the perception if something is logical or virtual may heavily dependent on the view. 

Logical seems to me the description of a thing (entity), in our case a (virtual) network. A virtual network logically consists out of virtual links and virtual routers (omitting switches, etc here). This would be the view from top (user of CN) to down. On the other hand, seen from the physical side, a virtual network logically consists out of instances on a physical link, instances on a router, etc.

Virtual on the other hand describes more the fact that you can use something which is actually not really existing, plus some more features as the ability to relocated, re-visitation, etc, probably going beyond the abilities of the lower (physical layer). An example would be direct link between two virtual routers, which in fact crosses multiple routers, i.e., you get the direct link which is actually not existing but constructed. 

To give an example from the computer world on virtual memory:
Virtual memory gives you something beyond the ability of real physical memory, e.g., continuous memory or memory beyond the real RAM by using space on a hard disk. Logically you have memory for application and the OS logically provides you with the means (real RAM or disk space) to have such a memory. 

Somebody (probably Joe) mentioned also that there is a mapping step from a logical level to the level below, e.g., mapping from need "x routers and links in a star topology" to the layer below (physical or virtual) in terms of "take VLAN X, router instance Z on router DS". 

The above text is for sure not ready to be casted in stone, but an attempt to get some textual definitions. Ideas of the text are not all mine, but include a condensed ideas of emails.

Open fire on my right now! :)

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Joe Touch
> Sent: Thursday, July 15, 2010 6:51 PM
> To: Didier Colle
> Cc: [email-masked]
> Subject: Re: [vnrg] Logical vs. virtual
> 
> (again, speaking as an individual participant):
> 
> On 7/15/2010 9:36 AM, Didier Colle wrote:
> > Dear Joe, all,
> >
> >> I tend to think of a logical device as not really adding to the
> >> capabilities of a physical one, though, whereas a virtual one seems
> to
> >> (at least to me).
> >
> > Please explain. What capabilities are you referring to?
> > So far, I think most people on the list have expressed a virtual
> network
> > having the same or a subset of the capabilities of the network. Do
> you
> > agree with that? And remains that statement true for a virtual device
> > rather than virtual network?
> 
> A physical network can't be relocated while running. A virtual one can.
> A physical network doesn't ensure separation from other physical
> networks; a virtual one should, IMO.
> 
> >  From your previous post today, these capabilities are not apparent.
> >> 1.c. what is the characteristic behavior/capability of the
> >> resulting system?
> >>
> >> I think that the defining characteristic of a VN is that it allows
> an
> >> existing network to concurrently emulate another, distinct and
> >> separate network.
>  >
> > Is that a characteristic/capability of the virtual network (VN) or of
> > the underlying existing network?
> 
> The VN. Without the VN, no such emulation would occur, IMO.
> 
> >> Maybe these are really just two aspects of a single thing, i.e., I
> >> would differentiate between:
> >>
> >> - a device which does not map 1:1 to a physical entity
> >> (could be a part of one, a group of many, or a group of parts)
> >>
> >> - a device which provides supports virtual networking
> >>
> >> Since we call the latter "virtual networking" (the name of this RG),
> I
> >> would propose that the latter would be the virtual device, and the
> >> former be the logical one.
> >
> > Hmm... so the resulting question is: What is virtual networking? ;-)
> 
> I had proposed a definition - which is a network composed of tunnels.
> The rest, IMO, is largely in support of that one distinguishing
> characteristic.
> 
> >> I don't think of it as a 'specialized form', but rather the fact
> that
> >> a single virtual router CANNOT be mapped onto a single physical
> device
> >> with no other logical components.
> >>
> >> I.e., a virtual router needs a base router to connect to the links
> of
> >> the tunnel. A virtual host needs a base router (as well) for the
> same
> >> reason.
>  >
> > Really? In your previous post you said: "A virtual link is the
> easiest
> > to define - it is a tunnel over some existing network path, i.e.,
> with
> > an additional layer of encapsulation that is used solely for the VN,
> but
> > which is otherwise not needed. A virtual router forwards packets
> between
> > virtual links. " So, virtual link is encapsulated (e.g., by tagging
> with
> > a VLAN-ID?) to allow multiplexing: is this something the virtual
> router
> > cannot do (although invisible to the user/owner of the virtual
> router)?
> 
> A virtual router can encapsulate, but doesn't know what to do with the
> encapsulated packet, IMO. At some point the packet needs to go out a
> physical interface, and I don't think virtual routers own any physical
> interfaces.
> 
> > Do you need for that another "base" router?
> 
> No; that's what I needed the base router for in the first place.
> 
> Joe
> _______________________________________________
> vnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/vnrg

---

From: "$witch" <[email-masked]>
Date: Tue, 08 Feb 2011 17:58:00 +0100

On 02/08/11 16:37, Martin Stiemerling wrote:
......

>
> Virtual on the other hand describes more the fact that you can use something which is actually not really existing, ...
>

Hi, Martin and all

as newbye am adding just "canonicals 2 cents" :

in my mind virtual has "temporary-limited" meaning more than 
"not-really-existing" while logical implies something that will be 
multiplexed by a phisical "something" (as in logical-interfaces and 
phisical-interfaces); maybe definition can include (or exclude) that 
interpretation.

Alessandro

---

From: Martin Stiemerling <[email-masked]>
Date: Fri, 11 Feb 2011 14:00:56 +0000

Hi 

14 

> $witch
> Sent: Tuesday, February 08, 2011 5:58 PM
> To: [email-masked]
> > Virtual on the other hand describes more the fact that you can use
> something which is actually not really existing, ...
> >
> 
> Hi, Martin and all
> 

IMHO "temporary limited" does catch the virtual part. A virtual network can exist for an arbitrary amount of time. 

  Martin

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 28320

---

From: "$witch" <[email-masked]>
Date: Fri, 11 Feb 2011 15:59:17 +0100

> Hi

ciao,

34,75 %

> IMHO "temporary limited" does catch the virtual part. A virtual network can exist for an arbitrary amount of time.

please clarify how can "something-which-is-actually-not-really-existing" 
"exist-for-an-arbitrary-amount-of-time"; it seem a lexical nonsense.

cheers

Alessandro

---

From: Roland Bless <[email-masked]>
Date: Fri, 11 Feb 2011 16:59:19 +0100

Hi,

the difference between logical and virtual isn't
that easy and sometimes seems artificial.
According to an older (but nice) German book on operating system
architecture (H. Wettstein, Systemarchitektur)
the following distinction is made:

* a virtual resource appears to a user of that resource
  as if he is the (exclusive) owner of that resource.
  A user's access is always carried out on the real resource.

Thus, a virtual resource simplifies the handling of
a scarce real resource, while hiding the shortage. Virtual
memory is a typical example here - a process can use
a larger virtual memory than there is physically real
memory available. However, real memory is accessed
in case the virtual resource is used - the virtual memory
manager has to decide which parts are mapped into
that physical memory region or swapped to disc respectively.

So splitting a physical link into several virtual
links is also a valid example if the virtual
links offer the same interface and features as the
real medium, e.g., each VLAN may appear in a host
as separate Ethernet interface.

The book explicitly distinguishes virtual from logical
resources as follows:

* a logical resource is created by transforming one
  or several features of a real resource and by
  offering it in this way to the user.

This requires use of a mapping layer that transforms
the interface of the real resource(s) into a more
purposeful interface. Thus, the logical resource/device
may be simpler to handle from a user's point of view
and constitutes an improved but different resource
or device.

For example, block-oriented devices are logical
devices if the physical underlying device offers
only character-oriented access. A well-known example
is to create a single (larger) logical volume out of
several different physical disks. File-oriented access
is also a logical concept, because it abstracts from
block-oriented sequential structures of the data storage.
Consider a logical desktop appearing as single one although
composed of two different adjacent screens in contrast
to larger virtual desktop.

An example in the networking context are all layers:
a) a link layer offering frame-oriented transport on
   top of the bit-oriented physical layer
b) an end-to-end IP packet transport on top of the concatenated
   link layer connections
c) a reliable transport link on top of an unreliable link
etc...

Note that both concepts are providing abstractions.
I'm not quite sure that the distinction between logical
and virtual is helpful or useful in our context. However,
it might explain why IP is not a virtual network, but
logical one (same for TCP on top of IP) - as I also postulated
in an earlier mail on this list.

Just my two cents.

Regards,
 Roland

---

From: Roland Bless <[email-masked]>
Date: Mon, 14 Feb 2011 13:35:39 +0100

Hi,

> that easy and sometimes seems artificial.

After spending some more thoughts on this:
it seems to be the case that both mechanisms are often combined
and that they can be applied on top of each other in various ways:
consider some kind of Ethernet link aggregation mechanism that probably
provides mainly a logical resource, but on top of this logical
link one could provide a virtual link, whose interface
looks exactly like an ordinary Ethernet link (except for
higher capacity, higher resilience etc.) between a single
pair of MAC addresses.
So that explains, why the distinction between logical
and virtual is often unclear or blurred.

> and constitutes an improved but different resource

Such transformations may be performed in order to:
change the size of transport units, change the capacity,
change the access delay, change the access mode, combine
several devices, distribute to several devices, etc.

Regards,
 Roland