Subject: [VoT] Clause 7 edgy on scope? (RE: Vectors of Trust I-D)

From: Colin Wallis <[email-masked]>
Date: Mon, 29 Jun 2015 23:14:02 +0000

Many thanks Justin and Leif

I’ve done a first pass/light read, and from that, I think it is a terrific first cut that gets us on the path to normalizing the discussions over the past 9 months.

Aside from a few tidy ups, I just have this slight concern whether all of Clause 7 (Discovery and Verification) is in scope for normative text?
I certainly appreciate that in most implementations and deployments, there would be a dependency on an operational trust framework and trustmark.
But is it too big a stretch to make that normative for this work?
Just a thought.. and more than happy to be proven wrong.. ☺.

Cheers
Colin

From: vot [mailto:[email-masked]] On Behalf Of Justin Richer
Sent: Saturday, 27 June 2015 3:15 p.m.
To: [email-masked]
Subject: [VoT] Vectors of Trust I-D

Hi Everyone,

I have taken the initial strawman proposal along with a substantial number of edits and inputs from several folks and have created an initial I-D of the document:

https://tools.ietf.org/id/draft-richer-vectors-of-trust-00

It’s still a very drafty draft, but hopefully it’s starting to make this a concrete thing. Please read it over and discuss it here on the list.

I would like to propose a bar-BoF in Prague for VoT for anyone who would like to discuss this. If you’re interested (and will be there in person), let me know!

 — Justin

---

From: Justin Richer <[email-masked]>
Date: Mon, 29 Jun 2015 20:49:04 -0400

Colin, that’s a great question, because I’m honestly not sure what the answer is yet. I think that the vectors only make sense in the context of some kind of trust framework setup, but that sometimes those policies will be hard-coded at configuration time and won’t need to be dynamically bound or discovered. That said, I think the real value of this is going to be cross-domain where an RP could subscribe to (and understand) multiple trust marks and be able to validate them at runtime. Still, that piece might be separable enough, and perhaps substantive enough, to be its own draft. 

That said, I figured I’d write it down down and figure out where it’s actually supposed to go later. :)

 — Justin

> On Jun 29, 2015, at 7:14 PM, Colin Wallis <[email-masked]> wrote:
> 
> Just a thought.. and more than happy to be proven wrong.. J.
>  
> Cheers
> Colin
>  
>  
> https://tools.ietf.org/id/draft-richer-vectors-of-trust-00 <https://tools.ietf.org/id/draft-richer-vectors-of-trust-00>
>

---

From: "Grassi, Paul A." <[email-masked]>
Date: Tue, 30 Jun 2015 01:35:48 +0000

I personally like the idea of discoverability at the onset, and the discussion that will follow.

This was great to read, thanks to you and Leif for the work!

On Jun 29, 2015, at 8:49 PM, "Justin Richer" <[email-masked]<mailto:[email-masked]>> wrote:

Colin, that's a great question, because I'm honestly not sure what the answer is yet. I think that the vectors only make sense in the context of some kind of trust framework setup, but that sometimes those policies will be hard-coded at configuration time and won't need to be dynamically bound or discovered. That said, I think the real value of this is going to be cross-domain where an RP could subscribe to (and understand) multiple trust marks and be able to validate them at runtime. Still, that piece might be separable enough, and perhaps substantive enough, to be its own draft.

That said, I figured I'd write it down down and figure out where it's actually supposed to go later. :)

 - Justin

On Jun 29, 2015, at 7:14 PM, Colin Wallis <[email-masked]<mailto:[email-masked]>> wrote:

I've done a first pass/light read, and from that, I think it is a terrific first cut that gets us on the path to normalizing the discussions over the past 9 months.

Aside from a few tidy ups, I just have this slight concern whether all of Clause 7 (Discovery and Verification) is in scope for normative text?
I certainly appreciate that in most implementations and deployments, there would be a dependency on an operational trust framework and trustmark.
But is it too big a stretch to make that normative for this work?
Just a thought.. and more than happy to be proven wrong.. :).

Cheers
Colin

From: vot [mailto:[email-masked]] On Behalf Of Justin Richer
Sent: Saturday, 27 June 2015 3:15 p.m.
To: [email-masked]<mailto:[email-masked]>
Subject: [VoT] Vectors of Trust I-D

Hi Everyone,

It's still a very drafty draft, but hopefully it's starting to make this a concrete thing. Please read it over and discuss it here on the list.

I would like to propose a bar-BoF in Prague for VoT for anyone who would like to discuss this. If you're interested (and will be there in person), let me know!

 - Justin

_______________________________________________
vot mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/vot

---

From: Mark Lizar <[email-masked]>
Date: Tue, 30 Jun 2015 12:34:50 +0100

nice and crisp.

I can really start to imagine how discovery and trust marks can be used to scale trust. Although there is some additional issues around the overarching trust framework (whatever that is, I am assuming law). For example assessing trust marks so that they are appropriate for the purpose and also for application in the framework, with a robust method for assessing and asserting integrity of trust marks.  In this context then I think it would be clear how the trust marks fit with VOT.  Its the gap between these elements I suspect that needs to be further articulated and understood.

nicely thought provoking   ..

> On 30 Jun 2015, at 02:35, Grassi, Paul A. <[email-masked]> wrote:
> 
> On Jun 29, 2015, at 8:49 PM, "Justin Richer" <[email-masked] <mailto:[email-masked]>> wrote:
> 
>>> On Jun 29, 2015, at 7:14 PM, Colin Wallis <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> From: vot [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Justin Richer
>>> To: [email-masked] <mailto:[email-masked]>
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/vot <https://www.ietf.org/mailman/listinfo/vot>
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/vot <https://www.ietf.org/mailman/listinfo/vot>

---

From: Colin Wallis <[email-masked]>
Date: Tue, 30 Jun 2015 20:50:06 +0000

Thanks for those comments on Clause 7.
It seems like the challenge is to find that sweet spot/fine line that gives the reader enough info on how to do the cross domain subscription/validation, without having the this whole draft standardizing trust frameworks and trustmarks.
Because that is a whole lot more work and takes the focus away from the original intent (which was my concern and hence the idea of making this part informative until such time as we have a supported trustmark and trust framework standard to reverse the cross domain things back into).

Cheers
Colin

From: Mark Lizar [mailto:[email-masked]]
Sent: Tuesday, 30 June 2015 11:35 p.m.
To: Grassi, Paul A.
Cc: Justin Richer; Colin Wallis; [email-masked]
Subject: Re: [VoT] Clause 7 edgy on scope? (RE: Vectors of Trust I-D)

nice and crisp.

On 30 Jun 2015, at 02:35, Grassi, Paul A. <[email-masked]<mailto:[email-masked]>> wrote:

 — Justin

Cheers
Colin

Hi Everyone,

 — Justin

---

From: "Bucci, Debbie (OS/ONC)" <[email-masked]>
Date: Tue, 30 Jun 2015 23:58:19 +0000

In re: trustmarks,  I would suggest there are exemplars out there today.  VOT should standardizes the container and let others duke out the content issue.

Sent from my iPhone

On Jun 30, 2015, at 4:50 PM, Colin Wallis <[email-masked]<mailto:[email-masked]>> wrote:

Cheers
Colin

From: Mark Lizar [mailto:[email-masked]]
Sent: Tuesday, 30 June 2015 11:35 p.m.
To: Grassi, Paul A.
Cc: Justin Richer; Colin Wallis; [email-masked]<mailto:[email-masked]>
Subject: Re: [VoT] Clause 7 edgy on scope? (RE: Vectors of Trust I-D)

nice and crisp.

 — Justin

Cheers
Colin

Hi Everyone,

 — Justin