Subject: RE: why gratuitous arp ?

From: Vivek Menezes <[email-masked]>
Date: Fri, 12 May 2000 11:37:59 -0700

Another thing to note is that the gratuitous arp can get lost. The protocol
has no means of
recovery from this. However since the arp entries on the hosts would timeout
they would get the correct mapping at some point of time.

Implementations might wanna consider this.

Vivek.

-----Original Message-----
From: Jerome Etienne [mailto:[email-masked]]
Sent: Friday, May 12, 2000 11:00 AM
To: Sumandra Majee
Cc: 'Hamayon Mujeeb'; [email-masked]
Subject: Re: why gratuitous arp ?

On Fri, May 12, 2000 at 10:47:56AM -0700, Sumandra Majee wrote:
> VRRP keeps the same IP<->mac binding. So in essence the end host doesn't
> need to know any new binding. 

as i understood what Hamayon Mujeeb said, it is needed. i will try
to rephrase it and hope it will help. 

before the virtual router start, the ARP cache of the hosts on the network 
may contain the 'IP address owner' associated with its real MAC 
address (i.e. not the VRRP one). So when the virtual router
start and send gratuitous ARP request for the virtual router
address (which happen to be the same), so the hosts updates
their cache.
If no gratuitous ARP is sent, the hosts won't be able to communicate
until the old entry timeout.

> However I think the switches(or other L2 device) do learn
> from this 
> request and update their table, apart from finding any duplication of ip
> address.

---

From: Jerome Etienne <[email-masked]>
Date: Fri, 12 May 2000 14:50:30 -0400

> Implementations might wanna consider this.

It may be a good idea to advice in the draft to send 3 requests to 
reduce this effect.