Subject: RE: Why Virtual MACs....?

From: "Casey S. Ajalat" <[email-masked]> (by way of Sumandra Majee <[email-masked]>)
Date: Tue, 15 May 2001 11:20:25 -0700

One thing to consider is that some OS actually drops gratuitous arp 
request. SO in that case the re-mapping will not occur till the arp cache 
times out, which can be rather large.
On ther other hand L2 bridge tables are learnt as soon as the learning 
bridge sees a new src mac on a port/vlan.

This doesn't always work because arp requests itself are unreliable. It is 
better to re issue the gratuitous arp request to lower the probability of loss.

Sumandra

Yet another way of looking at this is:

Scenario 1: Virtual IP but Unique MAC (Badri's suggestion)

- Master Router fails
- Secondary now has IP (IP aliasing for example)
- Secondary issues Grat ARP
- Switch DB is not changed (at L2) but ALL hosts now update their ARP-Cache 
Tables to reflect new MAC for the same IP

Scenario 2: Virtual IP/MAC (RFC 2238)

- Master router fails
- Secondary now owns BOTH Virtual IP/MAC
- Secondary issues Grat ARP
- Switch DB is updated (at L2), all hosts see Grat ARP but their ARP-Cache 
is unchanged

In the first example, the burden is on the host to make sure they reference 
the VRRP IP via the proper MAC address.  In the second (and VRRP Standard), 
the burden is on the switches to reflect the new location of the virtual 
MAC.  The latter is of course preferred.  In a Data Center environment 
where you potentially can have dozens of hosts using the same default 
router (or hundreds in the case of RFC 3069) it quickly becomes clear why 
the current implementation of VRRP makes sense.  i.e. it is significantly 
quicker and more reliable for a couple of switches to update the new 
location of a host/port (i.e. vMAC) in the switch MAC tables than it is for 
hundreds of hosts to update their ARP-Cache tables.

Casey

At 10:49 AM 4/5/2001, Fernandes, Flavio wrote:

>Another way of "looking" at what VRRP tries to address via Virtual Macs:
>
>As VRRP was defined, a concern existed (and still exists) in moving IP
>address
>ownership around.
>
>That is so because management stations normally use IPs as indexes for
>tables in
>their monitoring scheme. It is a bad trouble to have stations confused about
>"who" the
>IP owner really is for the purposes of walking SNMP tables, ping, telnet,
>etc...
>
>Thus, moving the ownership of Mac addresses was the solution found (virtual
>Macs to be
>more exact. :)).
>
>-- flavio
>
>
>-----Original Message-----
>From: Vikram [mailto:[email-masked]]
>Sent: Thursday, April 05, 2001 10:19 AM
>To: Badri Srinivasan S; VRRP
>Subject: Re: Why Virtual MACs....?
>
>
>The moot purpose of the virtual mac is to allow the learning bridges to
>know which lan segment the virtual router is in other than letting the
>failover to be transparent(and fast) to endhosts.
>
>If I missed anything please fill me in.
>
>tks,
>
>vikram
>
>--- Badri Srinivasan S <[email-masked]> wrote:
> > Hi:
> >
> > another doubt down the line...
> >
> > 1. Why is it necessary that the source MAC addr of the VRRP
> > Advertisements
> > must me set to the Virtual MAC addr...i really dont understand the
> > real
> > purpose of virtual MACs...
> >
> > Can we solve the prob without using vMACs but only virtual IPs in the
> > following way..
> >
> > -->Whenever a VRRP router becomes a master, add the virtual IP
> > address
> > to the master's ethernet by doing a IP aliasing..
> > -->Then let the Master do a gratutious ARP for the virtual IP addr
> > ----
> > real MAC combination so that the hosts update their ARP cache with
> > this.
> >
> > -->so when the host wants to send a pckt to the virtual IP, its wiil
> > look into its ARP cache & get the real MAC of the Master..
> > or else , it can make  an ARP req  for the Virtual IP addr , and the
> > Master replies with its real MAC addr & not any vMAC..
> >
> > so the pckts ultimately reach the Master...
> > When the Master goes to the backup state it removes the virtual IP
> > alias..
> > The new Master performs the same steps whenit starts just as above..
> > i.e --> Do an IP alias for the virtual IP
> >     --> do a gratutious ARP with virtual IP --- the new Masters real
> > MAC...
> >
> >
> > if it can be implemented like this , what is the purpose of Virtual
> > MAC..
> >
> > please reply..
> >
> > thanks & Regards,
> > Badri
> >
>
>
>=====
>----
>NO sense being pessimistic. It wouldnt work anyway
>
>__________________________________________________
>Do You Yahoo!?
>Get email at your own domain with Yahoo! Mail.
>http://personal.mail.yahoo.com/

---

From: Jerome Etienne <[email-masked]>
Date: Tue, 15 May 2001 14:30:42 -0400

On Tue, May 15, 2001 at 11:20:25AM -0700, Casey S. Ajalat wrote:
> request. 

i would be very interested to know which OS do it and would very gratefull
to anybody who provide this information.

---

From: Jerome Etienne <[email-masked]>
Date: Tue, 15 May 2001 14:30:42 -0400