Subject: RE: [VRRP] Subsecond Timers for VRRPv3

From: [email-masked]
Date: Mon, 18 Aug 2003 19:33:28 -0500

Hi Sonum,

Would you please specify the reasoning behind your favor of 
1/10 second ?

Folks,

We have just received 2 mail with the preferences; one 
with 1/10 and the other with 1/1000. It will be hard to make 
the decision without knowing preferences from enough people.

Please respond with your choice and the reason behind that.

regards
Mukesh

> -----Original Message-----
> From: ext Mathur Sonum-CSM109 [mailto:[email-masked]]
> Sent: Friday, August 15, 2003 1:11 PM
> To: Gupta Mukesh (IPRG/MtView); [email-masked]
> Subject: RE: [VRRP] Subsecond Timers for VRRPv3
> 
> 
> 
> We are in favor of 1/10 second. It is definitely a good idea 
> to include this in the new version of VRRP for IPv4 and get 
> it standardised. One suggestion to do this is to use one of 
> the unused bits in the packet. The bit setting can indicate 
> that the units in Advert Int are in seconds or in 1/10th of second. 
> 
> --
> Sonum
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Friday, August 15, 2003 10:43 AM
> > To: [email-masked]
> > Subject: [VRRP] Subsecond Timers for VRRPv3
> > 
> > 
> > Folks,
> > 
> > In the WG meeting in Vienna, we all agreed that the 
> > sub-second timers should be allowed at least in VRRPv3 
> > but we couldn't agree about the granularity of the 
> > advertizing interval for allowing them.
> > 
> > There were concerns that if we allow the advertizing
> > intervals in miliseconds, it will allow the user to
> > bombard the LAN with VRRP packets which is dangerous.
> > 
> > Advertizing intervals in the units of 1/10 seconds
> > or 1/100 seconds seemed like good choices.
> > 
> > We would like to know what is everyone's opinion 
> > about this. Please reply with your preference.
> > 
> > 1) 1/10 second
> > 2) 1/100 second
> > 3) 1/1000 second (miliseconds)
> > 
> > regards
> > Mukesh
> > 
> > _______________________________________________
> > vrrp mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/vrrp
> > 
> 

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: "Don Provan" <[email-masked]>
Date: Mon, 18 Aug 2003 17:49:32 -0700

I haven't heard that the interval field is expanding, and it
sounds as if we're avoid making the unit variable. In that case,
1/1000 seems wrong because the max interval is now 1/4 of a
second. And 1/100 doesn't seem that much better, capping at 2.55
seconds. So that would lead me to 1/10, but is this small enough
to satisfy the requirement? I know the goal is faster failovers,
but I don't recall if a minimum target was set.
-don

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: Monday, August 18, 2003 5:33 PM
> To: [email-masked]; [email-masked]