Subject: [VRRP] Subsecond Timers for VRRPv3

From: [email-masked]
Date: Fri, 15 Aug 2003 12:42:39 -0500

Folks,

In the WG meeting in Vienna, we all agreed that the 
sub-second timers should be allowed at least in VRRPv3 
but we couldn't agree about the granularity of the 
advertizing interval for allowing them.

There were concerns that if we allow the advertizing
intervals in miliseconds, it will allow the user to
bombard the LAN with VRRP packets which is dangerous.

Advertizing intervals in the units of 1/10 seconds
or 1/100 seconds seemed like good choices.

We would like to know what is everyone's opinion 
about this. Please reply with your preference.

1) 1/10 second
2) 1/100 second
3) 1/1000 second (miliseconds)

regards
Mukesh

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: Ben Black <[email-masked]>
Date: Fri, 15 Aug 2003 11:30:47 -0700

It would be especially short-sighted to use coarse-grained timers.  I
don't see a problem with millisecond resolution.

Also, keeping people from doing something stupid, like setting the timers
to 1ms on a 10Mb/s LAN, would seem like an implementation decision, not the
sort of thing that should be built into the protocol.

Ben

---

From: danny mitzel <[email-masked]>
Date: Fri, 15 Aug 2003 12:58:53 -0700 (PDT)

> sub-second timers should be allowed at least in

since I missed the working group meeting and
didn't see explicit justification for this decision
in the meeting minutes I'm wondering if someone
could summarize the justification for this feature?

I don't have the paper right here in front of
me, but the original vrrpv2 design incorporated
findings from the higginson&shand DEC TR referenced
in the RFC.  a simple picture showing 
a generalized internetwork, illustrating where
failures could occur in end-to-end connectivity,
and then expected recovery interval for typical
IETF standardized protocols.  basically illustrated
that protocol recovery on the order of seconds
was inline with Internet standards.

have these findings changed?  is there a movement
toward end-to-end connectivity containing only
vrrp ``routing'' and L2 with transparent, sub-second
recovery?

later,danny

__________________________________
Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software
http://sitebuilder.yahoo.com