Subject: RE: [VRRP] Subsecond Timers for VRRPv3

From: [email-masked]
Date: Tue, 19 Aug 2003 08:19:34 +0300

Telecom operators are used to 50ms (SDH, Sonet) failover time.
MPLS is promising 50ms.
There is work going on in OSPF and IS-IS to reach "millisecond convergence"

From application side :  SS7 signaling doesn't behave well if there is over 700ms cut.

So 100ms granularity is too big.
Probably 10ms granularity would be OK. 

br esa

> -----Original Message-----
> From: ext Mathur Sonum-CSM109 [mailto:[email-masked]]
> Sent: 19 August, 2003 05:07
> To: Gupta Mukesh (IPRG/MtView); [email-masked]
> Subject: RE: [VRRP] Subsecond Timers for VRRPv3
> 
> 
> 
> We had a requirement to get failover time in the order of 
> hundreds of milli seconds. But to keep the system 
> interoperable with existing implementations, the check for 
> milliseconds granularity is ignored in our implementation 
> right now. If the router is configured for Advt Interval of 
> 100 msecs, it would send value = 0 in the 1 byte Advt 
> Interval field of the packet. This will be same for 
> configured value of 100 to 900 msecs. 
> 
> If we have this requirement of minimum failover time in some 
> milliseconds, then we need to either expand the field or use 
> some of the unused bits in the packet. That leads to this 
> question - what is the minimum failover time that we want to 
> set in the standards ? We are ok with 100 msecs.
> 
> --
> Sonum
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Monday, August 18, 2003 5:33 PM
> > To: Sonum Mathur; [email-masked]
> > Subject: RE: [VRRP] Subsecond Timers for VRRPv3
> > 
> > 
> > Hi Sonum,
> > 
> > Would you please specify the reasoning behind your favor of 
> > 1/10 second ?
> > 
> > Folks,
> > 
> > We have just received 2 mail with the preferences; one 
> > with 1/10 and the other with 1/1000. It will be hard to make 
> > the decision without knowing preferences from enough people.
> > 
> > Please respond with your choice and the reason behind that.
> > 
> > regards
> > Mukesh
> > 
> > > -----Original Message-----
> > > From: ext Mathur Sonum-CSM109 [mailto:[email-masked]]
> > > Sent: Friday, August 15, 2003 1:11 PM
> > > To: Gupta Mukesh (IPRG/MtView); [email-masked]
> > > Subject: RE: [VRRP] Subsecond Timers for VRRPv3
> > > 
> > > 
> > > 
> > > We are in favor of 1/10 second. It is definitely a good idea 
> > > to include this in the new version of VRRP for IPv4 and get 
> > > it standardised. One suggestion to do this is to use one of 
> > > the unused bits in the packet. The bit setting can indicate 
> > > that the units in Advert Int are in seconds or in 1/10th 
> of second. 
> > > 
> > > --
> > > Sonum
> > > 
> > > > -----Original Message-----
> > > > From: [email-masked] [mailto:[email-masked]]
> > > > Sent: Friday, August 15, 2003 10:43 AM
> > > > To: [email-masked]
> > > > Subject: [VRRP] Subsecond Timers for VRRPv3
> > > > 
> > > > 
> > > > Folks,
> > > > 
> > > > In the WG meeting in Vienna, we all agreed that the 
> > > > sub-second timers should be allowed at least in VRRPv3 
> > > > but we couldn't agree about the granularity of the 
> > > > advertizing interval for allowing them.
> > > > 
> > > > There were concerns that if we allow the advertizing
> > > > intervals in miliseconds, it will allow the user to
> > > > bombard the LAN with VRRP packets which is dangerous.
> > > > 
> > > > Advertizing intervals in the units of 1/10 seconds
> > > > or 1/100 seconds seemed like good choices.
> > > > 
> > > > We would like to know what is everyone's opinion 
> > > > about this. Please reply with your preference.
> > > > 
> > > > 1) 1/10 second
> > > > 2) 1/100 second
> > > > 3) 1/1000 second (miliseconds)
> > > > 
> > > > regards
> > > > Mukesh
> > > > 
> > > > _______________________________________________
> > > > vrrp mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/vrrp
> > > > 
> > > 
> > 
> 
> _______________________________________________
> vrrp mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/vrrp
> 

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: Ben Black <[email-masked]>
Date: Mon, 18 Aug 2003 22:17:27 -0700

Good points, but why is everyone suggesting engineering to exactly the
current requirements instead of leaving room for future enhancements?

I say again that the resolution should be millisecond (if not smaller),
and any restrictions on that should be in implementations, not in the
specification.

Ben