Subject: [VRRP] VRRP MIB(s) - some questions and request for comments

From: [email-masked]
Date: Mon, 18 Aug 2003 20:30:25 -0700

HI,

We published a draft "draft-ietf-vrrp-ipv6-mib-00.txt " that defines managed object for VRRPv3 
defined in " draft-ietf-vrrp-ipv6-spec-05.txt". 

There were some question at the WG meeting about the rational behind 
two different MIBs, one for VRRP for IPv4 and another for VRRP for IPv6.

The following "were" the reasons for defining two separate MIBs.

The main Reason:
-VRRP protocol is inherently IP version specific. Though the protocol
seems similar in certain aspects, VRRP for IPv6 is different from VRRP
for IPv4 and hence require two different MIBs.

Other reasons:
- We already have a working VRRP IPv4 protocol and a corresponding MIB
definition that is being used by industry.
- It is not necessary to update the VRRP for IPv4 MIB (RFC 2787) 
to make it IPv6 address aware - according to RFC3291:
====
MIB modules which define management information that is 
specific to particular IP version (either IPv4 or IPv6)
and which is very unlikely to ever be applicable to 
another IP version do not need to be redefined.
====
 
This being said, we would like to know the views of every one 
who understand both the protocols to express if it "makes sense" 
to have a single MIB definition.

- With the removal of authentication in VRRP for IPv4, both the 
protocols are much closer than before (from configuration/management/statistics point of view)

- Major difference being "associated IP address" in VRRPv2. 

- With the changes specified in "draft-ietf-vrrp-spec-v2-09.txt"
we will require to define a new MIB for VRRPv2 any way.

- The present MIB tables are indexed on "interface Index" and "VRID". I can 
see a way to introduce "Version" into the index to identify if the row 
corresponds to VRRPv2 or VRRPv3 (and hence if it is IPv4 or IPv6). This 
could be messy but we can come up with a way to define one MIB.

- Putting on a network administrator hat, would you expect statistics 
(for example Invalid vrID packets received) in one table for both the protocols? 
Or 
one table with two entries - one for VRRPv2 and the other for VRRPv3? 
Or
Two separate tables each having statistics for one particular protocol version?

Please voice your opinion for and against having two different MIBs and the reason(s)
behind your opinion.

Based on your input, we will proceed with the changes to the existing draft.

thanks

Brian
Kripa
Kalyan.

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: Vikram Pendharkar <[email-masked]>
Date: Tue, 19 Aug 2003 14:14:48 -0400

>Please voice your opinion for and against having two different MIBs and the reason(s)
We think that keeping the tables separate would be a cleaner approach. 
The query would usually be for v4 or v6 but not both at the same time.

Regards,
Vikram

-- 
Vikram Pendharkar			
Ericsson IP Infrastructure