Subject: RE: [VRRP] Some comments on draft-ietf-vrrp-ipv6-spec-08.txt

From: "John Cruz \(johcruz\)" <[email-masked]>
Date: Wed, 9 May 2007 13:14:27 -0700

Hi Steve,

This is regarding issue 1:

Rather than not running DAD, would the following achieve
the same effect?

The VRRP master does not respond to ND neighbor solicitation
for VRRP protected addresses if the source address is the
unspecified address (::). With this, when the address owner is
back up after being down, it will send a ND-NS for duplicate
address detection process. The current master would not respond.
Therefore, the IPv6 address will get installed and VRRP will
start. This will then make the current master to move to
standy state.

Does this make sense?
John

> Issue 1:  
> We think that the draft should mention that one MUST NOT run DAD on
> interfaces where the VRRP protected IP address == interface 
> IP address.
> It may even make sense to say one MUST NOT run DAD on any 
> VRRP protected
> address.  In either case, the usual result for DAD on such 
> addresses is
> a DAD failure.    
> 

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: "Stephen Nadas \(RL/TNT\)" <[email-masked]>
Date: Thu, 10 May 2007 12:21:53 -0500

Seems like this means changing ND somewhat so I think I prefer a
different approach.  Or draft could mention, both as alternatives
(either don't run dad or modify ND as described).  I wasn't looking for
much here, perhaps just a note that mentions the issue.   

-Steve 

-----Original Message-----
From: John Cruz (johcruz) [mailto:[email-masked]] 
Sent: Wednesday, May 09, 2007 4:14 PM
To: Stephen Nadas (RL/TNT); [email-masked]
Cc: [email-masked]
Subject: RE: [VRRP] Some comments on draft-ietf-vrrp-ipv6-spec-08.txt 

Hi Steve,

Rather than not running DAD, would the following achieve the same
effect?

The VRRP master does not respond to ND neighbor solicitation for VRRP
protected addresses if the source address is the unspecified address
(::). With this, when the address owner is back up after being down, it
will send a ND-NS for duplicate address detection process. The current
master would not respond.
Therefore, the IPv6 address will get installed and VRRP will start. This
will then make the current master to move to standy state.

Does this make sense?
John

> interfaces where the VRRP protected IP address == interface IP 
> address.
> It may even make sense to say one MUST NOT run DAD on any VRRP 
> protected address.  In either case, the usual result for DAD on such 
> addresses is
> a DAD failure.    
>

---

From: "John Cruz \(johcruz\)" <[email-masked]>
Date: Thu, 10 May 2007 10:47:15 -0700

In that case, I'll add a note that indicates the problems one
could encouter when running DAD and the suggested workaround
is to disable DAD if VRRP protected address == interface IP
address.

John 

> From: Stephen Nadas (RL/TNT) [mailto:[email-masked]] 
> Sent: Thursday, May 10, 2007 10:22 AM
> To: John Cruz (johcruz); [email-masked]
> Cc: [email-masked]
> start. This