Subject: [VRRP] VRRPV3-MIB protocol error trap question

From: "tony vanderpeet" <[email-masked]>
Date: Tue, 04 Sep 2012 13:24:51 +1200

I am implementing the protocol error trap in the VRRPV3 MIB and have spotted a possible hole in the MIB. I wonder if this was picked up in discussions and a work-around devised? 

When an advertisement is received with an unrecognised VR ID, a protocol error trap is generated, with the object vrrpv3StatisticsProtoErrReason. This object has value vrIdError(4) in this case, but what should the index of the object be? In particular, what should the VR ID part of the index be? 

I am inclined to create a variable binding with a fake OID using the unrecognised VR ID, since this will actually convey the information required (which VR ID is invalid, and the address type and ifIndex). 

What, if any, discussion has taken place around this issue, and was there any conclusion reached? 

Thanks 
Tony 

Tony van der Peet
Software Architect
Allied Telesis Labs Limited
27 Nazareth Ave
Christchurch, NZ
Tel: +64-3-3399532 (DDI)
Mob: +64-27-2091860

---

From: "Kalyan (Srinivas)Tata" <[email-masked]>
Date: Wed, 5 Sep 2012 20:12:23 -0700

From: Kalyan (Srinivas)Tata
Sent: Wednesday, September 05, 2012 8:11 PM
To: 'tony vanderpeet'
Subject: RE: [VRRP] VRRPV3-MIB protocol error trap question

Hi Tony,

This was an editing error in which the  vrIdError was not removed from the vrrpV3StatisticsProtoErrReason when vrrpv3RouterVrIdErrors was added as a global counter.

(exactly for the reason you mentioned)

vrrpv3RouterVrIdErrors should be used for counting the number of vrid errors.
Thanks
Kalyan
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]> On Behalf Of tony vanderpeet
Sent: Monday, September 03, 2012 6:25 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [VRRP] VRRPV3-MIB protocol error trap question

Thanks

Tony

Tony van der Peet
Software Architect

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 17 Sep 2012 22:32:13 +0100

Hi,
Is there an Erratum that should be raised for this?
Thanks,
Adrian
 
From: [email-masked] [mailto:[email-masked]] On Behalf Of Kalyan
(Srinivas)Tata
Sent: 06 September 2012 04:12
To: [email-masked]
Subject: [VRRP] FW: VRRPV3-MIB protocol error trap question

 
Hi Tony,
This was an editing error in which the  vrIdError was not removed from the
vrrpV3StatisticsProtoErrReason when vrrpv3RouterVrIdErrors was added as a global
counter.
(exactly for the reason you mentioned)
vrrpv3RouterVrIdErrors should be used for counting the number of vrid errors. 
Thanks
Kalyan
From: [email-masked] [mailto:[email-masked]] On Behalf Of tony
vanderpeet
Sent: Monday, September 03, 2012 6:25 PM
To: [email-masked]
Subject: [VRRP] VRRPV3-MIB protocol error trap question
 
I am implementing the protocol error trap in the VRRPV3 MIB and have spotted a
possible hole in the MIB. I wonder if this was picked up in discussions and a
work-around devised? 
 
When an advertisement is received with an unrecognised VR ID, a protocol error
trap is generated, with the object vrrpv3StatisticsProtoErrReason. This object
has value vrIdError(4) in this case, but what should the index of the object be?
In particular, what should the VR ID part of the index be? 
 
I am inclined to create a variable binding with a fake OID using the
unrecognised VR ID, since this will actually convey the information required
(which VR ID is invalid, and the address type and ifIndex). 
 
What, if any, discussion has taken place around this issue, and was there any
conclusion reached? 
 
Thanks 
Tony 

Tony van der Peet
Software Architect

---

From: "Kalyan (Srinivas)Tata" <[email-masked]>
Date: Mon, 24 Sep 2012 16:28:48 -0700

Hi Adrian,
               I replied to that email too fast without reviewing the history. Please disregard my reply.  Creating the OID with the invalid VRID received and setting the vrrpv3StatisticsProtoErrReason to vrIdError(4) would be the correct behavior.
Thanks
Kalyan
From: Adrian Farrel [mailto:[email-masked]]
Sent: Monday, September 17, 2012 2:32 PM
To: Kalyan (Srinivas)Tata; [email-masked]
Subject: RE: [VRRP] FW: VRRPV3-MIB protocol error trap question

Hi,

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]> On Behalf Of Kalyan (Srinivas)Tata
Sent: 06 September 2012 04:12
To: [email-masked]<mailto:[email-masked]>
Subject: [VRRP] FW: VRRPV3-MIB protocol error trap question

Hi Tony,

Thanks

Tony

Tony van der Peet
Software Architect