Subject: [weirds] Internationalized Registration Data

From: Dave Piscitello <[email-masked]>
Date: Tue, 4 Oct 2011 14:37:30 -0700

As providing support for internationalized registration data is one of the design objectives for WEIRDS, you may find it useful to read - and comment - on the following:

Draft Final Report of the Internationalized Registration Data Working Group
http://www.icann.org/en/announcements/announcement-3-03oct11-en.htm

ICANN is seeking public comments on the draft Final Report [PDF, 437 KB] of the joint SSAC-GNSO Working Group on Internationalized Registration Data (IRD-WG). This draft Final Report studies the feasibility and suitability of introducing display specifications to deal with the internationalization of registration data and finds that it is feasible to introduce submission and display specifications to deal with Internationalized Domain Name Registration Data and recommends a series of next steps that could be undertaken to address further the technical and policy issues identified in this report.

---

From: Alessandro Vesely <[email-masked]>
Date: Wed, 05 Oct 2011 14:01:55 +0200

On 04/Oct/11 23:37, Dave Piscitello wrote:
> As providing support for internationalized registration data is one of
> the design objectives for WEIRDS, you may find it useful to read - and
> comment - on the following:
> 
> Draft Final Report of the IRD-WG
> <http://gnso.icann.org/issues/ird/ird-draft-final-report-03oct11-en.pdf>

The four models illustrated at the end are interesting.  However, the
concept of a "must be present" representation is ill-defined.  Since
registration data ought to have legal standing, the "must" should be
for the local representation.  (Note that multilingual communities may
support multiple scripts.)

I'd suggest a "may be present" approach, permitting ASCII to the
extent allowed by local regulations and policies, and providing
transliteration/translation of specific terms (e.g. as parenthesized
comments, the other way than figure 1) to the extent that registrant
and registrar are willing to supply and check, respectively.

The existence of a comprehensible contact is a clear indication that
it may make sense to try and get hold of the person.  For email
addresses in particular, an RFC 2142 role name apparently implies
accepting English.  Otherwise, contacts would need to be cluttered
with Accept-Language tags.