Subject: [weirds] RESTful presentation to APWG

From: Dave Piscitello <[email-masked]>
Date: Fri, 11 Nov 2011 12:25:14 -0800

All hello,

I want to report that my presentation to the Antiphishing Working Group on the RESTful work (largely based on the USENIX ;login article) was very positively received, as in several people asked about the timeframe when they can expect to begin to use it. The general feeling expressed was that structured data is welcomed, and data tagged indicating language/character set is an attractive way forward.

I had some hallway discussions about ways to share some development effort to do implement/demonstrate some additional features beyond the initial prototyping and deployment.  

I've sent APWG members the WEIRDS mailing list information (info page, archives). Hopefully we will see some new participation.

---

From: Arturo Servin <[email-masked]>
Date: Sat, 12 Nov 2011 17:49:04 +0900

Hi,

	We have a prototype working but it is in a development environment behind our intranet.

	I will try to have it ready for public access before the BoF in Taipei.

Regards,
/as

On 12 Nov 2011, at 05:25, Dave Piscitello wrote:

> _______________________________________________
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds

---

From: Andy Newton <[email-masked]>
Date: Sat, 12 Nov 2011 05:31:33 -0500

Arturo,

Most excellent news. Is there a draft describing the data format, for the curious?

-andy

---

From: Arturo Servin <[email-masked]>
Date: Sat, 12 Nov 2011 23:27:49 +0800

Not yet.

	The first step is just to mimic the output of the whois, so it is kinda plain text. We have some ideas that I would like to discuss during the week.

Regards,
.as

---

From: Dave Piscitello <[email-masked]>
Date: Sat, 12 Nov 2011 08:01:05 -0800

Yes, great news that you are experimenting. 

Steve Sheng, Francisco Arias and I are working with some folks on ICANN's SSAC to pull together an initial set of data objects from ICANN's registrar accreditation agreement (RAA), EPP, and ICANN's registrar escrow XML (currently http://www.icann.org/en/escrow/registrar-escrow-08nov01.htm#xmlformat). 

Optimistically, we could have a data model and xml schema in a month or so. Of course, it would be a straw man and subject to consideration by a broader ICANN community.  Adoption of the schema is a policy matter for gTLDs and ccTLDs would decide amongst themselves or individually to adopt it. Clearly the optimal situation is for all TLDs and registrars to employ a common schema.

---

From: Arturo Servin <[email-masked]>
Date: Sun, 13 Nov 2011 09:46:26 +0800

Dave,

	Thank you for the link, very interesting. I can see some intersections (and differences) between the domain and the number world of whois.

	For the organization, are you considering a subset of vcard (RFC6350)?

	I think this is also a question for others considering using whois rest services as producers and consumers of information.

Regards,
.as