Subject: Re: [weirds] New Version Notification for draft-sheng-weirds-icann-rws-dnrd-01.txt

From: Carlos Martinez-Cagnazzo <[email-masked]>
Date: Wed, 21 Mar 2012 16:03:03 -0300

:=)

--
Carlos Martinez-Cagnazzo
R+D Engineer
http://www.labs.lacnic.net

On 3/21/12 4:01 PM, Andy Newton wrote:
> On Mar 21, 2012, at 12:54 PM, Carlos Martinez-Cagnazzo wrote:
>
>> then we can discuss data formats over
>> large quantities of beer
> Are you buying? Because, my friend, you haven't enough money if this thread is any indication of how that discussion will go.
>
> -andy

---

From: Darío Gómez <[email-masked]>
Date: Tue, 10 Apr 2012 14:43:43 -0300

Dear colleagues,

My name is Dario Gomez, I'm the rest whois developer on LACNIC.
I working on the propose modifications in

http://tools.ietf.org/html/draft-sheng-weirds-icann-rws-dnrd-01

and could notate than never talk about the Autonomous systems numbers topic.
I take the opportunity to propose a solution for ASNs:

3.6. Hosts

Queries for information about autonomuos systems (or nameservers) are of
the form /autnum/XXX/... where the path segment following ’autnum’ is a
autonomuos system number [RFC5396].

Here are some example queries:

base URL: http://whois.tld/somepath

/autnum/28000/ - queries for autonomuos system for number 28000.

4.1. Autonomuos Systems

Example Query: http://whois.test/autnum/1234/

Response:

<?xml version="1.0" encoding="UTF-8"?>
<rws xmlns="urn:ietf:params:xml:ns:rws-1.0">
<result>
<autnum:object
xmlns:domain="urn:ietf:params:xml:ns:rwsAutonomousSystem-1.0"
href="/autnum/1234">
<autnum:number>1234</autnum:number>
<autnum:contact type="admin" href="/contact/AIL">
AIL
</autnum:contact>
<autnum:contact type="tech" href="/contact/AIL">
AIL
</autnum:contact>
<autnum:contact type="abuse" href="/contact/ABL2">
ABL2
</autnum:contact>
<autnum:registrar href="/registrar/UY-LACN-LACNIC">
UY-LACN-LACNIC
</autnum:registrar>
<autnum:crDate>2005-01-05T09:10:56Z</autnum:crDate>
<autnum:chDate>2008-03-26T10:11:18Z</autnum:chDate>
</autnum:object>
</result>
<additional>
<contact:object xmlns:contact="urn:ietf:params:xml:ns:rwsContact-1.0"
href="/contact/AIL">
<contact:id>AIL</contact:id>
<contact:postalInfo type="int">
<contact:name>Arturo Servin</contact:name>
<contact:org>LACNIC - Latin American and Caribbean IP address</contact:org>
<contact:addr>
<contact:street>Rambla Rep. Mexico</contact:street>
<contact:street>6125</contact:street>
<contact:city>Montevideo</contact:city>
<contact:sp>MVD</contact:sp>
<contact:pc>11600</contact:pc>
<contact:cc>UY</contact:cc>
</contact:addr>
</contact:postalInfo>
<contact:voice x="1234">+59826042222</contact:voice>
<contact:fax>+59826042222</contact:fax>
<contact:email>[email-masked]</contact:email>
<contact:registrar href="/registrar/UY-LACN-LACNIC">
UY-LACN-LACNIC
</contact:registrar>
<contact:crDate>2008-01-25T22:00:00.0Z</contact:crDate>
<contact:upDate>2011-05-12T09:00:00.0Z</contact:upDate>
</contact:object>
<registrar:object
xmlns:registrar="urn:ietf:params:xml:ns:rwsRegistrar-1.0"
href="/registrar/UY-LACN-LACNIC">
<registrar:id>UY-LACN-LACNIC</registrar:id>
<registrar:name>LACNIC - Latin American and Caribbean IP
address</registrar:name>
</registrar:object>
</additional>
</rws>

Kind regards,
Darío

El 21/03/12 19:42, Smith, Bill escribió:
> +1
>
>
>
> On Mar 21, 2012, at 3:35 PM, "Murray S. Kucherawy" <[email-masked]> wrote:
>
>>> -----Original Message-----
>>> From: [email-masked] [mailto:[email-masked]] On Behalf Of Andy Newton
>>> Sent: Wednesday, March 21, 2012 12:02 PM
>>> To: <[email-masked]>
>>> Cc: <[email-masked]>
>>> Subject: Re: [weirds] New Version Notification for draft-sheng-weirds-icann-rws-dnrd-01.txt
>>>
>>> Are you buying? Because, my friend, you haven't enough money if this
>>> thread is any indication of how that discussion will go.
>> We're certainly earning our name.  :-)
>> _______________________________________________
>> weirds mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/weirds
> _______________________________________________
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds

-- 

Darío Gómez
Departamento de Ingeniería
LACNIC
Tel.: +598 26042222 Int. 4405
Fax: +598 26042222 ext. 4112
Rambla Rep. de México 6125 - C.P. 11400
Montevideo, Uruguay
www.lacnic.net