Subject: [weirds] Requirements document and milestones (Was: Post-BoF charter)

From: Pete Resnick <[email-masked]>
Date: Sun, 8 Apr 2012 10:40:28 -0500

Now that we're settled in on the rest of the language in the charter, I 
have some questions regarding the work items. In particular:

> Milestones
>      Nov 2012	Draft WEIRDS requirements to the IESG for publication as
> 		an Informational RFC.
>
>      Jul 2013	Draft WEIRDS specifications for registry queries and responses
> 		to the IESG for publication on the Standards Track.
>    

Personally, I'm not a big fan of publishing requirements documents. A 
published requirements document is important if there will be ongoing 
post-WG efforts that will have to take it into account. But I do not 
foresee any efforts to standardize this technology taking place outside 
of the context of this WG, and in particular I don't see this document 
concentrating on the future: It's level-setting for the internal work of 
the WG. I think having a requirements list (perhaps in the form of an 
Internet-Draft) in which the WG can document their consensus on 
requirements is a fine thing, but I don't see it as an interesting 
deliverable.

Do others think a requirements document is necessary as a specific 
deliverable, or can it simply be a WG-internal work item?

The other thing that I noticed is that the second milestone is "Draft 
WEIRDS specifications". That sounds to me like "one or more documents", 
and they're all due at the same time. Can we come up with more granular 
deliverables at this time, or are we leaving that as a future exercise? 
I'm ambivalent on the point, and I don't think having them is 
*necessary* for me to put the charter on the IESG's agenda, but I do 
suspect I'm going to get the question during IESG review of the charter.

Thanks,

pr

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Incorporated - Direct phone: (858)651-4478, Fax: (858)651-1102

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 9 Apr 2012 04:58:33 +0000

I'd say there's no need to publish the requirements document alone.  It could be either used as a reference for WG work and ultimately discarded, or compressed and merged into the "main" technical document if there ends up being such a thing and we decide it's good to list our requirements as justification for the output.

I'd also suggest we use the three existing individual submission "weirds" documents as milestones replacing that generic one to which you're referring.  The dates for the query and RIR ones could both be November of this year, and the domains one in July, unless people feel that last one could resolve quicker.

-MSK

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 9 Apr 2012 11:42:39 +0000

From: [email-masked] [mailto:[email-masked]] On Behalf Of Pete Resnick
Sent: Sunday, April 08, 2012 11:40 AM
To: [email-masked]
Subject: [weirds] Requirements document and milestones (Was: Post-BoF charter)

Now that we're settled in on the rest of the language in the charter, I have some questions regarding the work items. In particular:

Milestones

              an Informational RFC.

[snip]

The other thing that I noticed is that the second milestone is "Draft WEIRDS specifications". That sounds to me like "one or more documents", and they're all due at the same time. Can we come up with more granular deliverables at this time, or are we leaving that as a future exercise? I'm ambivalent on the point, and I don't think having them is *necessary* for me to put the charter on the IESG's agenda, but I do suspect I'm going to get the question during IESG review of the charter.

Pete, a small group of us has been discussing one possible approach to meet the "Draft WEIRDS specifications" milestone. We think there's a need for multiple documents, including one document that addresses common needs (things like basic HTTP/TLS transport, HTTP response codes, and the like) for both names and numbers, another document for a names query specification, and two names documents for XML- and JSON-formatted names responses. RIR query and response documents would also be in the mix. Excluding the requirements, that's six documents.

Scott

---

From: Jim Galvin <[email-masked]>
Date: Mon, 09 Apr 2012 09:22:43 -0400

+1

-- On April 9, 2012 4:58:33 AM +0000 "Murray S. Kucherawy" 
<[email-masked]> wrote regarding Re: [weirds] Requirements document 
and milestones (Was:	Post-BoF	charter) --

>
>
> I’d say there’s no need to publish the requirements document
> alone.  It could be either used as a reference for WG work and
> ultimately discarded, or compressed and merged into the “main”
> technical document if there ends up being such a thing and we decide
> it’s good to list our requirements as justification for the output.
>
>
>
> I’d also suggest we use the three existing individual submission
> “weirds” documents as milestones replacing that generic one to
> which you’re referring.  The dates for the query and RIR ones could
> both be November of this year, and the domains one in July, unless
> people feel that last one could resolve quicker.
>
>
>
> -MSK

---

From: Ray Bellis <[email-masked]>
Date: Tue, 10 Apr 2012 08:36:29 +0000

On 9 Apr 2012, at 12:42, Hollenbeck, Scott wrote:

Pete, a small group of us has been discussing one possible approach to meet the “Draft WEIRDS specifications” milestone. We think there’s a need for multiple documents, including one document that addresses common needs (things like basic HTTP/TLS transport, HTTP response codes, and the like) for both names and numbers, another document for a names query specification, and two names documents for XML- and JSON-formatted names responses. RIR query and response documents would also be in the mix. Excluding the requirements, that’s six documents.

That sounds like a good plan - I've not been involved in that small group but it's exactly what I would have proposed.

Ray

---

From: Eric Brunner-Williams <[email-masked]>
Date: Tue, 10 Apr 2012 09:35:48 -0400

On 4/10/12 4:36 AM, Ray Bellis wrote:
>>
>> Pete, a small group of us has been discussing one possible approach
>> to meet the “Draft WEIRDS specifications” milestone. We think
>> there’s a need for multiple documents, including one document that
>> addresses common needs (things like basic HTTP/TLS transport, HTTP
>> response codes, and the like) for both names and numbers, another
>> document for a names query specification, and two names documents
>> for XML- and JSON-formatted names responses. RIR query and response
>> documents would also be in the mix. Excluding the requirements,
>> that’s six documents. 
> 
> That sounds like a good plan - I've not been involved in that small
> group but it's exactly what I would have proposed.

i agree with ray, with an additional document dealing with structural
variations and constraints on data redistribution.

-e

---

From: Ray Bellis <[email-masked]>
Date: Tue, 10 Apr 2012 16:01:54 +0000

> variations and constraints on data redistribution.

Please elaborate.  The latter sounds like a policy issue.

Ray

---

From: Pete Resnick <[email-masked]>
Date: Wed, 11 Apr 2012 20:06:41 -0500

Can I ask whoever was last holding the pen on the charter to write up 
some milestones based on either Scott's (or Murray's more compact) 
suggestions? (I'm fine with either; up to you all.) I'll then get the 
charter on the IESG agenda for two weeks from now.

pr

On 4/10/12 3:36 AM, Ray Bellis wrote:

>> to meet the "Draft WEIRDS specifications" milestone. We think there's 
>> a need for multiple documents, including one document that addresses 
>> common needs (things like basic HTTP/TLS transport, HTTP response 
>> codes, and the like) for both names and numbers, another document for 
>> a names query specification, and two names documents for XML- and 
>> JSON-formatted names responses. RIR query and response documents 
>> would also be in the mix. Excluding the requirements, that's six 
>> documents.
>

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 12 Apr 2012 19:06:52 +0000

Pete,

Attached.

I think the specific format(s) discussion can be left to the WG, so I've made the milestones slightly more generic than what Scott suggested.

Comments from the community, please.

-MSK

From: [email-masked] [mailto:[email-masked]] On Behalf Of Pete Resnick
Sent: Wednesday, April 11, 2012 6:07 PM
To: Ray Bellis
Cc: [email-masked]
Subject: Re: [weirds] Requirements document and milestones (Was: Post-BoF charter)

Can I ask whoever was last holding the pen on the charter to write up some milestones based on either Scott's (or Murray's more compact) suggestions? (I'm fine with either; up to you all.) I'll then get the charter on the IESG agenda for two weeks from now.

pr

Ray

--

Pete Resnick <http://www.qualcomm.com/~presnick/><http://www.qualcomm.com/~presnick/>

---

From: Ray Bellis <[email-masked]>
Date: Fri, 13 Apr 2012 10:02:24 +0000

On 12 Apr 2012, at 20:06, Murray S. Kucherawy wrote:

Pete,

Attached.

I think the specific format(s) discussion can be left to the WG, so I’ve made the milestones slightly more generic than what Scott suggested.

Wasn't the plan for separate response docs for XML and JSON ?

Ray

---

From: Andy Newton <[email-masked]>
Date: Fri, 13 Apr 2012 08:44:31 -0400

> Wasn't the plan for separate response docs for XML and JSON ?

And I think it still is. As has been explained to me in the past, a milestone may constitute more than one document by the time the WG is done trying to meet that milestone.

-andy

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Fri, 13 Apr 2012 15:05:51 +0000

> -----Original Message-----
> From: Andy Newton [mailto:[email-masked]]
> Sent: Friday, April 13, 2012 5:45 AM
> To: Ray Bellis
> Cc: Murray S. Kucherawy; [email-masked]
> Subject: Re: [weirds] Requirements document and milestones (Was: Post- BoF charter)
> 
> And I think it still is. As has been explained to me in the past, a
> milestone may constitute more than one document by the time the WG is
> done trying to meet that milestone.

Right.  We could go the other way and list both, and then possibly decide not to do one or the other.  But either way, both cases are covered.

If Pete prefers it, we could be explicit, but I don't think it's necessary.

-MSK

---

From: Ray Bellis <[email-masked]>
Date: Fri, 13 Apr 2012 16:55:43 +0000

> If Pete prefers it, we could be explicit, but I don't think it's necessary.

That's fair enough if the milestone says "a specification", or some similar generic word for a document.

But the text specifically says:

"Aug 2013	Draft specifying the format for responses to domain name
		registration data queries to the IESG for approval as a
		Proposed Standard."

The plain English reading of that is -one- draft.

Ray

---

From: Francisco Obispo <[email-masked]>
Date: Fri, 13 Apr 2012 10:05:31 -0700

In any case both documents should model the same data requirements.

Sent from my iPhone

On Apr 13, 2012, at 8:05 AM, "Murray S. Kucherawy" <[email-masked]> wrote:

> _______________________________________________
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds

---

From: Steve Sheng <[email-masked]>
Date: Mon, 16 Apr 2012 16:24:47 -0700

Hello Ray, Murray and all,

What do you think of this proposal:

Milestones

    Nov 2012  Draft specifying the common infrastructure document to the
         IESG for approval as a Proposed Standard.

   Feb 2013	Draft specifying the RESTful URL query format for RIRs to the
         IESG for approval as a Proposed Standard.

    Mar 2013	Draft specifying the format for responses to RIR queries
         to the IESG for approval as a Proposed Standard.

    Jul 2013	Draft specifying the RESTful URL query format for domain name
         registration data to the IESG for approval as a Proposed
         Standard.

    Aug 2013	Draft(s) specifying the format(s) for responses to domain name
         registration data queries to the IESG for approval as a
         Proposed Standard.

Changes: 

1. Added a milestone on a draft specifying the common infrastructure
document. 

Rationale: This will be one document that addresses common needs (things
like basic HTTP/TLS transport, HTTP response codes, signaling, and the
like) for both names and numbers.

2. Changed domain draft on data format to plural, giving the option of
specifying additional output formats.

3. Adjusted timelines accordingly.

Steve

-----Original Message-----
From: Ray Bellis <[email-masked]>
Date: Fri, 13 Apr 2012 09:55:43 -0700
To: "Murray S. Kucherawy" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [weirds] Requirements document and milestones (Was: Post-BoF
charter)

>> Right.  We could go the other way and list both, and then possibly
>>decide not to do one or the other.  But either way, both cases are
>>covered.
>>

---

From: Ray Bellis <[email-masked]>
Date: Tue, 17 Apr 2012 07:58:10 +0000

Works for me :)

Thx

Ray

Sent from my iPhone