Subject: [weirds] I-D Action: draft-ietf-weirds-using-http-02.txt

From: [email-masked]
Date: Mon, 25 Mar 2013 10:13:56 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Web Extensible Internet Registration Data Service Working Group of the IETF.

	Title           : Using the Registration Data Access Protocol (RDAP) with HTTP
	Author(s)       : Andrew Lee Newton
                          Byron J. Ellacott
                          Ning Kong
	Filename        : draft-ietf-weirds-using-http-02.txt
	Pages           : 11
	Date            : 2013-03-25

Abstract:
   This document describes the usage of the Registration Data Access
   Protocol (RDAP) using HTTP.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-weirds-using-http

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-weirds-using-http-02

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-weirds-using-http-02

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 25 Mar 2013 11:05:23 -0700

Does this resolve our outstanding issues?  Are we ready for WGLC on this
one?

-MSK, co-chairin'

On Mon, Mar 25, 2013 at 10:13 AM, <[email-masked]> wrote:

> _______________________________________________
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds
>

---

From: Andy Newton <[email-masked]>
Date: Mon, 25 Mar 2013 18:35:00 +0000

Murray,

Do you want the people who opened tickets in the issue tracker to confirm the closure of the issues by closing the tickets?

-andy

From: "Murray S. Kucherawy" <[email-masked]<mailto:[email-masked]>>
Date: Monday, March 25, 2013 2:05 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [weirds] I-D Action: draft-ietf-weirds-using-http-02.txt

Does this resolve our outstanding issues?  Are we ready for WGLC on this one?

-MSK, co-chairin'

On Mon, Mar 25, 2013 at 10:13 AM, <[email-masked]<mailto:[email-masked]>> wrote:

Abstract:

_______________________________________________
weirds mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/weirds

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 25 Mar 2013 12:04:45 -0700

That would be ideal.

On Mon, Mar 25, 2013 at 11:35 AM, Andy Newton <[email-masked]> wrote:

>  Murray,
>
>  Do you want the people who opened tickets in the issue tracker to
> confirm the closure of the issues by closing the tickets?
>
>  -andy
>
>   From: "Murray S. Kucherawy" <[email-masked]>
> To: "[email-masked]" <[email-masked]>

---

From: "John Levine" <[email-masked]>
Date: 25 Mar 2013 21:04:15 -0000

>issues by closing the tickets?

They would be me.

Ticket 4, about the content type, is fixed, so I'll close it.

Ticket 5, about rate limiting, is fixed, so I'll close it.

R's,
John

---

From: "John Levine" <[email-masked]>
Date: 25 Mar 2013 21:04:46 -0000

>Does this resolve our outstanding issues?  Are we ready for WGLC on this

Both of the tickets are closed and I see no issues in the other changes.

---

From: Ray Bellis <[email-masked]>
Date: Tue, 26 Mar 2013 13:10:05 +0000

> Does this resolve our outstanding issues?  Are we ready for WGLC on this one?

Should my general comment about CORS handling be addressed in this document ?

Ray

---

From: Andy Newton <[email-masked]>
Date: Tue, 26 Mar 2013 14:56:54 +0000

>Should my general comment about CORS handling be addressed in this

Can you open a ticket for this? That's the best way to ensure I don't miss
it.

In general, I think CORS should be RECOMMENDED.

-andy

---

From: Ray Bellis <[email-masked]>
Date: Tue, 26 Mar 2013 15:01:53 +0000

> Can you open a ticket for this? That's the best way to ensure I don't miss

OK, if I can remember how :)

> In general, I think CORS should be RECOMMENDED.

agreed - strictly speaking it's a policy decision for the registry, but if it's not mentioned they'll forget to think about it.

Ray

---

From: Jean-Philippe Dionne <[email-masked]>
Date: Tue, 26 Mar 2013 11:42:03 -0400

Hi,

I have a few more comments about the relation between this document and 
draft-ietf-weirds-json-response.

Section 6 "Extensibility" (and 7.1) reserves a namespace inside the json 
response.  I would move it to draft-ietf-weirds-json-response.

In section 7.1, the requested prefix is "lunarNic".  However, the 
examples in draft-ietf-weirds-json-response are "lunarNic_".  Given the 
variable name called "lunarNicName", is it under the "lunarNic" 
namespace or not?

Section 8.2 refers to [draft-ietf-weirds-json-response], it creates 
cross-references, which I don't think is necessary.

Regards
Jean-Philippe

On 03/25/2013 02:05 PM, Murray S. Kucherawy wrote:
> On Mon, Mar 25, 2013 at 10:13 AM, <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>
>       This draft is a work item of the Web Extensible Internet
>     Registration Data Service Working Group of the IETF.
>
>     [email-masked] <mailto:[email-masked]>

---

From: Andy Newton <[email-masked]>
Date: Tue, 26 Mar 2013 19:39:38 +0000

Jean-Philippe,

My responses in line:

>response.  I would move it to draft-ietf-weirds-json-response.

That namespace registry is used by both the response and query drafts. It
is not specific only to json_response, therefore having it in this
document is appropriate.

>variable name called "lunarNicName", is it under the "lunarNic"

The registration is for "lunarNic". The use in json-response is
"lunarNic_" as specified in Section 4.2 of json-response: "Insertion of
unspecified values into JSON responses SHOULD have names prefixed with a
short identifier followed by an underscore followed by a meaningful name."

Likewise for rdap-query: "Custom path segments can be created by prefixing
the segment with a
   unique identifier followed by an underscore character (0x5F)."

In the example above, the JSON name should be "lunarNic_name".

>cross-references, which I don't think is necessary.

I agree. That paragraph could be moved to json-response and the
cross-reference can be avoided.

-andy

---

From: Jean-Philippe Dionne <[email-masked]>
Date: Tue, 26 Mar 2013 16:09:59 -0400

Hi,

> is not specific only to json_response, therefore having it in this
I did not relalize that was the same namespace used in the query path 
segment.

> In the example above, the JSON name should be "lunarNic_name".
Sorry about that, I missed this one.

Thank you for the clarification
Jean-Philippe