Subject: [weirds] json schema for weirds model

From: Maarten Wullink <[email-masked]>
Date: Sun, 24 Mar 2013 19:48:34 +0000

I don't if this has been asked before but maybe it is good idea to use the json schema (described in http://tools.ietf.org/html/draft-zyp-json-schema-04) to describe the weirds data structures?

Cheers,

Maarten Wullink
r&d engineer SIDN.

---

From: Andrew Newton <[email-masked]>
Date: Sun, 24 Mar 2013 16:24:48 -0400

Actually, a good bit of the RDAP JSON response has already been described
via JSON Content Rules in Appendix B of draft-newton-json-content-rules (
http://tools.ietf.org/html/draft-newton-json-content-rules-01#appendix-B).

Non-normative schema in JSON Schema or JSON Content Rules might be useful
as a separate Informational document, but at this time doing either as
normative text is probably unwise. There is current debate in the IETF
regarding the utility of schema languages for JSON, and we shouldn't hold
up WEIRDS waiting for that debate to be resolved. And note that I'm saying
this and I'm an author of one of those proposals.

-andy

On Sun, Mar 24, 2013 at 3:48 PM, Maarten Wullink <[email-masked]>wrote:

> I don't if this has been asked before but maybe it is good idea to use the
> json schema (described in
> http://tools.ietf.org/html/draft-zyp-json-schema-04) to describe the
> weirds data structures?
>
> Cheers,
>
> Maarten Wullink
> r&d engineer SIDN.
> _______________________________________________
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds
>