Subject: Re: [weirds] review comments on draft-ietf-weirds-rdap-query

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 4 Mar 2013 15:58:01 +0000

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Andy Newton
> Sent: Tuesday, February 26, 2013 10:38 PM
> To: Marc Blanchet
> Cc: [email-masked]; [email-masked]
> Subject: Re: [weirds] review comments on draft-ietf-weirds-rdap-query
> 
> On 2/27/13 10:12 AM, "Marc Blanchet" <[email-masked]> wrote:
> 
> >minor comment. you may ignore it. one ref could be
> >wikipedia:http://en.wikipedia.org/wiki/Representational_state_transfer
> 
> Marc,
> 
> Let me think about this. We had a somewhat amusing discussion on this
> list over this very topic without much of a conclusion.

I don't like the idea of including a reference to a Wikipedia document that can changed by anyone, but don't mind adding text that explains the REST acronym and attempts to explain RESTful in generic terms.

Scott

---

From: Marc Blanchet <[email-masked]>
Date: Mon, 4 Mar 2013 11:04:11 -0500

> I don't like the idea of including a reference to a Wikipedia document that can changed by anyone, but don't mind adding text that explains the REST acronym and attempts to explain RESTful in gener…

My comment is minor. However, given that the whole document is based on the RESTful assumption, then it would be good to have something. You are right that wikipedia is a moving target.  Maybe Fielding thesis/paper? 

Since we are really using the RESTful approach in many of our protocols, it may be time for the apps area to write something about it and have it everybody referenced. I've been trying to find this with no luck yet.

Marc.

---

From: Steve Sheng <[email-masked]>
Date: Mon, 4 Mar 2013 08:12:27 -0800

-----Original Message-----
From: <Hollenbeck>, Scott <[email-masked]>
Date: Monday, March 4, 2013 7:58 AM
To: Andy Newton <[email-masked]>, Marc Blanchet <[email-masked]>
Cc: "[email-masked]" <[email-masked]>,
"[email-masked]"
<[email-masked]>
Subject: Re: [weirds] review comments on draft-ietf-weirds-rdap-query

>I don't like the idea of including a reference to a Wikipedia document
>that can changed by anyone, but don't mind adding text that explains the
>REST acronym and attempts to explain RESTful in generic terms.

How about this? 

[REST]     Fielding, R. and R. Taylor, "Principled Design of the Modern
Web Architecture", ACM Transactions on Internet Technology Vol. 2, No. 2,
May 2002.

This is the paper that Roy Fielding introduces the REST architectural
style. 

>
>Scott
>_______________________________________________
>weirds mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/weirds

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 4 Mar 2013 16:12:46 +0000

> From: Marc Blanchet [mailto:[email-masked]]
> Sent: Monday, March 04, 2013 11:04 AM
> To: Hollenbeck, Scott
> Cc: Andy Newton; [email-masked]; draft-ietf-weirds-rdap-
> [email-masked]
> > I don't like the idea of including a reference to a Wikipedia
> document that can changed by anyone, but don't mind adding text that
> explains the REST acronym and attempts to explain RESTful in generic
> terms.
> 
> My comment is minor. However, given that the whole document is based on
> the RESTful assumption, then it would be good to have something. You
> are right that wikipedia is a moving target.  Maybe Fielding
> thesis/paper?

That's exactly what I'm looking at right now...

Scott

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 4 Mar 2013 17:15:32 +0000

> Behalf Of Marc Blanchet
> Sent: Tuesday, February 26, 2013 9:13 PM
> To: Andy Newton
> Le 2013-02-26 à 01:23, Andy Newton <[email-masked]> a écrit :

[snip]

> >> <MB>If we are going to have multiple queries specified in multiple
> >> RFCs, we may better setup an IANA registry for > these, so they are
> >> all listed in the same place. Moreover, different from
> >> draft-ief-weirds-using-http, I think we > should not only register
> >> extensions, but all defined queries, therefore the ones in this
> >> document. And this document should be the creator of the registry.
> >> Here is a suggested
> >> contribution:
> >
> > The IANA registry specified in draft-ietf-weirds-using-http is used
> by
> > draft-ietf-weirds-rdap-query and draft-ietf-weirds-json-response.
> > Moving it to rdap-query doesn't really help that dependency.
> 
> I don't really care about which document creates the registry. I just
> found more natural to be in the one that defines the semantics.
> 
> >
> > While registering the IETF specified queries is doable,
> 
> I think we should.
> 
> > do we conversely
> > register the IETF specified JSON names? That would be a big
> registration.
> 
> good question. Let me think about it.

Have you reached any conclusions, Marc?

Scott

---

From: Marc Blanchet <[email-masked]>
Date: Mon, 4 Mar 2013 12:18:00 -0500

> Have you reached any conclusions, Marc?

sorry. have not taken the time. don't wait for me...

Marc.