Subject: [weirds] WEIRDS implementation demo

From: "Murray S. Kucherawy" <[email-masked]>
Date: Fri, 1 Mar 2013 10:21:37 -0800

The Secretariat has assigned us 8am-9am on Tuesday, March 12, in room Boca
1 for implementation demos.  We only have that one hour before other
sessions begin, so please come prepared!

-MSK

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Fri, 01 Mar 2013 16:30:09 -0200

Unless we write a detailed plan of what we are going to do, I don't
think it will be enough.

In any case, I think we can continue in the term room. Or in the hallways :D

regards

Carlos

On 3/1/13 4:21 PM, Murray S. Kucherawy wrote:
> The Secretariat has assigned us 8am-9am on Tuesday, March 12, in room
> Boca 1 for implementation demos.  We only have that one hour before
> other sessions begin, so please come prepared!
> 
> -MSK
> 
> 
> _______________________________________________
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds
>

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Fri, 1 Mar 2013 11:51:39 -0800

Do we have a lot of people planning to do demos?  Are the demos going to be
complicated?

I don't understand how an hour would not be enough, unless there's a large
number of implementations I haven't heard of yet.

Who's got something to show (or will by then), and how long do you need?

-MSK

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Fri, 01 Mar 2013 17:59:12 -0200

You're absolutely right. Depends on how many we are.

Starting the roll call: We'll be presenting our server implementation.

~C.

On 3/1/13 5:51 PM, Murray S. Kucherawy wrote:
> Do we have a lot of people planning to do demos?  Are the demos going to
> be complicated?
> 
> I don't understand how an hour would not be enough, unless there's a
> large number of implementations I haven't heard of yet.
> 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     > [email-masked] <mailto:[email-masked]>

---

From: Byron Ellacott <[email-masked]>
Date: Tue, 5 Mar 2013 05:29:22 +0000

Hi all,

APNIC's pilot server is now several revisions behind the drafts, but I'm
happy to volunteer (someone else from APNIC :-) to be there to show it
working in its current state.

http://rdap.apnic.net/ip/

  Byron

---

From: Ernie Dainow <[email-masked]>
Date: Tue, 5 Mar 2013 17:01:11 -0500

We would like to demo our Domain Name Registry test server. It returns live
data for all domains in .info. It implements the latest RDAP drafts
(excluding search).

I won't be in Orlando but Jim Galvin will be there to do this and answer
questions. Will there be any remote participation? Some other sessions have
WebEx or Meetecho scheduled.

-Ernie

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 7 Mar 2013 12:32:20 -0800

Change of location: Now in Caribbean 4.  Still on Tuesday morning at 8am.

-MSK, WEIRDS co-chair

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 7 Mar 2013 16:27:55 -0800

Colleagues,

I'm wondering about structure for the demos on Tuesday morning.  For
example, do we need to set up an agenda for the bake-off, or do people just
want to set up their demos in corners and let people wander among them,
try, and comment?

Should we appoint someone to report to the working group later that day, or
should that also be done organically?

On Thu, Mar 7, 2013 at 12:32 PM, Murray S. Kucherawy <[email-masked]>wrote:

>> Boca 1 for implementation demos.  We only have that one hour before other

---

From: "Carlos M. martinez" <[email-masked]>
Date: Thu, 07 Mar 2013 23:55:52 -0200

I think we should have a basic testing protocol in place.

On 3/7/13 10:27 PM, Murray S. Kucherawy wrote:
> example, do we need to set up an agenda for the bake-off, or do people
> just want to set up their demos in corners and let people wander among
> them, try, and comment?
> 
> Should we appoint someone to report to the working group later that day,
> or should that also be done organically?
> 
> 
> On Thu, Mar 7, 2013 at 12:32 PM, Murray S. Kucherawy
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     On Fri, Mar 1, 2013 at 10:21 AM, Murray S. Kucherawy
>     <[email-masked] <mailto:[email-masked]>> wrote:
> 
>         The Secretariat has assigned us 8am-9am on Tuesday, March 12, in
>         room Boca 1 for implementation demos.  We only have that one
>         hour before other sessions begin, so please come prepared!
> 
>         -MSK
> 
> 
> 
> 
>

---

From: Marc Blanchet <[email-masked]>
Date: Thu, 7 Mar 2013 18:00:57 -0800

- we have been preparing a test plan and test scripts. We will be able to do some testing on the different implementations during the tuesday session. My colleague Jean-Philippe could drive that testing and report results to the wg.

Regards, Marc.

---

From: "Carlos M. martinez" <[email-masked]>
Date: Fri, 08 Mar 2013 00:16:53 -0200

I'm willing to collaborate with him and others. I like the idea of
preparing a report to the WG.

cheers

~Carlos

---

From: Jean-Philippe Dionne <[email-masked]>
Date: Fri, 08 Mar 2013 11:02:30 -0500

Hi,

Could you share here pointers to your client or server implementations
prior to the demo?  It will help us to find some common ground for
testing.

I'd like to establish what resources servers make available to clients,
what can be queried and what cannot.

Up to now, my sources are the servers listed at rdap.org and the
'rdapper' client.

Thank you
Jean-Philippe

---

From: Arturo Servin <[email-masked]>
Date: Fri, 08 Mar 2013 14:23:11 -0200

Ours (it is already listed in rdap.org):

	http://restfulwhoisv2.labs.lacnic.net/restfulwhois/

examples

	http://restfulwhoisv2.labs.lacnic.net/restfulwhois/ip/200.7.84.0/23/

	http://restfulwhoisv2.labs.lacnic.net/restfulwhois/entity/UY-LACN-LACNIC/

	Any bugs, comments or complaints with Carlos or me. We both will be in
Orlando.

Regards,
as

---

From: Ernie Dainow <[email-masked]>
Date: Fri, 8 Mar 2013 17:00:28 -0500

You can get all the information for our server at
http://rdg.afilias.info/rdap/help

-Ernie

On Fri, Mar 8, 2013 at 11:02 AM, Jean-Philippe Dionne <
[email-masked]> wrote:

> > - we have been preparing a test plan and test scripts. We will be able
> to do some testing on the different implementations during the tuesday
> session. My colleague Jean-Philippe could drive that testing and report
> results to the wg.
> >
> > Regards, Marc.
> >

---

From: "Carlos M. Martinez (ML)" <[email-masked]>
Date: Fri, 8 Mar 2013 22:03:23 -0200

Sure. We have an online demo at http://restfulwhoisv2.labs.lacnic.net/restfulwhois you can look at.

However, I'll be running the server in a VM for testing.

regards

Carlos

---

From: Ning Kong <[email-masked]>
Date: Mon, 11 Mar 2013 19:04:57 -0400

Hi folks,

We just set up an online demo at http://rdap.restfulwhois.org.

Our server support:
	1)   5 types of query (IP, Domain, Entity, AS and Nameserver)
        2)   3 types of response (JSON, XML and our self-defined presentation format)
	3） Client authentication by RFC 2617 (only one authenticated user: admin/admin)

Our server don't support:
	1)   Authorization (no different between admin with anonymous user)
	2)   Logout

The following examples can be used as inputs for test.
1)   IP:
	1.0.0.0  
	1.0.0.0/8
	39.1.2.3 
	39.1.2.3/8
2)   Domain:
	baidu.cn
	qq.cn
	faha.cn 
3)   Entity
	APNIC
	bu1048055833141
	s1265874462073
4)   AS
	1223
	2569
	3661
	3662 
5)   Nameserver
	ns2.ee28.cn
	ns1.google.com

Any comments are appreciated! See you tomorrow morning.

Cheers,
Ning

> Do we have a lot of people planning to do demos?  Are the demos going to be complicated?
> 
> I don't understand how an hour would not be enough, unless there's a large number of implementations I haven't heard of yet.
> 
> On Fri, Mar 1, 2013 at 10:30 AM, Carlos M. Martinez <[email-masked]> wrote:

---

From: Francisco Obispo <[email-masked]>
Date: Mon, 11 Mar 2013 16:09:16 -0700

Hi Ning,

The XML output for  qq.cn doesn't seem to be a valid XML doc:

<handle>20030321s10001s00193214-cn</handle>
<name>qq.cn</name>
<status>clientTransferProhibited, </status>
<port43>whois.cnnic.cn</port43>
<registrationDate>2003-03-21 22:42:05</registrationDate>
<registrationBy>ABC</registrationBy>
<lastChangedDate></lastChangedDate>
<lastChangedBy></lastChangedBy>
<sponsoredBy>cnniccn115</sponsoredBy>
<expirationDate>2013-03-21 22:42:05</expirationDate>
<transferDate></transferDate>
<entities><handle>qq1048056475479</handle>
<entityNames>中国联合网络通信有限公司黑龙江省分公司, [email-masked], </entityNames>
<roles>registrant, </roles>
<emails>[email-masked], </emails>
<remarks>, </remarks>
<links><value>http://restfulwhois.org/entity/qq1048056475479</value>
<rel>self</rel>
<href>http://restfulwhois.org/entity/qq1048056475479</href>
</links>
<registrationDate></registrationDate>
<lastChangedDate></lastChangedDate>
<lastChangedBy></lastChangedBy>
</entities>

The JSON seems to be just fine.

> The following examples can be used as inputs for test.

Francisco Obispo 
Director of Applications and Services - ISC
email: [email-masked]
Phone: +1 650 423 1374 || INOC-DBA *3557* NOC
PGP KeyID = B38DB1BE

---

From: Byron Ellacott <[email-masked]>
Date: Mon, 11 Mar 2013 23:13:29 +0000

APNIC's pilot is online at http://rdap.apnic.net/ - the output does not conform to current spec; I believe it conformed to the last revision pre-WG adoption.  You can see the general gist of the mechanisms, however.  We are linked from rdap.org, too.

  Byron

From: Ning Kong <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, 12 March 2013 9:04 AM
To: "Murray S.Kucherawy" <[email-masked]<mailto:[email-masked]>>
Cc: Carlos Martinez <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [weirds] WEIRDS implementation demo

Hi folks,

Our server support:

The following examples can be used as inputs for test.
1)   IP:
1.0.0.0
1.0.0.0/8
39.1.2.3
39.1.2.3/8
2)   Domain:
baidu.cn<http://baidu.cn>
qq.cn<http://qq.cn>
faha.cn<http://faha.cn>
3)   Entity
APNIC
bu1048055833141
s1265874462073
4)   AS
1223
2569
3661
3662
5)   Nameserver
ns2.ee28.cn<http://ns2.ee28.cn>
ns1.google.com<http://ns1.google.com>

Cheers,
Ning

-MSK

On Fri, Mar 1, 2013 at 10:30 AM, Carlos M. Martinez <[email-masked]<mailto:[email-masked]>> wrote:
Unless we write a detailed plan of what we are going to do, I don't
think it will be enough.

regards

Carlos

On 3/1/13 4:21 PM, Murray S. Kucherawy wrote:
> [email-masked]<mailto:[email-masked]>

_______________________________________________
weirds mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/weirds

---

From: Jean-Philippe Dionne <[email-masked]>
Date: Mon, 11 Mar 2013 19:45:32 -0400

Hi,

I can see the json embedded inside the html response, but I cannot get
only json.  Do I need to specify an "Accept:" header to get it?

Thank you
Jean-Philippe

On 2013-03-11 19:04, Ning Kong wrote:
> baidu.cn <http://baidu.cn>
> qq.cn <http://qq.cn>
> faha.cn <http://faha.cn> 
> 3)   Entity
> APNIC
> bu1048055833141
> s1265874462073
> 4)   AS
> 1223
> 2569
> 3661
> 3662 
> 5)   Nameserver
> ns2.ee28.cn <http://ns2.ee28.cn>
> ns1.google.com <http://ns1.google.com>
> 
>>     room

---

From: Ning Kong <[email-masked]>
Date: Mon, 11 Mar 2013 23:35:04 -0400

Hi Francisco,

You're right. Thanks for your feedback. We'll fix it later.

Cheers,
Ning

---

From: Ning Kong <[email-masked]>
Date: Tue, 12 Mar 2013 00:11:04 -0400

Hi Jean-Philippe,

Thanks for your feedback.

The current response is only JSON objects embedded in the HTML response. The representation and xml presentation formats are just converted from JSON objects. 

Setting http header is not available now. We will modify this function soon.

Cheers,
Ning

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 12 Mar 2013 00:50:00 -0400

I didn't follow up on appointing someone to provide a brief report about
the demo session when the WG meets at 10:30am tomorrow.  Does someone want
to volunteer?

-MSK

On Tue, Mar 12, 2013 at 12:11 AM, Ning Kong <[email-masked]> wrote:

> The current response is only JSON objects embedded in the HTML response.
> The representation and xml presentation formats are just converted from
> JSON objects.
>

---

From: Jean-Philippe Dionne <[email-masked]>
Date: Tue, 12 Mar 2013 01:32:23 -0400

Hi,

I volunteer to present a report.

Jean-Philippe

On 2013-03-12 00:50, Murray S. Kucherawy wrote:
> the demo session when the WG meets at 10:30am tomorrow.  Does someone
> want to volunteer?
> 
> -MSK
> 
> 
> On Tue, Mar 12, 2013 at 12:11 AM, Ning Kong <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     Hi Jean-Philippe,
> 
>     The current response is only JSON objects embedded in the HTML
>     response. The representation and xml presentation formats are just
>     converted from JSON objects.
> 
>     >> 1.0.0.0/8 <http://1.0.0.0/8>
>     >> 39.1.2.3
>     >> 39.1.2.3/8 <http://39.1.2.3/8>
>     >> 2)   Domain:
>     >> baidu.cn <http://baidu.cn> <http://baidu.cn>
>     >> qq.cn <http://qq.cn> <http://qq.cn>
>     >> faha.cn <http://faha.cn> <http://faha.cn>
>     >> 3)   Entity
>     >> APNIC
>     >> bu1048055833141
>     >> s1265874462073
>     >> 4)   AS
>     >> 1223
>     >> 2569
>     >> 3661
>     >> 3662
>     >> 5)   Nameserver
>     >> ns2.ee28.cn <http://ns2.ee28.cn> <http://ns2.ee28.cn>
>     >> ns1.google.com <http://ns1.google.com> <http://ns1.google.com>
>     >>
>     >>> Do we have a lot of people planning to do demos?  Are the demos
>     going
>     >>> to be complicated?
>     >>>
>     >>> <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>     >>>
>     <mailto:[email-masked] <mailto:[email-masked]>>
>     >>> [email-masked] <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 12 Mar 2013 08:23:33 -0400

Apologies, Jean-Philppe.  I didn't see this until just now and took Andrew
volunteering in the meeting to give a short report.  Thank you for offering!

-MSK

On Tue, Mar 12, 2013 at 1:32 AM, Jean-Philippe Dionne <
[email-masked]> wrote:

> >     >>>    In any case, I think we can continue in the term room. Or in
> the
> >     >>>    hallways :D
> >     >>>
> >     >>>    regards
> >     >>>
> >     >>>    Carlos
> >     >>>