Subject: [weirds] jcard and entities

From: Pieter Vandepitte <[email-masked]>
Date: Wed, 03 Apr 2013 09:02:22 +0200

Hi,

does anybody know how an entity will look like with jcards? Or isn't
it decided yet that we will go on with jcards?

I think there are roughly 2 possibilities: either [1] we integrate RIR
and DNR specific attributes as VCARD extensions or [2] we integrate
jcard as a property of the entity. Are there other idea's?

[1] will look like

["vcard",
     [
       ["version", {}, "text", "4.0"],
       ["fn", {}, "text", "Simon Perreault"],
       ["n",
         {},
         "text",
         ["Perreault", "Simon", "", "", ["ing. jr", "M.Sc."]]
       ],

       ...

       ["x-weirds-handle", {}, "text", "XXXX"],
       ["x-weirds-port43", {}, "text", "whois.example.net"],

       ...

     ]
]

[2] will look like

       {
         "handle" : "XXXX",
         "vcard"  :
           ["vcard",
             [
               ["version", {}, "text", "4.0"],
               ["fn", {}, "text", "Simon Perreault"],
               ["n",
                 {},
                 "text",
                 ["Perreault", "Simon", "", "", ["ing. jr", "M.Sc."]]
               ],
               ...
             ]
           ]
         ],
         ...

         "port43" : "whois.example.net",

       }

I would prefer [1]
-- 
*Pieter Vandepitte*
*Software Engineer*
+32 16 29 89 27
*www.dnsbelgium.be* <http://www.dnsbelgium.be/>

---

From: Andy Newton <[email-masked]>
Date: Wed, 3 Apr 2013 09:43:07 +0000

>it decided yet that we will go on with jcards?

[..snip..]

>         "port43" : "whois.example.net",

This is the form proposed by Simon and being incorporated as we speak.
See http://www.ietf.org/mail-archive/web/weirds/current/msg02153.html

The reason for this is that RDAP has its own set of common data structures
that are uses by many object classes including the entity object class. If
we went with approach 1 then those structures would be different between
entities and all other object classes in RDAP.

I'm working on the new draft and it will be out as soon as possible.

-andy

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 03 Apr 2013 06:47:30 -0600

On 4/3/13 1:02 AM, Pieter Vandepitte wrote:
> Hi,
> 
> does anybody know how an entity will look like with jcards? Or
> isn't it decided yet that we will go on with jcards?

As a reminder, I sure hope that folks here (especially the document
editors and WG chairs) are paying attention to the work of the
JCARDCAL WG:

https://datatracker.ietf.org/wg/jcardcal/

The JCARDCAL WG is moving quite quickly, so if you have feedback
please provide it on the [email-masked] mailing list.

Thanks!

Peter (JCARDCAL WG co-chair)

- -- 
Peter Saint-Andre
https://stpeter.im/