Subject: [weirds] Nameserver ip version and usage of variants in domain object examples

From: Maarten Wullink <[email-masked]>
Date: Tue, 2 Apr 2013 08:34:52 +0200

Reading throught the response document
(http://tools.ietf.org/html/draft-ietf-weirds-json-response-02) i
noticed the following.

In section "8. The Nameserver Object Class"
The description of a nameserver includes a "ipAddresses" element with
an array of ip addresses. There is no attribute there for the ip
address with which one can determine if it is an v4 of v6 address.

The IP address description in section "10.  The IP Network Object Class"
does however have a "ipVersion" element which can have value 4 or 6.

Is it an option to change the nameserver object to also include the ip
version attribute like this?

 "ipAddresses" :
         [
           {"2001:db8::123", 6},
           {"192.0.2.1", 4}
         ],

Also
In Appendix "C.  IDN Query and Response Model"
The example given uses a notation of the "variants" element that does
not match the description of the element given in section 9.2.

Cheers,

Maarten

- -- 
Maarten Wullink MSc|Technical advisor / R&D engineer
SIDN | Meander 501 | 6825 MD | Postbus 5022 | 6802 EA | ARNHEM
T +31 (0)26 352 55 45 | M +31 (0)6 21 26 87 55 | F +31 (0)26 352 55 05
[email-masked] | www.sidn.nl

---

From: Francisco Obispo <[email-masked]>
Date: Mon, 1 Apr 2013 23:37:17 -0700

How about:

"ipAddresses":{
	"v4":["192.0.2.1"],
	"v6":["2001:db8::123"]
},

> version attribute like this?

Francisco Obispo 
Director of Applications and Services - ISC
email: [email-masked]
Phone: +1 650 423 1374 || INOC-DBA *3557* NOC
PGP KeyID = B38DB1BE

---

From: Maarten Wullink <[email-masked]>
Date: Tue, 2 Apr 2013 08:48:22 +0200

On 04/02/2013 08:37 AM, Francisco Obispo wrote:
> How about:
> 
> 
> "ipAddresses":{ "v4":["192.0.2.1"], "v6":["2001:db8::123"] },
> 

I have a slight preference for your solution, but the version
identifier should be kept consistent with the one used in section 10
(ip address object) and should be "4" or "6". (or change section 10)

>> Is it an option to change the nameserver object to also include
>> the ip version attribute like this?
>> 
>> "ipAddresses" : [ {"2001:db8::123", 6}, {"192.0.2.1", 4} ],
> 
> Francisco Obispo Director of Applications and Services - ISC email:
> [email-masked] Phone: +1 650 423 1374 || INOC-DBA *3557* NOC PGP
> KeyID = B38DB1BE
> 

- --

---

From: Andy Newton <[email-masked]>
Date: Tue, 2 Apr 2013 14:04:54 +0000

>(ip address object) and should be "4" or "6". (or change section 10)

I prefer Francisco's solution too. We can change the identifier for IP
address object classes to "v4" and "v6". I don't think that is a big deal.

-andy