Subject: [weirds] Fwd: I-D Action: draft-blanchet-weirds-bootstrap-ianaregistries-01.txt

From: Marc Blanchet <[email-masked]>
Date: Wed, 27 Nov 2013 15:42:14 -0500

Hello,
 please find an updated version of the bootstrap using IANA registries. I have discussed with IANA about the various registries, their implementation and deployment. The text in IANA Considerations hopefully reflect the discussion with IANA. However, the text is mine and has not been verified by IANA yet. 

Chairs, I would like to call for wg adoption of this document.

Good reading while cooking the turkey (for some of you...) ;-)

Marc.

Début du message réexpédié :

> De: [email-masked]
> Objet: I-D Action: draft-blanchet-weirds-bootstrap-ianaregistries-01.txt
> Date: 27 novembre 2013 15:35:17 HNE
> À: [email-masked]
> Répondre à: [email-masked]
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
> 	Title           : Finding the Authoritative Registration Data (RDAP) Service
> 	Author(s)       : Marc Blanchet
> 	Filename        : draft-blanchet-weirds-bootstrap-ianaregistries-01.txt
> 	Pages           : 7
> 	Date            : 2013-11-27
> 
> Abstract:
>   This document specifies a method to find which Registration Data
>   Access Protocol (RDAP) server is authoritative to answer queries for
>   a requested scope, such as domain names, IP addresses or Autonomous
>   System numbers, using data available in IANA registries.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-blanchet-weirds-bootstrap-ianaregistries
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-blanchet-weirds-bootstrap-ianaregistries-01
> 
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-blanchet-weirds-bootstrap-ianaregistries-01
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Andy Newton <[email-masked]>
Date: Wed, 27 Nov 2013 21:47:42 +0000

From: Marc Blanchet <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, November 27, 2013 3:42 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [weirds] Fwd: I-D Action: draft-blanchet-weirds-bootstrap-ianaregistries-01.txt

I support this, as it puts a stake in the ground for the endless bootstrapping threads.

-andy

---

From: Arturo Servin <[email-masked]>
Date: Thu, 28 Nov 2013 14:33:26 -0200

> Chairs, I would like to call for wg adoption of this document.

Support.

Also, one comment:

In the ASN registry, it could be easy to parse (perhaps) if we have
three columns:

First and second as the initial and end ASNs in the range, if just
one, then both entries are the same. The third as stated is the URL of
the RDAP server.

Best regards,
as

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Thu, 28 Nov 2013 15:34:18 -0200

Support adoption.

On 11/28/13, 2:33 PM, Arturo Servin wrote:
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds
>

---

From: Ernie Dainow <[email-masked]>
Date: Fri, 29 Nov 2013 14:20:32 -0500

Some comments.

"the longest match" as used in several places is not fully descriptive, 
and different.

Section 2. Domain Name RDAP Registry
     domain names are found by doing the longest match
This is a string search of the longest match starting from the end of 
the target name and the end of each value in the Domain column.

3.1.  IPv4 Address Space RDAP Registry
     IPv4 address is found by doing a longest match of the target 
address with the values of the Prefix column
The example query for "192.0.2.0/24" matches the "192/8" entry does not 
follow. There is no string search that will return this match. This 
search requires some semantics, which should be explained.

3.2.  IPv6 Address Space RDAP Registry
same issue as 3.1

4.  Nameserver
Isn't the lookup the same as for a domain name? Just refer back to 
Section 2.

5.  Entity
Add recommendation to use links.
     if the entity identifier was received from a previous query, it 
will generally contain a link to retrieve the complete entity. If it 
does not, the same RDAP server could be queried for that entity.

7.  Deployment Considerations
While the suggestions for doing a sequence of DNS checks if there is no 
lookup match could be useful to some clients, I think a much simpler 
recommendation should also be made.
1. The IANA registries are fetched by an off-line process (such as a 
nightly cron job) and stored in files.
2. The client reads the registries from the stored files.
3. If the RDAP client does not find an entry in the IANA file, it sends 
the request to an RDAP redirector (ref: draft-ietf-weirds-redirects).

-Ernie

---

From: Arturo Servin <[email-masked]>
Date: Sat, 30 Nov 2013 12:14:20 -0200

On Fri, Nov 29, 2013 at 5:20 PM, Ernie Dainow <[email-masked]> wrote:
> "the longest match" as used in several places is not fully descriptive, and
> different.
>
> This is a string search of the longest match starting from the end of the
> target name and the end of each value in the Domain column.
>
>     IPv4 address is found by doing a longest match of the target address
> with the values of the Prefix column
> follow. There is no string search that will return this match. This search
> requires some semantics, which should be explained.
>

For v4 and v6 is the longest match is the more specific prefix, just
like in routing. So it is not a search string as mentioned in Section
2. I think it would be good to clarify the differences.

/as