Subject: Re: [weirds] DNS Bootstrapping revisited

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 2 Dec 2013 12:07:06 +0000

From: Murray S. Kucherawy [mailto:[email-masked]]
Sent: Saturday, November 30, 2013 11:25 PM
To: Hollenbeck, Scott
Cc: [email-masked]; John Levine; [email-masked]
Subject: Re: [weirds] DNS Bootstrapping revisited

On Tue, Nov 26, 2013 at 4:17 AM, Hollenbeck, Scott <[email-masked]<mailto:[email-masked]>> wrote:
> -----Original Message-----
> From: Carlos M. Martinez [mailto:[email-masked]<mailto:[email-masked]>]
> Sent: Tuesday, November 26, 2013 7:13 AM
> To: Hollenbeck, Scott; John Levine; [email-masked]<mailto:[email-masked]>
> Subject: Re: [weirds] DNS Bootstrapping revisited
>
> Is bootstrapping some queries and not all acceptable for the WG ?
Good question. As I said, "If bootstrapping remains a problem to be addressed we should be very clear about the limitations and types of queries that it cannot address".

Can you clarify "types of queries"?   Are you talking about something other than names queries vs. number queries?

[SAH] No, I'm specifically referring to bootstrapping a search for a domain pattern like "example*", or an entity search with no association to an earlier query. There are some patterns for which it is impossible to determine a server identity or a clue that can be used to associate a query with a server. Those limitations need to be acknowledged.

Scott

---

From: John R Levine <[email-masked]>
Date: Mon, 2 Dec 2013 09:27:10 -0500 (EST)

> [SAH] No, I'm specifically referring to bootstrapping a search for a domain pattern like "example*", or an entity search with no association to an earlier query. There are some patterns for which i…

Completely agree.  I understand (in general principle) how one might 
bootstrap individual domain names at the TLD level, IP addresses, and 
ASNs.  I don't think there is any plausible way to bootstrap anything 
else.

R's,
John

---

From: "Linlin Zhou" <[email-masked]>
Date: Wed, 4 Dec 2013 10:25:09 +0800

> From: weirds [mailto:[email-masked]] On Behalf Of John R Levine
> Sent: Monday, December 02, 2013 10:27 PM
> To: Hollenbeck, Scott
> Cc: [email-masked]
> > Can you clarify "types of queries"?   Are you talking about something
other
> than names queries vs. number queries?
> >
> > [SAH] No, I'm specifically referring to bootstrapping a search for a
domain
> pattern like "example*", or an entity search with no association to an
earlier
> query. There are some patterns for which it is impossible to determine a
server
> identity or a clue that can be used to associate a query with a server.
Those
> limitations need to be acknowledged.
> 
ASNs.
> I don't think there is any plausible way to bootstrap anything else.
> 
+1 
Domain name, IP and ASNs are 3 query types that could be possibly
bootstrapped.
> R's,
> John
> _______________________________________________
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds