Subject: [weirds] bootstrapping

From: Andy Newton <[email-masked]>
Date: Wed, 19 Feb 2014 18:23:29 +0000

Section 6 of the current draft says that clients are fetching an XML file.

Why can¹t it be a JSON file? And while we are at it, why can¹t the
registry use the ³links² data structure from Section 5.2 of json-response?
Since clients already have to know how to parse this, it would be less
work for them.

Using the links structure, each link object could be constructed as
follows:
1) value is the domain name, v4 or v6 address, or the asn
2) rel is a relationship specifying the query type supported (so each
.EXAMPLE might have multiple entries, one for each query type they
support. E.g. ³domainlookup² for /domain, ³domainsearchbyname² for
/domains?name=xxx, etc...)
3) href is the base URI for RDAP
4) hreflang and title are optional but the registry can put whatever they
want
5) media is best left out I guess
6) type should be ³application/rdap+json²

-andy

---

From: Marc Blanchet <[email-masked]>
Date: Wed, 19 Feb 2014 14:26:15 -0500

Le 2014-02-19 à 13:23, Andy Newton <[email-masked]> a écrit :

> Why can¹t it be a JSON file?

- good question. The default was the current structured format used by all IANA registries.
- it could be both: i.e. an XML normative format and an XSLT that convert its to json, and both formats being offered by IANA. I think that is doable and can be asked to 
 IANA. I'll chat with IANA about that.

> And while we are at it, why can¹t the
> _______________________________________________
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds

---

From: Kim Davies <[email-masked]>
Date: Wed, 19 Feb 2014 12:41:01 -0800

On Feb 19, 2014, at 11:26 AM, Marc Blanchet <[email-masked]<mailto:[email-masked]>> wrote:

Le 2014-02-19 à 13:23, Andy Newton <[email-masked]<mailto:[email-masked]>> a écrit :

It should be no problem. Our preference is not to need to support a proliferation of differing formats, but this seems relatively straightforward to maintain.

kim