Subject: Re: [weirds] Question: Nameserver data looked up by IP address

From: Peter Koch <[email-masked]>
Date: Sun, 2 Feb 2014 14:25:05 +0100

On Fri, Jan 31, 2014 at 04:45:21PM +0000, Andy Newton wrote:

> >I suppose, but it's a little strange.  NS records only contain names,
> >and an IP address might be the A/AAAA RDATA at several names.  How
> >would you know which nameserver you were talking about?
> 
> I agree. This more like a search than a lookup.

indeed, therefore it should be optional - at most.
Many queries of this kind would result in multiple (sometimes
even "many") objects being returned.

-Peter

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 3 Feb 2014 18:51:11 +0000

> -----Original Message-----
> From: weirds [mailto:[email-masked]] On Behalf Of Andy Newton
> Sent: Friday, January 31, 2014 11:45 AM
> To: Andrew Sullivan; [email-masked]
> Subject: Re: [weirds] Question: Nameserver data looked up by IP address
> 
> On 1/31/14 8:17 AM, "Andrew Sullivan" <[email-masked]> wrote:
> 
> >On Fri, Jan 31, 2014 at 01:06:26PM +0000, Hollenbeck, Scott wrote:
> >k about adding it, though. Should we? It doesn't seem unreasonable.
> >Examples:
> >>
> >> nameserver/192.0.2.0
> >> nameserver/2001:db8::0
> >
> If we want to support this, it should be /nameservers?ip=X where X is
> either an IPv4 or IPv6 address.

Does anyone have any issues with adding this as a search option? Should this be interpreted as "search for domain names delegated to a server at this address" or "search for name server names that resolve to this address"?

Scott

---

From: Andy Newton <[email-masked]>
Date: Mon, 3 Feb 2014 19:05:00 +0000

On 2/3/14 1:51 PM, "Hollenbeck, Scott" <[email-masked]> wrote:

>Does anyone have any issues with adding this as a search option? Should
>this be interpreted as "search for domain names delegated to a server at
>this address" or "search for name server names that resolve to this
>address"?

I have no problem adding the latter. The former does seem useful, but if
it is currently not a requirement then it can be added later.

-andy

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 3 Feb 2014 19:24:32 +0000

> From: Andy Newton [mailto:[email-masked]]
> Sent: Monday, February 03, 2014 2:05 PM
> To: Hollenbeck, Scott; Andrew Sullivan; [email-masked]
> >this be interpreted as "search for domain names delegated to a server
> >at this address" or "search for name server names that resolve to this
> >address"?
> 
> I have no problem adding the latter. The former does seem useful, but
> if it is currently not a requirement then it can be added later.

I just read through one of the new ICANN registry agreements to see what the text actually says. Unfortunately, it does not specifically describe the response to a name server query by IP address. Here's an example from the .beer TLD agreement (http://www.icann.org/sites/default/files/tlds/beer/beer-agmt-html-09jan14-en.htm):

1.7. Nameserver Data:

1.7.1 Query format:  whois "NS1.EXAMPLE.TLD", whois "nameserver (nameserver name)", or whois "nameserver (IP Address)"

1.7.2 Response format:

Server Name: NS1.EXAMPLE.TLD 
IP Address: 192.0.2.123 
IP Address: 2001:0DB8::1 
Registrar: Example Registrar, Inc.
WHOIS Server: whois.example-registrar.tld 
Referral URL: http://www.example-registrar.tld 
>>> Last update of WHOIS database: 2009-05-29T20:15:00Z <<<

This response looks like an answer to the latter question. The text does say that "The fields specified below set forth the minimum output requirements.  Registry Operator may output data fields in addition to those specified below, subject to approval by ICANN, which approval shall not be unreasonably withheld" - which appears to be consistent with Andy's suggestion. We could do "search for name server names that resolve to this address" (to help people meet the requirement) and leave "search for domain names delegated to a server at this address" for "in addition to those specified".

Scott

---

From: Andy Newton <[email-masked]>
Date: Mon, 3 Feb 2014 20:57:58 +0000

On 2/3/14 2:24 PM, "Hollenbeck, Scott" <[email-masked]> wrote:

>This response looks like an answer to the latter question. The text does
>say that "The fields specified below set forth the minimum output
>requirements.  Registry Operator may output data fields in addition to
>those specified below, subject to approval by ICANN, which approval shall
>not be unreasonably withheld" - which appears to be consistent with
>Andy's suggestion. We could do "search for name server names that resolve
>to this address" (to help people meet the requirement) and leave "search
>for domain names delegated to a server at this address" for "in addition
>to those specified".

This seems reasonable to me.

-andy

---

From: "Mikkelsen, Asbjorn" <[email-masked]>
Date: Tue, 4 Feb 2014 09:07:58 +0000

The DotName ICANN agreement includes language about IP-address lookups:

"Nameserver ("nameserver"): Search only by nameserver objects. The input string is searched in the nameserver field or the IP address field."
( http://www.icann.org/en/about/agreements/registries/name/appendix-05-01dec12-en.htm )

If you go to http://whois.nic.name and do a NAMESERVER lookup for 8.8.8.8 it returns the out-of-zone name server with name "8.8.8.8" and two in-zone name servers with the associated IP-address "8.8.8.8":

   Name Server ID: 2473998_HOST_NAME-VRSN
   Name Server Name: 8.8.8.8
   Name Server Status: ok
   Name Server Registrar ID: 69_REGISTRAR_NAME-VRSN
   Name Server Registrar: Tucows Domains Inc.
   Created On: 2013-10-03T07:51:09Z
   Updated On: 2013-10-03T07:51:09Z

   Name Server ID: 1918975_HOST_NAME-VRSN
   Name Server Name: 0.MICHAEL.KROPAT.NAME
   Name Server Status: ok
   IP Address Associated: 8.8.8.8
   IP Address Associated: 66.220.0.213
   Name Server Registrar ID: 5235_REGISTRAR_NAME-VRSN
   Name Server Registrar: Dynamic Network Services, Inc
   Created On: 2010-11-21T22:51:38Z
   Updated On: 2010-11-21T22:52:18Z

   Name Server ID: 2442158_HOST_NAME-VRSN
   Name Server Name: N.T4K.NAME
   Name Server Status: ok
   IP Address Associated: 8.8.8.8
   Name Server Registrar ID: 74_REGISTRAR_NAME-VRSN
   Name Server Registrar: Online SAS
   Created On: 2013-07-24T03:34:38Z
   Updated On: 2013-07-24T03:34:38Z

Regards,

Asbjorn

-----Original Message-----
From: weirds [mailto:[email-masked]] On Behalf Of Hollenbeck, Scott
Sent: Monday, February 03, 2014 20:25
To: Andy Newton; Andrew Sullivan; [email-masked]
Subject: Re: [weirds] Question: Nameserver data looked up by IP address

1.7. Nameserver Data:

1.7.2 Response format:

Scott
_______________________________________________
weirds mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/weirds

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 4 Feb 2014 13:15:37 +0000

I just submitted rdap-query-10 with additional text to include name server search by IP address.

Scott

---

From: Naoki Kambe <[email-masked]>
Date: Wed, 05 Feb 2014 10:27:00 +0900 (JST)

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 4 Feb 2014 13:15:37 +0000
> I just submitted rdap-query-10 with additional text to include name server search by IP address.

Thank you for submitting but I have a simple question.
What if querying this with a wild card? For example,

 /nameservers&ip=192.0.2.*
 /nameservers&ip=2001:db8::*

Although these formats don't exactly conform to RFC1166 or RFC5952.
Regards,

Naoki Kambe

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 5 Feb 2014 12:01:41 +0000

> From: weirds [mailto:[email-masked]] On Behalf Of Naoki Kambe
> Sent: Tuesday, February 04, 2014 8:27 PM
> To: [email-masked]

Wildcard searches aren't included.

Scott