Subject: Re: [weirds] IETF 89 scheduling

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 18 Feb 2014 23:08:45 -0800

Colleagues,

The draft agenda is a bit overdue.  So far the agenda contains a 15 minute
session for interop results discussion and a 20 minute session for talking
about bootstrapping, plus a few minutes for administrivia up front.  We
have a 2.5 hour slot allocated, leaving 110 minutes for "any other
business".

Do we need time to talk about the .well-known/templates/etc. issue this
time, or is that pretty much resolved (debate on apps-discuss
notwithstanding)?

Are there any open issues on any of the other documents, or are they all
ready for WGLC (except for bootstrapping)?

I'll upload the agenda sometime tomorrow evening based on the feedback I
get here (or not).

-MSK

On Fri, Jan 17, 2014 at 11:47 AM, Simon Perreault <
[email-masked]> wrote:

> Le 2014-01-17 14:02, Murray S. Kucherawy a écrit :
>
>  Please propose agenda items for London.
>>
>
> 15 minutes for discussion of interop results.
>
> Thanks,
> Simon
> --
> DTN made easy, lean, and smart --> http://postellation.viagenie.ca
> NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
> STUN/TURN server               --> http://numb.viagenie.ca
>
> _______________________________________________
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds
>

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 19 Feb 2014 12:04:31 +0000

From: weirds [mailto:[email-masked]] On Behalf Of Murray S. Kucherawy
Sent: Wednesday, February 19, 2014 2:09 AM
To: Simon Perreault
Cc: [email-masked]
Subject: Re: [weirds] IETF 89 scheduling

Colleagues,

The draft agenda is a bit overdue.  So far the agenda contains a 15 minute session for interop results discussion and a 20 minute session for talking about bootstrapping, plus a few minutes for administrivia up front.  We have a 2.5 hour slot allocated, leaving 110 minutes for "any other business".

Do we need time to talk about the .well-known/templates/etc. issue this time, or is that pretty much resolved (debate on apps-discuss notwithstanding)?
If it's been resolved I'm unaware of the resolution and no one has suggested that changes need to be made to rdap-query, which still includes .well-known. I'd very much like to see this on the agenda.
Scott

---

From: Marc Blanchet <[email-masked]>
Date: Wed, 19 Feb 2014 08:14:49 -0500

> Do we need time to talk about the .well-known/templates/etc. issue this time, or is that pretty much resolved (debate on apps-discuss notwithstanding)?

My take:
- all specs are pretty stable and "done". bootstrap included.
- but: the .well-known/template that affects both bootstrap and query is on-going. This should be our top priority to resolve. When resolved (and whatever doc updated if needed), then I think we should go LC for all of them.

therefore, I think we should spend as much time needed to resolve the .well-known-template-uri discussion. Maybe by making sure the appropriate parties are in the room... hint to the chairs...

Regards, Marc.

> 
> Are there any open issues on any of the other documents, or are they all ready for WGLC (except for bootstrapping)?
> 
> I'll upload the agenda sometime tomorrow evening based on the feedback I get here (or not).
> 
> -MSK
> 
> 
> 
> On Fri, Jan 17, 2014 at 11:47 AM, Simon Perreault <[email-masked]> wrote:

---

From: Andy Newton <[email-masked]>
Date: Wed, 19 Feb 2014 17:09:08 +0000

From: Marc Blanchet <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, February 19, 2014 at 8:14 AM
To: "Murray S. Kucherawy" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [weirds] IETF 89 scheduling

I agree that this should be our top priority. Reviewers on the apps-discuss list mentioned that we could drop .well-known and that met with no objections. So I think .well-known can be dropped from rdap-query.

Now the templates discussion is another issue entirely. On the apps-discuss list I noted that the architectural issue was that they wanted us to avoid URI collisions and that templates were just one method for doing so. Since our bootstrap method allows for arbitrary base URIs, RDAP does not suffer from URI collisions. So far that assertion has not been challenged on apps-discuss. However, it most likely needs to be explicitly discussed at the meeting (and on THIS list).

-andy

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Fri, 21 Feb 2014 00:26:34 -0800

On Wed, Feb 19, 2014 at 9:09 AM, Andy Newton <[email-masked]> wrote:

>
> I agree that this should be our top priority. Reviewers on the
> apps-discuss list mentioned that we could drop .well-known and that met
> with no objections. So I think .well-known can be dropped from rdap-query.
>

Just back from a short vacation and I'm a bit behind, so I'll have to dig
this up (though it's great to hear!).

I recall Mark saying in Vancouver that .well-known was just one possible
solution to the issue at hand, so it's no surprise that dropping it is
acceptable so long as we still don't land on a solution that the web folk
find objectionable, or we're back to where we started.  But I think you've
touched on that here:

>
> Now the templates discussion is another issue entirely. On the
> apps-discuss list I noted that the architectural issue was that they wanted
> us to avoid URI collisions and that templates were just one method for
> doing so. Since our bootstrap method allows for arbitrary base URIs, RDAP
> does not suffer from URI collisions. So far that assertion has not been
> challenged on apps-discuss. However, it most likely needs to be explicitly
> discussed at the meeting (and on THIS list).
>
>
This is pretty much in line with my (at present, hazy) understanding of the
issue and our approach to solving it for WEIRDS.

I'll invite Mark to attend our session.  Given that this is our only major
topic, and it doesn't appear we're in conflict with httpbis or other
web-specific WGs, the odds might be in our favor that we can settle the
matter at long last.

-MSK

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Fri, 21 Feb 2014 09:47:00 -0800

The draft agenda is now available here:
http://www.ietf.org/proceedings/89/minutes/minutes-89-weirds

It's pretty straightforward.  If there are any other topics that need face
time in London, please let us know ASAP as the final agenda is due on
Monday.

-MSK

On Fri, Feb 21, 2014 at 12:26 AM, Murray S. Kucherawy
<[email-masked]>wrote:

> This is pretty much in line with my (at present, hazy) understanding of
> the issue and our approach to solving it for WEIRDS.
>

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Fri, 21 Feb 2014 10:13:04 -0800

Yes, I uploaded the agenda as minutes.  We're trying something
Jeopardy-like this time where we post the minutes, and then you all have to
execute the meeting that leads us back to the as-yet-unspecified agenda.

I'm clearly too decaffeinated.  The agenda is now here:
http://www.ietf.org/proceedings/89/agenda/agenda-89-weirds.  Sorry about
that.

-MSK

On Fri, Feb 21, 2014 at 9:47 AM, Murray S. Kucherawy <[email-masked]>wrote:

> On Fri, Feb 21, 2014 at 12:26 AM, Murray S. Kucherawy <[email-masked]
> > wrote:
>
>> I'll invite Mark to attend our session.  Given that this is our only
>> major topic, and it doesn't appear we're in conflict with httpbis or other