Subject: RE: [REMOTEUI] Widex charter proposal draft

From: [email-masked]
Date: Fri, 2 Sep 2005 11:18:45 +0300

Well, I think that we agreed to have the protocol UI semantic independent and discovery and session setup mechanism independent. We haven't mentioned that the protocol should be transport protocol independent.

In fact, the whole purpose of the working group is to define a single mandatory to implement protocol for synchronising XML DOM events.

Vlad

> -----Original Message-----
> From: ext Dave Raggett [mailto:[email-masked]]
> Sent: 02 September, 2005 10:59
> To: Stirbu Vlad (Nokia-TP-MSW/Tampere)
> Cc: [email-masked]; [email-masked]
> Subject: RE: [REMOTEUI] Widex charter proposal draft
> 
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> On Fri, 2 Sep 2005 [email-masked] wrote:
> 
> > One of the ideas behind the RUI BoF was that the protocol must be 
> > service discovery and session setup independent; there was a 
> > debate on what this "independent" really means and the answer was 
> > that the protocol should be usable with any existing service 
> > discover and session mechanism, e.g. SIP/SDP, UPnP, 
> > Rendezvous/Bonjour, etc., and that the protocol should not depend 
> > on a particular one.
> 
> Sorry for not having made myself clearer. I believe we all agree on 
> defining the message formats for DOM events and updates using XML in 
> a way that is independent of the transport protocol. However, I feel 
> it would be valuable to also provide a normative binding to at least 
> one transport protocol such as SIP so that people can implement the 
> solution in an interoperable way.
> 
> > The reason behind this assumption/requirement is that we should be 
> > able to use the protocol in multiple environments regardless of 
> > what is the session setup mechanism in a particular one. For 
> > example, in a cellular network SIP/SDP is the right choice but in 
> > a home network (see www.dlna.org) where UPnP is used for service 
> > discovery we'll have to use UPnP Remote UI to start the ui 
> > remoting session.
> 
> Which event transport protocol would you use in a home network,
> and why couldn't we include bindings to that in the spec?
> 
> Providing explicit bindings makes the proposal much more concrete
> and will attract more implementers.
> 
> - -- 
>   Dave Raggett <[email-masked]>  W3C lead for multimodal interaction
>   http://www.w3.org/People/Raggett +44 1225 866240 (or 867351)
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.2.4 (GNU/Linux)
> 
> iD8DBQFDGAZLb3AdEmxAsUsRAsnLAKCzaKVga5YPY9v799a+8GZP1/F9WwCg3jjq
> +Y9zEg7i+EdiRAtZ+F3LYCs=
> =fwDq
> -----END PGP SIGNATURE-----
> 

_______________________________________________
REMOTEUI mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/remoteui

---

From: Dave Raggett <[email-masked]>
Date: Fri, 2 Sep 2005 09:56:46 +0100 (BST)

On Fri, 2 Sep 2005 [email-masked] wrote:

> Well, I think that we agreed to have the protocol UI semantic 
> independent and discovery and session setup mechanism independent. 
> We haven't mentioned that the protocol should be transport 
> protocol independent.
>
> In fact, the whole purpose of the working group is to define a 
> single mandatory to implement protocol for synchronising XML DOM 
> events.

So what's wrong with my suggestion that the charter covers defining 
XML message formats and normative bindings to at least SIP, and 
perhaps other protocols?

- --