Subject: [woes] JSON Web Key (JWK) Specification

From: Mike Jones <[email-masked]>
Date: Sun, 1 May 2011 07:09:30 +0000

I've posted the JSON Web Key (JWK) specification<http://self-issued.info/docs/draft-jones-json-web-key.html> for representing public keys as JSON objects based on the decisions made at the last IIW<http://self-issued.info/?p=390>.  The introduction to the spec reads:

A JSON Web Key (JWK) is a JSON data structure that represents a set of public keys as a JSON object. The JWK format is used to represent bare keys; representing certificate chains is an explicit non-goal of this specification. JSON Web Keys are referenced in JSON Web Signatures (JWSs) using the jku (JSON Key URL) header parameter.

An example from the spec is:

{"keyvalues":
  [
    {"algorithm":"ECDSA",
     "curve":"P-256",
     "x":"MKBCTNIcKUSDii11ySs3526iDZ8AiTo7Tu6KPAqv7D4",
     "y":"4Etl6SRW2YiLUrN5vfvVHuhp7x8PxltmWWlbbM4IFyM",
     "keyid":"1"},

    {"algorithm":"RSA",
      "modulus": "0vx7agoebGcQSuuPiLJXZptN9nndrQmbXEps2aiAFbWhM78LhWx4cbbfAAtVT86zwu1RK7aPFFxuhDR1L6tSoc_BJECPebWKRXjBZCiFV4n3oknjhMstn64tZ_2W-5JsGY4Hc5n9yBXArwl93lqt7_RN5w6Cf0h4QyQ5v-65YGjQR0_FDW2QvzqY368QQMicAtaSqzs8KJZgnYb9c7d0zgdAZHzu6qMQvRL5hajrn1n91CbOpbISD08qNLyrdkt-bFTWhAI4vMQFh6WeZu0fM4lFd2NcRwr3XPksINHaQ-G_xBniIqbw0Ls1jF44-csFCur-kEgU8awapJzKnqDKgw",
     "exponent":"AQAB",
     "keyid":"2011-04-29"}
  ]
}

The specification is available at these locations:

*        http://www.ietf.org/internet-drafts/draft-jones-json-web-key-00.txt

*        http://www.ietf.org/internet-drafts/draft-jones-json-web-key-00.xml

*        http://self-issued.info/docs/draft-jones-json-web-key-00.html

*        http://self-issued.info/docs/draft-jones-json-web-key-00.txt

*        http://self-issued.info/docs/draft-jones-json-web-key-00.xml

*        http://self-issued.info/docs/draft-jones-json-web-key.html (will point to new versions as they are posted)

*        http://self-issued.info/docs/draft-jones-json-web-key.txt (will point to new versions as they are posted)

*        http://self-issued.info/docs/draft-jones-json-web-key.xml (will point to new versions as they are posted)

*        http://svn.openid.net/repos/specifications/json_web_key/1.0/ (Subversion repository, with html, txt, and html versions available)

I also updated the description of the JSON Web Signature (JWS)<http://self-issued.info/docs/draft-jones-json-web-signature.html> header parameter "jku" (JSON Key URL) to reference the JWK spec in draft -02<http://self-issued.info/docs/draft-jones-json-web-signature-02.html>.

                                                            -- Mike

---

From: Nat <[email-masked]>
Date: Sun, 1 May 2011 00:32:11 -0700

Thanks Mike. 

I plan to update core a bit to match the OAuth d15 terminology. 

=nat via iPhone

On 2011/05/01, at 0:09, Mike Jones <[email-masked]> wrote:

> I’ve posted the JSON Web Key (JWK) specification for representing public keys as JSON objects based on the decisions made at the last IIW.  The introduction to the spec reads:
>  
> ·        http://www.ietf.org/internet-drafts/draft-jones-json-web-key-00.txt
> ·        http://www.ietf.org/internet-drafts/draft-jones-json-web-key-00.xml
> ·        http://self-issued.info/docs/draft-jones-json-web-key-00.html
> ·        http://self-issued.info/docs/draft-jones-json-web-key-00.txt
> ·        http://self-issued.info/docs/draft-jones-json-web-key-00.xml
> ·        http://self-issued.info/docs/draft-jones-json-web-key.html (will point to  new versions as they are posted)
> ·        http://self-issued.info/docs/draft-jones-json-web-key.txt (will point to new versions as they are posted)
> ·        http://self-issued.info/docs/draft-jones-json-web-key.xml (will point to new versions as they are posted)
> ·        http://svn.openid.net/repos/specifications/json_web_key/1.0/ (Subversion repository, with html, txt, and html versions available)
>  
> I also updated the description of the JSON Web Signature (JWS) header parameter “jku” (JSON Key URL) to reference the JWK spec in draft -02.
>  
>                                                             -- Mike
>  
> _______________________________________________
> Openid-specs-ab mailing list
> [email-masked]
> http://lists.openid.net/mailman/listinfo/openid-specs-ab