Subject: [woes] Proposed BoF agenda

From: Paul Hoffman <[email-masked]>
Date: Wed, 13 Jul 2011 09:57:16 -0700

Greetings again. Richard and I propose the following agenda for our meeting that is in less than two weeks:

Agenda for WOES BoF, IETF 81, Quebec
Richard Barnes and Paul Hoffman, temporary BoF chairs

Agenda bashing, blue shee launching - 5 min
Maining list history of the proposed charter (Richard/Paul) - 15 minutes
A word from our sponsor (Stephen/Sean) - 5 minutes
Charter issue 1: key format - 20 minutes
Charter issue 2: basing on CMS - 20 minutes
Other charter issues - rest of time

(We will post this to the IETF agenda site later when they allow us to.)

Suggested changes to the agenda are welcome. More discussion of the charter in the coming two weeks is even more welcome.

--Paul Hoffman

---

From: Mike Jones <[email-masked]>
Date: Wed, 13 Jul 2011 17:27:26 +0000

I strongly disagree with the "basing on CMS" wording.  I'd be OK with wording more like "drawing upon existing inputs such as CMS, XMLDSIG, and XMLENC".

There's a lot to reuse from these documents.  But it's prejudicial to have a discussion that starts from the assumption that we are basing this work on CMS.

				Thanks,
				-- Mike

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Hoffman
Sent: Wednesday, July 13, 2011 9:57 AM
To: [email-masked]
Subject: [woes] Proposed BoF agenda

Agenda bashing, blue shee launching - 5 min Maining list history of the proposed charter (Richard/Paul) - 15 minutes A word from our sponsor (Stephen/Sean) - 5 minutes Charter issue 1: key format - 20 minutes Charter issue 2: basing on CMS - 20 minutes Other charter issues - rest of time

--Paul Hoffman

_______________________________________________
woes mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/woes

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 13 Jul 2011 10:42:20 -0700

> There's a lot to reuse from these documents.  But it's prejudicial to have a discussion that starts from the assumption that we are basing this work on CMS.

As someone who participated in the early XMLDSIG and XMLENC work, I have to ask: what do they have for this JSON work that CMS doesn't? That is, there was a conscious attempt to mirror CMS structures in them. Where they strayed (such as on namespaces), they went to hell.

One or two examples here would really help.

--Paul Hoffman

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 14 Jul 2011 21:33:34 +0100

> One or two examples here would really help.

Indeed. I think the KeyInfo from XMLDSIG is maybe a
slightly better model than (almost) forcing
IssuerAndSerialNumber from 5280 as is done in CMS.
That's the level at which I think we need to have
the discussion to understand what people are claiming
is wrong with basing on CMS.

For me, other than that example, I really fail to
see anything wrong with basing on CMS, so some
examples would be very good, even if they only
come two weeks after I first asked.

(Or, maybe all the disquiet on this topic is
really format-wars yet again and from the security
p-o-v, content-free;-)

S.