Subject: Re: [Wpack] Call for adoption of draft-yasskin-wpack-use-cases (redux)

From: Ted Hardie <[email-masked]>
Date: Wed, 1 Sep 2021 12:52:47 +0100

So, I'm quite late to this discussion (yay, vacation), but I think Sean's
approach makes sense here.  We can move things in and out as consensus
emerges.

regards,

Ted

On Thu, Aug 19, 2021 at 6:56 PM Sean Turner <[email-masked]> wrote:

> Mike,
>
> I may be more laissez faire than most about WG adoption. I think of it as
> the document is a starting point. To date we haven’t had people falling on
> their swords, so I was leaning more towards the “get this version in, hack
> on it for -01” camp. If a lot of people are in the same camp as you we can
> always call this one off, get the I-D updated and start over.
>
> spt
>
> > On Aug 19, 2021, at 12:15, Mike Bishop <[email-masked]> wrote:
> >
> > This seems like the wrong order of things to me.  If the point is to
> adopt a document that describes the scenarios we actually have consensus
> on, why are the others not moved to the appendix in the version prior to
> the adoption call?
> >
> > If the point is simply to have consensus on the fact that we have a
> scenario document, fine, but even if it's temporary I don't really like the
> idea of having a WG-adopted document that describes scenarios as in-scope
> that don't have consensus.
> >
> > -----Original Message-----
> > From: Wpack <[email-masked]> On Behalf Of Sean Turner
> > Sent: Wednesday, August 18, 2021 10:14 PM
> > To: WPACK List <[email-masked]>
> > Subject: [Wpack] Call for adoption of draft-yasskin-wpack-use-cases
> (redux)
> >
> > Hi! This message starts a WG call for adoption of
> draft-yasskin-wpack-use-cases. This is the 2nd WG call for adoption for
> this I-D; the 1st WG call for adoption did not garner enough interest for
> the chairs to make a decision, but at IETF 111 the WG discussed adopting
> the I-D and trimming it down version to only agreed use cases (and sticking
> the others in an appendix). The I-D can be found here:
> > https://datatracker.ietf.org/doc/draft-yasskin-wpack-use-cases/
> >
> > This adoption call will run until 10 September 2021 at 2359 UTC.* Please
> indicate whether or not you would like to see this I-D adopted as a WG item.
> >
> > Thanks,
> > Sean and Dave
> >
> > * Note that I am allowing a little extra time here because it is
> vacation time.
> > _______________________________________________
> > Wpack mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/wpack
>
> _______________________________________________
> Wpack mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/wpack
>

---

From: Larry Masinter <[email-masked]>
Date: Wed, 1 Sep 2021 11:43:41 -0700

Why do working groups have “use cases”? Why not just argue about mechanisms without any?
What does it mean to have “rough consensus” on the set of use cases?

I don’t think it is useful to expect consensus on use cases. The idea is to have a realistic set of situations that can be used to evaluate proposed mechanisms for whatever you’re trying to accomplish, with the goals of accomplishing

*	Predictable interoperability of conforming implementations
*	Possibility of implementation in the use cases with acceptable performance, security, privacy, simplicity

Different people will naturally have different priorities among use cases, and for desirable aspects.

Rather than consensus, I think it is better to cast the net widely.

In the case of WPACK and the web, there is already a broadly implemented and deployed mechanism for accomplishing the goal of packaging together resource representations, namely MIME multipart. I’d hoped the working group would consider doing the work of analyzing why the proposed mechanisms are (or are not) better than the existing standards for at least some of the use cases.

--

 <https://LarryMasinter.net> https://LarryMasinter.net  <https://interlisp.org> https://interlisp.org

From: Wpack <[email-masked]> On Behalf Of Ted Hardie
Sent: Wednesday, September 1, 2021 4:53 AM
To: Sean Turner <[email-masked]>
Cc: WPACK List <[email-masked]>; Mike Bishop <[email-masked]>
Subject: Re: [Wpack] Call for adoption of draft-yasskin-wpack-use-cases (redux)

So, I'm quite late to this discussion (yay, vacation), but I think Sean's approach makes sense here.  We can move things in and out as consensus emerges.

regards,

Ted

On Thu, Aug 19, 2021 at 6:56 PM Sean Turner <[email-masked] <mailto:[email-masked]> > wrote:

Mike,

I may be more laissez faire than most about WG adoption. I think of it as the document is a starting point. To date we haven’t had people falling on their swords, so I was leaning more towards the “get this version in, hack on it for -01” camp. If a lot of people are in the same camp as you we can always call this one off, get the I-D updated and start over.

spt

> On Aug 19, 2021, at 12:15, Mike Bishop <[email-masked] <mailto:[email-masked]> > wrote:
> 
> This seems like the wrong order of things to me.  If the point is to adopt a document that describes the scenarios we actually have consensus on, why are the others not moved to the appendix in the version prior to the adoption call?
> 
> If the point is simply to have consensus on the fact that we have a scenario document, fine, but even if it's temporary I don't really like the idea of having a WG-adopted document that describes scenarios as in-scope that don't have consensus.
> 
> From: Wpack <[email-masked] <mailto:[email-masked]> > On Behalf Of Sean Turner
> To: WPACK List <[email-masked] <mailto:[email-masked]> >
> Subject: [Wpack] Call for adoption of draft-yasskin-wpack-use-cases (redux)
> 
> Hi! This message starts a WG call for adoption of draft-yasskin-wpack-use-cases. This is the 2nd WG call for adoption for this I-D; the 1st WG call for adoption did not garner enough interest for the chairs to make a decision, but at IETF 111 the WG discussed adopting the I-D and trimming it down version to only agreed use cases (and sticking the others in an appendix). The I-D can be found here:
> This adoption call will run until 10 September 2021 at 2359 UTC.* Please indicate whether or not you would like to see this I-D adopted as a WG item.
> 
> Thanks,
> Sean and Dave
> 
> * Note that I am allowing a little extra time here because it is vacation time.
> [email-masked] <mailto:[email-masked]> 

_______________________________________________
Wpack mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/wpack

---

From: Sean Turner <[email-masked]>
Date: Thu, 30 Sep 2021 13:47:52 -0400

> On Sep 1, 2021, at 14:43, Larry Masinter <[email-masked]> wrote:
> 

You have asked for the WG to analyze MIME multipart a couple of times now. With no one else in the group undertaking that analysis, it would seem to fall on your shoulders to present it. Even if that analysis was done and MIME multipart could be shown to support all agreed use cases, I am not sure that would stop the work that is underway because we are not the protocol police. I am not saying that the WG would not consider MIME multipart, but until such time as somebody does that analysis the WG seems to be okay with a bundle defined as a CBOR-array.

spt