Subject: RE: [XCON] Open Issue: Hidden Participants

From: "Eric Burger" <[email-masked]>
Date: Wed, 10 Mar 2004 10:14:56 -0500

We are always free to invite in a machine.  The question is whether that is a fundamental, architectural decision for how to do IVR, and thus *requires* them to be hidden, or is it just something a user or moderator can do (just REFER or INVITE them to the conference).

If you believe it is a fundamental need, then they must be hidden, to make user interfaces for the bulk of implementations reasonable.

If you believe it is just a convenience (which is my personal stand), then they don't need to be totally hidden.

Frankly, IMHO it is a style choice, so I will accept the consensus, either way it goes.

> -----Original Message-----
> From: Drage, Keith (Keith) [mailto:[email-masked]]
> Sent: Tuesday, March 09, 2004 7:28 PM
> To: Eric Burger; Kozdon, Peter; [email-masked]
> Subject: RE: [XCON] Open Issue: Hidden Participants
> 
> 
> See below
> 
> Keith
> 
> > -----Original Message-----
> > From: Eric Burger [mailto:[email-masked]]
> > Sent: 09 March 2004 20:28
> > To: Kozdon, Peter; [email-masked]
> > Subject: RE: [XCON] Open Issue: Hidden Participants
> > 
> snipped
> > 
> > 
> > We do have consensus that Lawful Intercept is entirely 
> > orthogonal to conference participants.  However, the logic of 
> > the above follows.  Just as IVR systems or conference 
> > recorders are not really participants, neither is LI 
> > hardware.  If we say that the approach for IVR is to plumb in 
> > as a hidden participant, then LI would have the same 
> > approach.  If we say that IVR is something different, e.g., 
> > just a part of the conference mixer, then it is truly "not 
> > there".  Likewise, I would expect LI to be "not there" -- 
> > something outside the XCON framework entirely.
> > 
> The test to me is does the entity follow the rules for 
> joining the conference that any other participant has to. 
> Lawful Intercept certainly does not.
> 
> I would agree with you that there is a case for IVR systems 
> and conference recorders being automatically included as part 
> of the conference function, and therefore they are not 
> participants in the conference. Is it possible that such 
> devices could also, for example, be referred in as normal 
> participants. I'm in a conference, and suddenly decide that 
> the current portion of the call should be recorded, and 
> therefore send the appropriate REFER causing the recording 
> device to join as a participant.
> 
> 
> 

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 10 Mar 2004 13:30:14 -0500

Eric,

I think there are two distinct cases here that are getting mixed:

- participants that wish to remain unobserved
- participants that watchers may want to ignore

The former is the case that is similar to legal intercept. Other than 
permitting anonymous participants to register (or not) I don't think 
anything needs to be done to support this.

I think Rohan was concerned about the latter. This need can be satisfied 
by ensuring that the participant list is annotated with enough 
attributes so that a watcher can choose to suppress the display of those 
participants that are uninteresting to its user. AFAIK there are no 
regulatory issues in this.

So, if participants that are recorders or IVRs are identifiable as such, 
then a watcher *may* choose to hide the display of them. This would be 
strictly a UI implementation issue for a particular client.

	Paul