Subject: RE: [XCON] CPCP Requirement: Hidden Participants

From: Adam Roach <[email-masked]>
Date: Mon, 1 Mar 2004 06:33:41 -0600

Er... I reponded to Eric, not to you. His message
was the first in which legal intercept was raised.

/a

> -----Original Message-----
> From: Drage, Keith (Keith) [mailto:[email-masked]]
> Sent: Saturday, February 28, 2004 19:04
> To: 'Adam Roach'; 'Eric Burger'; [email-masked]'
> Subject: RE: [XCON] CPCP Requirement: Hidden Participants
> 
> 
> It would have been better that you replied to one of the 
> later messages in this thread.
> 
> Your comments make it look like my own comments below refer 
> to legal intercept, when they do not. We have already agreed 
> that hidden participants are nothing to do with legal intercept.
> 
> regards
> 
> Keith
> 
> > -----Original Message-----
> > From: Adam Roach [mailto:[email-masked]]
> > Sent: 26 February 2004 03:46
> > To: Eric Burger; [email-masked]'
> > Subject: RE: [XCON] CPCP Requirement: Hidden Participants
> > 
> > 
> > I know this issue has been settled, but just as a general
> > announcement for any work in any working group: the IAB
> > and IESG have stated positions on the topic of legal
> > intercept that are (to my understanding) binding on all
> > IETF protocols.
> > 
> > These positions are detailed in RFC 2804, and are
> > summarized as follows: "The IETF has decided not to consider
> > requirements for wiretapping as part of the process for
> > creating and maintaining IETF standards."
> > 
> > /a
> > 
> > > -----Original Message-----
> > > From: Eric Burger [mailto:[email-masked]]
> > > Sent: Tuesday, January 20, 2004 10:01
> > > To: [email-masked]
> > > Subject: RE: [XCON] CPCP Requirement: Hidden Participants
> > > 
> > > 
> > > Would Legal Intercept be in or out?  E.g., hidden 
> > > participants that CANNOT be known.
> > > 
> > > > -----Original Message-----
> > > > From: Drage, Keith (Keith) [mailto:[email-masked]]
> > > > Sent: Friday, December 19, 2003 6:14 AM
> > > > To: [email-masked]; [email-masked]
> > > > Cc: [email-masked]
> > > > Subject: RE: [XCON] CPCP Requirement: Hidden Participants
> > > > 
> > > > 
> > > > I believe hidden users are appropriate.
> > > > 
> > > > I do not believe that this adds complexity to the 
> > > > specifications (particularly to the specification of CPCP), 
> > > > so I see no need to make it a DEFER as far as the 
> > > > specifications are concerned. It may add complexity to the 
> > > > implementation, so I am quite happy to see it a MAY in the 
> > > > requirements, so that it is optional to implement.
> > > > 
> > > > As regards the legal implications of hidden users, then yes, 
> > > > there may be priveleged users that are able to request the 
> > > > identity of hidden users (along with an indication that they 
> > > > are hidden). This of course requires the enabling of such a 
> > > > privileged user in the first place.
> > > > 
> > > > Secondly, it may not be necessary to identify hidden users, 
> > > > but merely that there are hidden users in the conference (in 
> > > > addition to any that may have made themselves visible). Some 
> > > > countries require some form of tone or announcement on voice 
> > > > conferences when someone else is listening in. They also 
> > > > require an announcement or other indication in the call is 
> > > > being recorded.
> > > > 
> > > > regards
> > > > 
> > > > Keith
> > > > 
> > > > Keith Drage
> > > > Lucent Technologies
> > > > [email-masked]
> > > > tel: +44 1793 776249
> > > > 
> > > > 
> > > > > -----Original Message-----
> > > > > From: [email-masked] 
> > > [mailto:[email-masked]]
> > > > > Sent: 15 December 2003 16:29
> > > > > To: [email-masked]
> > > > > Cc: [email-masked]
> > > > > Subject: RE: [XCON] CPCP Requirement: Hidden Participants
> > > > > 
> > > > > 
> > > > > 
> > > > > 
> > > > > > -----Original Message-----
> > > > > > From: ext Michael Hammer [mailto:[email-masked]]
> > > > > > Sent: 15.December.2003 18:17
> > > > > > To: Khartabil Hisham (NMP-MSW/Helsinki)
> > > > > > Cc: [email-masked]
> > > > > > Subject: Re: [XCON] CPCP Requirement: Hidden Participants
> > > > > > 
> > > > > > 
> > > > > > Related to this is there a requirement that, while not 
> > > > > revealing the 
> > > > > > identity of a hidden user, the conference policy contains 
> > > > > > state indication 
> > > > > > about either the presence of hidden users, or the 
> > > > > > possibility/preclusion 
> > > > > > that such hidden users may be present?
> > > > > > 
> > > > > > I am anticipating that:
> > > > > > 1) Laws may exist that require notification of such.
> > > > > 
> > > > > That's a good point. This might require changes to the 
> > > > > conference event package to indicate if there are hidden 
> > > > > participants or not, and if so, how many.
> > > > > 
> > > > > The question remain: is there a need for such a feature (to 
> > > > > hide users?)?
> > > > > 
> > > > > Regards,
> > > > > Hisham
> > > > > 
> > > > > > 2) In some conferences, participants may want technical 
> > > > > > assurance that 
> > > > > > hidden users are not possible before they speak.
> > > > > > 
> > > > > > Mike
> > > > > > 
> > > > > > 
> > > > > > At 02:55 PM 12/15/2003 +0200, 
> > [email-masked] wrote:
> > > > > > >This is in reference to requirements REQ-A7 and REQ-E10 in 
> > > > > > 
> > > > 
> > 
>http://www.ietf.org/internet-drafts/draft-ietf-xcon-cpcp-reqs-00.txt
> > > >
> > > >    REQ-A7: It SHOULD be possible to participate in a 
> > conference as a
> > > >    hidden user. Hidden user is present in a conference, but 
> > > his presence
> > > >    is not revealed.
> > > >
> > > >    REQ-E10: It MUST be possible to allow and disallow 
> > > hidden membership
> > > >    in a conference.
> > > >
> > > >Should a conference policy, using CPCP, specify if a user 
> > > can be hidden? 
> > > >This means that the conference state package does not report the 
> > > >participation on the hidden user. CPCP is used to identify 
> > > which users are 
> > > >hidden. The list of hidden users is only manipulated by a 
> > > privileged user 
> > > >such as the moderator.
> > > >
> > > >Regards,
> > > >Hisham
> > > >
> > > >_______________________________________________
> > > >XCON mailing list
> > > >[email-masked]
> > > >https://www1.ietf.org/mailman/listinfo/xcon
> > > 
> > > 
> > 
> > _______________________________________________
> > XCON mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/xcon
> > 
> > _______________________________________________
> > XCON mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/xcon
> > 
> > 
> 
> 
> _______________________________________________
> XCON mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/xcon
> 
> _______________________________________________
> XCON mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/xcon
> 

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: Rohan Mahy <[email-masked]>
Date: Tue, 10 Feb 2004 10:45:42 +0100

Well, (hidden) announcement servers are already invited to basic 
conferences today, so clearly this is not a wacky future requirement.  
I don't really see what the big deal is in terms of complexity of 
implementation/specification, but perhaps you can fill me in sometime 
at SIPit.

thx,
-r

On Tuesday, February 10, 2004, at 09:00  AM, 
<[email-masked]> wrote:

> We are all creative here and can come up with many use cases and 
> features, but there is a line that we have to draw in order to get 
> something finished. We're aiming at basic conferencing first.
>
> /Hisham
>
>> From: ext Rohan Mahy [mailto:[email-masked]]
>> Sent: 10.February.2004 02:20
>> To: Eric Burger
>> Cc: Khartabil Hisham (Nokia-TP/Helsinki); [email-masked]
>> Hi,
>> I believe there are plenty of uses for hidden participants.  A robot
>> that announces folks when they enter or whispers things to you in a
>> sidebar via IM should be hidden.  They detract from my view of who is
>> there.  This is very different from anonymous.
>>
>> thx,
>> -rohan
>>
>>
>>>> Sent: Wednesday, February 04, 2004 5:33 AM
>>>> To: [email-masked]; [email-masked]; Eric Burger; [email-masked]
>>>> I agree with Keith. That's why we removed hidden participants
>>>> and are content with anonymous. Legal interception can be
>>>> local implementation and policy.
>>>>
>>>> /Hisham
>>>>
>>>>> From: [email-masked] [mailto:[email-masked]]On
>>>> Behalf Of ext
>>>>> Drage, Keith (Keith)
>>>>> Sent: 04.February.2004 11:47
>>>>> To: Cullen Jennings; Eric Burger; XCON-IETF
>>>>> In the current mechanisms I know of for supporting legal
>>>>> intercept (in 3GPP), the interceptor would not even be a
>>>>> participant, therefore I am not convinced that this is
>>>>> relevant to the issue of hidden participants anyway.
>>> [snip]
>>>
>>>

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Sun, 29 Feb 2004 01:03:43 -0000

It would have been better that you replied to one of the later messages in this thread.

Your comments make it look like my own comments below refer to legal intercept, when they do not. We have already agreed that hidden participants are nothing to do with legal intercept.

regards

Keith