Subject: [XCON] Open Issue: Hidden Participants

From: Adam Roach <[email-masked]>
Date: Mon, 8 Mar 2004 14:04:10 -0600

[as chair]

At the XCON meeting, there was a rather lively discussion
that continued the "Hidden Participants" discussion that
had started on the list. It was agreed that the topic was
worth discussion, but that we did not have enough time to
pursue it in the meeting.

I'm calling on everyone, especially those involved in the
meeting discussion (Rohan, Alan, Eric, Roni, Hisham, Dave)
to continue this discussion so we can close this issue
in the near future. Alan and I would like to be able to
last-call this document shortly, and this is the key issue
that needs to be resolved before a new revision of the
draft can be produced.

/a

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: "Kozdon, Peter" <[email-masked]>
Date: Mon, 8 Mar 2004 15:27:36 -0800

Hidden listeners operation is probably illegal in many US states as well as
in many countries - when you make a call there is a requirement in
California the all parties are aware of the presence of a 3rd party or
recording device, note- that party may be anonymous, etc.. (Exception --
legal intercept.)

We should follow the similar logic for XCON - provide an indication of a
recording device and/or anonymous participant's) 

Peter Kozdon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adam
Roach
Sent: Monday, March 08, 2004 12:04 PM
To: [email-masked]'
Subject: [XCON] Open Issue: Hidden Participants

[as chair]

At the XCON meeting, there was a rather lively discussion that continued the
"Hidden Participants" discussion that had started on the list. It was agreed
that the topic was worth discussion, but that we did not have enough time to
pursue it in the meeting.

I'm calling on everyone, especially those involved in the meeting discussion
(Rohan, Alan, Eric, Roni, Hisham, Dave) to continue this discussion so we
can close this issue in the near future. Alan and I would like to be able to
last-call this document shortly, and this is the key issue that needs to be
resolved before a new revision of the draft can be produced.

/a

---

From: "Eric Burger" <[email-masked]>
Date: Tue, 9 Mar 2004 15:28:20 -0500

I think we got caught up on the name.

There are two needs.

The first, which I think we may have consensus on, is the need for anonymous participants.  That is, participants that are present in the conference, but do not have their identities revealed.

The second, which is more blurry, is the need for participants that are truly hidden.  Some want to use hidden participants for automatons, e.g., IVR systems or conference recorders.  (IMHO, bad idea, but that is really just MHO, not strictly black-and-white.)

We do have consensus that Lawful Intercept is entirely orthogonal to conference participants.  However, the logic of the above follows.  Just as IVR systems or conference recorders are not really participants, neither is LI hardware.  If we say that the approach for IVR is to plumb in as a hidden participant, then LI would have the same approach.  If we say that IVR is something different, e.g., just a part of the conference mixer, then it is truly "not there".  Likewise, I would expect LI to be "not there" -- something outside the XCON framework entirely.

> From: Kozdon, Peter [mailto:[email-masked]]
> Sent: Monday, March 08, 2004 6:28 PM
> To: [email-masked]'
> Subject: RE: [XCON] Open Issue: Hidden Participants
> 
> 
> that continued the
> meeting discussion
> that needs to be

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Wed, 10 Mar 2004 00:28:22 -0000

See below

Keith

> From: Eric Burger [mailto:[email-masked]]
> Sent: 09 March 2004 20:28
> To: Kozdon, Peter; [email-masked]
snipped
> 
> 
> We do have consensus that Lawful Intercept is entirely 
> orthogonal to conference participants.  However, the logic of 
> the above follows.  Just as IVR systems or conference 
> recorders are not really participants, neither is LI 
> hardware.  If we say that the approach for IVR is to plumb in 
> as a hidden participant, then LI would have the same 
> approach.  If we say that IVR is something different, e.g., 
> just a part of the conference mixer, then it is truly "not 
> there".  Likewise, I would expect LI to be "not there" -- 
> something outside the XCON framework entirely.
> 
The test to me is does the entity follow the rules for joining the conference that any other participant has to. Lawful Intercept certainly does not.

I would agree with you that there is a case for IVR systems and conference recorders being automatically included as part of the conference function, and therefore they are not participants in the conference. Is it possible that such devices could also, for example, be referred in as normal participants. I'm in a conference, and suddenly decide that the current portion of the call should be recorded, and therefore send the appropriate REFER causing the recording device to join as a participant.

---

From: "Eric Burger" <[email-masked]>
Date: Wed, 10 Mar 2004 13:31:36 -0500

I like it (hidden indicator)!

> From: Paul Kyzivat [mailto:[email-masked]]
> Sent: Wednesday, March 10, 2004 1:30 PM
> To: Eric Burger
> Cc: Drage, Keith (Keith); [email-masked]
> Subject: Re: [XCON] Open Issue: Hidden Participants
> 
> 
> Eric,
> 
> I think there are two distinct cases here that are getting mixed:
> 
> - participants that wish to remain unobserved
> - participants that watchers may want to ignore
> 
> The former is the case that is similar to legal intercept. Other than 
> permitting anonymous participants to register (or not) I don't think 
> anything needs to be done to support this.
> 
> I think Rohan was concerned about the latter. This need can 
> be satisfied 
> by ensuring that the participant list is annotated with enough 
> attributes so that a watcher can choose to suppress the 
> display of those 
> participants that are uninteresting to its user. AFAIK there are no 
> regulatory issues in this.
> 
> So, if participants that are recorders or IVRs are 
> identifiable as such, 
> then a watcher *may* choose to hide the display of them. This 
> would be 
> strictly a UI implementation issue for a particular client.
> 
> 	Paul
> 
> Eric Burger wrote:
> > We are always free to invite in a machine.  The question is 
> whether that is a fundamental, architectural decision for how 
> to do IVR, and thus *requires* them to be hidden, or is it 
> just something a user or moderator can do (just REFER or 
> INVITE them to the conference).
> > 
> > If you believe it is a fundamental need, then they must be 
> hidden, to make user interfaces for the bulk of 
> implementations reasonable.
> > 
> > If you believe it is just a convenience (which is my 
> personal stand), then they don't need to be totally hidden.
> > 
> > Frankly, IMHO it is a style choice, so I will accept the 
> consensus, either way it goes.
> > 
> > 
> >>From: Drage, Keith (Keith) [mailto:[email-masked]]
> >>Sent: Tuesday, March 09, 2004 7:28 PM
> >>To: Eric Burger; Kozdon, Peter; [email-masked]
> >>The test to me is does the entity follow the rules for 
> >>joining the conference that any other participant has to. 
> >>Lawful Intercept certainly does not.
> >>
> >>I would agree with you that there is a case for IVR systems 
> >>and conference recorders being automatically included as part 
> >>of the conference function, and therefore they are not 
> >>participants in the conference. Is it possible that such 
> >>devices could also, for example, be referred in as normal 
> >>participants. I'm in a conference, and suddenly decide that 
> >>the current portion of the call should be recorded, and 
> >>therefore send the appropriate REFER causing the recording 
> >>device to join as a participant.
> >>
> >>
> >>
> > 
> > 
> >

---

From: "Kozdon, Peter" <[email-masked]>
Date: Wed, 10 Mar 2004 18:49:48 -0800

I agree that automatons are processing resources and could be considered as
logical parts of the conference fabric, for example an IVR could monitor the
conference and provide a trigger in response to a phrase that could be
consumed elsewhere. Similarly a device that announces participants, etc..
However, IMHO a conference recorder does not fall into this category and
should probably be a visible resource maybe with an indicator to show
whether it is or is not active. Similarly - a player resources which
delivers content or information to the conference should also be visible -
it seems desirable to know where such content is coming from.

-----Original Message-----
From: Eric Burger [mailto:[email-masked]] 
Sent: Tuesday, March 09, 2004 1:28 PM
To: Kozdon, Peter; [email-masked]
Subject: RE: [XCON] Open Issue: Hidden Participants

There are two needs.

The first, which I think we may have consensus on, is the need for anonymous
participants.  That is, participants that are present in the conference, but
do not have their identities revealed.

The second, which is more blurry, is the need for participants that are
truly hidden.  Some want to use hidden participants for automatons, e.g.,
IVR systems or conference recorders.  (IMHO, bad idea, but that is really
just MHO, not strictly black-and-white.)

We do have consensus that Lawful Intercept is entirely orthogonal to
conference participants.  However, the logic of the above follows.  Just as
IVR systems or conference recorders are not really participants, neither is
LI hardware.  If we say that the approach for IVR is to plumb in as a hidden
participant, then LI would have the same approach.  If we say that IVR is
something different, e.g., just a part of the conference mixer, then it is
truly "not there".  Likewise, I would expect LI to be "not there" --
something outside the XCON framework entirely.

> Hidden listeners operation is probably illegal in many US states as 
> well as in many countries - when you make a call there is a 
> requirement in California the all parties are aware of the presence of 
> a 3rd party or recording device, note- that party may be anonymous, 
> etc..
> (Exception --
> legal intercept.)
> 
> We should follow the similar logic for XCON - provide an indication of 
> a recording device and/or anonymous participant's)
> 
> Peter Kozdon
> 
> 
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf Of 
> Adam Roach
> At the XCON meeting, there was a rather lively discussion that 
> continued the "Hidden Participants" discussion that had started on the 
> list. It was agreed that the topic was worth discussion, but that we 
> did not have enough time to pursue it in the meeting.
> 
> I'm calling on everyone, especially those involved in the meeting 
> discussion (Rohan, Alan, Eric, Roni, Hisham, Dave) to continue this 
> discussion so we can close this issue in the near future. Alan and I 
> would like to be able to last-call this document shortly, and this is 
> the key issue that needs to be resolved before a new revision of the 
> draft can be produced.
> 
> /a
>