Subject: [XCON] CPCP Originator URI

From: "Jani, Manish" <[email-masked]>
Date: Wed, 21 Apr 2004 19:25:30 -0700

How is URI of the originator who made CPCP request is constructed?
 
Consider following example:
 
If an application want to specify additional privilege to modify ACL,
say RIGHT_TO_MODIFY_ACL then Policy would like 
<PCL-target>
    <PCL-target-URI>sip:[email-masked]</PCL-target-URI>
    <Privileges>RIGHT_TO_MODIFY_ACL</Privileges>
</PCL-target>
 
Now when Alice wants to modify ACL, would make CPCP request like 
      PUT
http://xcap.example.com/services/conferences/users/Alice/conference.xml?
         Conference/ACL/ACL-target-URI HTTP/1.1
         Content-Type:text/plain

      <ACL-target-URI
Access-type="Expelled">sip:[email-masked]</ACL-target-URI>

How would CPCP implementation find out the URI of the originator, in
this case, sip:[email-masked] in order to determine if the originator
is allowed to modify ACL?
 
- Option 1: Can get User name (Alice) and domain name (example.com) and
put keyword "sip:" in front (sip:[email-masked]). This is not a clean
way. Also this will break if http request contains IP address instead of
domain name.
- Option 2: Specify in http request by name value pair.
 
Thanks,
Manish

---

From: [email-masked]
Date: Thu, 22 Apr 2004 10:00:28 +0300

The privilege you talk about will not be handled this way. But in any case, the conference policy server will need to assert the identity of the user using, for example, HTTP digest. It can then map it to the sip address.
 
Regards,
Hisham

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of ext Jani, Manish
Sent: 22.April.2004 05:26
To: [email-masked]
Subject: [XCON] CPCP Originator URI

If an application want to specify additional privilege to modify ACL, say RIGHT_TO_MODIFY_ACL then Policy would like 
<PCL-target>
    <PCL-target-URI>sip:[email-masked]</PCL-target-URI>
    <Privileges>RIGHT_TO_MODIFY_ACL</Privileges>
</PCL-target>
 
Now when Alice wants to modify ACL, would make CPCP request like 
      PUT http://xcap.example.com/services/conferences/users/Alice/conference.xml?
         Conference/ACL/ACL-target-URI HTTP/1.1
         Content-Type:text/plain

      <ACL-target-URI Access-type="Expelled">sip:[email-masked]</ACL-target-URI>

How would CPCP implementation find out the URI of the originator, in this case, sip:[email-masked] in order to determine if the originator is allowed to modify ACL?
 
- Option 1: Can get User name (Alice) and domain name (example.com) and put keyword "sip:" in front (sip:[email-masked]). This is not a clean way. Also this will break if http request contains IP address instead of domain name.
- Option 2: Specify in http request by name value pair.
 
Thanks,
Manish