Subject: [XCON] Comments on draft-ietf-xcon-floor-control-req-00

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Fri, 2 Apr 2004 15:54:41 +0100

I have the following comments on the above document.

1)	I understand that it has been discussed to group the requirements. I would suggest that the appropriate grouping would be in the following categories.

a)	requirements relating to floor control protocol between floor participant and floor control server
b)	requirements relating to floor control protocol between floor chair and floor control server
c)	requirements relating to management of the floor control server by the conference server.
I would suggest allocating the existing requirements as follows:
a)	REQ-5, REQ-6, REQ-8, REQ-10, REQ-12, REQ-13, REQ-14, REQ-17, REQ-18, REQ-19, REQ-a
b)	REQ-7, REQ-9, REQ-11, REQ-17, REQ-18, REQ-19, REQ-20, REQ-b
c)	REQ-1, REQ-2, REQ-3, REQ-4, REQ-15, REQ-16

2)	In REQ-6, As phrased this requirement is a floor participant requirement. The second sentence actually identifies a further missing requirement that this additional information, if available, MUST be give to the floor chair.

3)	In REQ-11, does the revoke also apply to a member of the floor control set, and thus remove that participant from the set? This is not a request for it to be a requirement to do so, merely to make clear what happens in this case.

4)	In REQ-18, it may not be necessary to allow all participants to request information about floor control requests. This may be information that is better reserved to the floor chair.

5)	In REQ-19, it may not be necessary to notify all participants about floor control requests. This may be information that is better reserved to the floor chair.

6)	Notifications to participants, and the floor chair, are controlled by CPCP. We need a new requirement to indicate that this is so, and that such control can be excercised on a per participant basis.

7)	There should be a new requirement that the floor chair can clear the current floor control set. Currently the only way the floor chair can manage the floor according to the requirements is to grant the floor and then revoke it, or to use CPCP to delete the floor entirely. If the floor chair, for example, wants to move on to the next agenda item, then then the requests of those waiting are no longer appropriate, and a new floor control set will need to be built up.

8)	Conferences can be cascaded, such that a participant of the conference can be a conference in its own right. This has equivalent impact on floors and the associated floor control servers. There should be some guidelines on what is acceptable from a fllor control perspective at day 1, and what might be left to further study.

9)	Do we require a security considerations section?

regards

Keith

Keith Drage
Lucent Technologies
[email-masked]
tel: +44 1793 776249

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: Michael Hammer <[email-masked]>
Date: Mon, 05 Apr 2004 11:40:08 -0400

At 03:54 PM 4/2/2004 +0100, Drage, Keith (Keith) wrote:
>4)      In REQ-18, it may not be necessary to allow all participants to 
>request information about floor control requests. This may be information 
>that is better reserved to the floor chair.
>
>5)      In REQ-19, it may not be necessary to notify all participants 
>about floor control requests. This may be information that is better 
>reserved to the floor chair.

Could someone clarify that the floor control requests are status elements 
visible in a specific view to the floor chair at least until they are 
granted or denied (cleared)?

What I am concerned about is the ability for a floor chair to drop out of a 
conference and for another participant to pick up as 
"vice-chair".  Presumable, requests that have been made prior to the 
transition, but not acted upon will be transferrable.

Mike

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Tue, 6 Apr 2004 09:48:22 +0100

My understanding of the way this works is that all floor requests are contained in the "floor control set".

Any change of floor control chair is handled by CPCP, but this does not need to have an impact on the contents of the floor control set. (As far as floor control is concerned, users are either chairs or participants, there is no concept of vice chair). Of course CPCP could also remove the floor entirely and all sorts of other floor modifications in between.

Any chair, including a new chair recently allocated by CPCP (or according to the current requirements any participant) can review the current floor control set, and therefore allocate a vacant floor to an entry in the floor control set.

Note there is also nothing that prevents more than one chair to a floor, so this change of floor chair could also be handled by mutual agreement, outside the CPCP and the floor control protocol, directly between existing floor chairs.

regards

Keith

> -----Original Message-----
> From: Michael Hammer [mailto:[email-masked]]
> Sent: 05 April 2004 16:40
> To: Drage, Keith (Keith)
> Cc: [email-masked]
> Subject: Re: [XCON] Comments on draft-ietf-xcon-floor-control-req-00
> 
>