Subject: [XCON] CPCP issue 13: floor control policy

From: [email-masked]
Date: Thu, 20 May 2004 18:43:01 +0300

This is not really an open issue, but I wanted to bring your attention to what is currently defined for the floor control policy and to see if there is anything missing. The currently defined satisfies all requirements in CPCP-reqs draft.

Currently defined:

"This element has its own XML namespace.  The absence of this
   namespace and its elements from an XML document indicates that the
   conference does not have a floor.

   The <Conference-floor-policy> is mandatory and contains the required
   boolean attribute that indicates if the floor is moderator controlled
   or not.  One or more <Floor> elements can appear in the
   <Conference-floor-policy> element.  The number of those elements
   indicates how many floors the conference can 	have.  A floor can be
   used for one or more media types; the mandatory <Media-types> element
   can contain zero or more of the <Video>, <Audio>, <Application>,
   <Data> ,<Control>, <Message>, and <text> elements indicating the
   media of the floor.  One type of media can only appear 	once.  Other
   media types can be defined by extensions.

   A floor can be controlled using many algorithms; the mandatory
   <Algorithm> element MUST contain one and only of the
   <Moderator-controlled>, <FCFS>, and <Random> elements indicating the
   algorithm.

   The <Max-floor-users> element in the <Floor> element is optional and,
   if present, dictates the maximum number of users who can have the
   floor at one time.  The optional <Moderator-URI> indicates the URI of
   the moderator.  It MUST be set if the attribute moderator-controlled
   is set to "true"."

Regards,
Hisham

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: Adam Roach <[email-masked]>
Date: Fri, 21 May 2004 14:57:43 -0500

I might have gotten the wrong model in my head, but I think
there are two correlators missing in here.

From one side, we need to bind the media streams in the CPCP
with media streams used in the session. From the other, you
need to bind the floor control protocol with the floors
in the CPCP.

For example (and I'm going to use SDP as my example session
description protocol), if you have a session that looks
like this:

        v=0
        o=example 2890844526 2890842807 IN IP4 126.16.64.4
        s=SDP Seminar
        c=IN IP4 224.2.17.12/127
        m=audio 49170 RTP/AVP 0
        a=mid:1
        m=video 51372 RTP/AVP 31
        a=mid:2
        m=video 64202 RTP/AVP 31
        a=mid:3

...and a CPCP document that looks like this:

  	<conference-fp:Conference-floor-policy>
   		<Floor>
   			<Media-types>
   				<Audio/>
   				<Video/>
   			</Media-types>
   			<Algorithm>
   				<FCFS/>
   			</Algorithm>
   		</Floor>
   		<Floor moderator-controlled="true">
   			<Media-types>
   				<Video/>
   			</Media-types>
   			<Algorithm>
   				<Moderator-controlled/>
   			</Algorithm>
   			<Moderator-URI>sip:[email-masked]</Moderator-URI>
   		</Floor>
   	</conference-fp:Conference-floor-policy>

...then you've got two missing links.

The first one is: Which video stream corresponds to the FCFS floor?
Which one corresponds to the moderator-controlled one?

The second is: how does one request and receive information about
each of the two floors? Even if this document does not hand out
specific connection information (such as a bfcp: URL), it still
needs to somehow correlate each floor with such information.

Talking off the top of my head, it seems that both issues could be
addressed by adding appropriate attributes to the XML. As a strawman,
I'll throw out the following:

 - Add a "mid" attribute to each media type in the <Media-types/> section.
 - Add a "floor-control" attribute to each floor that contains information
   necessary for working with the floor.

For example:

  	<conference-fp:Conference-floor-policy>
   		<Floor
floor-control="bfcp://floorcontroller.example.com/53280">
   			<Media-types>
   				<Audio mid="1" />
   				<Video mid="3" />
   			</Media-types>
   			<Algorithm>
   				<FCFS/>
   			</Algorithm>
   		</Floor>
   		<Floor
floor-control="bfcp://floorcontroller.example.com/53281">
   			<Media-types>
   				<Video mid="2" />
   			</Media-types>
   			<Algorithm>
   				<Moderator-controlled/>
   			</Algorithm>
   			<Moderator-URI>sip:[email-masked]</Moderator-URI>
   		</Floor>
   	</conference-fp:Conference-floor-policy>

I realize that this usage raises at least as many issues as it attempts
to solve (e.g. how do you distribute BFCP user IDs? Do we want to require
MIDs to identify streams?), but I wanted to throw out a strawman to get
people thinking about the issue.

/a

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, May 20, 2004 10:43
> To: [email-masked]
> Subject: [XCON] CPCP issue 13: floor control policy
> 
> 
> This is not really an open issue, but I wanted to bring your 
> attention to what is currently defined for the floor control 
> policy and to see if there is anything missing. The currently 
> defined satisfies all requirements in CPCP-reqs draft.
> 
> Currently defined:
>