Subject: [XCON] CPCP issue 1: External Lists in CPCP

From: [email-masked]
Date: Thu, 20 May 2004 18:37:40 +0300

There has been suggestions that external lists can be placed as a resource in the conference policy dial-out list or dial-in list.

In the dial-out case, the external list (or its participants, to be more accurate) can be invited into the conference by the focus in 2 ways:

1. The creator of the conference places the XCAP URI for the external list URI (assuming that the list was created using the XCAP list usage) into Dial-out list. When it is time for the focus to invite users into the conference, the focus uses the XCAP list URI to fetch the URIs for the members of the external list. It then sends INVITE (in SIP terms) to the members of that external list. This results in all participants connected to one focus.

2. The creator of the conference places the SIP URI of the external list into the Dial-out list. When it is time for the focus to invite users into the conference, the focus sends INVITE to the all the members of that dial-out list, including an INVITE to the external list. This INVITE may result in another cascaded conference being created.

Which scenario is more appealing to people. The 3rd option of course is to disable this feature.

In the dial-in case, 2 ways are also possible:

1. The XCAP URI for the external list is placed. This enables the focus to fetch the member URIs in order to determine if a user is allowed to participate in a conference or not.

2. The SIP URI for the external list is placed. The focus then only accepts participation from the group (they could create a separate conference and try to cascade it into this conference).

Again, the 3rd option here is to disable this feature.

I am leaning towards option 1 in both cases. But this introduces another complexity: What if the external list membership changes? Should the focus react in any way. My proposal for an answer to this problem is no, the focus does not react in any way. The focus only deals with the copy it fetched. This copy is not persistent. I.e. If a second conference occurrence happens, the focus will be required to fetch a copy of the external list again.

Comments?

Regards,
Hisham

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: Adam Roach <[email-masked]>
Date: Thu, 20 May 2004 16:59:04 -0500

[not as chair]

[email-masked] [mailto:[email-masked]] wrote:

> I am leaning towards option 1 in both cases. But this 
> introduces another complexity: What if the external list 
> membership changes? Should the focus react in any way. My 
> proposal for an answer to this problem is no, the focus does 
> not react in any way.

Why not? XCAP includes an event package that can be used to
find out when an XCAP document has been updated. I don't see
any obvious justification for operating with stale data when
mechanisms exist to keep it fresh.

I'm not saying that I necessarily disagree with you as much as
I'd like you to explain the logic behind your proposal, since
it's kind of counterintuitive (to me, at least).

/a

---

From: [email-masked]
Date: Fri, 21 May 2004 09:10:30 +0300

> -----Original Message-----
> From: ext Adam Roach [mailto:[email-masked]]
> Sent: 21.May.2004 00:59
> To: Khartabil Hisham (Nokia-TP-MSW/Helsinki); [email-masked]
> Subject: RE: [XCON] CPCP issue 1: External Lists in CPCP
> 
> 
> [not as chair]
> 

Just to reduce complexity at the focus, nothing more. I don't have strong feelings either way.

/Hisham