Subject: [XCON] CPCP issue 11: Relating a sidebar to a conference

From: [email-masked]
Date: Thu, 20 May 2004 18:42:25 +0300

There are some requirements for sidebars. An example requirement is that the audio is the main conference can appear in the sidebar in the background with a lower volume than the conversation that is taking place in the sidebar. Another requirement is that only the current participants in the main conference can join or be invited into a side bar.

A sidebar is thought of as a separate conference with it's own conference URI. In order to satisfy the requirements, the following is an idea for creating a side bar using conference policy:

- A user creating a sidebar must include the main conference as a participant. This is achieved by adding the main conference URI to the dial-out list or to the list of potential participants to be referred.
- The sidebar focus then either dials out (invites) the main conference into the side bar or refers it.
- The media policy that is part of the conference policy indicates that the main conference audio, for example, has a lower volume than the rest of the participants
- The main conference focus learns that there is a sidebar to it because it was invited to join the sidebar (another conference)
- The focus of the main conference MUST only accept invitations (or refers) to join a sidebar after it has examined the sidebar's participants' lists (DL, ACL) and concluded that all sidebar participants and creator are in fact participants of the main conference. It can also learn the sidebar's participant list by subscribing to the conference state event package

Some sidebars are created in an ad hoc manner. I.e. a conference policy is not created. In this case creating a sidebar is performed as follows:

- A user creating a sidebar must refer or invite users to join the side bar, using SIP or other protocol means
- That user then refers the main conference to the sidebar is includes the main conference in the invitations that it sent to participants to join the sidebar
- The main conference focus learns that there is a sidebar to it because it was invited to join the sidebar (another conference)
- The focus of the main conference MUST only accept invitations (or refers) to join a sidebar after it has examined the sidebar's participants' lists and concluded that all sidebar participants and creator are in fact participants of the main conference. It can do that by subscribing the conference state event package

Comments or other ideas?

Regards,
Hisham

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 21 May 2004 09:54:58 -0400

I've been fighting the idea that a sidebar is a separate conference since
the idea first was proposed.  One of the main reasons given for making
it a separate conference is that non main conference participants
were needed in a sidebar.  If you are going to prohibit someone not
in the main conference from being in the sidebar, then I want to
re-examine the idea that the sidebar is a separate conference.

It's not if non main conference participants are excluded - it's a mixing
state.  You can completely simulate a sidebar with mixing commands (media
policy) if you have a subset of the main conference participants.

Brian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, May 20, 2004 11:42 AM
> To: [email-masked]
> Subject: [XCON] CPCP issue 11: Relating a sidebar to a conference
> 
> 
> There are some requirements for sidebars. An example 
> requirement is that the audio is the main conference can 
> appear in the sidebar in the background with a lower volume 
> than the conversation that is taking place in the sidebar. 
> Another requirement is that only the current participants in 
> the main conference can join or be invited into a side bar.
> 
> A sidebar is thought of as a separate conference with it's 
> own conference URI. In order to satisfy the requirements, the 
> following is an idea for creating a side bar using conference policy:
> 
> - A user creating a sidebar must include the main conference 
> as a participant. This is achieved by adding the main 
> conference URI to the dial-out list or to the list of 
> potential participants to be referred.
> - The sidebar focus then either dials out (invites) the main 
> conference into the side bar or refers it.
> - The media policy that is part of the conference policy 
> indicates that the main conference audio, for example, has a 
> lower volume than the rest of the participants
> - The main conference focus learns that there is a sidebar to 
> it because it was invited to join the sidebar (another conference)
> - The focus of the main conference MUST only accept 
> invitations (or refers) to join a sidebar after it has 
> examined the sidebar's participants' lists (DL, ACL) and 
> concluded that all sidebar participants and creator are in 
> fact participants of the main conference. It can also learn 
> the sidebar's participant list by subscribing to the 
> conference state event package
> 
> Some sidebars are created in an ad hoc manner. I.e. a 
> conference policy is not created. In this case creating a 
> sidebar is performed as follows:
> 
> - A user creating a sidebar must refer or invite users to 
> join the side bar, using SIP or other protocol means
> - That user then refers the main conference to the sidebar is 
> includes the main conference in the invitations that it sent 
> to participants to join the sidebar
> - The main conference focus learns that there is a sidebar to 
> it because it was invited to join the sidebar (another conference)
> - The focus of the main conference MUST only accept 
> invitations (or refers) to join a sidebar after it has 
> examined the sidebar's participants' lists and concluded that 
> all sidebar participants and creator are in fact participants 
> of the main conference. It can do that by subscribing the 
> conference state event package
> 
> Comments or other ideas?
> 
> Regards,
> Hisham
>

---

From: Alan Johnston <[email-masked]>
Date: Fri, 21 May 2004 09:42:27 -0500

>re-examine the idea that the sidebar is a separate conference.

According the conferencing framework, a sidebar is not a separate conference.

>policy) if you have a subset of the main conference participants.

I agree.

> > following is an idea for creating a side bar using conference policy:

No - a sidebar does have its own URI, but it is an alias for the main 
conference.  It resolves to the same focus as the main conference, but 
invokes a different media policy - ie mixing.

> > conference into the side bar or refers it.

No - see the conferencing framework - this is not at all how sidebars work.

> > conference state event package

No - they are not separate conferences.  Sidebars are about special mixing 
cases - none of these things should happen.

Sidebars will mainly be dealt with in the media policy work.  However, CPCP 
must have a way of requesting the focus create a sidebar (assign a URI) and 
the ability to add participants (both participants within the conference 
and users not in the conference).

Thanks,
Alan Johnston
MCI
sip:[email-masked]
(not as chair)