Subject: [XCON] CPCP issue 15: Start/Stop times

From: [email-masked]
Date: Thu, 20 May 2004 18:44:15 +0300

Currently conference start time and stop time can only be represented as follows and do not satisfy the recently agreed requirements:

   	<conference-time:Conference-time>
   		<Conference-occurrence>
   			<Start-time>2003-06-16T10:00:00Z</Start-time>
   			<Stop-time>2003-06-16T12:00:00Z</Stop-time>
   		</Conference-occurrence>
   	</conference-time:Conference-time>

In order to satisfy the requirements, the following is proposed:

-   REQ-A9: It MUST be possible to define the time when media mixing may
   start ("don't-mix-before-time") and stop ("cannot-continue-after")
   operating in the conference.

Change <Start-time> and <Stop-time> to <Mixing-start-time> and <Mixing-stop-time>

-    REQ-A10: It MUST be possible to define the time after which users are
   allowed to join the conference.

Introduce <Can-join-after> element

-   REQ-A11: It MUST be possible to define the time after which new users
   are not allowed to join the conference anymore.

Introduce <Must-join-before> element

-    REQ-A12: It MUST be possible to define the time when users or
   resources on the dial-out list are invited to join the conference.

Introduce <Invite-users> elements

-    REQ-A13: It MUST be possible define whether the conference can be
   extended. Note: This does not guarantee that resources are available.

This can be achieved by documenting that <Mixing-stop-time> can be changed to later time

-   REQ-A15a: It MUST be possible to define when media mixing starts
   based on the latter of the mixing start time, and the time the first
   participant arrives.

   REQ X15b: It MUST be possible to define when media mixing starts
   based on the latter of the mixing start time, and the time the first
   key participant arrives.

Introduce attribute 'require-participant' in <Mixing-start-time> with values "key-participant" and "participant".

-    REQ-A16a: It MUST be possible to define when media mixing stops based
   on the earlier of the mixing stop time, and the time the last
   participant leaves the conference.

   REQ-A16b: It MUST be possible to define when media mixing stops based
   on the earlier of the mixing stop time, and the time the last key
   participant leaves.

   REQ-A16c: It MUST be possible to define when media mixing stops based
   on the time only.

Introduce attribute 'require-participant' in <Mixing-stop-time> with values "key-participant" and "participant".

-    REQ-A17: It MUST be possible to define that the users and resources
   on the dial-out list are invited only after first key participant has
   joined.

Introduce attribute 'require-participant' in <Invite-users> with values "key-participant" and "participant".

An example:

   	<conference-time:Conference-time>
   		<Conference-occurrence>
   			<Mixing-start-time require-participant="key-participant">2003-06-16T10:00:00Z</Start-time>
   			<Mixing-stop-time require-participant="participant">2003-06-16T12:00:00Z</Stop-time>
   			<Can-join-after>2003-06-16T09:55:00Z</Can-join-after>
  			<Must-join-before>2003-06-16T10:30:00Z</Must-join-before>
    			<Invite-users require-participant="key-participant">2003-06-16T09:55:00Z</Invite-users>
   		</Conference-occurrence>
   	</conference-time:Conference-time>

Regards,
Hisham

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: Adam Roach <[email-masked]>
Date: Mon, 24 May 2004 07:36:12 -0500

[not as chair]

[email-masked] [mailto:[email-masked]] wrote:

> Introduce attribute 'require-participant' in <Invite-users> 
> with values "key-participant" and "participant".

I think this might be a bit confusing. Consider a conference
that is composed purely of dial-out participants, and there
are no key participants. With the values you propose, it sounds
like such a conference could never be made to exist. That is,
the most liberal policy (require-participant="participant")
*sounds* like it requires a user to be in the conference
before any of the dial-out participants are contacted.

You either need more values, or a lot of explanation around
the semantics of require-participant="participant".

/a