Subject: [XCON] draft-srinivasan-xcon-eventpkg-extensions

From: Cullen Jennings <[email-masked]>
Date: Sat, 10 Mar 2007 12:49:53 -0800

It's hard to read this draft and have enough context to fully  
understand what is going on here - a bit more background would  
probably help people understand it better.

Cullen

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: Srivatsa Srinivasan <[email-masked]>
Date: Mon, 12 Mar 2007 09:42:57 -0700

Sure, the motivation for this draft is described in the Limitations section and we can re-word it to make it easier to read in the next revision. Was there anything in specific that you thought could be described better?

The primary motivation for defining a new MIME sub-type here is to overcome the two limitations that prevent the XCON data model to be fully backward compatible with the schema in the SIP conference event package RFC 4575.

An example may help. The <controls> element under <available-media> defined in the XCON data model may have many controls. Each time a control changes, a notification would be generated for users interested in those changes (who have an active subscription to the conference event package). Since <available-media> does not have a state attribute defined, without the change proposed in this draft, the whole XML element would be sent with every single change that happens to every control under <available-media>. In addition, certain schema elements in the SIP conference event package have been re-defined.

Thanks,
Srivatsa.

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]]
> Sent: Saturday, March 10, 2007 12:50 PM
> To: [email-masked]
> Subject: [XCON] draft-srinivasan-xcon-eventpkg-extensions
>
>