Subject: [XCON] RE: More comments on draft-ietf-xcon-framework-07.txt

From: "Oscar Novo \(JO/LMF\)" <[email-masked]>
Date: Mon, 14 May 2007 16:22:02 +0200

Mary,
 
Comments inline as [ON]
 
Regards,
 
Oscar

________________________________

From: Mary Barnes [mailto:[email-masked]] 
Sent: 30. huhtikuuta 2007 14:37
To: Oscar Novo (JO/LMF); [email-masked]
Cc: [email-masked]
Subject: RE: More comments on draft-ietf-xcon-framework-07.txt

Hi Oscar,
 
Responses embedded below [MB].
 
Thanks,
Mary 

	-----Original Message-----
	From: Oscar Novo (JO/LMF) [mailto:[email-masked]] 
	Sent: Monday, April 30, 2007 2:57 AM
	To: Barnes, Mary (RICH2:AR00); [email-masked]
	Cc: [email-masked]
	Subject: RE: More comments on draft-ietf-xcon-framework-07.txt

	Hi Mary, 
	 
	I have just a coupled of comments.
	 
	- I still think the replacement of the "common conference
information" for "conference information data model" is important. Now,
this concept is only defined in the framework and it can be very
confusing for the readers. I don't think the substitution of this term
will impact the whole text. In the framework you have this term only in
20 places, mainly in the 'terminology' and the 'centralized conferencing
data model' section. 
	[MB] I do understand how the term "common" has lost its original
context since we no longer have the templates, thus there's only one set
of information. But, a global replacement won't work quite right, at
least in terms of the basic definition, where the "common conference
information" is defined as: 
	   " The common
	      conference information is the data type (i.e., the XML
schema) for
	      a conference object".  
	How about we just drop the phrase "common" and refer to it as
"Conference Information"?
	[/MB] 
	 
	[ON] OK, for me it's fine if we change "Common Conference
Information" for "Conference Information"
	 
	- Regarding section 5.1 there is some text not clear and very
confuse, for instance: 
	"The data model defined in [17] would be the basis for
conferencing systems supporting enhanced conferencing features.The
additional information defined in [17] provides the details of the
specific media mixing details, the associated client roles and the
available floor controls". 
	The data model doesn't define any additional information. That
was defined in the template document. That's why I said that section
still have some concepts about the templates. 
	[MB] Okay, now I see your specific concern.  Would it be clearer
and less confusing if we just drop "additional" from that sentence?
[/MB] 
	 
	[ON] Actually the problem is not only in that sentence although
in all the section. I recommend you to re-write a bit more all section
5.1. In previous e-mails I sent you a text for section 5.1. You could
use that text if you think is suitable for your draft.

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: "Mary Barnes" <[email-masked]>
Date: Mon, 14 May 2007 11:13:36 -0500

One more comment below [MB2].  
 
Mary 

	-----Original Message-----
	From: Oscar Novo (JO/LMF) [mailto:[email-masked]] 
	Sent: Monday, May 14, 2007 9:22 AM
	To: Barnes, Mary (RICH2:AR00); [email-masked]
	Cc: [email-masked]
	Subject: RE: More comments on draft-ietf-xcon-framework-07.txt

	Mary,
	 
	Comments inline as [ON]
	 
	Regards,
	 
	Oscar

	Hi Oscar,

	Thanks,
	Mary 

		-----Original Message-----
		From: Oscar Novo (JO/LMF)
[mailto:[email-masked]] 
		Sent: Monday, April 30, 2007 2:57 AM
		To: Barnes, Mary (RICH2:AR00); [email-masked]
		Cc: [email-masked]
		Subject: RE: More comments on
draft-ietf-xcon-framework-07.txt

		Hi Mary, 

		- I still think the replacement of the "common
conference information" for "conference information data model" is
important. Now, this concept is only defined in the framework and it can
be very confusing for the readers. I don't think the substitution of
this term will impact the whole text. In the framework you have this
term only in 20 places, mainly in the 'terminology' and the 'centralized
conferencing data model' section. 
		[MB] I do understand how the term "common" has lost its
original context since we no longer have the templates, thus there's
only one set of information. But, a global replacement won't work quite
right, at least in terms of the basic definition, where the "common
conference information" is defined as: 
		   " The common
		      conference information is the data type (i.e., the
XML schema) for
		      a conference object".  
		How about we just drop the phrase "common" and refer to
it as "Conference Information"?
		[/MB] 
		 
		[ON] OK, for me it's fine if we change "Common
Conference Information" for "Conference Information"
		 
		- Regarding section 5.1 there is some text not clear and
very confuse, for instance: 
		"The data model defined in [17] would be the basis for
conferencing systems supporting enhanced conferencing features.The
additional information defined in [17] provides the details of the
specific media mixing details, the associated client roles and the
available floor controls". 
		The data model doesn't define any additional
information. That was defined in the template document. That's why I
said that section still have some concepts about the templates. 
		[MB] Okay, now I see your specific concern.  Would it be
clearer and less confusing if we just drop "additional" from that
sentence?  [/MB] 
		 
		[ON] Actually the problem is not only in that sentence
although in all the section. I recommend you to re-write a bit more all
section 5.1. In previous e-mails I sent you a text for section 5.1. You
could use that text if you think is suitable for your draft. 
		 
		[MB2] But, I think that initial suggestion was missing
the point that the model in the framework must support clients that just
support only the data in the  SIPPING event pkg and that don't support
the data model define [17 - the XCON data model].  Those paragraphs are
intended to provide the justification for defining additional data
beyond that provided 
		by the SIPPING event package. 
		 
		I did make some other slight changes to that text here's
the OLD/NEW of that 2nd paragraph in section 5.1:
		OLD:
		   In order to support more complex media manipulations
and enhanced
		   conferencing features the common conference
information contains
		   additional data, beyond that defined in [10].  The
data model defined
		   in [17] would be the basis for conferencing systems
supporting
		   enhanced conferencing features.  The additional
information defined
		   in [17] provides the details of the specific media
mixing details,
		   the associated client roles and the available floor
controls.  This
		   information would allow authorized clients to
manipulate the mixer's
		   behavior via the focus, and the resultant
distribution of the media
		   to all or individual participants.  By doing so, a
client can change
		   its own state and/or state of other participants in
the conference.

		NEW:
		   In order to support more complex media manipulations
and enhanced
		   conferencing features the conference information, as
reflected by the 
		   data model defined in [17], contains additional
		   data beyond that defined in [10].  The information
defined in [17] 
		   provides specific media mixing details, 
		   available floor controls and other data necessary to
support enhanced 
		   conferencing features.  This information allows
		   authorized clients to manipulate the mixer's behavior
via the focus,
		   with the resultant distribution of the media to all
or individual
		   participants.  By doing so, a client can change its
own state and/or
		   state of other participants in the conference.
		 
		[/MB2]

---

From: "Oscar Novo \(JO/LMF\)" <[email-masked]>
Date: Tue, 15 May 2007 09:03:26 +0200

Now it's a bit more clear. For me it's fine like that.
 
Thanks,
 
Oscar

Sent: 14. toukokuuta 2007 19:14

Mary 

	-----Original Message-----
	From: Oscar Novo (JO/LMF) [mailto:[email-masked]] 
	Sent: Monday, May 14, 2007 9:22 AM
	To: Barnes, Mary (RICH2:AR00); [email-masked]
	Cc: [email-masked]
	Subject: RE: More comments on draft-ietf-xcon-framework-07.txt

	Mary,
	 
	Comments inline as [ON]
	 
	Regards,
	 
	Oscar

	Hi Oscar,

	Thanks,
	Mary 

		-----Original Message-----

		Hi Mary, 

		 

		 

		NEW:
		 
		[/MB2]