Subject: [xml2rfc] Refs not sorting

From: Brian Rosen <[email-masked]>
Date: Fri, 24 Sep 2021 11:57:05 -0400

I’m certain this is a “duh” thing.  My references are not sorting.  The beginning of the file is:
<?xml version='1.0' encoding='utf-8'?>
<?xml-stylesheet type='text/xsl' href='rfc2629.xslt' ?>
<!DOCTYPE rfc SYSTEM "rfc2629-xhtml.ent" >
<?rfc strict="true" ?>
<?rfc toc="true" ?>
<?rfc tocdepth="4" ?>
<?rfc symrefs="true" ?>
<?rfc sortrefs="true" ?>
<?rfc compact="true" ?>
<?rfc subcompact="false" ?>
<rfc xmlns:xi="http://www.w3.org/2001/XInclude" category="std" docName="draft-ietf-rum-rue-08" ipr="trust200902" obsoletes="" updates="" submissionType="IETF" xml:lang="en" version="3" consensus="yes">
  <!-- ***** FRONT MATTER ***** -->
  <front>

sortrefs=“true” is it, right?  It was originally “yes”, no difference.  The references section looks like:
 <back>
    <references>
      <name>Normative References</name>
      <?rfc include="http://xml.resource.org/public/rfc/bibxml/reference.RFC.2119.xml"?>
      <?rfc include="http://xml.resource.org/public/rfc/bibxml/reference.RFC.8446.xml"?>

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 24 Sep 2021 18:17:20 +0200

V3 ignores PIs. These now go into the rfc tag as attributes. 

A little warning might go a long way here…

Sent from mobile, sorry for terse

> On 24. Sep 2021, at 17:57, Brian Rosen <[email-masked]> wrote:
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Julian Reschke <[email-masked]>
Date: Fri, 24 Sep 2021 18:35:55 +0200

Am 24.09.2021 um 18:17 schrieb Carsten Bormann:
> ...

Yep.

<https://greenbytes.de/tech/webdav/rfc7991.html#element.rfc.attribute.sortRefs>

Best regards, Julian